14:31:14 <colindixon> #startmeeting release daily sync
14:31:14 <odl_meetbot> Meeting started Wed Sep 17 14:31:14 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:14 <odl_meetbot> The meeting name has been set to 'release_daily_sync'
14:31:19 <colindixon> #topic roll call
14:31:28 <tbachman> #info tbachman for groupbasedpolicy
14:31:30 <colindixon> #info colindixon for TTP (and ponies!)
14:31:35 <tbachman> ponies?
14:31:44 <colindixon> why not?
14:31:47 <tbachman> lol
14:32:01 <abhijitkumbhare> #info abhijitkumbhare for OF plugin
14:32:03 <oflibMichal> #info oflibMichal
14:32:09 <colindixon> tbachman: I saw that you went to UW
14:32:13 <colindixon> and now live in bmore
14:32:16 <tbachman> yes :)
14:32:19 <hideyuki_> #info Hideyuki Tai for VTN
14:32:28 <colindixon> I went to UMD for undergrad and then UW for grad school
14:32:28 <tbachman> colindixon: saw that you did your PhD there
14:32:30 <tbachman> yeah
14:32:41 <tbachman> but — you grew up on the West Coast?
14:32:48 <colindixon> nope, DC
14:32:51 <tbachman> ah
14:32:54 <vjanandr> #info Vijay for SNBI
14:33:01 * tbachman is headed there today
14:33:11 <tbachman> OpenStack Meetup
14:33:26 <colindixon> cool stuff
14:33:29 <tbachman> :)
14:33:48 <colindixon> ok, edwarnicke, gzhao are you guys around?
14:33:58 <xsited1> #info thomas packetcable
14:34:15 <colindixon> oh, good, controller verify seems wedged
14:34:25 <phrobb> #info Phil Robb
14:35:03 <abhijitkumbhare> colindixon - no longer in Austin?
14:35:13 <colindixon> abhijitkumbhare: i’m still in Austin
14:35:21 <edwarnicke> #info edwarnicke
14:35:22 <tbachman> abhijitkumbhare: we’re talking past ;)
14:35:29 <tbachman> colindixon: who was your advisor?
14:35:33 <LuisGomez> #info LuisGomez
14:35:35 <edwarnicke> colindixon: Are we missing gzhao ?
14:35:41 <colindixon> tbachman: Tom Anderson and Arvind Krishnamurthy
14:35:42 <tbachman> he’s online
14:35:42 <abhijitkumbhare> thought colindixon mentioned he is now in baltimore :)
14:35:54 <tbachman> ah, cool!
14:35:58 <colindixon> edwarnicke: I haven’t seen him, no
14:36:13 * edwarnicke notes we are missing our fearless leader :(
14:36:21 <colindixon> ok, people should feel free to #info in, but lets try to get started
14:36:27 <colindixon> edwarnicke: do you want to wait?
14:36:35 <tbachman> autorelease as next topic?
14:36:57 <tbachman> or status?
14:36:58 <colindixon> #topic RC1 (and auto-release)
14:37:19 <goldavberg_phone> #info goldavberg for lispflowmapping
14:37:26 <colindixon> #link http://nexus.opendaylight.org/content/groups/staging/org/opendaylight/integration/distribution-karaf/0.2.0-Helium-RC1/ we have RC1 artifacts
14:37:56 * edwarnicke does a happy dance!
14:38:10 <colindixon> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_.28Your_Project.2FFeatures_in.29_RCs this contains instructions on how to test your stuff in RC1 (and all other RCs)
14:38:23 <colindixon> edwarnicke: did we want to cove anything else in auto-release?
14:38:58 <LuisGomez> #info I will pass system test for RC1 today, just need to adjust 1 job
14:39:01 <edwarnicke> We had several healthy runs of autorelease... current run has an issue that looks like it was the fact that someone merged a fix that was being cherry picked in ;)
14:39:25 <edwarnicke> LuisGomez: I think I found the root cause of the compatible-with-all bug you were seeing
14:39:28 <edwarnicke> LuisGomez: Will fix today
14:40:10 <LuisGomez> which bug? compatible-with-all is working now
14:40:21 <colindixon> #info edwarnicke notes that we’ve had several successful runs of the RC1 auto release (nightlies) and that the current one hit a snag
14:40:26 * tbachman is now confused
14:40:56 <colindixon> #info edwarnicke thinks he already knows what broke and how to fix it, he also has ideas about fixing a compatible-with-all bug in integration
14:41:00 <colindixon> tbachman: questoin?
14:41:07 <edwarnicke> colindixon: I have identified the source of the snag and fixed it.  Source of the snag was in the autorelease job itself.
14:41:11 <tbachman> LuisGomez: are you saying -all works?
14:41:15 <tbachman> or asking?
14:41:26 <LuisGomez> tbachman, yesterday yes
14:41:28 <colindixon> #undo
14:41:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24f8250>
14:41:30 <edwarnicke> LuisGomez: How was it fixed?
14:41:30 <LuisGomez> let me check
14:41:41 <colindixon> #info edwarnicke has already found the source of the snag and fixed it
14:41:58 <edwarnicke> gzhao: What is the spreadsheet for reporting RC1 testing?
14:41:59 <LuisGomez> https://jenkins.opendaylight.org/integration/view/CSIT%20Jobs/job/integration-master-csit-karaf-compatible-all/
14:42:04 <LuisGomez> yes it works
14:42:19 * tbachman is very confused
14:42:37 <tbachman> LuisGomez: did you invoke REST API calls?
14:42:38 <edwarnicke> tbachman: What is the source of your confusion?
14:42:40 * tbachman presumes so
14:42:41 <colindixon> it appears as though conroller-verify is down: https://jenkins.opendaylight.org/controller/job/controller-verify/
14:43:12 <tbachman> maybe it’s a difference between the build integration used to test and RC1
14:43:15 <tbachman> but for RC1
14:43:19 <tbachman> in order to get REST to work
14:43:31 <tbachman> I had to load the restconf bundle before the -all bundle
14:43:46 <tbachman> LuisGomez: did you see something similar?
14:43:47 <edwarnicke> colindixon: Its the whole Jenkins instance
14:43:51 <edwarnicke> colindixon: helpdesk email sent
14:43:54 <edwarnicke> controller-dev cced
14:44:02 <tbachman> edwarnicke: thx!
14:44:06 <colindixon> for those curious what comes next, it’s going to be per-project status reports (anything important) and then blocking issues
14:45:04 <LuisGomez> tbachman, i just install the integration feature that has all compatible features
14:45:14 <tbachman> okay :)
14:45:21 <tbachman> LuisGomez: thx!
14:45:23 <colindixon> #info tbachman notes that for him, to get REST in RC1 to work, he had to load the restconf bundle feature before running the compatible-with-all feature
14:45:24 <LuisGomez> i am not sure about the order
14:45:36 <gzhao> edwarnicke: https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309
14:45:49 <edwarnicke> LuisGomez: tbachman's issue is the one I think I know how to fix
14:45:55 <edwarnicke> LuisGomez: Traces to a packaging bug in aaa-authz
14:46:16 <colindixon> #info the problem seems to have resolved itself for LuisGomez, but edwarnicke also thinks he knows how to fix it if it’s still persisting for tbachman
14:46:29 <LuisGomez> tbachman, i still need to test RC1
14:46:44 <tbachman> colindixon: thx for info-ing
14:46:46 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 this is where to report your the testing you do in RC1
14:46:54 <tbachman> gzhao: can we edit that?
14:47:05 <tbachman> ah, yes we can :)
14:47:06 <colindixon> #info ^^^^^^ go test and report
14:47:34 <edwarnicke> colindixon: Perhaps we should also encourage folks to retest nightlies as they come out?
14:48:33 <LuisGomez> i see l2switch is fixed now, not sure if this fix made RC1
14:48:41 <colindixon> #info also, you should test nightlies if you can, more testing is more better. instructions on where to find nightlies are on the testing wiki page linked above
14:48:41 <tbachman> gzhao: what’s column F, “Test compatible with feature” for?
14:49:11 <colindixon> tbachman: it’s the set of features ou tested with
14:49:12 <colindixon> I think
14:49:19 <LuisGomez> vtn has still issues in their system test
14:49:41 <tbachman> hmmm - isn’t that essentially what the thing in  column B defines?
14:50:01 <LuisGomez> is hideyuki here?
14:50:01 <colindixon> #info tbachman asks what column F (“Test compatible with feature”) is supposed to be reporting
14:50:13 <colindixon> hideyuki_ #Infoed in
14:50:36 <gzhao> edwarnicke: list features when testing with compatible-with which features have been tested.
14:50:45 <hideyuki_> LuisGomez: Hi!
14:51:00 <colindixon> #Info colindixon notes that the explanation on the sheet is: “Please input the feature IDs that you tested compatible with the testing feature”
14:51:06 <LuisGomez> hideyuki_, any issue with vtn and karaf now?
14:51:13 <gzhao> tbachman: I think you can edit
14:51:21 <tbachman> yes :)
14:51:24 <colindixon> I think column B is the feature under test
14:51:27 <tbachman> gzhao: thx - sorry for hte confusion
14:51:37 <gzhao> tbachman: np
14:51:52 <colindixon> I think column F is the background features that were loaded in addition
14:52:01 <colindixon> gzhao: is that right?
14:52:38 <gzhao> colindixon: yes,
14:52:38 <tbachman> It’s confusing to me b/c I thought the definition of the odl-integration-compatible-with-<project> were project specific
14:52:51 <tbachman> they were there b/c they weren’t compatible with other things
14:53:04 <gzhao> colindixon:  test feature alone and test feature compatibility, column F is for latter one
14:53:26 <edwarnicke> hideyuki_: https://bugs.opendaylight.org/show_bug.cgi?id=1866#c3 I see those services provided in karaf
14:53:27 <colindixon> tbachman: most projects are compatible with all
14:53:56 <colindixon> I think column F will either be odl-integration-compatibility-with-all or odl-integration-compatibility-with-<project-from-column-B>
14:53:59 <tbachman> colindixon: but aren’t those projects just in the -all feature?
14:54:05 <edwarnicke> colindixon: I would tend to concur
14:54:30 <tbachman> In other words — odl-integration-compatible-with-groupbasedpolicy is just our feature with odl-integration-compatible-with-all
14:54:40 <edwarnicke> tbachman: Yes :)
14:54:45 <tbachman> so, if you’re compatible, you should be in -all
14:55:05 <tbachman> are we supposed to list  all the features in -all here?
14:55:14 <tbachman> or that we’ve *tested* those features?
14:55:23 <gzhao> tbachman: what tested
14:55:25 <tbachman> (i.e. tested TTP, etc.)
14:55:26 <tbachman> ah
14:55:33 <colindixon> #info column B is for the feature being tested, it and it’s dependencies should be the only things loaded when you do the “single feature” test which you’ll report with “Yes” in column D
14:56:07 <edwarnicke> colindixon: Would you perhaps add this stuff to the wiki page on testing your RC?
14:56:21 <colindixon> #Info column F is for reporting what other features you loaded to test when doing your “feature compatibility test”, which when run, you report with “Yes” in column E
14:57:03 <LuisGomez> that is correct
14:57:41 <colindixon> #info note that column F should likely be “odl-integration-compatibility-with-all” (for projects which don’t have any expected compatibility issues), or “odl-integration-compatibility-with-<project-from-column-B>” (for projects that do have known compatibility issues)
14:57:52 <gzhao> colindixon: I am intending people just put feature ID, so there in https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=528993842 it has all feature listed, but name should works fine.
14:58:05 <gzhao> colindixon: in column F
14:58:16 <colindixon> #action colindixon to add explanation about the testing report spreadsheet to the testing part of the karaf step by step wiki page
14:58:36 <hideyuki_> #info VTN project has detected some bugs in controller and openflowplugin. Bug 1491, 1759, and 1866.
14:58:45 <colindixon> #undo
14:58:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x26956d0>
14:58:53 <colindixon> #topic project status reports
14:58:53 <edwarnicke> hideyuki_: 1759 is fixed and merged, have you tried it?
14:59:04 <hideyuki_> #info VTN project has started testing RC1, and has not detected any isues of VTN features so far.
14:59:12 <colindixon> #info hideyuki_ notes that VTN project has detected some bugs in controller and openflowplugin. Bug 1491, 1759, and 1866.
14:59:19 <hideyuki_> https://bugs.opendaylight.org/show_bug.cgi?id=1759#c7
14:59:23 <edwarnicke> hideyuki_: On 1886 please see https://bugs.opendaylight.org/show_bug.cgi?id=1866#c3 as I can clearly see those services registered by the compatibility bundle in karaf
14:59:38 <colindixon> here, if there are any issues projects want to bring forward, now is the time
14:59:52 <hideyuki_> edwarnicke: The issue with the AD-SAL OF plugin is not fixed yet.
15:00:28 <gzhao> #info each project should check their current status and report if project is till green/red/yellow
15:00:36 <edwarnicke> hideyuki_: Which ones?  Have you tried the fix for 1759 ?
15:00:50 <gzhao> https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 <= current project status
15:00:54 <hideyuki_> edwarnicke: 1759
15:01:07 <edwarnicke> hideyuki_: Do you mean 1759 is not fixed?
15:01:20 <hideyuki_> edwarnicke: Before the patches are merged, I've tested for bug 1759.
15:01:32 <edwarnicke> hideyuki_: OK :)
15:01:46 <hideyuki_> edwarnicke: Before the patches are merged, I checkout the patches, and tested for bug 1759.
15:02:02 <edwarnicke> hideyuki_: Any thoughts on https://bugs.opendaylight.org/show_bug.cgi?id=1866#c3
15:02:03 <tbachman> #info groupbasedpolicy has tested both odl-groupbasedpolicy-ofoverlay and odl-integration-compatible-with-groupbasedpolicy, and both passed
15:02:13 <abhijitkumbhare> For 1759 hideyuki_ - it looks its working for the OF 1.0/1.3 plugin but not AD-SAL-only OF 1.0 plugin
15:02:13 <edwarnicke> hideyuki_: Because I am genuinely confused... I can see those services provided in karaf
15:02:17 <hideyuki_> Is the AD-SAL OF plugin (the old OF plugin) in Karaf distribution in Helium?
15:02:50 <hideyuki_> edwarnicke: are you talking bout 1866?
15:02:51 <edwarnicke> hideyuki_: michal_rehak reports that https://bugs.opendaylight.org/show_bug.cgi?id=1491 is in progress and is expected to be fixed tomorrow
15:02:59 <colindixon> while we’re here: tbachman, abhijitkumbhare, vjanandr, xsited, or others, do you have any project-specific issues to report or ask for help with>
15:02:59 <edwarnicke> hideyuki_: Yes, 1866
15:03:15 <edwarnicke> goldavberg_phone: Welcome! :)
15:03:17 * tbachman keeps mum
15:03:30 <LuisGomez> hideyuki_, for some reason vtn system test is failing but maybe it is just the test code, i will try offline to debug it offline
15:03:35 <abhijitkumbhare> No
15:03:50 <hideyuki_> edwarnicke: I'll talk you later about 1866, ok?
15:04:01 <gzhao> colindixon: per yesterday's action, document type is tracked and list here: https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1408765403
15:04:06 <edwarnicke> hideyuki_: Cool, thanks :)
15:04:19 <edwarnicke> colindixon: Did you ever get docs from l2switch?
15:04:31 <hideyuki_> LuisGomez: Thank you!
15:04:32 <gzhao> colindixon: not all projects give me the info though.
15:05:08 <vjanandr> colindixon: we have not run into any issues until now
15:05:12 <colindixon> ok
15:05:28 <hideyuki_> LuisGomez: I'll talk with Venkat about the vtn system test. I think he can figure out the root cause, and fix test code.
15:05:40 <edwarnicke> vjanandr: Thank you for merging the fix to snbi so promptly :)
15:05:48 <LuisGomez> hideyuki_, thanks
15:06:06 <vjanandr> edwarnicke: thank you Ed for fixing that :)
15:06:17 <colindixon> hideyuki_: have you gotten what you needed here, or are there more issues you need to resolve?
15:07:25 <colindixon> #topic documentation
15:07:42 <hideyuki_> colindixon: No.
15:07:45 <hideyuki_> colindixon: Thank you!
15:07:54 <colindixon> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1408765403 this shows what information we currently have projects about the kinds of documentation projects intend to produce
15:08:11 <hideyuki_> colindixon:  I have one question.
15:08:16 <hideyuki_> Is the AD-SAL OF plugin (the old OF plugin) in Karaf distribution in Helium?
15:08:18 <colindixon> #info it’s still incomplete despite gzhao’s pushing to get the missing info with in M5
15:08:27 <colindixon> hideyuki_: I don’t know, edwarnicke?
15:08:40 <edwarnicke> hideyuki_: It is not
15:08:57 <hideyuki_> edwarnicke: Thank you.
15:09:25 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/11258/ the l2switch project has pushed documentation, which might be a good place to go look for an example
15:09:49 * edwarnicke does a happy dance to see example docs :)
15:10:18 <gzhao> colindixon: xsited1 asked is there a model citizen for documentation that he can follow
15:10:29 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/project:docs,n,z others have pushed docs as well (lispflowmapping and yangtools)
15:10:47 <colindixon> gzhao: networkstatic asked the same question, I’m not sure yet, but there are at least examples
15:10:58 <colindixon> somebody needs to look through them and double check things
15:11:08 * gzhao colindixon reads my mind
15:12:16 <colindixon> #action colindixon, regXboi, or mlemay to review some of the pushed docs and try to find a good example to put forward as an exemplar
15:12:28 <colindixon> #info please, please, please start your docs if you can
15:12:34 <colindixon> #topic blocking issues
15:13:07 <colindixon> does anyone have blocking issues to report here?
15:13:22 <colindixon> I know that VTN has bugs they’re trying to sort out and system test stuff that was reported above
15:13:37 <colindixon> I know that tbachman has an issue with REST that edwarnicke is on
15:13:41 <colindixon> anything else?
15:13:58 <edwarnicke> Dana reported some other issues to release
15:14:10 <tbachman> colindixon: good point, but we have a workaround, so not blocking yet :)
15:14:57 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2014-September/000433.html dana reported some issues here
15:15:54 <colindixon> #info it appears that they aren’t blocking, but should be tackled
15:16:13 <colindixon> edwarnicke, phrobb, gzhao any other known blocking issues
15:16:14 <colindixon> ?
15:16:44 <gzhao> colindixon: no from me.
15:17:22 <edwarnicke> colindixon: I think for me mostly its just the stuff identified
15:17:29 <colindixon> ok
15:17:31 <gzhao> colindixon: just want to check each project current in yellow status, are they still in yellow
15:17:47 <colindixon> gzhao: which projects are in yellow?
15:18:01 <gzhao> https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068
15:18:23 <tbachman> gzhao: why is GBP yellow?
15:18:29 <tbachman> lol
15:18:31 <tbachman> never mind
15:18:33 <tbachman> green :)
15:18:34 <gzhao> tbachman: haha
15:19:04 <colindixon> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1136082068 gzhao would like to have yellow projects report in if the move to green
15:19:16 <hideyuki_> gzhao: Could you change the status of VTN project to GREEN?
15:19:34 <gzhao> hideyuki_: sure thanks
15:19:36 <colindixon> gzhao: if you want that information, my guess is that you’ll need to send an e-mail explaining that you want all projects to be green for the release
15:19:43 <hideyuki_> gzhao: I would like to chagne the status, but it seems to me that i have no right to edit the spreadsheet.
15:19:49 <hideyuki_> gzhao: Thank you!
15:19:58 <gzhao> hideyuki_: np
15:20:01 <colindixon> gzhao: and explaining that you can make a note that the scope has been reduced to do so
15:20:03 <edwarnicke> gzhao: Correct me if I'm wrong though, we do have everybody in karaf and in autorelease now, right :)
15:20:30 <colindixon> gzhao: with a reduced scope TTP is now also green
15:20:53 <colindixon> xsited: is packetcable green now?
15:20:54 <gzhao> colindixon: ok, the status was showing project reported at M5, so for those projects in yellow, they should take actions to bring project back to green.
15:21:28 <gzhao> edwarnicke: yes, that is RC1 requirement
15:21:40 * edwarnicke does a happy dance :)
15:21:47 <colindixon> gzhao: I think that many projects are assuming that if they missed delivering the features they said they’d deliver in their release plan, that they would be yellow forever
15:22:10 <colindixon> gzhao: if we want to make it clear that you can be green despite delivering less functionality, we should do that
15:22:12 <edwarnicke> colindixon: I don't think that's so... a project could reduce the scope of their delivery
15:22:36 <colindixon> edwarnicke: that wasn’t the interpretation that I had, but if it’s the interpretation we want to have we need to clarify
15:22:57 <gzhao> colindixon: their M5 will be yellow forever, but for current status is their current standing.
15:23:06 * edwarnicke is confused... because he thought edwarnicke and colindixon just agreed, and it sounds like colindixon thinks we just disagreed
15:23:13 <colindixon> and make it clear to projects that their goal should be to reduce their scope (and document the reduced scope) so that they are green
15:23:25 <colindixon> edwarnicke: no, no, I agree
15:23:38 <colindixon> I’m just saying I don’t think everyone understood what we intended
15:23:45 <edwarnicke> colindixon: Cool :)
15:24:25 <colindixon> #action gzhao to send a mail to projects still in yellow explaining that their goal should be to get to green, and that reducing the scope of their deliverables (and documenting that) to do so is fine
15:24:32 <colindixon> does that make sense?
15:24:50 <gzhao> colindixon: yes,
15:24:51 <colindixon> also anything else before I give people 5 minutes before the pre-RC2 meeting?
15:25:21 <edwarnicke> LOL... colindixon are we going to do this hour all over again? :)
15:25:38 <gzhao> good timing.
15:25:53 <hideyuki_> what is the pre-RC2 meeting?
15:25:54 <colindixon> edwarnicke: not sure, we can ask phrobb :p
15:26:03 <colindixon> ok, going once
15:26:16 <colindixon> going twice
15:26:31 <colindixon> #endmeeting