14:31:20 <gzhao> #startmeeting release daily sync
14:31:20 <odl_meetbot> Meeting started Thu Sep 18 14:31:20 2014 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:20 <odl_meetbot> The meeting name has been set to 'release_daily_sync'
14:31:32 <gzhao> #topick roll call
14:31:44 <gzhao> #topic roll call
14:31:46 <goldavberg> #info goldavberg for lispflowmapping
14:31:59 <gzhao> #info gzhao for release
14:32:21 <tbachman> #info tbachman for groupbasedpolicy
14:34:06 <gzhao> please #info in
14:34:11 <abhijitkumbhare> #info abhijitkumbhare OpenFlow plugin
14:34:23 <hideyuki> #info Hideyuki for VTN
14:34:24 <edwarnicke> #info edwarnicke
14:34:47 * tbachman thanks gzhao profusely for running these meetings, and for all the cat-herding that he does so well! :)
14:35:00 * edwarnicke second tbachman in thanking gzhao :)
14:35:01 <xsited1> #info thomas packetcable
14:35:07 <gzhao> 1 more minute
14:35:19 * gzhao thanks tbachman edwarnicke
14:35:54 <gzhao> #topic auto-release
14:36:25 <edwarnicke> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Download_the_RC <- now with the link for last nights nightly, RC1-2
14:36:37 <gershon> info: gershon defense4all
14:36:44 <gershon> Hi everybody!
14:36:52 <tbachman> #info gershon defense4all
14:37:01 <tbachman> gershon: needs the ‘#’ sign :)
14:37:11 <gershon> Ok, thanks, sorry:)
14:37:16 <tbachman> np! :)
14:37:17 <gzhao> the last daily build failed  after 5 successful built
14:37:23 <gzhao> https://www.irccloud.com/pastebin/KMTYIonZ
14:37:33 <edwarnicke> gershon: No worries, you'll get the hang of it :)
14:37:42 <edwarnicke> gzhao: Someone is already working on that :)
14:37:55 <gzhao> edwarnicke: ok
14:38:11 <edwarnicke> gzhao: Now quite sure what happened yet, but the patch verified, seems to have become grumpy on that one test on merge
14:38:45 <gzhao> edwarnicke: do you know which project is working on the fix?
14:38:46 <tbachman> #link : https://www.irccloud.com/pastebin/KMTYIonZ  <= trace showing daily build failed
14:39:20 <tbachman> #info gzhao says the last daily build failed after 5 successful builds
14:40:40 <gzhao> #info edwarnicke said someone is already working on that
14:40:44 <gzhao> #undo
14:40:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2526310>
14:40:45 <edwarnicke> gzhao: controller
14:41:10 <gzhao> #info edwarnicke  said controller team is already working on the fix
14:41:42 <colindixon> #Info colindixon for TTP
14:41:58 <gzhao> any other thing worth to mention about autorelease?
14:42:12 * edwarnicke hope the autorelease is becoming boring :)
14:42:33 <colindixon> edwarnicke: that would be the hope
14:42:34 <gzhao> #topic issues and status
14:42:49 <gzhao> any blocking issues
14:43:45 <edwarnicke> I could use a windows expert
14:44:04 <colindixon> edwarnicke: the only windows expert we have that I know of is regXboi
14:44:16 <edwarnicke> the permgen and memory sizes have been raised for the linux karaf... but I need someone who understands windows to do the same for the windows side
14:44:52 <gzhao> How about we use this standard for status: blocking issue-> red, testing feature alone , comparability and document not started ->yellow, testing on schedule to be finished before RC2, document type identified and started ->green
14:47:40 <gzhao> #info defense4all, sdni, ovsdb, pcmm, plugin2oc, sfc are current projects in yellow status, do we have reps from these project to report status
14:47:59 <AsafOron> #info: AsafOron D4A
14:48:28 <gzhao> AsafOron: using the above standard, is D4A still yellow?
14:48:56 <tbachman> #info gzhao proposes using the following standard for status: blocking issue-> red, testing feature alone , comparability and document not started ->yellow, testing on schedule to be finished before RC2, document type identified and started ->green
14:49:23 <gzhao> #chair edwarnicke tbachman colindixon
14:49:23 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao tbachman
14:49:32 <gzhao> sorry forgot to do that
14:49:33 <tbachman> :)
14:49:54 <AsafOron> D4A is green
14:49:58 <gzhao> AsafOron: thanks
14:50:30 <gzhao> xsited1: how about pcmm
14:51:01 <tbachman> asaforon: can you info that?
14:51:27 <tbachman> pound-info
14:51:28 <tbachman> ?
14:51:33 <goldavberg> gzhao: what makes sfc yellow? as far as i know we are code freezed. and fully Karafed
14:52:01 <tbachman> #info D4A is green
14:52:14 <gzhao> edwarnicke: will you be able to answer status for SFC? they haven't sent status for M5, nor documentation.
14:52:31 <AsafOron> tx tbachman
14:52:34 <tbachman> gzhao: I think goldavberg is trying to answer status right now :)
14:52:37 <tbachman> asaforon: np!
14:52:49 <gzhao> goldavberg: unless project contact report status change, otherwise it uses M5 status(last reported status)
14:52:51 * tbachman has managed to be on just one meeting atm… for once! ;)
14:52:51 <edwarnicke> gzhao: goldavberg is an SFC commiter :)
14:53:14 <tbachman> gzhao: so, you only accept these from the project contact?
14:53:23 <tbachman> (makes sense, just wanted to make sure we all understand)
14:53:45 <gzhao> tbachman: no, anyone can represent the project can report their status.
14:53:52 <ChristineH> excuse me that I join late. Is it reporting each project's status?
14:53:53 <goldavberg> gzhao: our weekly meeting starts in 7 minutes, so will probably discuss it then :)
14:54:03 <tbachman> ChristineH: can you # info in?
14:54:10 <edwarnicke> gzhao: Just pinged paulq... he's on his way
14:54:12 <ChristineH> #info Christine for SNMP4SDN
14:54:18 <tbachman> ChristineH: thx! :)
14:54:20 <goldavberg> i don't really know what our documentation or testing status is
14:54:25 <xsited1> gzhao: yellow: first draft of docs laid out, heading back to unit testing
14:54:33 <gzhao> goldavberg: ok, ask paulq to send me email with documentation types as well for SFC
14:54:39 <tbachman> xsited: want to # info that?
14:54:50 <paulq> paulq is here
14:54:51 <paulq> :)
14:54:52 <goldavberg> gzhao: looks like Paul just joined us
14:55:04 * tbachman notes its good to have the status updates as info’s for meetbot meeting minutes
14:55:06 <edwarnicke> paulq: Please #info in :)
14:55:10 <tbachman> hey paulq ! :)
14:55:14 <paulq> #info paulq for sfc
14:55:26 <paulq> morning tbachman
14:55:28 <paulq> :D
14:55:31 <tbachman> :)
14:55:52 <gzhao> paulq: hello, we need to know SFC is till in yellow status or not as well as what document types need to produce for Helium for SFC
14:56:18 <gzhao> #info xsited1 said PCMM remains in yellow
14:56:21 <paulq> gzhao: just got back from travel..I'll check the status today and send email asap
14:56:21 <xsited1> #info packetcable status: yellow: first draft of docs laid out, heading back to unit testing, praying for longer RC cycle
14:56:35 <gzhao> xsited1: thanks
14:56:38 <tbachman> xsited: thx!
14:56:59 <paulq> sfc group call is in 4 mins, I'll know more then :)
14:57:23 <gzhao> paulq: ok, could you email me after?
14:57:36 <paulq> gzhao: yes!
14:57:38 <gzhao> paulq: +release
14:57:43 <gzhao> paulq: thanks a lot
14:58:05 <gzhao> any project has any blocking issues
14:58:23 <gzhao> is there any project hasn't started testing RC1 feature alone
14:59:26 <gzhao> is there any project hasn't started testing RC1 compatibility test?
14:59:39 <ChristineH> snmp4sdn has started but has problem
14:59:44 <tbachman> gzhao: do you have the link to that spreadsheet?
14:59:45 <hideyuki> VTN project has detected some bugs in controller. Bug 1491, 1866, and 1939. VTN project hopes that these bugs are fixed in Helium.
14:59:49 <edwarnicke> ChristineH: What is your issue?
14:59:58 <edwarnicke> hideyuki: I thought 1491 was resolved?
15:00:14 <ChristineH> edwarnicke: I wrote some commands in Karaf for snmp4sdn, but the console said no such command
15:00:28 <tbachman> #info VTN project has detected some bugs in controller. Bug 1491, 1866, and 1939. VTN project hopes that these bugs are fixed in Helium
15:00:34 <hideyuki> edwarnicke: No.
15:00:43 <edwarnicke> hideyuki: 1939 looks like it came in this morning?
15:00:59 <tbachman> #info snmp4sdn has started testing but has problem
15:01:07 <edwarnicke> hideyuki: Checking...
15:01:33 <edwarnicke> hideyuki: OK... let me see what's going on with 1491 :)
15:01:45 <gzhao> ChristineH: details about the problem?
15:01:45 <edwarnicke> hideyuki: I know michal_rehak is working on 1866 as we speak
15:01:46 <abhijitkumbhare> hideyuki and edwarnicke - about 1491 -
15:01:54 <edwarnicke> abhijitkumbhare: yes?
15:01:55 <abhijitkumbhare> ETA is tomorrow
15:02:11 <tbachman> #info gzhao asks if there are any projects that haven't started testing RC1 feature alone or with compatibility
15:02:23 <edwarnicke> hideyuki: Just got back that 1491 is being worked, ETA tomorrow
15:02:29 <abhijitkumbhare> sorry - had to step away from the desk for a min
15:02:41 <colindixon> #info TTP hasn’t tested in RC1 yet, but expects it to be straightforward
15:02:42 <hideyuki> #info Bug 1491 is partially fixed. But, as I wrote in Bugzilla, it is failed to change UDP port and ICMP type/code.
15:02:47 <edwarnicke> abhijitkumbhare: I am going to just stop answering for OFplugin now and let you do it  :)  You actually know what you are talking about :)
15:02:49 <tbachman> #info abhijitkumbhare says that a fix for BUG 1491 is ETA romorrow
15:02:58 <tbachman> hideyuki: thx!
15:03:00 <tbachman> #undo
15:03:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2649d50>
15:03:07 <tbachman> (removed my redundant one)
15:03:23 <gzhao> edwarnicke: btw, do you have the bug number to fix the issue auto-release encoutered?
15:03:24 <abhijitkumbhare> edwarnicke - I had asked michal the status today morning for 1491 :)
15:03:26 <ChristineH> gzhao, edwarnicke: for example, there is a command 'snmp4sdn:ReadDB <filepath>' for karaf console, but the console shows 'No such command' (I can't remember exactly the error message, anyway)
15:03:41 <tbachman> #info edwarnicke says michal_rehak is working on 1866
15:04:18 <gzhao> ChristineH: feature:list -i shows it has been installed?
15:05:06 <gershon> gzhao: defense4all has started testing...
15:05:29 <gzhao> gershon: thanks
15:06:20 <abhijitkumbhare> just confirming with hideyuki & edwarnicke - https://bugs.opendaylight.org/show_bug.cgi?id=1759 is not blocking - right? michal has the fix - but its not merged because edwarnicke thinks its a little risky for Helium at this stage
15:06:44 <edwarnicke> abhijitkumbhare: I thought I *did* merge the fix for 1759...
15:06:56 <edwarnicke> abhijitkumbhare: I might have put it off till after RC1 though... ;)
15:07:00 <edwarnicke> abhijitkumbhare: I don't remember
15:07:02 <abhijitkumbhare> OK
15:07:15 <edwarnicke> hideyuki: Can you confirm you see 1759 fixed in master?
15:07:22 <abhijitkumbhare> On the bug it still says "Also we agreed with Ed that AD-SAL code should not be touched this late before helium."
15:07:27 <tbachman> Do we have a convention for putting the gerrits into the bug log if/when they’re closed?
15:07:48 <abhijitkumbhare> OK - edwarnicke its merged
15:08:03 <abhijitkumbhare> Good to knock off that bug :)
15:08:04 <hideyuki> edwarnicke: Yes, I've confirmed that 1759 is fixed. (but, 1759 is fixed only for MD-SAL OF plugin. it is not fixed for AD-SAL OF plugin yet.)
15:08:37 <tbachman> #info hideyuki confirms that 1759 is fixed. (but, 1759 is fixed only for MD-SAL OF plugin. it is not fixed for AD-SAL OF plugin yet.)
15:08:53 <hideyuki> tbachman: Thanks. I forgot #info.
15:08:58 <tbachman> :)
15:09:07 <gzhao> other other issues?
15:09:20 <gzhao> any other issues?
15:10:31 <gzhao> #topic documentation and other things
15:12:19 <gzhao> #info controller of plugin, ofjava, p2oc, sfc and integration need to tell gzhao their document types.
15:12:34 <gzhao> #undo
15:12:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2638a10>
15:13:03 <gzhao> #info controller of plugin, ofjava, p2oc, sfc, ttp and integration need to tell gzhao their document types.
15:14:12 <gzhao> also, any preferred date time each project like to do their release view?
15:14:36 <tbachman> gzhao: I think we need to get confirmation from the TSC first on the times/dates?
15:14:43 <colindixon> gzhao: I think preferred times are going to have to be sussed out offline or at least by one-on-one calling people out
15:14:51 <colindixon> and I don’t think we have confirmation about times we can use for the TSC
15:14:53 <colindixon> yeah
15:15:26 <gzhao> tbachman: yes, I just want let people to select a time fits them the best
15:15:32 <tbachman> ah
15:16:02 <colindixon> gzhao: that’s not how it’s going to work
15:16:09 <colindixon> the TSC is likely to block out 2-3 hour-long slots
15:16:13 <colindixon> and you’ll get to pick one
15:16:23 <colindixon> or say which ones work best
15:16:26 <gzhao> tbachman: colindixon since we will schedule each project for 10 minutes, if no preference, phrobb and I will just assign them
15:17:38 <gzhao> however, project from different timezone, I hope they can give a range works better for them
15:19:01 <gzhao> colindixon: ok, we let TSC decide date time first, then ask for project if they want to do it at certain time.
15:19:12 <phrobb> Yea, my suggestion would be for George and I to produce a schedule (keeping in mind the Time Zones of the project contacts) and put it out there and if someone has a problem with the proposed time, we'll work to reschedule them as best we can.
15:19:28 <tbachman> phrobb: gzhao +1
15:20:20 <tbachman> #action gzhao and phrobb to produce a release review schedule (keeping in mind the Time Zones of the project contacts) and put it out there and if someone has a problem with the proposed time, we'll work to reschedule them as best we can.
15:20:27 <gzhao> Do we have anything to discuss for documentation and anything related to release?
15:20:33 <phrobb> For the TSC, as I mentioned on the email to the TSC, a quorum of TSC members is not needed for the Release Reviews but we will do our best to accommodate as many TSC member's participation as we can.
15:23:15 <gzhao> ok, will end meeting unless someone has objection
15:23:31 * tbachman watches gzhao raise gavel
15:23:50 <ChristineH> gzhao: my laptop was down, now finally come back.
15:23:59 <gzhao> tbachman: haha , you do it better than me
15:24:03 <tbachman> lol
15:24:23 <tbachman> gzhao: you’re doing great! :)
15:24:39 <gzhao> ChristineH:  no problem, are you able to pin point where is wrong?
15:24:53 <ChristineH> gzhao: I haven't used 'feature:list -i', but I use 'feature:list|grep snmp', and I see odl-snmp4sdn-all and odl-snmp4sdn-snmp4sdn marked with 'x'
15:26:08 <gzhao> Actually a general question, when people encounter this issue, which ML is best for asking for help?
15:27:23 <ChristineH> Truly, snmp4sdn needs expert's help for trouble shooting :)
15:28:04 <gzhao> ChristineH: could you put down the steps you did, error you saw and send to integration-dev, where probably knows most for Karaf testing AFAIK
15:28:07 <tbachman> ChristineH: are you able to see/use any commands?
15:28:33 <tbachman> (commands you’ve created)
15:29:42 <gzhao> ok 1 minute to go
15:30:11 <gzhao> 3
15:30:38 <ChristineH> tbachman: I created 5 (or 6) commands, well, I haven't tried each of them since the first command already fails (console said no such command). However, actually, in my local computer, one command can be executed and others are 'no such command'
15:31:22 <ChristineH> tbachman: typo. In my local computer, one command was able to be executed and others are 'no such command'
15:31:43 <tbachman> ChristineH: is there any relationship to that command and an order in a list?
15:31:47 <tbachman> (e.g. first, last, etc.)
15:32:43 <tbachman> gzhao: you can end the meeting if you want — I can stay on and try to help out ChristineH
15:32:54 <ChristineH> tbachman: I think no. These commands are independent.
15:33:16 * tbachman has to read up on how commands are added to karaf cli
15:33:37 <gzhao> tbachman: thanks
15:33:45 <gzhao> #endmeeting