14:30:34 <gzhao> #startmeeting release daily sync
14:30:34 <odl_meetbot> Meeting started Fri Sep 19 14:30:34 2014 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:34 <odl_meetbot> The meeting name has been set to 'release_daily_sync'
14:30:54 <gzhao> #topic roll call
14:31:07 <gzhao> Please #info in
14:31:15 <gzhao> #info gzhao for release
14:31:48 <phrobb> #info Phil Robb
14:32:09 * regXboi parachutes in
14:32:13 <colindixon> #info colindixon for TTP
14:32:51 <gzhao> #chair colindixon edwarnicke
14:32:51 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao
14:32:53 * colindixon notes that we *really* need to add a #rollcall command that records just the rollcall all in one place so we can get started whenever
14:33:07 * colindixon adds it to his list of things to add to the meetbot
14:33:19 <regXboi> colindixon: your meetbot fu is that strong?
14:33:37 <hideyuki_> #info Hideyuki for VTN
14:34:00 <colindixon> regXboi: only one way to find out?
14:34:00 <regXboi> #info regXboi for general mischief and gadfly-ness
14:34:12 <xsited1> #info thomas packetcable
14:34:49 <gzhao> give one more minute for people to info in
14:36:02 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow plugin (on another meeting same time)
14:36:40 <gzhao> #topic autorelease
14:36:56 <gzhao> do we have rep from bgpcep
14:37:07 <paulq_> #info paulq for sfc
14:37:24 <colindixon> https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/
14:37:32 <colindixon> it seems as though the auto-release is failing the last two runs
14:37:54 <gzhao> https://www.irccloud.com/pastebin/8oj2sfr5
14:38:16 <gzhao> it seems failed at bpgcp
14:38:40 <alagalah> #info alagalah for GBP
14:38:43 <edwarnicke> #info edwarnicke
14:38:49 <oflibMichal> #info oflibMichal
14:38:55 <edwarnicke> Apologies... I was distracted investigating the autorelease failure
14:39:00 <colindixon> #link https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ the last two auto-releases (58 and 59) have failed at BGPCEP
14:39:17 <alagalah> edwarnicke: gzhao My apologies, tbachman has inexplicably gone offline so I think he may have Interwebs failure
14:39:34 <edwarnicke> gzhao: The nightly did build successfully though, and has been added here: https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Download_the_RC
14:39:39 <edwarnicke> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Download_the_RC
14:40:02 <colindixon> #undo
14:40:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x26498d0>
14:40:05 <gzhao> nightly build RC1-3 was successfully push to nexus
14:40:29 <colindixon> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#Download_the_RC the nightly build (RC1-3) did build successfully and can be downloaded here
14:41:04 <gzhao> alagalah: no problem
14:41:17 <edwarnicke> gzhao: Could you pause the test runs while I investigate so that I don't loose the workspace to one?
14:41:48 <colindixon> edwarnicke: have you pinged rovarga or do we think it’s an issue with autorelease and not bgpcep?
14:42:21 <edwarnicke> colindixon: I actually don't think this is bgpcep's issue
14:42:30 <edwarnicke> colindixon: So here's whats' weird
14:43:12 <edwarnicke> #link https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/59/console complains it can't find artifact org.opendaylight.controller:sal-dom-xsql:bundle:1.1-Helium-RC1-v201409191037
14:43:25 <rovarga> it is a failure in controller
14:43:48 <edwarnicke> #link https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ws/.m2repo/org/opendaylight/controller/sal-dom-xsql/1.1-Helium-RC1-v201409191037/ and yet here is that artifact in the m2repo for the workspace
14:44:19 <edwarnicke> colindixon: rovarga Can you double check me here that I'm not crazy?
14:44:29 <edwarnicke> Because it looks like its complaining about an artifact that is *present*
14:45:05 <rovarga> [ERROR] MavenReportException: Error while creating archive:
14:45:12 <rovarga> Exit code: 1 - /opt/jenkins-odlautorelease/workspace/autorelease-helium-worker/controller/opendaylight/md-sal/sal-dom-xsql/src/main/java/org/opendaylight/xsql/XSQLProvider.java:5: error: cannot find symbol
14:45:16 <rovarga> import org.opendaylight.yang.gen.v1.http.netconfcentral.org.ns.xsql.rev140626.XSQL;
14:46:04 <gzhao_> rovarga: yes, that is the error shown in auto-release
14:47:40 <rovarga> note that this is javadoc:aggregate
14:47:50 <rovarga> and since xsql's javadoc failed
14:48:01 <rovarga> it cannot pull in the appropropriate jar
14:48:53 <rovarga> so once xsql passes javadoc, so will bgpcep
14:49:20 <edwarnicke> rovarga: Ah
14:49:30 <gzhao> rovarga: ok, need research more which change cause this
14:49:38 <colindixon> #info rovarga notes that it appears as though xsql’s javadoc build is failing which is why bcpcep can’t find the jar and so fixing that should fix the auto-release
14:49:48 <colindixon> anything else we need to cover on auto-release?
14:50:44 <edwarnicke> rovarga: Any other hints gratefully accepted
14:51:12 <tbachman> #info tbachman for groupbasedpolicy
14:51:28 <gzhao> tbachman: -:)
14:51:33 <colindixon> welcome!
14:51:37 <tbachman> sorry folks!
14:51:39 <tbachman> back :)
14:51:46 <tbachman> my IRC client was out to lunch :(
14:51:48 <colindixon> edwarnicke and rovarga, can I #action you two to work on this?
14:51:50 <tbachman> had to go off VPN
14:52:16 <edwarnicke> colindixon: I think its fair to action me
14:52:34 <edwarnicke> colindixon: I would be hesitant to punish rovarga 's kindness by putting that monkey on his hack :)
14:52:36 <edwarnicke> back
14:53:01 <colindixon> #action edwarnicke to work on resolving the auto-release issue with the new information from the bgpcep team
14:53:13 <colindixon> note not mentioning rovarga by name so that he isn’t actioned
14:53:19 <colindixon> gzhao: next topic?
14:53:30 <colindixon> #topic RC2 release
14:54:03 <colindixon> #info we’re planning to cut RC2 artifacts on Monday 9/22 at 5p pacific (that’s midnight UTC between 9/22 and 9/23)
14:54:10 <gzhao> For final release cut set on Monday, any project see any issues
14:54:35 <colindixon> #info the TSC has said that those artifacts will be the Helium release artifacts unless there are any show-stopping issues
14:54:47 <colindixon> ^^^^^ THAT IS A BIG DEAL ^^^^^
14:55:10 <edwarnicke> colindixon: Could you say that louder! :)
14:55:23 <colindixon> edwarnicke: if I could figure out how on IRC, I would
14:55:38 <gzhao> current three projects in yellow are: integration, ovsdb and pcmm
14:55:51 <regXboi> colindixon: you need to add #shout
14:56:37 * tbachman is sorry for joining the party late
14:57:09 <tbachman> were there issues brought up with RC1-3?
14:57:15 <colindixon> tbachman, hideyuk__, xsited, abhijitkumbhare, paulq_, alagalah, oflibMichal, edwarnicke, gzhao, phrobb, regXboi (everyone that’s #infoed in) please note that we are planning to use RC2 artifacts for Helium release unless any major issues are found
14:57:28 <tbachman> that’s a good shout :)
14:57:50 <gzhao> there are a lot of projects not update https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309
14:57:56 <tbachman> I’ve currently found 2 NPEs in RC1-3 :(
14:58:01 <hideyuk__> colindixon: OK.
14:58:01 <edwarnicke> #info edwarnicke understands that the RC2 artifacts scheduled to be cut Monday Sept 22 at 5pm PST will be used as release artifacts unless a show stopper is uncovered
14:58:06 <gzhao> we would need their karaf feature testing status
14:58:13 <edwarnicke> tbachman: You are a testing machine!
14:58:14 <gzhao> colindixon:  you do need #shout
14:58:19 <tbachman> lol
14:58:26 <tbachman> breaking machine is more like it
14:58:32 <colindixon> #action gzhao to send a mail to release saying that RC2 artifacts are going to be release artifacts
14:58:41 <colindixon> #undo
14:58:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2649290>
14:58:59 <colindixon> #action gzhao to send a mail to release saying that RC2 artifacts are going to be release artifacts including instructions to update the testing doc
14:59:32 <colindixon> so, yeah, I don’t know how else to yell about this?
14:59:39 <colindixon> I could #agreed it so it’s more bold in the notes
14:59:47 <colindixon> but people aren’t going to read the notes
15:00:18 <colindixon> I think we’re going to have just try to get acks today and over the weekend
15:00:26 <edwarnicke> Suffice it to say: go scream it at your friends
15:00:37 <edwarnicke> Could folks #info in their acks as I did above?
15:00:59 <colindixon> gzhao: maybe it makes sense to add a box to the testing spreadsheet for projects to ack it?
15:01:38 <gzhao> ack edwarnicke 's info to make sure everyone is on the same page?
15:01:51 <colindixon> tbachman, hideyuk__, xsited, abhijitkumbhare, paulq_, alagalah, oflibMichal, edwarnicke, gzhao, phrobb, regXboi (everyone that’s #infoed in) please #Info an ack of the fact that we’re planning to make RC2 artifacts the Helium release barring show-stopping bugs
15:02:19 <gzhao> #info /me acks
15:02:28 <abhijitkumbhare> ack colindixon - will need to take a look
15:02:28 <colindixon> #info colindixon acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs
15:02:28 <gzhao> #undo
15:02:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2649990>
15:02:35 <gzhao> #undo
15:02:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x26490d0>
15:02:42 <colindixon> #info colindixon acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs
15:02:43 <regXboi> #info regXboi acks (not sure why - i'm only here for mischief :) )
15:02:50 <gzhao> #info gzhao acks
15:03:07 <oflibMichal> #info +1 / ack
15:03:12 <phrobb> #info ACK
15:03:12 <tbachman_> not my day on IRC :(
15:03:16 <tbachman_> what are we acking?
15:03:18 <edwarnicke> edwarnicke: ACs regXboi 's mischief  :)
15:03:21 * tbachman_ keeps dropping off :(
15:03:35 <colindixon> tbachman: “colindixon acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs”
15:03:56 <tbachman_> #info tbachman acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs
15:04:03 <colindixon> sweet
15:04:16 <colindixon> ok, I mean, the next thing is to hunt people down via e-amil and IRC
15:04:20 <colindixon> which is all we can do
15:04:35 * edwarnicke casts about for his spear and face paint
15:04:36 <colindixon> and we’ll probably have to re-cut again on Tuesday, but we can hope
15:04:48 * edwarnicke is more hopeful that colindixon
15:04:48 * colindixon is ever the optimist
15:04:57 <colindixon> ok
15:05:00 <hideyuk__> #info Hideyuki acks that he understands RC2 artifact will be release artifacts barring show stoping bugs
15:05:03 <colindixon> thanks!
15:05:17 <edwarnicke> edwarnicke: I think we are pretty likely to get a good image out of RC2... I may be up all night fixing small issues in build... but I think we will get a good image
15:05:22 <colindixon> #topic project status reports/issues
15:05:31 <colindixon> any projects have issues that they want to bring up
15:05:41 <tbachman_> #info groupbasedpolicy is seeing two NPEs
15:05:41 <colindixon> I know that VTN is likely still working on things, how is that going hideyuk__
15:05:47 <tbachman> Was going to see if anyone else has encountered them
15:05:47 <tbachman> or if they’re already known and being fixed
15:06:01 <colindixon> tbachman: do we have bugs?
15:06:02 <gzhao> Luis yesterday mentioned some bug in openflow plugin
15:06:04 <tbachman> not yet
15:06:10 <tbachman> yeah
15:06:15 <edwarnicke> tbachman_: Which things?
15:06:17 <tbachman> I’ll open them now
15:06:19 <colindixon> tbachman: can we file bugs to track them?
15:06:30 <edwarnicke> tbachman: many thanks :)
15:06:34 <tbachman> colindixon: will get right on this — and will put the bugs in here :)
15:06:40 <colindixon> thanks
15:06:47 <colindixon> gzhao: we probably want to keep a list of known blocking bugs
15:07:09 <gzhao> colindixon: yes
15:07:32 <gzhao> colindixon: but we need to have bugs reported first
15:07:47 <hideyuk__> #info VTN project is working on system test failures. https://lists.opendaylight.org/pipermail/vtn-dev/2014-September/000608.html
15:07:57 <colindixon> #undo
15:07:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x250de10>
15:08:14 <colindixon> #link https://lists.opendaylight.org/pipermail/vtn-dev/2014-September/000608.html hideyuk__ says VTN project is working on system test failures
15:08:20 <colindixon> it will end up as a link that way
15:08:33 <colindixon> any other projects facing issues
15:08:49 <colindixon> I’m assuming not (or that nobody’s testing) since we haven’t heard anything
15:09:07 <colindixon> #action colindixon to work with gzhao to start making a list of known helium blocking bugs
15:09:26 <colindixon> #action colindixon to work with gzhao to hunt down projects make them fill out the testing spreadsheet
15:09:46 * gzhao is a little surprised no one says anything about 9/22
15:10:00 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 this is the helium testing spreadsheet
15:10:09 * regXboi suspects people are in shock
15:10:15 <colindixon> gzhao: what projects are still in yellow/red?
15:10:27 <gzhao> red: documentation
15:10:28 * regXboi wanders away - back in a few
15:10:39 <gzhao> yellow: integration, ovsdb and pcmm
15:10:56 <gzhao> I think ovsdb probably should be moved to green
15:11:00 <tbachman> here’s one: https://bugs.opendaylight.org/show_bug.cgi?id=1984
15:11:01 <colindixon> have you heard from the yellow projects about why they’re yellow and if they’ll get to green?
15:11:15 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=1984 one of the NPE bugs reported by GPB
15:11:41 <colindixon> #info documentation is still a project in red (but that is known and unlikely to change)
15:11:49 <gzhao> Madhu: can you confirm that ovsdb is green (
15:12:14 <colindixon> #info pcmm, integration and ovsdb are currently yellow
15:12:22 <tbachman> and the other https://bugs.opendaylight.org/show_bug.cgi?id=1985
15:12:24 <colindixon> I understand why integration might be yellow
15:12:37 <gzhao> colindixon: initially projects are put in M5 status, and with reduced scope complete Karaf etc, they moved to green
15:12:40 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=1985 the other NPE bug reported by GBP
15:12:43 <tbachman> #link https://bugs.opendaylight.org/show_bug.cgi?id=1985 the other NPE reported by GBP
15:12:48 <colindixon> #undo
15:12:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x251cc90>
15:13:12 <colindixon> gzhao: yeah I understand that
15:13:15 <tbachman> I think Madhu might have also seen that first one
15:13:18 <tbachman> in OVSDB
15:13:38 <colindixon> so, Madhu and xsited do you know if pcmm and ovsdb should be moved to green?
15:14:20 <colindixon> #action gzhao to follow up with Madhu and xsited directly about ovsdb and pcmm to figure out if they can be moved to green
15:14:27 <Madhu> gzhao: colindixon we are facing issues with flow programming
15:14:27 <colindixon> #topic blocking issues
15:14:43 <Madhu> so guys.. not sure how folks are moving project to green
15:14:45 <colindixon> #undo
15:14:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x251cd90>
15:14:52 <colindixon> Madhu: we haven’t
15:14:58 <Madhu> is it okay to move projects to green status even with known issues ?
15:15:01 <colindixon> do you have a link for the bug(s)
15:15:20 <tbachman> colindixon: I think he’s seen the same as 1984
15:15:22 <Madhu> colindixon: yes. we have opened quite a few
15:15:22 <gzhao> Madhu: Karaf feature tested alone and compatibility, testing and documentation are on schedule
15:15:39 <gzhao> Madhu: no blocking issue
15:15:50 <colindixon> Madhu: no, but we’re trying to understand where we’re at in terms of things
15:15:57 <colindixon> so if you have blocking bugs
15:16:01 <colindixon> we’d like to track them
15:16:10 <colindixon> so we can get things together as efficiently as possible
15:16:13 <Madhu> colindixon: gzhao yes. we have blocking issues
15:16:20 <colindixon> Madhu: I got that
15:16:30 <Madhu> we are working actively to debug / fix some of them
15:16:42 <colindixon> #Info Madhu notes that ovsdb is having issues with flow programming (blocking issues), hence being yellow
15:17:00 <tbachman> #info tbachman notes that GBP is having issues with flow programming (blocking issue)
15:17:03 <edwarnicke> abhijitkumbhare: Do you have any report of issues for OFplugin from OVSDB ?
15:17:19 <colindixon> Madhu: and did you hear that the current plan is to try to use RC2 artifacts (cut on Monday) for Helium release if we don’t have any show-stopping bugs?
15:17:32 <gzhao> colindixon: Madhu having blocking issue is red status
15:17:40 <edwarnicke> tbachman: Anything other than 1984 and 1985 ?
15:17:43 <Madhu> colindixon: yep. I saw the emails :)
15:17:54 <gzhao> colindixon: Madhu :yellow is documentation and testing behind schedule.
15:17:57 <tbachman> edwarnicke: those are the only ones I have
15:18:08 <colindixon> Madhu: so, if you have bugs with links, gzhao, edwarnicke, and everyone can try to help
15:18:23 <edwarnicke> tbachman: OK... and how are they blocking flow programming (one looks like a stats issue and the other an issue on switch disconnect at at glance)
15:18:24 <colindixon> gzhao and I are going to keep a list of blocking bugs so that we have some idea of where we stand
15:18:33 <edwarnicke> tbachman: (not objecting, trying to understand :) )
15:18:44 <Madhu> guys. the bugs aren't specific to openflowplugin or mdsal or yangtools
15:18:47 <tbachman> edwarnicke: certainly :)
15:18:52 <Madhu> there are bugs in also usage
15:18:57 <tbachman> I seem to miss the last 2 flows on one node
15:18:58 <abhijitkumbhare> edwarnicke - I don't see any reported bugs from OVSDB to OF plugin at the moment
15:18:59 <Madhu> which are specific to ovsdb as well
15:19:02 <tbachman> 58/58 are good on one
15:19:04 <Madhu> i will send u guys the bug id
15:19:06 <edwarnicke> abhijitkumbhare: Have you had any report of bugs to OFplugin from OVSDB?
15:19:07 <tbachman> but only 56/58 are on the other
15:19:32 <colindixon> edwarnicke: abhijitkumbhare responded above saying “I don't see any reported bugs from OVSDB to OF plugin at the moment”
15:19:34 <tbachman> it doesn’t happen every time, either
15:19:35 <Madhu> edwarnicke: please read my messages agove.
15:19:59 <abhijitkumbhare> Madhu edwarnicke - are there any blocking issues?
15:20:06 <colindixon> #info Madhu notes that these issues may not turn out to be bugs outside of OVSDB
15:20:15 <edwarnicke> tbachman: So clearly we need to dig into that, do you have reason to tie those to 1984 and 1985 (asking because I am trying to prioritize getting the flows working, and I am guessing the NPEs may not be related to that)
15:20:24 <Madhu> edwarnicke: abhijitkumbhare we are debugging issues...
15:20:26 <edwarnicke> Madhu: Thank you for doing the debugging work
15:20:42 <colindixon> Madhu: even so, it would be nice to have (even a really simple one line) bug report for those things so people outside OVSDB can track things as well and maybe help
15:20:42 <Madhu> edwarnicke: abhijitkumbhare it takes time and am here in this meeting when debugging :)
15:20:44 <edwarnicke> Madhu: How can we help you to make sure that if these are outside OVSDB, they get handled asap?
15:20:56 <tbachman> edwarnicke: yeah, flows are most important. If those bugs are unrelated, am happy to ignore.
15:21:16 <edwarnicke> tbachman: I don't *know* they are unrelated ;)  I was just curious if you knew they *were* related :)
15:21:54 <tbachman> edwarnicke: I need to triple-check, but I don’t believe I see the NPEs when it works (doesn’t happen every time)
15:21:55 <edwarnicke> tbachman: Which two flows are missing?
15:21:59 <Madhu> colindixon: edwarnicke gzhao abhijitkumbhare we are all working actively on issues... we don't know the exact root-causes. we don't want to file a bug stating "flow programming is broken". it can very well be usage issue
15:21:59 <tbachman> the last two :)
15:22:04 <edwarnicke> tbachman: That is very useful info
15:22:05 <Madhu> and some are very random
15:22:13 <tbachman> actually
15:22:16 <tbachman> I take that back
15:22:24 <tbachman> I need more runs
15:22:27 <tbachman> to be sure
15:22:29 <Madhu> we will pass on the bug info today once we get somewhere.
15:22:30 <edwarnicke> Madhu: You have my cell ( 919-621-0958 )... seriously, call me as soon as you know.
15:22:37 <colindixon> since we’re on the topic already
15:22:39 <Madhu> edwarnicke: thanks sir. i will
15:22:41 <colindixon> #topic blocking issues
15:22:42 * tbachman will perform some more debugging
15:22:49 <gzhao> Madhu: also could you ack like “colindixon acks that he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs”
15:22:51 <Madhu> tbachman: are u testing in karaf ?
15:23:09 <Madhu> gzhao: ack.
15:23:25 <gzhao> Madhu: thanks
15:23:30 <colindixon> #Info tbachman and Madhu seem to be debugging potentially-related issues around flow programming and will keep people abreast of the issues
15:23:40 <Madhu> colindixon: thanks
15:23:50 <gzhao> #info Madhu acks he understands RC2 artifacts (cut Monday at 5p pacific) will be release artifacts barring show stoping bugs
15:23:52 <Madhu> edwarnicke: 1 clue though
15:23:53 <colindixon> thanks
15:24:04 <gzhao> ChristineH: welcome
15:24:06 <Madhu> when i have a bunch of flows to be programmed in quick succession
15:24:08 <colindixon> so, do we have other blocking issues
15:24:18 <Madhu> the flow programming doesn't fail.. but gets lost somewhere in the jungle
15:24:25 <Madhu> so i had to introduce thread.sleep to make it work .
15:24:32 <Madhu> yep... Thread.sleep().
15:24:34 <colindixon> #info we have a break in auot-release which edwarnicke is hunting down
15:24:41 <Madhu> I need that sleep... but am giving it to my code
15:24:48 <tbachman> RODL
15:24:52 <tbachman> ROFL even ;)
15:24:54 <colindixon> :-)
15:24:59 <colindixon> any other known blocking issues
15:25:07 <tbachman> Rolling out the door laughing?
15:25:23 <gzhao> ChristineH: did you resolve the issues you found yesterday?
15:25:39 <Madhu> brb guys. busy debugging. ping if it is absolutely needed :). thanks for all the great work colindixon gzhao edwarnicke
15:25:51 <colindixon> ChristineH: just so you know, we are planning to cut RC2 artifacts on monday at 5p pacific (midnight UTC between 9/22 and 9/23) and use them for the helium final release unless there are show-stopping issues
15:25:58 <gzhao> Madhu: thanks
15:26:09 <colindixon> ChristineH: it would be great if you could ack that just so we know that you understand :-)
15:26:11 <ChristineH> hi gzhao and all. SNMP4SDN's status is still yellow, because karaf command problem is still not yet solved (but already move forward than yesterday), I think the bug is internal and will be solved soon. Besides, snmp4sdn's MD-SAL is not yet completed.
15:26:38 <ChristineH> colindixon: I see.
15:27:15 <ChristineH> gzhao: the karaf command can be seen now, just there's other internal bug.
15:27:36 <colindixon> gzhao, ChristineH: what is the issue?
15:28:43 <gzhao> ChristineH:  snmp4sdn's MD-SAL is not yet completed? only bug fixing should be done at this stage
15:28:58 <gzhao> colindixon: yesterday ChristineH
15:29:24 <gzhao> colindixon: could see karaf command after installed feature, today it seems to be different issue.
15:29:43 <gzhao> colindixon: s/could/couldn't
15:30:36 <colindixon> #info it appears as though snmp4sdn is having issues with karaf and may or may not be code-frozen
15:31:04 <colindixon> gzhao: that would indicate that the karaf features were blocking while loading
15:31:13 <colindixon> was the integration feature test still working?
15:32:36 <gzhao> colindixon: bundle:list showed it miss some dependency, I think ChristineH
15:32:39 <gzhao> fixed that
15:33:09 <ChristineH> gzhao, colindixon: the APIs which are exposed by MD-SAL are frozen, but I didn't have enough time to carefully test the implementation
15:33:27 <colindixon> ChristineH: ah so this is testing
15:34:08 <colindixon> #info ChristineH notes that the the part of the code which isn’t frozen is because of bug testing
15:34:25 <colindixon> ChristineH: please reach out to gzhao, edwarnicke, me or anyone else
15:34:28 <colindixon> if you need help
15:34:48 <ChristineH> colindixon: thanks! :)
15:35:00 <gzhao> ChristineH: do you have a bug that can used to track the issue?
15:35:57 <ChristineH> gzhao: not yet, but I believe should :)
15:36:04 <gzhao> any other projects have issue or status
15:36:15 <gzhao> meeting time is 6 minutes over
15:36:15 <ChristineH> let me post them later.
15:36:24 <gzhao> ChristineH: thanks
15:36:31 <colindixon> #action ChristineH to file a bug around the issues they are facing, she will e-mail gzhao with that info
15:36:43 <colindixon> edwarnicke, gzhao or any other projects have blocking issues?
15:36:49 <colindixon> otherwise, we’l end the meeting
15:37:09 <gzhao> I don't have anything now
15:37:24 <colindixon> ok
15:37:34 <colindixon> thanks everyone!
15:37:39 <colindixon> #endmeeting