14:30:22 <gzhao> #startmeeting release daily sync
14:30:22 <odl_meetbot> Meeting started Mon Sep 22 14:30:22 2014 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:30:22 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:30:22 <odl_meetbot> The meeting name has been set to 'release_daily_sync'
14:30:40 <gzhao> #topic roll call
14:30:43 <phrobb> #info Phil Robb
14:30:45 * tbachman runs into the meeting
14:30:50 <tbachman> #info tbachman for groupbasedpolicy
14:30:58 <LuisGomez> info LuisGomez for integration
14:31:12 <LuisGomez> #info LuisGomez for integration
14:31:19 <oflibMichal> #info oflibMichal for openflowjava
14:31:21 <gzhao> #info gzhao for release
14:31:35 <abhijitkumbhare> #info abhijitkumbhare for openflowplugin
14:31:39 <xsited1> #info thomas packetcable
14:32:03 * colindixon forgot to put water in the coffee pot before turning it on and jumping in the shower
14:32:07 <gzhao> #chair colindixon tbachman edwarnicke
14:32:07 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao tbachman
14:32:14 <tbachman> colindixon: lol
14:32:17 <tbachman> crisis :)
14:32:21 <colindixon> #info colindixon for TTP (and caffeine)
14:32:29 <tbachman> my fingers won’t move w/o it
14:32:51 <PriyankaChopra> #info PriyankaChopra for plugin2oc
14:32:54 <abhijitkumbhare> gzhao & edwarnicke  will have to  disappear for 10-15 min to drop the kid to school at 7:45 or 7:50
14:32:59 <goldavberg_> #info goldavberg for lispflowmapping
14:33:23 <gzhao> abhijitkumbhare: ok
14:33:30 <gershon> #info gershon defense4all
14:33:46 <abhijitkumbhare> sorry should have said: gzhao & edwarnicke, I will have to  disappear for 10-15 min to drop the kid to school at 7:45 or 7:50
14:34:06 <gzhao> oh
14:34:29 <abhijitkumbhare> not gzhao & edwarnicke 's kid :)
14:34:37 <gzhao> abhijitkumbhare: lol
14:35:26 <edwarnicke> #info edwarnicke
14:35:35 * edwarnicke was just updating the spreadsheet :)
14:35:48 <gzhao> #topic auto-release
14:36:04 <gzhao> auto-release just succeeded about 3 minutes ago
14:36:15 <gzhao> #77
14:36:37 <gzhao> edwarnicke: do you have any update for auto release
14:36:40 <edwarnicke> gzhao: Nightly went out
14:36:57 <colindixon> #link https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ auto-release #77 just worked a few minutes back
14:37:00 <gzhao> edwarnicke: yes, RC1-6 was in nexus
14:37:06 <edwarnicke> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_.28Your_Project.2FFeatures_in.29_RCs <- included last night nightly
14:38:25 <gzhao> #topic blocking issues
14:38:44 <gzhao> https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163
14:38:52 <tbachman> #info groupbasedpolicy is working with openflowjava team to resolve a blocking bug on group mod programming
14:39:11 <tbachman> #link https://bugs.opendaylight.org/show_bug.cgi?id=2023 <= bug for openflowjava bug affecting groupbasedpolicy
14:39:30 <edwarnicke> #info root cause of 1997 identified.  I have tested a 'machete' fix and gone from reliable failure to reliable success... michal_rehak is working on a proper fix and expects it to be done in an hour or so
14:39:55 <tbachman> #info we also have a new bug filed, where our application doesn’t always seem to start
14:40:05 <edwarnicke> colindixon: Would you please verify 1991 is fixed?
14:40:09 <tbachman> #link https://bugs.opendaylight.org/show_bug.cgi?id=2019 <= Bug for groupbasedpolicy application not starting every time
14:40:27 <edwarnicke> tbachman: Could we get more data there on 2019 ?
14:40:40 <edwarnicke> tbachman: what does failure look like?  any exceptions in the logs, etc
14:40:46 <tbachman> edwarnicke: will do — I have a capture
14:40:51 <edwarnicke> tbachman: ACK
14:40:52 <colindixon> #action colindixon to verify that bug 1991 is fixed ASAP
14:41:22 <tbachman> edwarnicke: updated
14:41:26 <gzhao> there are still 26 bugs on http://goo.gl/AhRSfF
14:42:18 <tbachman> gzhao: today will be a busy day :)
14:42:20 <tbachman> lol
14:42:32 <edwarnicke> gzhao: 2000 appears to be an artifact of 1997
14:43:19 * tbachman forgets if we’re using the TWS for release purposes today
14:43:31 <edwarnicke> hideyuki has confirmed 1988 fix is in, and he hypothesised https://bugs.opendaylight.org/show_bug.cgi?id=1993 was a side effect of 1988
14:43:33 <gzhao> what if some blocking issue cannot be resolved by 5:00 PST today
14:43:38 <tbachman> #info there are still 26 bugs on http://goo.gl/AhRSfF
14:43:44 <abhijitkumbhare> edwarnicke - about 1985; mbobak (martin bobak) is working on a better fix with vishnoianil's help (instead of prasanna's null check fix https://git.opendaylight.org/gerrit/#/c/11434 as marked in the spreadsheet - I expect it done today sometime)
14:43:46 * edwarnicke begs not to have a call, just do IRC
14:43:54 <edwarnicke> abhijitkumbhare: Good to know :)
14:43:55 * regXboi wanders in
14:44:00 <tbachman> #link http://goo.gl/AhRSfF <= helpful lnk created by colindixon for looking up showstopper bugs
14:44:08 <colindixon> tbachman: thanks
14:44:12 <regXboi> edwarnicke: is  https://git.opendaylight.org/gerrit/#/c/11337/ still up in the air?
14:44:13 <colindixon> just saved me typing
14:44:20 <tbachman> colindixon: thank YOU :)
14:44:26 <tbachman> (for creating that link)
14:44:29 <edwarnicke> regXboi: please please please check https://git.opendaylight.org/gerrit/#/c/11337/
14:44:37 <edwarnicke> regXboi: I have no one else to turn to to check windows stuff
14:44:49 <edwarnicke> regXboi: This is long since fixed in unix
14:45:01 * regXboi goes to build
14:45:44 <edwarnicke> dave_tucker: What do you know about https://bugs.opendaylight.org/show_bug.cgi?id=1885
14:45:57 <tbachman> 1885?
14:45:59 <edwarnicke> dave_tucker: Its a bit old, and I am aware of fixes that probably fixed this
14:46:01 <tbachman> that was like… so long ago
14:46:08 <abhijitkumbhare> abhijitkumbhare disappears
14:46:26 <zxiiro> Hi Folks, I'm Thanh Ha. I'm just starting today at LF and will be working with you all on OpenDaylight.
14:46:35 <tbachman> zxiiro: welcome :)
14:46:41 <gzhao> Do we have any blocking issue that hasn't been attended ?
14:46:47 <phrobb> gzhao, for process sake should all bugs presented on Colin's showstopper list be represented in the "Blocking Issues" spreadsheet?
14:46:49 <gzhao> zxiiro: welcome
14:46:55 <phrobb> Welcome zxiiro!
14:46:58 <alagalah> #info alagalah for GBP
14:46:58 <colindixon> welcome zxiiro
14:47:19 <edwarnicke> phrobb: Which list?
14:47:27 <regXboi> ok... this is going to be a while - my .m2 is so out of date I don't remember precisely when it was in date
14:47:28 <edwarnicke> phrobb: link ?
14:47:30 <gzhao> phrobb: it listed in the first line.
14:47:30 <hideyuki_> #info Hideyuki for VTN
14:47:33 <alagalah> edwarnicke: Its linked above
14:47:38 <alagalah> edwarnicke: by tbachman
14:47:53 <gershon> edwarnicke: Q please: Does today 5 PST RC2 should be launched? We have some defense4all fixes in gerrit now...
14:47:53 <zxiiro> Thanks :)
14:48:18 <edwarnicke> phrobb: Quite a few of those are either ancient or junk http://goo.gl/AhRSfF
14:48:37 <edwarnicke> phrobb: We should definitely scrub it down, but you will swamp out the *actual* show stoppers if you dump that in
14:48:48 * regXboi fires up windows VM while waiting for test build
14:49:02 <colindixon> gershon: fixes that get in by 5p will ship with RC2
14:49:06 <colindixon> 5p pacific
14:49:11 <phrobb> edwarnicke:  cool, don't want to drown the real info, but want to make sure we are capturing status on all outstanding showstoppers
14:49:13 <edwarnicke> gershon: yes, 5pm PST RC2 goes out, and RC2 will be the release artifacts unless there are showstoppers in which case we will respin
14:49:20 <edwarnicke> phrobb: totally :)
14:49:24 <colindixon> our plan is to make RC2 the release version unless there are showstoppers
14:49:43 <tbachman> ~6hr
14:49:51 <tbachman> er
14:49:53 <tbachman> 9nr
14:49:55 <tbachman> lol
14:49:57 <alagalah> colindixon: Is "showstopper" defined as any bug causing a "blocked" yellow status for any project?
14:49:58 <gzhao> phrobb: edwarnicke I will take an action on the list http://goo.gl/AhRSfF
14:50:22 <tbachman> gzhao: action… to.. ?
14:50:39 <edwarnicke> colindixon: to be precise, RC2 will be cut tonight with release versions or Helium to a staging repo.  The TSC is expected to decide whether to bless those to the release repo on Thursday if we don't find showstoppers in subsquent testing.  My point is... the train *is* leaving tonight.. the only question is if there will be subsequent trains
14:50:47 * tbachman isn’t opposed to gzhao doing actions… just wasn’t sure what the action was here
14:50:50 <colindixon> alagalah: showstopper is not explicitly defined, but casually I’ve been thinking that it’s “a project says they can’t be used in the state that they exist in RC2"
14:51:06 <alagalah> colindixon: Good enough
14:51:06 <gershon> colindixon & edwarnicke: great, thanks, so we (defense4all) will deliver our fixes up to 5p PST...
14:51:08 <colindixon> edwarnicke: thank you
14:51:09 <edwarnicke> gershon: I would strongly advice you to treat 5pm PST tonight as the *hard* deadline
14:51:27 <colindixon> #info edwarnicke says “to be precise, RC2 will be cut tonight with release versions or Helium to a staging repo.  The TSC is expected to decide whether to bless those to the release repo on Thursday if we don't find showstoppers in subsquent testing.”
14:51:38 <colindixon> #info edwarnicke follows up with “My point is... the train *is* leaving tonight.. the only question is if there will be subsequent trains"
14:51:46 <gzhao> colindixon: edwarnicke phrobb : understand RC2 is final cut, if blocking issue fix cannot go by time, do we delay cutting
14:52:08 <alagalah> edwarnicke: gershon Silly question... if defense4all submits fixes, how long does it take to get into Nexus so that the RC2 build at 5pm picks them up? Surely that would be the "hard" deadline?
14:52:11 <gzhao> tbachman: to go through the list and see if it should be listed as blocking issue
14:52:18 <colindixon> #info alagalah asks what “showstopper” is defined to be
14:52:22 <edwarnicke> alagalah: Excellent point
14:52:30 * regXboi watches the build spin
14:52:33 <colindixon> #info colindixon responds “showstopper is not explicitly defined, but casually I’ve been thinking that it’s that a project says they can’t be used in the state that they exist in RC2"
14:52:46 <edwarnicke> alagalah: As a point of clarification, autorelease builds from *master* (or in a few cases, project specified alternate branch)
14:52:58 <tbachman> gzhao: okay — we probably should push the projects to revisit some of them…. as edwarnicke points out, there are probably things in there that are either fixed, old, no longer applicable, duplicates of more recent ones, etc.
14:52:59 <edwarnicke> alagalah: So if defense4all gets their patches into their master branch, they are good
14:53:08 <alagalah> edwarnicke: As in the merge completes, correct?
14:53:14 <edwarnicke> alagalah: Yes
14:53:20 <colindixon> alagalah: if it’s in git on master (or the other branch) we build i, so nexus doesn’t matter
14:53:24 <edwarnicke> alagalah: And I would also really appreciate it if it built ;)
14:53:27 <gzhao> tbachman: yes
14:53:31 <tbachman> #info edwarnicke points out that autorelease builds from *master* (or in a few cases, project specified alternate branch) for final RC
14:53:34 <alagalah> colindixon: edwarnicke Appreciate clarification.
14:54:05 <phrobb> gzhao: If we have blocker issues still outstanding at 5pm today, I do not see a reason to tag the build  as a Release.  That said, all projects with a blocking bug should be doing everything they can to apply a fix by 5pm today.
14:54:17 <gzhao> edwarnicke: are we able to get another VM, so we can run test build more frequently?
14:54:24 <edwarnicke> #link https://jenkins.opendaylight.org/odlautorelease/job/autorelease-helium-worker/ autorelease builds... please watch, if your stuff breaks, please fix
14:54:25 <colindixon> alagalah: also, I *think* that the jenkins merge job doesn’t need to succeed for things to be merged onto master, they are merged immeditagely on +2 and submit and if merge fails you have to work that out after the fact
14:54:30 <gzhao> is this something that zxiiro can help?
14:54:39 * edwarnicke will not be in a slow and gentle mood chasing down folks who break autorelease today ;)
14:54:50 <dlenrow> Sorry I'm late have you discussed status of AAA issues that came up over the weekend?
14:54:51 <gershon> edwarnicke: Sure, we will be ready much before 5pm...
14:54:52 <tbachman> lol
14:54:52 <edwarnicke> colindixon: That is the normal way
14:54:54 <alagalah> colindixon: ty
14:55:10 <phrobb> dlenrow:  not we have not
14:55:15 <colindixon> #info gzhao asks if we will delay the RC2 build if there are show stoppers
14:55:17 <dlenrow> phrobb: thx
14:55:33 <gzhao> dlenrow: not yet
14:55:41 <alagalah> gzhao: I think Ed addressed that
14:55:48 <colindixon> #Info phrobb responds that there’s probably no reason to tag it for release if theyre are known, non-fixed showstoppers still there, but all projects should be running hard to fix show stoppers by 5p pacific
14:55:53 <edwarnicke> gzhao: No... the RC2 build will not be delayed for showstoppers... but there is the possiblity of respin for showstoppers
14:56:32 * gzhao find colindixon types really fast
14:56:33 <colindixon> #info colindixon also notes, per edwarnicke’s comment above, that RC2 is just going to go in a staging zone, so that decision can be made after the fact, thus delaying the build seems inadvisable, we’ll just run it again later
14:56:51 <edwarnicke> colindixon: thank you for your clarification, hugely helpful :)
14:56:59 <alagalah> gzhao: edwarnicke So its not a matter of IF RC2 is built tonight, but a matter of whether it is picked up as the Release by the TSC on Thu, correct ?
14:57:06 <edwarnicke> alagalah: Yes
14:57:10 <colindixon> alagalah: exactly!
14:57:19 * colindixon points up to his #info ^^^^^
14:57:27 * alagalah <<<----- is Captain Obvious
14:57:41 <edwarnicke> alagalah: To the rescue! :)
14:57:55 <gzhao> alagalah: yes
14:58:30 * edwarnicke wonders about #repeat
14:58:35 <gzhao> dlenrow: any progress for the two blocking issue for AAA
14:58:56 <alagalah> edwarnicke: #deja-vous
15:01:09 <colindixon> ok
15:01:09 <gzhao> any bug should be listed in the blocking issue spreadsheet and are not? except for GBP's 2023,2019
15:01:26 <edwarnicke> gzhao: 2023 is there :)
15:01:27 * alagalah is relieved, thought the IRC silence meant the interwebs was asleep
15:02:16 <gzhao> edwarnicke: refresh, then saw it
15:02:27 <edwarnicke> gzhao: :)
15:02:28 <colindixon> #action everyone go look at the bug list and find your project and deal with them here: http://goo.gl/AhRSfF
15:03:18 <gzhao> #topic testing status
15:03:27 <colindixon> #undo
15:03:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x272e110>
15:03:28 <colindixon> one sec
15:03:40 <gzhao> colindixon: sorry
15:03:42 <colindixon> #action “deal with them” means (i) fix them and change their status to resolved, (ii) change their status because they’ve already been fixed, (iii) change the target milestone to Lithium, and/or (iv) revise their severity down from critical or blocker
15:03:47 <colindixon> #topic testing status
15:03:49 <colindixon> go :-)
15:03:57 <gzhao> according to https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309
15:04:17 <gzhao> about 50% testing not yet completed for top level karaf features
15:04:19 <colindixon> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309 the testing spreadsheet
15:04:26 <edwarnicke> gzhao: Could we move this tab to the big spreadsheet... I couldn't find it this weekend
15:04:43 <gzhao> edwarnicke: ok
15:04:51 <colindixon> that looks like less than half
15:04:55 <colindixon> edwarnicke: meeting minutes
15:04:59 <edwarnicke> colindixon: I can fill in a lot of those
15:05:00 <colindixon> edwarnicke: they will rock your world
15:05:15 <edwarnicke> gzhao: colindixon is right, leave it be so others keep finding it where they expect it
15:05:54 * regXboi watches the build spin more
15:06:30 * tbachman hands regXboi a karaf of ODL to enjoy while he waits
15:06:40 <gzhao> edwarnicke: I will make a copy or link to the big spreadsheet
15:06:44 <colindixon> #info gzhao generously says we have half of our top-level-features tested, it looks like 11/27 this second
15:06:46 <tbachman> (sorry folks)
15:06:49 <regXboi> tbachman: really???
15:06:57 <tbachman> lol
15:06:59 <colindixon> :-)
15:07:03 <colindixon> tbachman can stay
15:07:32 <colindixon> #info edwarnicke says he has a lot of things he can fill in this second
15:07:32 <abhijitkumbhare> back
15:08:01 <colindixon> #action test your projects!!!!! TEST THEM NOW!!!!! (and report it on the testing spreadsheet)
15:08:05 <gzhao> abhijitkumbhare: that is really quick
15:08:34 <abhijitkumbhare> its just 6-7 min away :)
15:08:39 * edwarnicke has actually poked primary sources of data to fill things in
15:08:47 <colindixon> #link https://wiki.opendaylight.org/view/Karaf:Step_by_Step_Guide#How_to_Test_.28Your_Project.2FFeatures_in.29_RCs that page contains info on how to get RCs to test with, how to run them, and where to report the results
15:09:00 <colindixon> edwarnicke: noted
15:09:10 <regXboi> edwarnicke: I just needto test the empty snapshot, correct?
15:09:13 <colindixon> edwarnicke: that wiki page actually ends with a link to the testing sheet and an explanation
15:09:38 <colindixon> ok….
15:09:48 <colindixon> TEST!!! TEST!!!! TEST!!!! !!!! !!!!! !!!!!
15:09:55 <colindixon> I think this topic is done :p
15:10:21 <colindixon> I think /shout should just find all nicks in the room and append them to the end of the message (that would be really useful)
15:10:43 <gzhao> shall we have each project to give a brief status to see how likely 5:00pm RC2 cut can be met
15:10:56 <edwarnicke> regXboi: You need to build opendaylight-karaf-resources, then integration/distributions/extra/karaf, then run cd integration/distributions/extra/karaf/target/assembly/bin, ./karaf and confirm with the windows equivalen to of ps that you see the correct mem flags for the JVM
15:10:58 <colindixon> gzhao: do we have anything else?
15:11:10 <edwarnicke> gzhao: 5pm PST cut will happen
15:11:18 <regXboi> edwarnicke: why?
15:11:30 <colindixon> gzhao: if we have nothing else, we can ask teh projects we have
15:11:33 <regXboi> isn't all I need to do is run the setenv and then check the env?
15:12:00 <gzhao> colindixon: not on this topci
15:12:09 <gzhao> s/topci/topic
15:12:44 <gershon> edwarnicke: sorry for dumb question, how can we retest defense4all not breaking anything in autorelease env after our merges...?
15:12:49 <edwarnicke> regXboi: You need to confirm that when you run karaf it is getting those setting by default on windows
15:13:00 <edwarnicke> gershon: Sort of :)
15:13:04 <colindixon> #topic blocking issues (counting down to midnight UTC)
15:13:11 <edwarnicke> gershon: autorelease runs a test build about every 4 hours
15:13:22 <edwarnicke> gershon: So that tests things in general :)
15:13:31 <gzhao> gershon: your change will be picked by scheduled autorelease test happened every 4 hours
15:13:47 <colindixon> are there projects which are concerned they will still have blocking issues in a bit over 9 hours?
15:13:50 <colindixon> that’s the question
15:14:00 <gzhao> edwarnicke: can we make this to be 2 hours by adding one more testing VM
15:14:27 <gershon> edwarnicke: great, understood, I'll follow the next autorelease build for our testings...
15:14:33 <alagalah> colindixon: tbachman I would say GBP fits that category with what we know now... correct tbachman?
15:14:45 <tbachman> alagalah: as in concerned?  yes
15:14:48 <gzhao> snmp reported still hasn't resolved the two blocking issues they have
15:15:17 <edwarnicke> gzhao: We could... and we technically have a second test VM... but the second test VM is broken and I haven't had time to sort that out :(
15:15:21 <tbachman> #info colindixon asks are there projects which are concerned they will still have blocking issues in a bit over 9 hours?
15:15:34 <tbachman> #info snmp reported still hasn't resolved the two blocking issues they have
15:15:44 <alagalah> colindixon: gzhao GBP currently is blocked by Bug#1997. Even though progress has been made, I have not seen an ETA for fix, hence, as of 08:15 PDT, we are blocked. tbachman fair?
15:15:59 <gzhao> edwarnicke: something helpdesk can help us?
15:16:03 <tbachman> alagalah: it’s actualy not 1997 — it’s 2023
15:16:09 <tbachman> 1997 is the OVDSB one, I think
15:16:18 <colindixon> #info alagalah and tbachman say that bug 2023 is blocking GBP at the moment, so that’s an issue
15:16:20 <alagalah> tbachman: It changed? I put all my data into 1997 yesterday
15:16:36 <tbachman> alagalah: ah… yeah, that’s a different problem
15:16:43 <tbachman> we were thinking they might be the same
15:16:51 <colindixon> #undo
15:16:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x282f310>
15:16:51 <edwarnicke> #info we thought 2023 was 1997 until a few hours ago
15:16:58 <alagalah> Apologies, off topic...#2023
15:16:59 <tbachman> but ed has found that they are not (1997 is openflowplugin, 2023 is openflowjava
15:17:03 <colindixon> #undo
15:17:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x282f310>
15:17:19 <edwarnicke> #info 1997 root cause has been idenfied, fix on the way
15:17:30 <colindixon> #info group based policy is blocking on two bugs right now 1997 and 2023
15:17:39 <alagalah> edwarnicke: colindixon gzhao Action to me to update 2023 with all the data I put into 1997 yesterday
15:17:42 <edwarnicke> alagalah: Are you guys blocking on 1997?
15:17:50 <gzhao> Madhu is aware of 1997?
15:17:50 <edwarnicke> alagalah: I thought you were only blocking on 2023?
15:17:52 <alagalah> edwarnicke: no, 2023
15:18:17 <tbachman> #undo
15:18:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x282ff10>
15:18:33 <tbachman> #info groupbasedpolicy is blocking on 2023
15:18:34 <colindixon> llo
15:18:50 * colindixon should have left things in tbachman’s hands
15:18:55 <tbachman> lol
15:19:02 <tbachman> no — you’re usually the right one :)
15:19:05 <tbachman> and actually
15:19:07 <tbachman> #undo
15:19:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x282ff10>
15:19:17 <tbachman> #info groupbasedpolicy is blocking on 2019 and 2023
15:19:20 <gzhao> any representative from AAA in this meeting?
15:19:22 <gershon> gzhao: thanks, will check it once ready...
15:19:33 <colindixon> it sound sounds like d4a has blocking issues
15:19:42 <colindixon> but they’re getting things fixed it sounds like that
15:19:49 <tbachman> gzhao: wasn’t dlenrow here?
15:20:08 <tbachman> (for aaa)
15:20:20 <gzhao> dlenrow: do we have someone working on bug 2009 and 2011
15:20:42 * tbachman wonders if dlenrow is actually dlenrow_afk
15:21:02 <gzhao> tbachman: we seem lost dlenrow
15:21:07 <tbachman> yeah
15:21:28 <tbachman> folks are busy :)
15:21:46 <colindixon> #info it sounds like defense4all has a few patches they need to get in, but are ready to go
15:21:57 * edwarnicke is about to get busy
15:22:10 <colindixon> #action gzhao to follow up with aaa to see about bugs 2009 and 2011
15:22:10 <tbachman> lol
15:22:11 <gzhao> tbachman: fix 1984 need GBP verifies
15:22:36 <tbachman> gzhao: good point — will do
15:23:02 <regXboi> so edwarnicke I have good news and bad news
15:23:05 <tbachman> edwarnicke: noticed in tony’s comment on 1984, there’s this: RegLoadNotifGroupDescStatsUpdatedCase
15:23:10 <edwarnicke> regXboi:Do tell
15:23:13 <tbachman> but GBP doesn’t use that
15:23:21 <regXboi> good news - it looks like the env gets set correctly
15:23:26 <edwarnicke> regXboi: Good
15:23:34 <regXboi> bad news - I can't prove your test to my satisfaction
15:23:41 <edwarnicke> regXboi: What is missing ?
15:24:04 <regXboi> windows does
15:24:15 <regXboi> windows doesn't like to give out environments of running processes
15:24:25 <regXboi> so I *think* it's correct
15:24:29 <regXboi> but I don't *KNOW*
15:25:05 <gershon> colindixon: ...defense4all just now finished to merge and build on master... waiting for the autorelease to see that nothing has been broken...
15:25:30 <edwarnicke> gershon: Many thanks :)
15:25:54 <colindixon> #info gershon says that defense4all has fixed all the show-stopping bugs they are aware of, but are waiting on auto-release to verify
15:26:00 <colindixon> the good news is that we should have one round of auto-release before 5p pacific :-)
15:26:02 <edwarnicke> gershon: You just now finished your merge?
15:26:02 <gzhao> edwarnicke: a new build just started 2 minutes ago
15:26:05 * regXboi looks some more
15:26:24 <edwarnicke> gershon: When did you finish your merge? and what is the commit id of your HEAD now?
15:26:31 <gzhao> gershon: edwarnicke let me restart it to make sure it picks up D4A in this round
15:26:43 <edwarnicke> gzhao: Sounds good :)
15:26:50 <dlenrow> We have people working on this. 2009 & 11
15:27:11 <colindixon> #info dlenrow says that that AAA has people working on bugs 2009 and 2011
15:27:13 <regXboi> ok edwarnicke: this patch isn't going to work
15:27:17 <colindixon> any other critical issues?
15:27:32 <gzhao> gershon: edwarnicke done
15:27:34 <regXboi> the problem is that the patches setenv.bat doesn't show up in the proper place in the distribution
15:27:37 <gershon> edwarnicke: https://jenkins.opendaylight.org/defense4all/job/defense4all-verify/59/ that is our latest build with changes...
15:27:54 <gzhao> gershon: normally it take ~4 hours for build to complete.
15:28:04 <colindixon> gershon: I think they’re just going to restart the current build
15:28:08 <colindixon> so that it includes your stuff
15:28:10 <gzhao> gershon: if it builds successfully
15:28:53 <gzhao> 2 minutes left
15:29:08 <gzhao> any topic?
15:29:21 <colindixon> #topic final call for issues
15:29:24 <regXboi> windows
15:29:32 <regXboi> sorry folks, it's gotta be said
15:29:45 <colindixon> #info colindixon imagines that this place will be busy for the rest of the day
15:29:51 <colindixon> #undo
15:29:51 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x282f910>
15:29:58 <gzhao> regXboi: should each project test on windows ?
15:30:17 <colindixon> gzhao, regXboi: without windows test infrastructure, I’m not sure how to do that
15:30:18 <regXboi> gzhao: I don't think that's going to happen
15:30:30 <regXboi> all I can do is say it looks correct
15:30:35 <regXboi> and right now, it doesn't
15:30:47 <gershon> gzhao: Great, many thanks!
15:31:05 <regXboi> the setenv.bat patch edwarnicke put in ends up putting the file in the wrong place
15:31:19 <regXboi> so it isn't picked up correctly by the karaf.bat when it runs
15:31:35 <edwarnicke> regXboi: Where is the right plalce?
15:31:40 <gzhao> ok, when people encounter issue, they should shout here or #odl-release
15:31:41 <edwarnicke> regXboi: Could you amend the patch?
15:31:47 <gzhao> incase there is a meeting here.
15:31:49 <regXboi> it needs to be in bin - the same place as karaf.bat
15:31:53 <gzhao> or ping me.
15:31:59 <colindixon> #info regXboi notest that edwarnicke’s windows patch to change JVM settings in karaf on windows appears to be incorrect
15:32:10 <edwarnicke> Doh
15:32:16 <regXboi> I don't think just changing the patch will get it there
15:32:22 <edwarnicke> regXboi: Could you amend the patch
15:32:29 <regXboi> you want it in resources/bin?
15:32:38 <edwarnicke> regXboi: regXboi Yep :)
15:32:52 <regXboi> ok, let me try that and if it works, I'll amend
15:33:07 <gzhao> #info when encounter blocking issues: please use #opendaylight-release #opendaylight-meeting or gzhao
15:33:16 <colindixon> sounds good
15:34:04 <colindixon> note that it’s #opendaylight-release (the second comment) not #odl-release (the first comment)
15:34:05 <colindixon> ok
15:34:14 <colindixon> I think we’ll just hang around and keep pushing
15:34:33 <colindixon> so, we can end this meeting whenever
15:35:02 <gzhao> colindixon: make this on going meeting?
15:35:18 <colindixon> gzhao: only if we want minutes
15:35:24 <colindixon> I’d at least end this meeting and start another
15:35:32 * tbachman seconds
15:35:38 <gzhao> colindixon: I guess there is no other meeting will use this channel
15:35:44 <colindixon> #endmeeting