16:58:31 <phrobb> #startmeeting TSC
16:58:31 <odl_meetbot> Meeting started Thu Jul 24 16:58:31 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:31 <odl_meetbot> The meeting name has been set to 'tsc'
16:58:38 <dmm> #info dmm
16:58:57 <colindixon> two minutes early!
16:58:58 <colindixon> wow
16:59:01 <phrobb> #topic TSC Members please #info in
16:59:09 <dlenrow> #info Lenrow
16:59:13 <alagalah> howdy y'all
16:59:31 <kwatsen> #info Kent Watsen
17:00:02 <phrobb> #chair colindixon regXboi
17:00:02 <odl_meetbot> Current chairs: colindixon phrobb regXboi
17:00:13 <alagalah> regXboi: Chaired again
17:00:19 <edwarnicke> #info edwarnicke
17:00:29 <phrobb> Anyone else want to help take notes?… just let me know
17:00:39 * alagalah Goes quiet
17:00:41 <colindixon> “:p
17:01:05 <ChrisPriceAB> #info charis price
17:01:15 * ChrisPriceAB new sudonim
17:01:36 <phrobb> #chair alagalah
17:01:36 <odl_meetbot> Current chairs: alagalah colindixon phrobb regXboi
17:01:58 <phrobb> Thanks for volunteering alagalah :-)
17:02:03 <kwatsen> i'm in the IETF lounge on the18th floor - will be on mute most of the time
17:02:42 <edwarnicke> edwarnicke: Is running a few minutes late on audio
17:03:28 <regXboi> #info regXboi
17:03:28 <alagalah> phrobb: lol
17:03:57 <colindixon> #topic upcoming events
17:04:30 <colindixon> #info there’s the OpenFlow World Congress in Dusseldorf which there’s a call for papers open
17:04:44 <colindixon> #info there’s also a hackfest there which we’re organizing
17:04:53 <alagalah> Can you #link the website ?
17:05:04 <dmm> links on the agenda
17:05:08 <colindixon> #info this is a big event for us, please reach out to ChrisPriceAB as he’s coordinating our efforts there
17:05:18 <colindixon> alagalah: working
17:05:33 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main the agenda for this whole meeting
17:05:56 <alagalah> colindixon: I was talking about the forum dude
17:05:59 <colindixon> #link http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress ODL minisummit at OFWC
17:06:07 <colindixon> #link http://www.opendaylight.org/events/2014-10-13/opendaylight-d%C3%BCsseldorf-hackfest hackfest
17:06:15 <alagalah> colindixon: got it, sorry
17:06:26 <colindixon> #link http://www.opendaylight.org/events/2014-09-29/opendaylight-developer-design-forum developer design forum
17:07:03 <colindixon> #topic committer additions to openflowplugin
17:07:05 <dmm> I provided the links for what you need over here in the agenda on https://wiki.opendaylight.org/view/TSC:Main#Agenda_Summary
17:07:29 <alagalah> dmm: apologies, didn't get a chance to check... bouncing between meetings
17:07:38 <colindixon> #info two people (Anil Vishnoi and Ed Warnicke) are up
17:08:02 <RobDolin> #info RobDolin proxy for Rajeev Nagar (MSFT)
17:08:04 <colindixon> #info 5 of 6 committers have voted in favor of this
17:08:30 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-July/001451.html this thread showing the voting
17:08:41 <dlenrow> #vote +1
17:08:46 <colindixon> dlenrow: wait
17:08:56 <phrobb> #startvote Shall Anil Vishnoi be promoted to committer on the OpenFlow Plugin Project?  -1, 0, +1
17:08:56 <odl_meetbot> Begin voting on: Shall Anil Vishnoi be promoted to committer on the OpenFlow Plugin Project? Valid vote options are -1, 0, +1.
17:08:56 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:08:56 <colindixon> phrobb: needs to start a vote
17:09:05 <edwarnicke> #vote +1
17:09:08 <kwatsen> #vote +1
17:09:08 <RobDolin> #vote +1
17:09:09 <dlenrow> #vote +1
17:09:10 <ChrisPriceAB> #vote +1
17:09:11 <regXboi> #vote +1
17:09:12 <dmm> #vote +1
17:09:26 <phrobb> #endvote
17:09:26 <odl_meetbot> Voted on "Shall Anil Vishnoi be promoted to committer on the OpenFlow Plugin Project?" Results are
17:09:26 <odl_meetbot> +1 (7): dmm, dlenrow, regXboi, edwarnicke, ChrisPriceAB, kwatsen, RobDolin
17:09:38 <phrobb> #startvote Shall Ed Warnicke be promoted to committer on the OpenFlow Plugin Project?  -1, 0, +1
17:09:38 <odl_meetbot> Begin voting on: Shall Ed Warnicke be promoted to committer on the OpenFlow Plugin Project? Valid vote options are -1, 0, +1.
17:09:38 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:09:43 <dmm> #vote +1
17:09:43 <ChrisPriceAB> #vote +1
17:09:44 <dlenrow> #vote +1
17:09:45 <edwarnicke> #vote 0
17:09:51 <regXboi> #vote +1
17:09:59 <RobDolin> #vote +1
17:10:05 <kwatsen> #vote +1
17:10:08 <phrobb> #endvote
17:10:08 <odl_meetbot> Voted on "Shall Ed Warnicke be promoted to committer on the OpenFlow Plugin Project?" Results are
17:10:08 <odl_meetbot> 0 (1): edwarnicke
17:10:08 <odl_meetbot> +1 (6): dlenrow, regXboi, dmm, ChrisPriceAB, kwatsen, RobDolin
17:10:25 <colindixon> phrobb: you can nab the #agreed
17:10:38 <phrobb> yea
17:10:47 <colindixon> and I’ll do the #topic after that
17:10:54 <colindixon> and then you can do the #startvote
17:11:04 <phrobb> #agreed Anil Vishnoi is promoted to committer on OpenFlow Plugin project
17:11:23 <phrobb> #agreed Ed Warnicke is promoted to Committer on OpenFlow Plugin project
17:11:39 <colindixon> #topic Chris O’Shea to committer on integration
17:11:58 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-July/001454.html evidence of 8 of 10 committers voting yes
17:12:00 <phrobb> #startvote Shall Chris O’Shea be promoted to committer on the Integration Project?  -1, 0, +1
17:12:00 <odl_meetbot> Begin voting on: Shall Chris O’Shea be promoted to committer on the Integration Project? Valid vote options are -1, 0, +1.
17:12:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:12:09 <alagalah> Maybe they were on vaca
17:12:15 <regXboi> #vote +1
17:12:18 <RobDolin> #vote +1
17:12:18 <edwarnicke> #vote +1
17:12:19 <dmm> #vote +1
17:12:20 <dlenrow> #vote +1
17:12:27 <kwatsen> #vote +1
17:12:30 <colindixon> #info he’s done a lot of work on providing mock interfaces in the project which has be helpful
17:12:37 <phrobb> #endvote
17:12:37 <odl_meetbot> Voted on "Shall Chris O’Shea be promoted to committer on the Integration Project?" Results are
17:12:37 <odl_meetbot> +1 (6): dlenrow, regXboi, dmm, edwarnicke, kwatsen, RobDolin
17:12:47 <phrobb> #agreed Chris O’Shea is promoted to committer on the Integration Project.
17:13:05 <colindixon> #topic board vote on modifications to TSC charter (and at large election updates)
17:13:35 <colindixon> #topic stable hydrogen release progress
17:14:01 * regXboi has very bad audio today
17:14:04 * regXboi staying on mute
17:14:29 * regXboi can't really hear the question
17:14:34 <regXboi> please put it in IRC
17:14:39 <colindixon> can you give the update in IRC quickly?
17:14:50 <regXboi> #info pretty much everybody has +1'd
17:14:55 <edwarnicke> edwarnicke: volunteers to be the ventriloquist dummy
17:15:05 <colindixon> do we know who the stragglers are?
17:15:06 <regXboi> #info there are a few gaps and we may need to remove the folks who haven't
17:15:18 <edwarnicke> regXboi: Who hasn't?
17:15:20 <regXboi> #info in future hydrogen/stable
17:15:24 <regXboi> #info looking
17:15:51 <regXboi> #link https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0
17:16:09 <regXboi> #info Defense4All and Affinity are gaps
17:17:28 <colindixon> #info edwarnicke sent email to Defense4All and they are not planning to participate in Hydrogen release
17:17:44 <colindixon> we can hear you fine
17:18:04 <phrobb> I'm back
17:18:36 <kwatsen> minor surgery if karaf
17:19:01 <kwatsen> right, I meant *if* we had karaf
17:19:24 <cdub> #info Chris Wright
17:19:53 <colindixon> #info colindixon asks if we can interpret this as n-2 yes votes and 2 don’t care votes and just ship it
17:20:14 <cdub> edwarnicke: can you say that again?
17:21:16 <colindixon> #info dmm says, as cdub suggests, sending something out the door that has “stable” on it with something like that seems bad
17:21:30 <colindixon> drop me from the queue
17:22:04 <RobDolin> drop me from the queue also.
17:22:40 <colindixon> #info regXboi says there are two options: (1) drop those projects and ship without them [edwarnicke is working on the mechanics to do that], (2) ship the release with them as is
17:23:34 <abhijitkumbhare> we may want to ship these projects with Hydrogen code only?
17:23:56 <edwarnicke> #info edwarnicke would like it known that doing the mechanics is should not be interpretted as a particular position one way or another
17:24:13 <colindixon> #info dmm asks what does it mean that all the documentation, release info, etc. lists these two projects as part of hydrogen, but they’re not in the stable hydrogen release
17:25:40 <colindixon> ambiguous dave, sorry
17:26:15 <colindixon> #action dlenrow to figure out if he can unstick affinity for the stable release over the next week
17:27:02 <networkstatic> poking cloudtoad on affinity now
17:28:43 <colindixon> #info regXboi and colindixon point out that we should probably make it explicit that participating in a simultaneous release means meaningfully participating in the stable releases
17:30:05 <edwarnicke> cdub: Could you #info in what you just said on the call so I can second it :)
17:30:12 <regXboi> cdub: can you scribe that into this channel?
17:30:17 <regXboi> I couldn't hear half of it
17:30:21 <colindixon> #info cdub clarifies that we don’t need projects to fix bugs (they might not have any) but they do need to provide testing feedback that they haven’t regressed
17:30:30 <colindixon> cdub: is that the short version?
17:30:33 <regXboi> #info yes, I +1 that
17:30:34 <cdub> colindixon: yup
17:30:43 <edwarnicke> #info second cdub's points
17:30:56 <cdub> colindixon: thanks for scribing
17:31:02 <edwarnicke> many thanks to dlenrow for contacting the affinity folks
17:32:39 <colindixon> #info currently, we know that Defense4All does not intend to participate in the hydrogen stable release, by next week we will know yes or no for Affinity (or we will declare that they are not)
17:33:09 <regXboi> #info question: do we need to look at projects having CI jenkins jobs so these questions become moot in the future?
17:33:23 * regXboi raises hand for above question
17:33:36 <colindixon> regXboi: I think you probably do want to have a human in the loop for testing
17:33:58 <cdub> regXboi: yes, that's what i was trying to say
17:34:08 <regXboi> cdub: I thought that might be it
17:35:00 <alagalah> cdub: +1
17:35:31 <colindixon> to be clear, don’t they have tests and we’re running them, and they’re passing
17:35:37 <colindixon> right?
17:35:38 <colindixon> LuisGomez:
17:36:12 <CASP3R> colindixon is that for Defense4All or Affinity ?
17:36:24 <colindixon> CASP3R: both? but really affinity?
17:36:50 <CASP3R> Defense4All i have tested that and it should be fine as they only use flow programmer and flow stats
17:37:03 <colindixon> #info colindixon asks what are we going to do next week with the information we have next week? drop them if they’re not participating? or include them as is if they’re not participating?
17:37:06 <edwarnicke> CASP3R: You are a rock star
17:37:07 <CASP3R> Affinity i don't believe we do any testing
17:37:31 <CASP3R> yes
17:37:55 <colindixon> #info CASP3R says he’s tested Defense4All and they pass
17:38:12 <CASP3R> Ok i change +1 for Defense4all
17:38:20 <cdub> we should probably ask the project to plus-one based on CASP3R's feedback
17:38:20 <colindixon> CASP3R: does Affinity have any tests?
17:38:28 <CASP3R> not that i know of
17:38:30 <colindixon> cdub: I would agree
17:38:37 <dlenrow> #info Nils Swart says he'll reach out to DMM to clarify Affinity status
17:38:39 <LuisGomez> Affinity no test whatsoever, D4A Chris did
17:38:39 <cdub> (as in...slippery slope to randomly +1 other project)
17:38:40 <regXboi> I did that
17:38:53 <colindixon> #info CASP3R says Affinity has no tests
17:39:22 <alagalah> colindixon: cdub +1 to that
17:39:54 <colindixon> #info cdub points out that we should probably ask the project to plus-one based on CASP3R's feedback rather than doing it for them
17:40:58 <colindixon> #info this topic is now closed pending feedback (by next week) from D4A and Affinity
17:41:51 <colindixon> #info dmm points out that we need to start being really clear what we’re going to expect from people in the Lithium release and future ones and what support we will provide
17:42:04 <cdub> dmm: +1 (both to what you said and for moving on ;)
17:42:15 <colindixon> #topic board vote/tsc at large elections
17:43:33 <colindixon> what’s the 1 year waiver for
17:43:40 <colindixon> I’m going to #info the suggestions we made passed including a 1 year waiver (starting yesterday, July 24, 2014)
17:44:13 <colindixon> #info the board passed the proposed modifications
17:44:49 <alagalah> phrobb: Does this expand the # of TSC members ?
17:45:18 <colindixon> #info phrobb says he’s going to send out a request for nominations
17:45:20 <kwatsen> the waiver is that an existing PTL TSC member doesn't have to step down immediately, if another from their company is elected
17:45:41 <colindixon> #info edwarnicke asks if we can’t establish how the nominations and elections are going to work and document it somewhere so that people know what to expect
17:45:44 <cdub> obviously need to create a new mailing list
17:45:51 <edwarnicke> cdub: LOL
17:45:51 <colindixon> I think that’s it
17:45:54 <colindixon> cdub: :-)
17:45:55 <edwarnicke> per project ?
17:45:56 <cdub> </snark>
17:46:00 <cdub> edwarnicke: lol
17:46:04 <alagalah> cdub: Morez emailz
17:47:00 <colindixon> #info the passed things include a waiver for current TSC members to have to step down if somebody from their company wins an at-large seat for one year starting yesterday (July 23, 2014)
17:47:11 <alagalah> So are we adding more TSC members? (asking again)
17:47:22 <edwarnicke> alagalah: If memory serves, yes, 2.
17:47:28 <colindixon> alagalah: yes, I think the plan is to add 2 at-large TSC members
17:47:35 <drizzt_> Snark asside, we may want an email list for Important announcements that we have everyone subscribe to.
17:47:35 <edwarnicke> (but you should know by know not to rely on my memory :) )
17:47:38 <alagalah> edwarnicke: colindixon thanks
17:47:52 <colindixon> nominations are drawn from and then voted on by the committers
17:48:09 <kwatsen> yes, +2, but must be from different companies
17:48:24 <alagalah> kwatsen: I disagree
17:48:36 <kwatsen> it's in the charter
17:48:45 <alagalah> kwatsen: Then the charter should be changed
17:48:53 <colindixon> #action phrobb to create a wiki page documenting how the process will happen
17:49:06 <colindixon> alagalah: it’s already gone back and forth between us and the board several times
17:49:22 <colindixon> I think that ship has sailed with *plenty* of time for comment and objections
17:49:25 <edwarnicke> kwatsen: I *think* that's only for the board seats... but may be misremembering.
17:49:29 <kwatsen> regarding elections, charter says, "These elected community seats must be filled with individuals from separate, unaffiliated companies."
17:49:50 <alagalah> colindixon: Fair but you work for a company, where there are others I respect and are ok with running things, RedHat has 3 folks I would follow
17:49:57 <edwarnicke> kwatsen: Have I told you lately how much I like your care with governance as written :)
17:50:07 <kwatsen> tsc charter, section 4, bullet 2
17:50:33 <colindixon> alagalah: I wouldn’t disagree on that point and we can talk about amending it later
17:50:41 <colindixon> alagalah: you could e-mail the TSC and ask
17:51:07 <colindixon> #topic future releases and project lifecycle
17:51:55 <colindixon> #info mlemay is presenting slides, they will be attached to the meeting minutes later
17:52:54 <colindixon> #info mlemay says that while Karaf features help, they are still too fine-grained to work with when it comes to documenting things, expose as installable to users, etc.
17:53:07 <colindixon> #info projects are too coarse-grained
17:53:53 <colindixon> #info the proposal is to use “components” as the unit in between the two
17:57:11 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations this link contains some information about what is being thought about components and how to use them
17:58:50 <marcbe-sel> Can you link in the presentation file?
17:59:06 <colindixon> #info edwarnicke says he thinks this is good, but that he wants to avoid forcing projects to do it in this release
17:59:26 <marcbe-sel> Thanks guys.
17:59:40 <colindixon> marcbe-sel: no worries
18:00:39 <colindixon> phrobb: I’ll let you #endmeeting
18:00:44 <phrobb> #endmeeting