#opendaylight-meeting: TSC

Meeting started by phrobb at 16:59:36 UTC (full logs).

Meeting summary

    1. dmm (dmm, 16:59:44)

  1. TSC members please #info in (phrobb, 17:00:05)
    1. regXboi (regXboi, 17:00:09)
    2. abhijt (dmm for abhijt) (dmm, 17:01:13)
    3. Madhu (Madhu, 17:02:00)
    4. Kent Watsen (kwatsen, 17:02:31)
    5. Ivan Wood for Microsoft (IvanWood, 17:02:50)
    6. edwarnicke (edwarnicke, 17:03:04)
    7. https://wiki.opendaylight.org/view/TSC:Main (dmm, 17:03:59)

  2. Event Updates (phrobb, 17:05:37)
    1. http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress (phrobb, 17:06:12)
    2. http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress we are low on submissions for the ODL mini summit in dusseldorf (colindixon, 17:06:36)
    3. please submit if you will be there (colindixon, 17:06:44)

  3. Sys Integration and Testing Update (phrobb, 17:06:54)
    1. Lenrow (dlenrow, 17:07:10)

  4. at large elections (colindixon, 17:11:13)
    1. https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process (edwarnicke, 17:12:14)
    2. https://wiki.opendaylight.org/view/TSC:2014_Committer-At-Large_TSC_Election and this is likely to be where we produce the results (colindixon, 17:12:54)
    3. phrobb goes through the process in detail (colindixon, 17:17:24)
    4. phrobb notes that the only feedback on the process in the last week was from ChrisPriceAB asking if we could make it so that there was time to make sure we know who has turned down the nomination before we vote (colindixon, 17:20:04)
    5. edwarnicke asks how we will order people as they’re listed? (suggests alpahbetical by last time) (colindixon, 17:20:54)
    6. ACTION: phrobb to make the modifications to the at-large election process wiki page and then send a mail to to the TSC asking for people to approve it (colindixon, 17:23:47)
    7. abhijit_kumbhare asks if we can allow people to pick whether they wanted to be sorted by first or last name, dmm says he’d vastly prefer to not to do something that is non-uniform in sorting (colindixon, 17:24:48)
    8. edwarnicke says that phrobb should make sure to note in the e-mail that people will not make their company’s platinum representative step down if they are elected (colindixon, 17:26:28)
    9. there is a discussion about whether the nomination process (that is who nominated who and if somebody self-nominated) should be done publicly or privately (colindixon, 17:29:28)
    10. several other data points are brought up: (1) IETF makes it private, (2) OpenStack PTLs are only self-nominated, (3) OpenStack core developers are nominated in public (colindixon, 17:30:56)
    11. Apache nominations are reported done in private (edwarnicke, 17:32:19)
    12. VOTE: Voted on "should the nominations be 1) private, 2) public, or 3) self-nomination-only?" Results are, 3: 6, 2: 1 (phrobb, 17:34:42)
    13. AGREED: nomination will be done as self-nomination-only (phrobb, 17:35:02)

  5. Project Infra and support staff discussion (phrobb, 17:35:43)
    1. we’ve seen over the past few weeks (and it’s been discussed at the board) that getting project infrastructure has taken longer than we’d like (colindixon, 17:36:54)
    2. the core issue is that many feel as though we need to flag budge to hire people and/or acquire infrastructure to help us out and dmm wants to get opinions from the TSC to accurately represent that to the board (colindixon, 17:38:03)
    3. LuisGomez seconds what dmm said (colindixon, 17:38:23)
    4. edwarnicke says, we need this resolved and please, Please, PLEASE we need a release manager (colindixon, 17:38:48)
    5. rocky from huawei says they’re trying to do something to help in the release manager space and that they’ve seen that having a community member be the release manager works well in OpenStack (colindixon, 17:40:04)
    6. it was pointed out that OpenStack has a Release Manager on staff with the foundation (edwarnicke, 17:40:14)
    7. ACTION: probb to put infra and support staff needs on Board agenda for next meeting (phrobb, 17:40:25)
    8. irc://irc.freenode.net:6667/#action phrobb to put infra and support staff needs on Board agenda for next meeting (phrobb, 17:40:49)

  6. stable hydrogen (colindixon, 17:41:24)
    1. dmm got ahold of affinity and they asked to not be present in stable hydrogen (colindixon, 17:41:41)
    2. regXboi says that removing affinity has the side effect of requiring new collateral (regXboi, 17:44:14)
    3. https://git.opendaylight.org/gerrit/#/c/9295/ - the patch is ready (edwarnicke, 17:44:29)
    4. dmm points out that we can't hold things against affinity because we didn’t say participating in hydrogen meant also participating in hydrogen stable as well (regXboi, 17:45:13)
    5. phrobb and others reached out to Defense4All and they have agreed that because their code passes their tests and they’ve made no changes, we can include them in hydrogen stable (colindixon, 17:45:33)
    6. there is discussion about whether we need to redo all the testing with this new approach, consensus is that we do (colindixon, 17:49:17)
    7. dmm asks "when do we expect to be finished with reving/testing Hydrogen Stable again?" (phrobb, 17:50:59)
    8. people say that we’re bogged down in Helium release stuff, so doing full tests may take longer than we’d expect (colindixon, 17:51:36)
    9. colindixon suggests targetting one week to get the rev/testing of Hydrogen Stable finished (by next Thursday). edwarnicke notes he is very heads down on Helium. The Helium M4 milestone is consuming most groups currently (phrobb, 17:53:31)

  7. helium packaging (colindixon, 17:53:44)
    1. the current most concrete proposed plan for release vehicles is to use karaf and let people build distributions out of features (or the component concept we’ve been developing) (colindixon, 17:56:57)
    2. dmm seeks feedback about this or alternatives from the TSC (colindixon, 17:57:07)
    3. Madhu notes that having a "base edition" composition of karaf features/components that works for people would be really good and then let people turn other things on as they choose (colindixon, 18:02:17)
    4. edwarnicke says that being “on by default” is probably a position that everyone would want, but because of conflicts not everyone can (colindixon, 18:02:28)
    5. dmm says that the level of flexibility from being able to turn features on and off is great, but how does it affect the testing matrix? (colindixon, 18:04:16)
    6. edwarnicke says we’ve discussed this over the last few weeks and we decided we would test each feature with *only* the other features it requires and with all features that it doesn’t *explicitly* say it conflicts with (colindixon, 18:05:14)
    7. discussion continues about whether we can have a base edition that works out of the box or if the political battle for who goes into it will kill us (colindixon, 18:07:02)
    8. LuisGomez asks if we can at least agree that all projects need to support karaf (colindixon, 18:07:20)
    9. dmm says we should start a thread on discuss or TSC to drive this forward so that we can make a decision about helium packaging next week (colindixon, 18:08:18)


Meeting ended at 18:08:43 UTC (full logs).

Action items

  1. phrobb to make the modifications to the at-large election process wiki page and then send a mail to to the TSC asking for people to approve it
  2. probb to put infra and support staff needs on Board agenda for next meeting


Action items, by person

  1. phrobb
    1. phrobb to make the modifications to the at-large election process wiki page and then send a mail to to the TSC asking for people to approve it


People present (lines said)

  1. colindixon (63)
  2. phrobb (23)
  3. edwarnicke (15)
  4. odl_meetbot (12)
  5. Madhu (11)
  6. tbachman (10)
  7. regXboi (7)
  8. dmm (6)
  9. abhijit_kumbhare (5)
  10. IvanWood (4)
  11. dlenrow (2)
  12. kwatsen (2)
  13. Youcef (1)


Generated by MeetBot 0.1.4.