17:00:52 <colindixon> #startmeeting tsc
17:00:52 <odl_meetbot> Meeting started Thu Aug  7 17:00:52 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:52 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:00 <colindixon> #topic roll call and agenda bashing
17:01:05 <dmm_> #info dmm
17:01:11 <regXboi> #info regXboi
17:02:23 <edwarnicke> #info edwarnicke
17:02:33 <kwatsen> #info Kent Watsen
17:02:44 <dlenrow> #info Dave Lenrow
17:03:25 <IvanWood> #info Ivan Wood for Microsoft
17:03:28 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda the agenda in it’s usual place
17:03:59 <cdub> #info Chris Wright
17:04:06 <ChrisPriceAB> #info Chris Price joined
17:04:31 <colindixon> #info dmm_ will be out next week, colindixon will fill in for administrative issues of running the meeting next week
17:04:44 <colindixon> #chair regXboi
17:04:44 <odl_meetbot> Current chairs: colindixon regXboi
17:04:54 <colindixon> #topic event updates
17:05:04 * ChrisPriceAB I can help scribe if needed.
17:05:21 <colindixon> #link http://spectrometer.opendaylight.org/ spectrometer gives stats on opendaylight commits and stuff
17:05:41 <colindixon> #link http://www.opendaylight.org/events/2014-08-25/opendaylight-meetup-and-evening-reception-vmworld opendaylight meetup at vmworld, limited space, please RSVP
17:05:47 <colindixon> #chair ChrisPriceAB
17:05:47 <odl_meetbot> Current chairs: ChrisPriceAB colindixon regXboi
17:06:27 <colindixon> #topic documentation
17:06:40 <colindixon> #action LuisGomez to send e-mail about who is taking over for Paul Zimmerman in terms of docs
17:06:58 <colindixon> #topic board update
17:07:23 <colindixon> #info dmm_ informed them about where we are (or are not) with hydrogen stable
17:07:58 <colindixon> #info dmm_ gave them the request for infrastructure, release manager and community manager
17:08:42 <colindixon> #info there wasn’t any pushback on that, but they asked for further details about the positions and infrastructure
17:09:10 <colindixon> #info if you have information, please reach out to dmm_ via e-mail
17:09:25 <colindixon> #topic at large tsc elections
17:11:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-August/001504.html the e-mail vote to approve the process failed to carry in the time that was proscribed
17:13:23 <colindixon> #info cdub was the one person who objected on the list and his only objection was that he wanted nomination happen on an open list
17:15:22 <colindixon> #info colindixon asks why this matters. if we only allow self-nomination the fact that it’s public or private shouldn’t matter.
17:16:00 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Committer-At-Large_Election_Process this is the process we’re talking about
17:17:18 <colindixon> #info cdub says he just wants to separate whether the nominations are public or private from how the nominations are done, e.g., self nomination only
17:19:22 <colindixon> #info there is a proposal to remove “or send a separate email with their self-nomination to the committer email list.“ from bullet point 3 of the nomination phase of the above process
17:19:59 <IvanWood> I believe the correct wording would be "term length" and "term limit"
17:20:38 <colindixon> #action kwatsen will edit the election process wiki to remove the or clause of bullet point 3 of the nomination phase and will edit for clarity about term limits and how many tsc members there will be, then send mail to the TSC
17:21:44 <colindixon> #action after the edits to the process, dmm_ will try to resuscitate the TSC e-mail vote on the process so that we can try to get it resolved for next week
17:22:07 <kwatsen> thanks Ivan
17:22:16 <colindixon> #topic Helium API Freeze clarity
17:22:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-August/001506.html
17:22:41 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium:Suggestions_for_Post_API_Freeze_Exception_Handling
17:24:49 <colindixon> #info both above links point to a paragraph that describes what the developers agree on as a working definition of API freeze
17:26:42 <colindixon> #info the second link tries to provide some clarity around what happens if you for whatever reason *have* to break API freeze
17:29:12 <colindixon> #info the high-level idea is to make it possible for people to change an API as long as everyone that is using that API agrees to it
17:32:22 <colindixon> https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Lessons_from_Hydrogen.2FHelium_that_Should_be_Applied
17:34:14 <colindixon> #info the goal is to provide as concrete a process as possible to do that in a way people can understand with well-know expectations
17:36:25 <colindixon> #info process is: (1) file a bug, (2) send an e-mail, (3) if there is agreement, record that [more details on the wiki]
17:43:36 <colindixon> #info one key point of note is agreement must be unanimous or escalated to the TSC before it’s approved
17:44:22 <colindixon> note that this will need to be sent to the release list so that people are aware of it
17:45:41 <cdub> nitpick: Send Email: "A SEEK AGREEMENT is done via an email to release@lists.opendaylight.org the -dev lists for the IMPACTED PROJECTS"
17:45:54 <cdub> "...and the -dev..."?
17:46:22 <colindixon> cdub: noted, I think you can just make that edit
17:47:40 <cdub> colindixon: done
17:47:40 <edwarnicke> cdub: The fix from you would be most welcome :)
17:48:14 <colindixon> #info regXboi asks about who the IMPACTED PROJECT is when the APIs are also exposed to the outside world, e.g., via REST
17:52:05 <colindixon> #info colindixon restates it as, we have an implicit assumption that the only promises from API freeze are internal to OpenDaylight, and we might want to make this explicit
17:52:30 <colindixon> #action regXboi to modify the simultaneous release plan to make that explicit there
17:52:42 <colindixon> #undo
17:52:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2589f50>
17:53:21 <regXboi> #action regXboi to modify the He, Li and template Simultaneous releases plan wiki pages to make the statement that the M4 API freeze applies to internal cross project APIs only
17:53:28 <colindixon> regXboi: thanks
17:53:29 <regXboi> colindixon: is that better?
17:53:39 <regXboi> and (I hope) incredibly specific?
17:54:04 <colindixon> regXboi: I always forget that #action items need to stand alone
17:56:43 <colindixon> #info dmm_ says he’d like to wait for a week to formally approve this process (ChrisPriceAB agrees with that)
17:57:36 <cdub> time of check to time of use
18:00:01 <colindixon> #info there some discussion about the tractability of finding all impacted projects and what happens if we fail to do that
18:00:45 <colindixon> #info colindixon and dmm_ point out that to get there people will have had to not follow the process and even then it will be limited in scope to code not yet merged (which is hopefully small)
18:03:02 <colindixon> #startvote should we adopt this as the process to deal with breaking API freeze? -1, 0, 1
18:03:02 <odl_meetbot> Begin voting on: should we adopt this as the process to deal with breaking API freeze? Valid vote options are -1, 0, 1.
18:03:02 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:03:10 <dmm_> #vote 1
18:03:10 <regXboi> #vote 1
18:03:12 <vasya10> #vote 1
18:03:14 <ChrisPriceAB> #vote +1
18:03:14 <odl_meetbot> ChrisPriceAB: +1 is not a valid option. Valid options are -1, 0, 1.
18:03:19 <kwatsen> #vote 1
18:03:20 <ChrisPriceAB> #vote 1
18:03:21 <vasya10> oh ok
18:03:23 <edwarnicke> #vote +1
18:03:23 <odl_meetbot> edwarnicke: +1 is not a valid option. Valid options are -1, 0, 1.
18:03:27 <cdub> #vote 1
18:03:29 <edwarnicke> #vote 1
18:03:31 <dlenrow> Neela #vote +1
18:03:34 <colindixon> #endvote
18:03:34 <odl_meetbot> Voted on "should we adopt this as the process to deal with breaking API freeze?" Results are
18:03:34 <odl_meetbot> 1 (7): vasya10, regXboi, ChrisPriceAB, edwarnicke, cdub, dmm_, kwatsen
18:03:57 <colindixon> #agreed it carries and the process for breaking API freeze is described on the wiki page above
18:04:39 <colindixon> #info note that vasya10 is not a TSC member and so his vote was not needed for it cary
18:04:40 <edwarnicke> colindixon: Who should email discuss, tsc, and release letting folks know?
18:04:57 <dmm_> Ed, can you do that?
18:05:27 <colindixon> #action edwarnicke to create the wiki page to record waivers (or find a delegate to do so)
18:05:30 <edwarnicke> dmm_: Would you, as I am the author, it would be nice to see it from a different voice
18:05:33 <dmm_> someone #endmeeting
18:05:35 <dmm_> sure
18:05:38 <edwarnicke> colindixon: NO
18:05:44 <colindixon> #undo
18:05:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x24a47d0>
18:05:44 <edwarnicke> I am *not* taking that AI
18:05:51 <edwarnicke> But we need someone to do it :)
18:06:01 <colindixon> ok, I’ll take those AIs to end the meeting
18:06:26 <colindixon> #info colindixon takes that AI to be able to end the meeting
18:06:51 <colindixon> #action dmm_ will e-amil release, tsc, and discuss to let folks know about the change
18:06:54 <colindixon> #endmeeting