16:59:58 <colindixon> #startmeeting tsc
16:59:58 <odl_meetbot> Meeting started Thu Aug 14 16:59:58 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:58 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:04 <colindixon> #topic roll call and agenda bashing
17:00:14 <colindixon> #chair phrobb ChrisPriceAB regXboi
17:00:14 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb regXboi
17:00:33 <colindixon> TSC members, please #info in
17:00:41 <regXboi> #info regXboi here
17:00:56 <colindixon> #info colindixon standing in for dmm
17:01:31 <IvanWood> #info Ivan Wood for Microsoft
17:01:38 <ChrisPriceAB> #info Chris Price in attendance
17:02:06 <cdub> #info Chris Wright
17:03:50 <kwatsen> #info kwatsen
17:04:09 <ChrisPriceAB> #info ad-hoc discussion on how a project may change a "project contact" when there is a need to change
17:04:16 <edwarnicke> #info edwarnicke
17:04:28 <colindixon> that’s regXboi, colindixon, IvanWood, ChrisPriceAB, kwatsen, and edwarnicke is 6 which is quorum
17:05:00 <ChrisPriceAB> #info The project comitters shall select a new project contact and inform the TSC of the change
17:05:51 <phrobb> #action phrobb to document the process to identify project contacts
17:06:15 <kwatsen> cdub is on also
17:06:42 <colindixon> #topic event updates
17:06:46 <cdub> kwatsen: indeed
17:06:49 <cdub> thanks
17:07:11 <colindixon> cdub, kwatsen thanks, I didn’t #info that, so it’s probably fine :p
17:08:21 <ChrisPriceAB> #info best place is to visit the events page on opendaylight.org
17:08:33 <colindixon> #link https://www.opennetworking.org/news-and-events/events this is the best place to go see what events are upcoming
17:09:39 <colindixon> #undo
17:09:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x259c5d0>
17:10:01 <phrobb> #link http://www.opendaylight.org/news/events
17:10:25 <dlenrow> #info lenrow
17:10:36 <ChrisPriceAB> #link http://www.opendaylight.org/news/events for opendaylight events
17:10:46 <colindixon> thanks phrobb and ChrisPriceAB
17:10:53 <ChrisPriceAB> #topic hydrogen stable
17:11:23 <ChrisPriceAB> #info Expect to get hydrogen Karaf built by next week, if this is not done we may need to make a priority call next TSC.
17:12:06 <colindixon> #info note that this topic is actually “integration/testing” and “karaf” not hydrogen stable
17:13:30 <colindixon> #info mlemay says we should be able to have a base distro with dlux, controller, openflowplugin etc. by next week, only major missing piece so far is OVSDB
17:14:47 <colindixon> #info Madhu_ says that the major issue is that NB APIs aren’t working, mlemay says it’s not working because of a CORS filter issue, but that should be easy enough to fix
17:15:56 <ChrisPriceAB> #info colindixon asks about the dependancy on other projects being on Karaf, given the core projects are working
17:17:05 <ChrisPriceAB> #info Madhu_ indicates we are not dependant on other projects however installation for those features/projects will be more cumbersome.
17:18:01 <ChrisPriceAB> #topic documentation
17:19:11 <ChrisPriceAB> #info mlemay states most people are OK with the toolchain, have started migrating we expect an improvement on Hydrogen
17:19:33 <ChrisPriceAB> #info mlemay indicates there is a dependancy on Karaf and dlux where he has ben focusing his effort
17:19:54 <Madhu_> #info OVSDB is also karaf ready, we just need to put it in integration. Which i will work with mlemay
17:20:04 <ChrisPriceAB> #info colindixon asks how the feednack has been from the broader project community
17:20:15 <colindixon> Madhu_: thanks! sorry if I wasn’t clear about that
17:20:31 <Madhu_> colindixon: np. sir :) was just making sure.
17:20:44 <ChrisPriceAB> #info mlemay indicates there is a lack of clear guidelines from the project on what is expected.
17:22:01 <ChrisPriceAB> #info colindixon indicates there should be a discussion on the TSC's expectation on the level of documentation produced by projects, mlemay agrees a set of document artifacts is something that should be clarified.
17:25:02 <ChrisPriceAB> #info LuisGomez indicates we have been awaiting completion of Karaf to define the release vehicles.  The release vehicle is then necessary for defining the release documentation and as such documentation id delayed by Karaf delays.
17:25:47 <ChrisPriceAB> #info general deiscussion on how to include documentation as a gating factor for projects to ensure there is sufficient focus on this durign the project.
17:26:30 <colindixon> #info phrobb says that the docs team has templates and guidelines ready as of yesterday’s meeting and we shoudl figure out if we can give them a TWS (or other) slot soon so they can spread that knowledge
17:26:37 <ChrisPriceAB> #info edwarnicke indicates documentation may be a good candidate for the simultaneous release process at M4 or a suitable release gate
17:26:58 * ChrisPriceAB Ed, you want to ratify my interpretation?
17:27:59 <cdub> ChrisPriceAB: less the specific Milestone, more the idea that it should be in release plan, and hydrogen release plan is too baked to add it, so figuring out for lithium...
17:28:20 <cdub> s/should be/could be/ if you want
17:28:23 * ChrisPriceAB thanks cdub
17:28:42 <cdub> i guess i can just #info ;)
17:30:15 <cdub> #info specific Milestone (e.g. M4) is part of it, but overall context is using release plan to codify how we want docs to be gating to a release, and it's appropriate for Lithium (retro-active for Hydrogen is not community-friendly since it's potential big shift in expectations)
17:30:36 <colindixon> #action Madhu_ to reach out to mlemay, phrobb, etc. to set up a docs topic for the TWS
17:31:05 <ChrisPriceAB> #topic elections
17:31:34 <edwarnicke> phrobb: Thank you for thinking of scrubbing the list, that's smart :)
17:31:53 <ChrisPriceAB> #info phrobb will begin the two week election nomination process today.
17:32:08 <ChrisPriceAB> #info as described and agreed previously by the TSC.
17:32:18 <cdub> #info colindixon suggests automating committer email list (e.g. from gerrit)
17:32:52 <cdub> colindixon: way too rational a thought
17:33:12 <ChrisPriceAB> #info phrobb will work on automation however it is not in place today.
17:33:12 <cdub> #info phrobb is actually working on that automation w/ odl infra folks
17:33:22 <ChrisPriceAB> #topic stable hydrogen release
17:33:35 <cdub> all those who touched it, take a step back
17:33:37 <ChrisPriceAB> #info colindixon asks who is running stable hydrogen releases.
17:33:42 * cdub neither
17:33:42 <tbachman> lol
17:33:55 <ChrisPriceAB> #info denial from both edwarnicke and regXbio
17:34:06 * ChrisPriceAB vocal denial :)
17:34:19 <regXboi> regXbio?  who is he?
17:34:31 <tbachman> A bio-hacker version of you ;)
17:35:00 * ChrisPriceAB chrispriceab cannot type
17:35:04 <edwarnicke> tbachman: I think I'm  the resident biohacker :)
17:35:09 <tbachman> lol
17:35:12 <tbachman> edwarnicke: yes  :)
17:35:30 * ChrisPriceAB I have lost the thread.
17:36:16 * edwarnicke has long since run out of cores :(
17:36:32 <tbachman> lol
17:37:43 <ChrisPriceAB> #info curet state of stable Hydrogen.  Defense for All and Affinity were not able to participate effectively.  Affinity has been removed from the release distribution and we have pushed the necessary changes.  No stable release has been built yet with these changes in place.
17:38:39 <ChrisPriceAB> #info there seems to be an issue with the autobuild script where Affinity is being built for hydrogen stable.  These are not being included in the distribution and it is not clear if this is a sufficient solution.
17:39:03 <ChrisPriceAB> #info edwarnicke asks if this is necessary to be addressed as Helium is due in 6 weeks.
17:39:17 <ChrisPriceAB> #info Madhu_ asks if anyone is waiting for the stable release.
17:39:48 <ChrisPriceAB> #info colindixon indicates there are receivers for the release awaiting bugfixes.
17:40:12 <cdub> considering we've done the bulk of the work...
17:40:34 <ChrisPriceAB> mmm, push the button...
17:40:53 <colindixon> #info to be clear, I don’t actually know of a person that is expecting it, but I do see people sending mail to the mailing list saying that they are using the hydrogen release regularly
17:43:10 <Madhu_> we need to test it if we have to release
17:43:35 * edwarnicke hides from regXboi's most recent question
17:43:36 <tbachman> there’s a physics formula for that
17:44:13 <colindixon> #info regXboi asks “how long do we expect stable hydrogen to live?"
17:44:15 <cdub> ChrisPriceAB: almost assuredly not, since we don't test for it
17:44:26 * ChrisPriceAB that was what I thought.
17:45:47 <cdub> colindixon: would like to add one thing to agenda: odlforge
17:45:53 <ChrisPriceAB> #info colindixon asks if we can push the artifacts this week and discuss next week the testing and releasing of those artifacts.
17:46:34 <ChrisPriceAB> #dlenrow indicates the ongoing support of stable release for incubation projects should be considered in the context of all projects being at incubation.
17:47:04 <regXboi> aw heck
17:47:14 <regXboi> #info dlenrow indicates the ongoing support of stable release for incubation projects should be considered in the context of all projects being at incubation.
17:47:21 <regXboi> #info regXboi has pushed the button
17:47:59 * ChrisPriceAB ty rexXboi
17:48:44 <cdub> incubation and core is long term discussion
17:48:52 <colindixon> thank you
17:48:54 <colindixon> cdub: I agree
17:49:20 <cdub> # i n f o regXboi pushed big red button, take to your shelters
17:49:24 <ChrisPriceAB> #info colindixon asks if non-automated testing would be too much to ask of projects
17:49:36 <regXboi> #info not red - green
17:49:56 * regXboi is not color-blind
17:50:01 <ChrisPriceAB> #info edwarnicke indicates he (and by inference others) do not have time to perform the manual effort of verification.
17:50:24 <ChrisPriceAB> #info abhijitkumbhare indicates he also does not have time in OF-Plugin
17:50:31 <edwarnicke> #info edwarnicke Did try to be precise about limiting inference ;)  May have failed ;)
17:51:05 <ChrisPriceAB> #info dlenrow proposes we ask on the lists for receivers of the release.
17:51:41 * ChrisPriceAB at least Madhu_ didn;t have to repeat himself again :D
17:52:09 * edwarnicke tries to sometimes be the guy saying those things so Madhu doesn't feel like he has to carry it all himself ;)
17:52:36 <ChrisPriceAB> #action dlenrow will initiate communications on the topic of indefinitely postponing the hydrogen stable release in lieu of delivering helium.
17:53:48 <colindixon> #info LuisGomez asks how much offline testing actually takes place for controller and openflowplugin
17:55:00 <ChrisPriceAB> #info ChrisPriceAB proposes a formal TSC vote be taken on this during next weeks call to provide dlenrow time to vet the community and TSC members to discuss with own projects.
17:55:29 <colindixon> #info edwarnicke responds saying that there are people he runs around to ask them to bless releases, but he would have to spend cycles just to do that nevermind test
17:55:39 * ChrisPriceAB optionally
17:56:18 <abhijitkumbhare> Just an Fyi (especially for LuisGomez ): We had tested it last time - and there have been no changes from the OpenFlow plugin after that.
17:56:39 <edwarnicke> dlenrow: I like your way of framing it a lot
17:56:40 <abhijitkumbhare> and probably no changes for any other projects
17:56:48 <ChrisPriceAB> #info colindixon proposes we communicate in a neutral fashion on users of stable hydrogen
17:56:48 <cdub> LuisGomez: status of "work in branch" is: http://pastebin.com/ZYCQ4q5d
17:56:59 * dfarrell07 (who has no voice) likes the third option
17:57:23 <edwarnicke> dfarrell07: You do have a voice, and we do care what you think :)
17:57:42 <dfarrell07> ^^thanks :)
17:58:07 * ChrisPriceAB +1 Ed
17:58:24 * cdub is -1 to opposed (double negative)
17:58:25 <kwatsen> i'm not opposed
17:58:38 * edwarnicke feels opposition would be double plus bad
17:58:43 <IvanWood> not opposed
17:59:32 <ChrisPriceAB> #colindixon approves dlenrow to act on his previous action point in a neutral fashion, he shall run the proposed text by colin, phil and dmayer.
17:59:44 <ChrisPriceAB> #info colindixon approves dlenrow to act on his previous action point in a neutral fashion, he shall run the proposed text by colin, phil and dmayer.
18:00:34 <cdub> LuisGomez: sorry, data is: http://pastebin.com/S8M9dR3i
18:00:39 <phrobb> #agreed TSC commissions Dave Lenrow to send a note to the ODL community to gauging priority of resources within project to dedicate efforts at this time to Helium, or to also push to release the first Hydrogen Stable release concurrent to Helium development now
18:00:50 <LuisGomez> cdub: i just saw last patches on hydrogen stable being by end of July
18:01:07 <cdub> yup, it's basically fully baked (minus testing)
18:01:21 <cdub> colindixon: just cross-post to all 100 mailing lists
18:02:28 <ChrisPriceAB> #action colindixon needs to raise the topic of release support at a future RSC meeting
18:02:35 <ChrisPriceAB> #action colindixon needs to raise the topic of release support at a future TSC meeting
18:02:53 <ChrisPriceAB> #undo
18:02:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x249ab50>
18:03:01 <ChrisPriceAB> #action colindixon needs to raise the topic of release support at a future TSC meeting
18:03:03 <tbachman> Is undo like a stack?
18:03:11 <tbachman> nice :)
18:03:14 <tbachman> thx colindixon
18:03:38 <ChrisPriceAB> #info cdub proposes a quikc discussion on odlforge
18:03:49 <edwarnicke> cdub: odlforge would be very happy making
18:06:03 <cdub> #link http://ci.openstack.org/stackforge.html this is template example for odl forge (this is openstack)
18:06:43 <cdub> #link https://github.com/odlforge example of new space for forge work related to odl
18:07:26 <mlemay> @cdub : I can’t wait for an ODL forge it would give a great pipeline for things and esxperimentation.. like the openstack forge…
18:07:37 <cdub> #action colindixon to add odlforge to next week's agenda
18:07:45 <rexpugh> I would like to stick around
18:08:14 <ChrisPriceAB> #info cdub will stay online for a non TSC call on odlforge
18:08:21 <colindixon> #info TSC members can now consider the meeting over, but those who are interested in information about odlforge can stay
18:08:51 <phrobb> #endmeeting