17:01:44 <phrobb> #startmeeting tsc
17:01:44 <odl_meetbot> Meeting started Thu Sep  4 17:01:44 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:44 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:44 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:49 <gzhao> folks, need to end this meeing
17:01:51 <dmm> #info dmm
17:01:56 <edwarnicke> #endmeeting
17:02:05 <tbachman> edwarnicke: phrobb beat you to it ;)
17:02:09 <edwarnicke> Apologies... was trying to end Karaf Happy Hour
17:02:18 <edwarnicke> #info edwarnicke (running 2 min late on audio)
17:02:39 <kwatsen> #info kwatsen
17:02:40 <phrobb> #chair gzhao colindixon Madhu
17:02:40 <odl_meetbot> Current chairs: Madhu colindixon gzhao phrobb
17:03:01 * colindixon does a magical powers super-chair dance
17:03:02 <EdM> #info
17:03:51 <ChrisPriceAB> #info Chris Price
17:03:58 <IvanWood> #info Ivan Wood
17:04:23 * edwarnicke contemplates buying colindixon a cape
17:05:10 <dlenrow> #info Lenrow
17:05:59 <colindixon> #topic agenda bashing
17:06:17 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda the agenda in it’s usual place
17:06:43 <colindixon> #info dmm says that there is are some post-helium hot issues at the bottom there
17:06:47 <colindixon> #topic events updates
17:07:12 <colindixon> #info the good price for hotels for the developer design forum ends tomorrow, so book now
17:07:33 <colindixon> #info the thread on discussion topics has been active, please add your topics and volunteer to lead them
17:07:52 <colindixon> #info sdn and openflow world congress is coming up in dusseldorf (sp?) in mid october
17:08:20 <colindixon> #topic at large elections
17:08:43 <colindixon> #info nominations complete, we’re now taking votes (committers should have e-mails) on the 4 candidates for the 2 seats
17:09:06 <colindixon> #info voting closes on 9/15 and as soon as that closes, phrobb, Neela, and dmm will review the results and announce the winners (hopefully in short order)
17:09:23 <colindixon> #topic board seat elections
17:09:39 <colindixon> #info this proeess will be launched as soon as the TSC at-large election ends
17:09:49 <colindixon> #topic TSC chair election
17:10:19 <colindixon> #info dmm would like to do it sooner rather than later, phrobb says we could do it the first TSC meeting after the at-large elections
17:11:10 <colindixon> #info edwarnicke asks for it to be pushed after the helium release, there is some resistance from phrobb and dmm since they think it should be pretty fast
17:11:30 <colindixon> #topic integration and testing
17:12:03 <colindixon> #info we’re still trying to pull the karaf distribution in integration and get it tested
17:12:28 <colindixon> #info gzhao and others say that the full karaf distributions should be ready next week
17:12:48 <colindixon> #info edwarnicke asks if we can get *some* testing started now given that many projects are there
17:19:43 <colindixon> #info there is some discussion around what test cases we have and how we’re going to get the integration tests we have *now* running and get the patches in the queue merged
17:21:43 <colindixon> #Info there is a meeting around auto-release with gzhao, edwarnicke and Giovanni tomorrow morning to start generating release candidates
17:22:17 <gzhao> #info Luis think RC0 should be delayed for a week
17:25:48 <colindixon> #info edwarnicke says we should just try to hit it, there is some discussion without an obvious answer as to how behind or not we’ll be
17:25:59 <colindixon> #topic simultaneous release readout
17:27:05 <colindixon> #info defense4all is listed as black, but gzhao has had communication with them and they are trying to get things done today
17:29:00 <colindixon> #Info most projects (11/21) have karaf done and in integration, others are in some state of in-progress (either awaiting review or code in progress)
17:32:31 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Status the spreadsheet is embedded here
17:35:24 <colindixon> #topic defense4all committer promotions
17:35:47 <dmm> #link https://lists.opendaylight.org/pipermail/tsc/2014-September/001576.html
17:37:59 <dfarrell07> edwarnicke: I think this is the link you mentioned: https://wiki.opendaylight.org/view/TSC:Committer-promotion-process
17:39:49 <colindixon> #info edwarnicke asks if there’s a history of commits from the to-be-added committers
17:40:08 <dfarrell07> #link https://wiki.opendaylight.org/view/TSC:Committer-promotion-process wiki describing committer promotion process
17:40:48 <edwarnicke> dfarrell07: Thanks for digging up the link
17:40:50 <colindixon> #info the response is that there are commits in their private git repo, but not publicly visible
17:41:00 <dfarrell07> edwarnicke: np :)
17:43:17 <colindixon> #info there is some pushback until there is a public history, dmm asks if this would negatively impact the project
17:43:33 <colindixon> #info the answer is that there would be no effect
17:45:21 <colindixon> #info the decision is to wait on this promotion until the commit history is there to better judge things
17:46:37 <colindixon> #topic karaf updates
17:47:01 <colindixon> #Info edwarnicke says we’re coming together slowly, but surely with a few projects lagging
17:47:57 <colindixon> #topic adding project infrastructure
17:48:26 <colindixon> #info dmm says that the problem he’s been running into when going to the board is not around support to get new resources, but rather quantifying what resources we need
17:48:48 <colindixon> #info jmedved says he will get quantified resources to run the extensive set of OpenFlow tests later today
17:51:17 <colindixon> #info jmedved also asks for the TSC and/or the integration team to call for the community at large to try to bang on the controller to test and find bugs
17:51:38 <colindixon> #info LuisGomez says that the time to do this is probably when we get RC0 out
17:55:41 <colindixon> #info Neela speaks up to say if there is an issue that people see as going unmet, please reach out to him and phrobb (ideally after getting together with others who have similar issues to document it)
17:57:07 <colindixon> #topic security response
17:57:52 <colindixon> #Info cdub points out again that we don’t have a process/team/group, yet, but he has the start of that put together and will present it next week
17:58:49 <cdub> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2014-August/000000.html
17:59:07 <colindixon> #topic cdub as a committer on odlparent
17:59:27 <colindixon> #info above link shows that cdub likely should have been a committer on odlparent from the start
17:59:46 <colindixon> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2014-August/000002.html this has the actual votes
18:00:53 <colindixon> #agreed cdub will be made a committer on odlparent
18:01:24 <colindixon> #topic helium milestones
18:01:26 <cdub> tykeal: ^^^^ (believe this is outstanding helpdesk ticket)
18:01:56 <tykeal> cdub: the agreement there? yeah, there's a relevant ticket already open
18:01:56 <colindixon> #info phrobb notes that we have let M5 slip from 9/1 to 9/5
18:02:17 <cdub> tykeal: i believe you have all bits needed to make it so
18:02:25 <tykeal> heh, that I do
18:02:35 <cdub> cool
18:03:05 <colindixon> #info we are currently not sure whether RC0 will slip or not, given that we’d have to turn it around in 2-4 days rather than a week
18:03:41 <colindixon> #info phrobb notes that no dates will change unless the TSC does anything and RC0 will be Tuesday
18:03:47 <colindixon> #topic documentation
18:04:00 <colindixon> #info manny can’t make this time because of an ongoing conflict
18:04:21 <colindixon> #info phrobb says that manny is saying that documentation is *still* red despite added resources
18:04:47 <colindixon> #info people should do anything/everything they can to get documentation written and more resources there, coordinate with the core docs teams
18:04:54 <colindixon> #endmeeting