16:58:30 <colindixon> #startmeeting tsc
16:58:30 <odl_meetbot> Meeting started Thu Sep 18 16:58:30 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:30 <odl_meetbot> The meeting name has been set to 'tsc'
16:58:36 * tbachman turns off online music, readies spinning ball
16:58:36 <colindixon> #topic roll call and agenda bashing
16:58:41 <colindixon> #chair phrobb regXboi
16:58:41 <odl_meetbot> Current chairs: colindixon phrobb regXboi
16:58:44 <dmm> #info dmm
16:58:47 <colindixon> #info colindixon
16:58:51 <regXboi> what, already?
16:58:54 * tbachman claps for colindixon
16:58:59 * ChrisPriceAB early :)
16:59:06 <regXboi> #info regXboi
16:59:09 <colindixon> it’s not like we’re going to *start* early :p
16:59:19 * ChrisPriceAB now now...
16:59:20 <colindixon> we’re just going to idly chat :-)
16:59:32 <ChrisPriceAB> #info Chris Price
17:00:52 * tbachman claps for edwarnicke
17:01:02 <IvanWood> #info Ivan Wood
17:01:03 <edwarnicke> #info edwarnicke
17:01:05 * colindixon notes that we need 6 people to get a quorum this time (I’m pretty sure)
17:01:07 <regXboi> #action colindixon to grep #info of TSC members joining to see histogram of when a meeting can start for next week
17:01:08 <colindixon> so that’s 6
17:02:21 <colindixon> kwatsen_, cdub #info in when you can :-)
17:02:28 <kwatsen_> #info Kent Watsen
17:04:01 <colindixon> #topic committer at large election results
17:04:02 <cdub> #info cdub
17:04:09 <colindixon> #undo
17:04:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2534750>
17:04:10 <cdub> #info Chris Wright
17:04:11 <colindixon> #undo
17:04:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2589790>
17:04:12 <regXboi> #link https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda
17:04:16 <colindixon> ugh
17:04:26 <colindixon> that wrecked havoc on everything
17:04:28 <phrobb> #info dmm welcomes colindixon and edwarnicke as the new Committers-At-Large
17:04:31 * ChrisPriceAB looking forward to the dixon-warnicke proposal!
17:04:31 <regXboi> #link https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda
17:04:34 <cdub> heh
17:04:41 <colindixon> cdub please #info again
17:04:42 * edwarnicke wonders if colindixon #infoed in for havock
17:05:12 <colindixon> #info cdub  is here and did #info in (I just borked it)
17:05:26 <regXboi> #topic event updates
17:05:40 <colindixon> #info design forum is coming up
17:05:53 <colindixon> #link http://www.opendaylight.org/events/2014-09-29/opendaylight-developer-design-forum
17:06:11 <phrobb> #link https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/10glP04x7AWi_baA_R8K7DGvd99CeOOXY5AZqC87vWlM/edit#gid=2032322710
17:06:41 <regXboi> #info confirmed - phrobb's link is the design forum spreadsheet
17:07:29 <colindixon> #info many of these topics do not have an “owner” and it’s difficult to schedule a topic w/o an owner
17:08:01 <colindixon> #info phrobb asks the TSC to review the list and see if there are high-priority items w/o owners so he can prioritize his time to go find owners for those
17:08:28 * regXboi thanks colindixon for saving his fingers
17:10:38 <phrobb> #link https://docs.google.com/spreadsheets/d/19hVW0PIzKlu6oaG5QGg8BdD02IiAvSp4VhuUq1eUj6Y/edit#gid=0
17:11:09 <colindixon> #info phrobb notes that his current plan is to have scheduled topics where we can, and then put other high-priority ideas (if we can’t schedule them) as unconference topics
17:11:16 <colindixon> #info above link is a proposed schedule
17:12:15 <ChrisPriceAB> ... before we move on.  raises hand
17:12:29 <colindixon> #info colindixon suggests doing a poll of TSC members to get a quick idea of what topics are important
17:13:03 <colindixon> #info phrobb asks people to register if you haven’t already, we are at ~150, but phrobb was expecting 200-300
17:14:00 <colindixon> #info ChrisPriceAB asks about how we have rooms, phrobb responds that we have 9 rooms: 1 that will fit everyone, 2 that will fit ~100 people, 6 that fit 35
17:14:12 <colindixon> #Info the 6 that fit 35 can be merged into 2 that fit 105 each
17:14:42 <alagalah> Are we going to be recording sessions, even in lower quality ?
17:14:44 <colindixon> #Info regXboi asks if we’re going to replicate live streaming? phrobb says he’s going to bring all the gear, so it will have one good live stream and some iPads as before
17:14:51 <alagalah> I mean ALL sessions, not just the popular ones
17:15:02 <colindixon> alagalah: good question
17:15:12 <colindixon> phrobb: do you have an answer?
17:15:19 * ChrisPriceAB we can set up streaming from notebooks etc on the day with recordings. That should be relatively easy.
17:15:19 <colindixon> #topic integration
17:15:49 * regXboi notes it may be easy, but somebody has to be tasked to actually do it ...
17:16:04 * ChrisPriceAB notes a volunteer 0.o
17:16:11 <colindixon> #info LuisGomez says that currently there are two issues: one with VTN and one with l2switch that are being worked on
17:16:28 <colindixon> #Info otherwise, we’re working on running all tests we have on RC1 and prepping for RC2
17:16:31 <regXboi> #topic documentation
17:16:33 <colindixon> thanks
17:17:08 <colindixon> #info the only core document manny is concerned about is the user guide
17:17:18 <dlenrow> #info lenrow
17:18:11 <phrobb> alagalah:  we will only livestream one  session.  We can WebEx + Record up to 5 additonal sessions via the apad-minis we have
17:18:19 <colindixon> #info they are not sure if they’re going to get the info they need from the people that have it, apparently those people are at Cisco, so manny is hunting them down
17:18:39 <colindixon> #info also, if any project has special things that need to happen before loading features from their project, let the docs people know
17:18:43 <regXboi> #topic helium release update
17:19:11 <alagalah> regXboi: +1
17:19:26 <regXboi> #info RC1 is built and under test
17:19:30 <colindixon> #info we had all projects make RC1 and meet the requirements put down by the TSC
17:20:03 <alagalah> phrobb: Thanks sir, given there are 3 streams and 2 unconf in parallel, then 5 sounds good
17:20:22 * ChrisPriceAB still feeling the lashes inflicted by Ed pre-RC1
17:20:47 * edwarnicke notes it was all done out of love
17:20:51 <colindixon> #info there was a break in auto-release overnight, but edwarnicke says it should be fixed at this point
17:21:04 <alagalah> ChrisPriceAB: edwarnicke Ahhhhh... love and lashes... video or never happened :)
17:21:07 <colindixon> #info there are four projects which have yet to express what (if any) docs they intend to provide
17:21:13 <colindixon> #topic TSC chair elections
17:21:48 * ChrisPriceAB alagalah, you didn't see the movie?
17:22:41 <xsited1> colin: was there docs preferred contact email?  i missed that.
17:22:56 <colindixon> xsited1: documentation@lists.opendaylight.org
17:23:18 <xsited1> doh!
17:23:19 <xsited1> thx
17:23:24 <colindixon> #info regXboi asks if there is a list of the responsibilities for the chair
17:23:50 <tbachman> Just realized that we haven’t updated this with manny: https://wiki.opendaylight.org/view/CrossProject:Documentation_Group
17:23:56 <tbachman> anyone have his email?
17:24:19 <colindixon> #info the answer seems to be that there aren’t a list of them, but reach out to phrobb or dmm or anyone else to figure that out if you’re curious
17:24:37 <colindixon> #info dmm proposes: (1) open up call for nominations and leave it open for 2 weeks, (2) after that there will be a very simple roll-call vote with a run-off in the case of tie
17:24:55 <colindixon> #info the goals were to make it low-overhead, lightweight and fast
17:26:23 <phrobb> #info edwarnicke asks about using condorcet for the election.  A: condorcet for the TSC chair is not needed.  The only people that vote on this election is the members of the TSC.
17:26:34 <colindixon> thanks phrobb
17:27:31 <colindixon> #info ChrisPriceAB asks if there was going to be an opportunity for candidates to express their stances and/or introduce themselves
17:28:42 <colindixon> #Info dmm says that seems reasonable, but asks if that would extend the time required past two weeks
17:28:43 <edwarnicke> #link http://www.opendaylight.org/project/tsc/charter
17:29:33 <colindixon> #info the consensus seems to be that it wouldn’t require that, people could put such position statements forward during the two week period
17:30:37 <alagalah> In case of tie, cage fight?
17:36:33 <alagalah> colindixon: Want me to info what I said ?
17:37:03 <colindixon> #info alagalah suggested that we have the run off in the case of no candidate getting a simple majority, we have the run off consist of the top n candidates for the smallest n such that they received a simple majority of votes in the first election
17:37:18 <colindixon> #info and presumably that would repeat if necessary
17:37:29 <alagalah> colindixon: WOW, thats much better than I would have said it... you make me sound coherent
17:37:39 <phrobb> #info Q: who can nominate for the TSC Chair
17:38:00 <phrobb> #info consensus is that the nominations will be self-nominations only
17:39:45 <colindixon> #Info closing this topic having decided (1) that it will be self-nomination, (2) that we will have a page describing the process including how to handle run-offs
17:40:09 <colindixon> #info dmm would like to start it as soon as possible, ideally in the next week
17:40:21 <ChrisPriceAB> #action phrobb will take an action to describe the TSC chair election process and outline the role of the TSC chair.
17:40:46 * ChrisPriceAB ooh I'm not running text today. apologies.
17:42:07 <colindixon> #topic discovery creation review
17:42:10 <dmm> @ChrisPriceAB :-)
17:42:21 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Discovery proposal
17:42:41 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-August/000146.html announcing the proposal >2 weeks ago
17:45:55 <colindixon> #info Description: Supports the discovery, identification, and synchronization of network elements with the controller as well as provides a framework for link or connection reconciliation between the network elements.
17:46:12 <colindixon> #Info Scope: This proposal does not include the algorithms to find new network elements, such as a ping sweep; It is assumed that finding is the responsibility of other modules. This proposal will interact with topology and inventory modules as network elements and links are discovered.
17:46:46 <colindixon> #info both the above were taking verbatim from the proposal pages
17:51:03 <colindixon> #info regXboi asks for a clear description of the problem trying to be solved?
17:52:59 <dlenrow> #info colindixon: I always think i'm on mute when not talking. If I screw up don't hesitate to mute me.
17:53:19 <phrobb> dlenrow:  OK :-)
17:55:13 <phrobb> #info colindixon asks "is this something that needs to be a separate project or does it logically fit into an existing project?
17:55:53 * ChrisPriceAB good point dlenrow
17:56:04 <phrobb> #info phudgins is happy to take direction on where/how this functionality would go.
17:56:22 * ChrisPriceAB off topic
17:56:59 <colindixon> #info the response seems to be that it should be it’s own project from ChrisPriceAB and edwarnicke
17:56:59 <phrobb> #info dlenrow and edwarnicke note that putting more stuff into the controller is not a great idea
17:58:26 <cdub> this is why we should incubate code not wiki pages
17:58:35 <colindixon> cdub: +1
17:58:46 <cdub> (not slight against this project, just our own process)
17:58:55 <colindixon> cdub: yeah
17:58:58 <phrobb> #info dmm notes that several TSC members don't understand this project well enough to vote
17:59:23 <phrobb> #info cdub notes that this is why incubate code instead of wiki pages
17:59:35 * ChrisPriceAB begs members to please take questions to the list for next week.
17:59:46 <dmm> @cdub yeah
18:00:04 <phrobb> #topic Helium Release date and time to cut final release candidate
18:00:07 <colindixon> thanks
18:00:18 <colindixon> #info we’ve been cutting RCs mondays at 5p pacific
18:00:42 <colindixon> #info we need a time and a date to cut the real release artifacts
18:03:14 <phrobb> #info regXboi suggests having a TSC meeting on Monday 9/29 to approve final release artifacts
18:03:17 <colindixon> #info edwarnicke says the issue is making sure they’re cut in time for the TSC to bless them on Thursday
18:03:52 <phrobb> #info edwarnicke asks "what input to the TSC decision will need to be available?"
18:04:30 <colindixon> #info regXboi asks for actual release artifacts and anything that any project thinks is big enough to be a show stopper
18:05:04 <colindixon> #info edwarnicke asks if we know when marketing is expecting us to produce downloadable things
18:05:51 <colindixon> #info Melissa and phil say that they usually put out press releases in the morning, but this release could go out on tuesday if that’s what we need
18:07:38 <colindixon> #info edwarnicke says that the other option we have is to cut RC2 artifacts as release artifacts on 9/22
18:08:14 <phrobb> #info edwarnicke suggests cut artifacts on Tuesday (9/23) giving two days of test before the TSC meeting on 9/25.  Or we can cut RC2 artifacts as release artifacts on 9/22
18:09:33 <phrobb> #info dmm asks edwarnicke to create an email thread with the options availlable (next Wednesday, Tuesday or Monday (from RC2)… Also gzhao to work with Ed on understanding find/fix rate for defects
18:09:53 <colindixon> #action edwarnicke and gzhao to send out an e-mail (to release and TSC) with the various options, e.g., those listed above
18:11:57 <regXboi> gzhao: can you mute?
18:12:44 <phrobb> #info edwarnicke notes that doing Release artifacts on Monday (9/22) allow for 3 days of testing before the TSC meeting on 9/25.  If no show-stoppers are present, we use that as the final, approve the bits on the TSC call on 9/25 and release to the public on Monday morning 9/29
18:12:50 <colindixon> thanks phrobb
18:13:24 <colindixon> I like it
18:13:33 <kwatsen> #agreed
18:13:48 <regXboi> #undo
18:13:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24f8c10>
18:13:49 <cdub> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Schedule <-- just a reminder of our current plan
18:14:02 <regXboi> #info edwarnicke notes that doing Release artifacts on Monday (9/22) allow for 3 days of testing before the TSC meeting on 9/25.  If no show-stoppers are present, we use that as the final, approve the bits on the TSC call on 9/25 and release to the public on Monday morning 9/29
18:14:19 <regXboi> #info last link is because the undo hit the wrong thing
18:14:29 <colindixon> yeah
18:16:16 <colindixon> #info we are making the above our current plan of action barring any show stoppers
18:16:35 <colindixon> #topic release reviews
18:17:15 <colindixon> #info phrobb says that the current plan is for two release review slots starting at 7:30a pacific (for two hours) on next Wednesday (9/24) and Thursday (9/25)
18:17:30 <phrobb> #agreed Final Release artifacts will be cut on Monday 9/22.  Release reviews will occur on Wednesday and Thursday (9/24, 9/25).  TSC to vote on final release of artifacts during the TSC call on 9/25.  Helium bits to go live the morning of 9/29
18:17:31 <colindixon> #info phrobb and gzhao will send mails out with a schedule about that
18:18:03 <colindixon> #endmeeting