17:00:14 <phrobb> #startmeeting tsc
17:00:14 <odl_meetbot> Meeting started Thu Sep 25 17:00:14 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:14 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:37 <phrobb> #chair gzhao colindixon
17:00:37 <odl_meetbot> Current chairs: colindixon gzhao phrobb
17:00:48 <colindixon> #topic roll call
17:00:51 <colindixon> #info colindixon
17:00:53 <dmm> #info dmm
17:00:58 <kwatsen> #info
17:01:02 <ChrisPriceAB> #info Chris Price
17:01:02 <phrobb> #topic TSC members please #info in
17:01:14 <ChrisPriceAB> #info Chris Price
17:01:14 <kwatsen> #info Kent Watsen
17:01:25 <phrobb> sorry colindixon
17:01:54 <IvanWood> #info Ivan Wood
17:02:28 <regXboi> #info Ryan Moats
17:02:33 <edwarnicke> On my way
17:02:47 * ChrisPriceAB loving the background music!
17:02:59 * regXboi - what no chair today?
17:03:05 * regXboi :-)s
17:03:15 <phrobb> #chair regXboi
17:03:15 <odl_meetbot> Current chairs: colindixon gzhao phrobb regXboi
17:03:16 <ChrisPriceAB> take a break!
17:03:24 * ChrisPriceAB oh too late!
17:03:37 <regXboi> somebody want to #link the agenda?
17:03:37 <kwatsen> Led Zepplin?
17:03:45 <regXboi> Gilbert and Sullivan?
17:04:04 <edwarnicke> having webex issues
17:04:04 <cdub> #info Chris Wright
17:04:12 <regXboi> how about aphex twin?
17:04:36 <edwarnicke> regXboi: Sounds like a complex mathematical algorithm
17:04:50 <regXboi> #link https://wiki.opendaylight.org/view/TSC:Main#Meeting_Agenda
17:04:51 <cdub> it is
17:04:54 <cdub> and it produces music
17:05:12 * regXboi points edwarnicke to http://en.wikipedia.org/wiki/Aphex_Twin
17:05:18 * edwarnicke is tempted to sing on the call
17:05:24 * ChrisPriceAB noooo
17:05:32 * regXboi +10000000 to ChrisPriceAB
17:05:48 <dlenrow> #info Lenrow
17:05:50 <regXboi> #topic Event Updates
17:06:14 <phrobb> #link http://events.linuxfoundation.org/events/opendaylight-developer-design-forum/program/schedule << link to dev forum schedule
17:06:18 <regXboi> #info phrobb reports that schedules for the summit event next week are still being massaged
17:08:04 <kwatsen> good man, Colin!
17:08:11 <regXboi> #info phrobb also reports on TSC chair elections - self-nominations are open until the weekend
17:08:18 <colindixon> #topic integration
17:08:53 <colindixon> #info LuisGomez reports that we are testing the release candidate and have been identifying blocking bugs and helping others find and solve them as well
17:09:07 <regXboi> #info LuisGomez reports on integration - they've identified one blocking issue for Helium which has been addressed and nothing more to report
17:09:38 <colindixon> #info regXboi, edwarnicke, and colindixon all would like to give a +10 to the integration team
17:09:41 <colindixon> #topic documentation
17:10:33 <colindixon> #info manny_ is working with edwarnicke to work on what’s going into the core release notes, barring him being hit by a truck the core docs will be done by EoD tomorrow
17:11:15 <regXboi> #info regXboi reports that the helium review included pushing projects to provide content to the doc projects
17:12:20 <regXboi> colindixon: got the action ready to go?
17:12:26 <regXboi> (i'm holding the topic for you
17:12:27 <colindixon> working on it
17:12:32 <colindixon> we’ll put it later when we talk about docs
17:12:34 <colindixon> just topic
17:12:36 <regXboi> #fopic helium release status
17:12:44 <regXboi> #topic helium release status
17:12:45 <colindixon> misspelled topic
17:12:48 * regXboi mumbles nice
17:13:46 <gzhao> https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163
17:13:56 <colindixon> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit?pli=1#gid=670022163 the blocking issues for Helium
17:14:55 <LuisGomez> +1000 to gzhao and his release spreadsheet
17:18:09 <gzhao> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=1622731782 <= blocking issue from Bugzilla by Colin
17:18:10 <phrobb> #link https://wiki.opendaylight.org/view/Project_Proposals:Discovery << Discovery Project Proposal
17:18:16 <alagalah> What alias is the email on ???
17:18:20 <alagalah> discuss ???
17:18:22 <tbachman> TSC
17:18:28 <gzhao> LuisGomez: thanks
17:18:35 <gzhao> tbachman: yes
17:18:51 <colindixon> #action phudgins to put the contents of the e-mail clarification in the proposal
17:18:55 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2014-September/001782.html Project Proposal for Discovery
17:19:41 <alagalah> colindixon: It seems like this is a proactive sweep of the network into Inventory as opposed to the network element self-identifying.
17:21:22 <colindixon> #info colindixon says he does not understand why the topology and inventory models don’t provide the support described
17:22:32 <colindixon> #info phudgins says that this is really a generic method to “discover” a device, find a module to own it, and then push it into the right existing model(s)
17:23:32 <rexpugh> Can't these project proposals have a seperate forum (dedicated meeting) to educate TSC and key committers to get offline consensus to drive TSC votes. Lack of time by TSC members is understandable but also an impediment to community progress. Great design summit topic!
17:23:43 <dlenrow> Even if you think this is a horrible idea, based on our bylaws we have no grounds to reject their request for incubation. Folks are allowed to incubate anything they are willing to work on. Why are we making him run the gauntlet before our inevitable approval?
17:24:14 <dlenrow> If this is in scope for ODL (i.e. it has to do with networking) we will approve for incubation
17:24:28 <colindixon> #action phudgins to to add the committers for HP to the wiki
17:26:18 <cdub> "This proposal does not include the algorithms to find new network elements, such as a ping sweep; It is assumed that finding is the responsibility of other modules. This proposal will interact with topology and inventory modules as network elements and links are discovered."
17:26:31 <cdub> kwatsen: ^^ that's the "Scope" section
17:27:11 <phrobb> #info rexpugh notes that the TSC should consider having  a separate meeting to educate TSC and key committers on project scope and description so that evaluation and approval for proposals can be done more quickly in TSC meeting.
17:27:27 <colindixon> #info edwarnicke asks for the scope to be explicitly stated to say that this project does not want to do the discovery but to provide APIs that help people do that once it’s discovered
17:28:54 <phrobb> #info colindixon asks if this is a generic form of discovery, we should get it to work with legacy projects as well as new ones… hence having committment/committer from those groups would be needed
17:29:38 <phrobb> #info phudgins notes that he would be happy to include other interested projects/committers in the project
17:31:11 <colindixon> #info edwarnicke says that he’s allergic forcing committers on anyone else, and so would favor approving things with the intended changes made (to committers, to scope, etc.)
17:32:15 <phrobb> #info dlenrow notes that getting into incubation for past project reviews has been very easy.  Sending this project off to provide more information multiple times seems against our past behavior
17:34:16 <phrobb> #info TSC members note that being liberal in acceptance to incubation is a core value, but also from past experience there are some topics (committers, scope understanding, potential relationship to across other ODL projects) is helpful to understand
17:36:01 <colindixon> is this conditional on committers and scope being fixed?
17:36:19 <dbainbri> i would say with the proposed changes to the proposal
17:36:24 <dbainbri> committers, scope
17:36:29 <dlenrow> We have conditionally approved in past
17:36:51 <dlenrow> Approve pending completion of blah, blah
17:37:05 <cdub> dlenrow: +1
17:38:14 <colindixon> #topic project merge jobs breaking
17:38:38 <colindixon> #info regXboi and edwarnicke note that a misconfigured merge job which broke integration
17:40:06 <colindixon> #info regXboi has done a linear walk of all the jenkins he cold find (based on the helium release) to make sure that no other merge jobs are broken in a way that will break things over the weekend
17:40:26 <colindixon> #Info this problem cost us a few days at a critical time and should be reviewed in the future
17:40:56 <colindixon> #Info edwarnicke pleads for us to ask the board for a community support person that can comb through things and find bugs like this early
17:41:53 <colindixon> #info dmm and colindixon agree that we this role should be filled
17:42:11 <colindixon> #topic release candidates
17:43:09 <colindixon> #info dmm notes that in the future we need to work on defining what release candidates are
17:43:38 <colindixon> #info regXboi asks if we ever agreed on release vehicles
17:44:11 <colindixon> #info colindixon notes that we did agree on karaf would be one of the release vehicles, but didn’t agree that it would be the only vehicle
17:44:24 <phrobb> #link http://odl-project-explorer.herokuapp.com/download << link to download page prototype
17:44:28 <colindixon> #undo
17:44:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x24a9050>
17:44:33 <colindixon> #topic Helium download tool
17:44:45 <colindixon> #link http://odl-project-explorer.herokuapp.com/download the download tool as it stands today
17:44:52 <dbainbri> updated: https://wiki.opendaylight.org/view/Project_Proposals:Discovery#Scope, let me know if this is not clear enough in terms of scope or committers.
17:45:15 <colindixon> #info phrobb has asked him for the full list of flip cards (mlemay_away has said he imagines it will be per-project)
17:46:26 <colindixon> #info edwarnicke says that this worries him because everything we’ve discussed previously was that all features would be presented, not just a subset or just projects
17:47:24 <colindixon> #info edwarnicke also note that it doesn’t work to download, phrobb confirms that and says this is just for look and feel
17:47:30 <phrobb> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1751723309
17:48:25 <colindixon> #info colindixon also says he thought it would be feature-based
17:48:42 <colindixon> #info phrobb asks if the list of features listed in the above sheet are the right things to show to users
17:49:10 <colindixon> #info edwarnicke says some of this is out of date and some may need to be modulated by asking projects what features they want to expose to users
17:51:49 <colindixon> #info colindixon suggests that we use this list as a starting point, reach out to projects if we think they should be exposing different features, also telling all projects what we’re planning on doing so they can adjust if they need
17:53:30 <colindixon> #info colindixon explicitly notes that to avoid the political issues, it seems we pretty much need to allow projects to surface whatever features they want
17:53:45 <colindixon> #info kwatsen asks why are we doing a web portal instead of an installer?
17:54:08 <colindixon> #info edwarnicke says the answer is that the people who wanted to do the work were willing to do that
17:54:11 <tbachman> time check
17:54:18 <tbachman> (Discovery project proposal)
17:55:02 <colindixon> #info phrobb asks if we want to surface internal features or just to drag them in through the other features
17:55:28 <colindixon> #info edwarnicke says he thinks it’s the latter, with the possible exception of clustering
17:55:40 <colindixon> tbachman: noted
17:56:03 <dmm> tbachman: yeah, I know
17:56:10 <tbachman> :)
17:56:32 * tbachman apologizes for being a pest :)
17:57:36 <colindixon> #info cdub says he doesn’t quite see how we’re going to execute this before Monday
17:57:41 <colindixon> #info phrobb agrees with that
17:58:10 <colindixon> #info colindixon suggests that we ship the custom distribution downloader after the release and the first release is just the karaf zip file
17:58:23 <colindixon> #Info phrobb asks what docs we need to produce to make that possible
17:59:09 <cdub> mlemay gets #action'd by not showing up...lesson to us all ;)
17:59:28 * alagalah cdub nice...
17:59:57 <dbainbri> @tbachman: thx ;)
18:00:43 <colindixon> #Info edwarnicke suggests a 4 column table of: (i) human-readable component name, (ii) human-readable description, (iii) features command to load that component, (iv) compatibility notes
18:00:54 <phrobb> #info LuisGomez asks what information is in each project's installation guide given it's relation to name/desc/features, etc
18:01:20 <colindixon> #info we need somebody to make this table, it could be pulled from install guide if projects are filling it out right
18:01:24 <LuisGomez> #info i just want to make sure we do not work twice
18:01:48 <colindixon> #topic release artifact approval
18:02:12 <colindixon> #agree will will review release artifacts at a special TSC meeting on Monday morning
18:02:19 <colindixon> #undo
18:02:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2534d10>
18:02:31 <colindixon> #agree will will review release artifacts at a special TSC meeting on Monday morning
18:02:34 <colindixon> #undo
18:02:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2534f50>
18:02:37 <colindixon> #agree will will review release artifacts at a special TSC meeting on Monday aftenoon
18:02:45 <colindixon> #action colindixon will lead producing the documentation table
18:04:13 <colindixon> #info colindixon asks if we can do it during lunch in the summit
18:04:17 <cdub> actually 12:15pm (lunch schedule)
18:04:36 <colindixon> #undo
18:04:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2534d10>
18:04:46 <colindixon> #agree we will meet at 12:15p pacific on Monday
18:05:19 <cdub> no objection
18:05:23 <kwatsen> no objection
18:06:12 <colindixon> #agree the TSC agrees that the karaf distribution (possibly modulated by the web downloader) will be *the* release vehicle for Helium
18:06:42 <dbainbri> #link https://wiki.opendaylight.org/view/Project_Proposals:Discovery
18:06:49 <regXboi> #undo
18:06:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2497450>
18:06:51 <phrobb> #startvote Shall the TSC accept the Discovery project into OpenDaylight as an Incubation Project? -1, 0, +1
18:06:51 <odl_meetbot> Begin voting on: Shall the TSC accept the Discovery project into OpenDaylight as an Incubation Project? Valid vote options are -1, 0, +1.
18:06:51 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:06:53 <colindixon> #info colindixon notes that for clarification, we would like the web downloader in the future, we are just using an alternative for quicker delivery by 9/29
18:06:54 <regXboi> #topic revisit of discovery
18:06:59 <regXboi> #link https://wiki.opendaylight.org/view/Project_Proposals:Discovery
18:07:03 <dmm> #vote +1
18:07:08 <regXboi> #vote +1
18:07:08 <dlenrow> #vote +1
18:07:21 <IvanWood> #vote +1
18:07:26 <colindixon> #vote +1
18:07:27 <ChrisPriceAB> #vote +1 (if we don't start one)
18:07:27 <odl_meetbot> ChrisPriceAB: +1 (if we don't start one) is not a valid option. Valid options are -1, 0, +1.
18:07:35 <cdub> #vote +1
18:07:37 <ChrisPriceAB> #vote +1
18:07:45 <edwarnicke> #vote +1
18:07:50 <phrobb> #endvote
18:07:50 <odl_meetbot> Voted on "Shall the TSC accept the Discovery project into OpenDaylight as an Incubation Project?" Results are
18:07:50 <odl_meetbot> +1 (8): dlenrow, regXboi, dmm, ChrisPriceAB, cdub, edwarnicke, colindixon, IvanWood
18:07:53 <kwatsen> #vote +1
18:07:59 * ChrisPriceAB congratulation!
18:08:00 <regXboi> #info congrats to discovery and welcome aboard!
18:08:06 <colindixon> #info note kwatsen had a late +1 vote for the record
18:08:07 <dbainbri> thx.
18:08:12 <phrobb> #agreed Discovery Project is moved to Incubation
18:09:13 <cdub> helium
18:09:33 <cdub> branch + stable release
18:09:36 <colindixon> #topic final topics
18:09:47 <colindixon> #info we need to talk about EOLing hydrogen
18:09:52 <colindixon> #undo
18:09:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x282fe10>
18:10:08 <colindixon> #info regXboi says we need to talk about EOLing hydrogen in the future
18:10:40 <colindixon> #info we need to establish whether and how projects have to cut stable release branches for helium (or to delay it), we can do that on Monday
18:11:08 <colindixon> #endmeeting