19:39:33 <phrobb> #startmeeting tsc
19:39:33 <odl_meetbot> Meeting started Mon Sep 29 19:39:33 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
19:39:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:39:33 <odl_meetbot> The meeting name has been set to 'tsc'
19:39:50 <phrobb> #topic Roll Call: TSC members please #info in
19:40:31 <regXboi> #info regXboi
19:40:39 <phrobb> #info TSC members in Conference Room Chris Price, Kent Watsen, Ed Warnicke, Dave Meyer, Colin Dixon, Jan Medved
19:45:56 <kwatsen> #info Kent Watsen
19:46:12 <phrobb> #link https://docs.google.com/spreadsheets/d/1TRYposNDFPaKcySlvwkOXvfR6Anx2EFujlIjoTthhRY/edit#gid=670022163
19:46:43 <ChrisPriceAB> #info Chris Price
19:50:40 <tbachman> folks — email with webex: https://lists.opendaylight.org/pipermail/tsc/2014-September/001797.html
19:52:58 <dlenrow> #info Lenrow
19:53:30 <colindixon> #info colindixon
19:53:51 <phrobb> #topic Helium Release Status
19:54:06 <phrobb> #chair regXboi colindixon
19:54:06 <odl_meetbot> Current chairs: colindixon phrobb regXboi
19:54:16 <regXboi> um
19:54:18 <regXboi> why?
19:54:20 <regXboi> :)
19:54:29 <colindixon> #info TSC members in the room are: dave lenrow, david meyer, colin dixon, chris prices, kent watsen, jan medved, ed warnicke, chris wright
19:54:42 * regXboi wonders ....
19:55:01 * ChrisPriceAB about?
19:56:14 <colindixon> #info there is a discussion of the current blocking issues (2098, 2091, 2103, 2106, 2108, and 2112)
19:56:33 <kwatsen> #info 2106 - statistical bug
19:56:43 <kwatsen> #info 2018 - never reproduced?
19:56:55 <colindixon> #undo
19:56:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x272e290>
19:57:10 <colindixon> #info 2108 is something edwarnicke saw once and has never been reporduced
19:57:11 <colindixon> #info colindixon says that he felt as though we had an almost ready-to-release version 5 days ago and it feels like we’ve regressed
19:57:17 <kwatsen> #info 2098 - dangling/missing nodes
19:57:51 <phrobb> #chair kwat
19:57:51 <odl_meetbot> Warning: Nick not in channel: kwat
19:57:51 <odl_meetbot> Current chairs: colindixon kwat phrobb regXboi
19:58:04 <phrobb> #chair kwatsen
19:58:04 <odl_meetbot> Current chairs: colindixon kwat kwatsen phrobb regXboi
19:58:15 <regXboi> #chair kwat
19:58:15 <odl_meetbot> Current chairs: colindixon kwat kwatsen phrobb regXboi
19:58:22 <regXboi> #unchair kwat
19:58:22 <odl_meetbot> Current chairs: colindixon kwatsen phrobb regXboi
19:58:36 <colindixon> #info 2112 is something which appears to have been a regression in GBP which they are currently bisecting
20:00:42 <kwatsen> #info 2106 can hand controller, fix is almost in
20:00:47 <kwatsen> #undo
20:00:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2484c90>
20:00:55 <kwatsen> #info 2106 can hang controller, fix is almost in
20:04:53 <colindixon> #topic what our options are now
20:05:16 <colindixon> #info marketing people have said (publicly) that we will release code today
20:06:28 <colindixon> #info we are left between a rock (release code with know bugs without workarounds) and a hard place (not releasing as promised)
20:07:26 <kwatsen> #info Ed details that it takes 8-10 hours to turn the crank, 4 hours just to build
20:07:31 <colindixon> #info the discussion boils down to the fact that it takes ~4.5 hours to even produce a zip file and then several hours to test
20:08:06 <kwatsen> #info Dave says no chance to release today, only decision is what to tell Marketing
20:09:29 <kwatsen> #undo
20:09:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x269ee50>
20:09:30 <colindixon> #info the key points to make is that (i) we found last-minute show-stopping bugs, (ii) we are committed to shipping good, stable code, and (iii) as a consequence we will not be shipping code today
20:09:41 <kwatsen> #info dmm says no chance to release today, only decision is what to tell Marketing
20:11:02 <colindixon> #info add (iv) we will be meeting daily to take stock of where we are and ship at the earliest possible date
20:15:32 <cdub> #info Chris Wright (just got into IRC, sorry)
20:15:44 <edwarnicke> #info edwarnicke just got IRC too
20:15:46 <colindixon> these are the bugs 2098, 2091, 2103, 2106, and 2112
20:15:55 * ChrisPriceAB been waiting...
20:16:13 * regXboi joins ChrisPriceAB
20:16:25 <jmedved> #info Jan Medved
20:16:43 <dmm> #info dmm
20:18:00 <phrobb> #startvote shall Helium be released on 9/29 with the defects 2098, 2091, 2103, 2106, and 2112 known and as yes unverified as resolved? -1, 0, +1
20:18:00 <odl_meetbot> Begin voting on: shall Helium be released on 9/29 with the defects 2098, 2091, 2103, 2106, and 2112 known and as yes unverified as resolved? Valid vote options are -1, 0, +1.
20:18:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
20:18:04 <dlenrow> #vote -1
20:18:10 <edwarnicke> #vote -1
20:18:11 <dmm> #vote -1
20:18:11 <regXboi> #vote -1
20:18:11 <ChrisPriceAB> #vote -1
20:18:11 <kwatsen> #vote -1
20:18:13 <cdub> #vote -1
20:18:19 <jmedved> #vote -1
20:18:21 <colindixon> #vote -1
20:18:29 <phrobb> #endvote
20:18:29 <odl_meetbot> Voted on "shall Helium be released on 9/29 with the defects 2098, 2091, 2103, 2106, and 2112 known and as yes unverified as resolved?" Results are
20:18:29 <odl_meetbot> -1 (9): dlenrow, jmedved, regXboi, ChrisPriceAB, edwarnicke, cdub, kwatsen, dmm, colindixon
20:22:04 <colindixon> #topic chair elections (brief aside)
20:22:35 <colindixon> #info kwatsen asks about whether we should also do a vice chair election at the same time as the TSC chair election
20:23:15 <colindixon> #info it’s pointed out that there is no occurrence of the term vice chair in the bylaws, or TSC charter
20:23:37 <colindixon> #info so there is no such vice chair to discuss
20:24:19 <colindixon> #info dlenrow asks if the chair comes with lots of travel and promoting and things that would be useful to share
20:24:35 <colindixon> #info dmm says there was at the beginning, but now Neela, Ambassadors, etc. make this not a requirement
20:25:38 <colindixon> #info kwatsen asks dmm, but you seemed to be very much in favor of vice chair a little bit back
20:26:35 <colindixon> #info dmm says there are two reasons for that: (i) he always seems to wind up traveling on Thursday mornings, and (ii) the chair should also be looking to mentor other members to provide redundant and diverse leadership
20:26:59 <colindixon> #info kwatsen says the only part that’s not visible to the whole TSC, but is visible to the chair is the board
20:27:23 <colindixon> #info those who sit on both (including dmm) say that isn’t really a big issue
20:28:10 <colindixon> #topic dealing with the fallout of the helium (non) release
20:31:16 <phrobb> #info four points, 1)  late discovery of showstopper bugs 2) As a tech community, we want to ship quality code, 3) this code is not ready to ship, 4) A new date for delivery is not yet known.
20:32:32 <colindixon> #info melissa asks other than the download page, where else do we need to send this
20:32:32 <phrobb> #info TSC to put this decision on discuss, tsc and release mailing lists
20:43:18 <colindixon> #topic technical, infrastructure, and process debt
20:44:11 <colindixon> #info everyone agrees that we really need to help solve this problem
20:44:33 <colindixon> #info some of it will involve the board, but there has historically been push back because we don’t have precise asks
20:45:09 <colindixon> #info we have some precise asks now which hopefully the board can board can help us meet
20:46:16 <colindixon> #info there is also a discussion that we may be growing so fast that reacting to problems we precisely understand will have us always behind
20:46:40 <colindixon> #info as a consequence we *need* at least some parts be proactive
20:47:36 <colindixon> #info the consensus is that we need a full-time infrastructure team (and maybe it’s not us, maybe it’s the LF) to keep this stuff going and anticipate needs
20:50:47 <colindixon> #info kwatsen says he thinks part of the problem is not just infrastructure, but also the simultaneous release plan
20:52:38 <colindixon> #info kwatsen suggests that we might try to target core projects that are supposed to be able to be released at any time
20:53:49 <colindixon> #info cdub says the discussion about putting the lithium release is broken in his mind, it should be wrapped into helium release goals
20:54:03 <colindixon> #info regXboi says he thinks if you do that Lithium is going to take longer than 6 months
20:54:15 <colindixon> #info colindixon suggests we just reduce the scope to make it take 6 months
20:54:26 <regXboi> the room dropped of?
20:54:28 <regXboi> er off?
20:55:33 <gzhao> regXboi: power off
20:55:35 <gzhao> accidently
20:55:52 <regXboi> ok, well - I've walked away from the bridge - we all need to do other things
20:56:12 <colindixon> #info regXboi notes that he is very much disagrees and thinks that this won’t work
20:56:17 <ChrisPriceAB> Enjoy your other things.
20:56:31 <regXboi> #info regXboi would *love* to be proven wrong
20:56:35 <colindixon> yeah
20:56:40 <colindixon> I’m trying to document things
20:56:52 <colindixon> #topic next meeting about the release
20:57:04 <colindixon> #agree the TSC will meet in salon 9 at 8a pacific tomorrow
20:57:08 <colindixon> #endmeeting