16:59:10 <phrobb> #startmeeting tsc
16:59:10 <odl_meetbot> Meeting started Thu Oct  9 16:59:10 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:10 <odl_meetbot> The meeting name has been set to 'tsc'
16:59:28 <dmm> #info dmm
16:59:28 <phrobb> #topic Roll Call - TSC members please #info in
16:59:47 <regXboi> #info regXboi is partially here
17:00:02 <phrobb> #chair dmm colindixon alagalah regXboi
17:00:02 <odl_meetbot> Current chairs: alagalah colindixon dmm phrobb regXboi
17:00:10 <colindixon> #info colindixon
17:00:14 <alagalah> #info alagalah (Keith) as proxy for Ed Warnicke
17:00:27 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda agenda as usual
17:00:36 <ChrisPriceAB> #info Chris Price
17:01:26 <regXboi> #info regXboi now here fully
17:01:30 <IvanWood> #info Ivan Wood
17:01:47 * ChrisPriceAB someone broke the internet in Sweden... Trying to get on webex, scribe well.
17:02:05 <kwatsen> #info Kent Watsen
17:02:16 <alagalah> ChrisPriceAB: maybe you need the internet allen key (see IKEA)
17:02:33 <regXboi> alagalah: seriously?
17:02:44 <alagalah> regXboi: It was there to be had
17:02:54 * ChrisPriceAB haha
17:03:01 <regXboi> alagalah: yeah, but I at least resisted the temptation
17:03:20 <dlenrow> #info Lenrow
17:03:36 <jmedved> #info jmedved
17:05:02 <colindixon> #topic dmm’s thanks
17:05:16 <colindixon> #info dmm wants to say thank you to the community, TSC, linux foundation and everyone
17:05:34 <alagalah> dmm: You rock
17:05:49 <tbachman> +1000
17:06:03 <dmm> @keith: my pleasure
17:06:34 <dlenrow> dmm: Many thanks
17:06:49 <dmm> @dlenrow: thank you
17:07:51 <phrobb> #topic Updates
17:08:18 <colindixon> tbachman: any chance you can scribe?
17:08:21 <colindixon> if you’re around?
17:08:23 <tbachman> sure!
17:08:26 <tbachman> chair?
17:08:29 * ChrisPriceAB acknowledge, can hear occasionally will not try to speak though...
17:08:29 <alagalah> #info phrobb Dusseldorf conf next week
17:08:34 <colindixon> #chair tbachman
17:08:34 <odl_meetbot> Current chairs: alagalah colindixon dmm phrobb regXboi tbachman
17:08:35 <alagalah> #chair tbachman
17:08:35 <odl_meetbot> Current chairs: alagalah colindixon dmm phrobb regXboi tbachman
17:08:40 * ChrisPriceAB still turning the ikea key
17:08:45 <tbachman> #info hackfest in Octoboer on 10/29
17:08:47 <alagalah> ChrisPriceAB: nice one
17:09:04 <tbachman> #info following week is openstack paris, with talks on ODL in the main conference and in the OpenSource ecosystem track
17:09:14 <alagalah> #link http://events.linuxfoundation.org/events/linuxcon-europe
17:09:27 <tbachman> #undo
17:09:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x28337d0>
17:09:46 <tbachman> #link http://events.linuxfoundation.org/events/linuxcon-europe Cloud Open + LinuxCon conference coming up
17:10:23 <alagalah> #link http://www.opendaylight.org/events/2014-10-29/opendaylight-tokyo-hackfest Tokyo ODL Hackfest
17:10:33 <tbachman> alagalah: thx!
17:10:39 <alagalah> tbachman: np
17:10:53 <Youcef> #info Youcef Laribi
17:11:07 <tbachman> #info Welcome to new TSC Chair Youcef Laribi, the new representative from Citrix
17:11:24 <dlenrow> Welcome Youcef!
17:11:36 <tbachman> #topic Stable Helium Update
17:12:21 <Youcef> Thanks dlenrow
17:12:31 <zxiiro> #info https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1307630876
17:12:37 <colindixon> #undo
17:12:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2492050>
17:12:47 <colindixon> #link https://docs.google.com/a/linuxfoundation.org/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1307630876
17:12:59 <tbachman> #info there are eight projects that are complete, with others waiting on dependencies
17:13:25 <tbachman> #info Most of the remaining projects are in steps 4, 5, or 6, with 8-9 of them that haven’t started yet
17:14:01 <tbachman> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Cutting_Stability_Branches <= Link describing steps for cutting Helium Stability Branches
17:15:04 <tbachman> #info zxiiro says that the remaining projects that haven’t started are likely doing so because they think they can’t start yet b/c they are blocked on dependent projects
17:15:40 <tbachman> #info colindixon notes that the autorelease for stable/helium is about 1 month away, so we need to get the branches cut soon
17:16:35 <tbachman> #info LuisGomez asks why there are two projects in the spreadsheet with no contact
17:16:45 <tbachman> #info phrobb notes that opflex is an error because it wasn’t in helium
17:17:16 <tbachman> #action zxiiro will track down the contact for sbni
17:17:17 <kwatsen> #info 8 projects completed, 7 projects in steps 4-6, 8 not started yet
17:17:36 <icbts> We’re waiting on a pair of blocker issue for Karaf 3.0.2 - hoping to have those down stream fixes available in next few days, then it’ll take our standard 72 vote period to make an RC available. Should be available then for your next Controller release.
17:17:38 <phrobb> #action zxiiro to remove opflex from helium/stable spreadsheet and find "handler" for sdni project
17:17:47 <tbachman> phrobb: thx!
17:18:16 <tbachman> I realized that my action was bad — let me correct
17:18:18 <tbachman> #undo
17:18:18 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2492f10>
17:18:19 <tbachman> #undo
17:18:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x26959d0>
17:18:20 <tbachman> #undo
17:18:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2695a90>
17:18:29 <tbachman> #info 8 projects completed, 7 projects in steps 4-6, 8 not started yet
17:18:36 <tbachman> : #action zxiiro to remove opflex from helium/stable spreadsheet and find "handler" for sdni project
17:18:48 <tbachman> #action zxiiro to remove opflex from helium/stable spreadsheet and find "handler" for sdni project
17:19:01 <tbachman> (the previous action probably didn’t happen b/c of the leading colon)
17:19:32 <tbachman> #topic System Integration and Testing
17:20:26 <tbachman> #info LuisGomez says there are two new workgroups in Integration: Project Engagement to get requirements for testing from the beginning and work closely with release management; and Performance Tools, to focus just on creating performance tools
17:20:52 <tbachman> #info LuisGomez said that someone has asked about Windows testing, as there are possibly issues with the Windows karaf distribution
17:21:14 <tbachman> #info LuisGomez asks if someone from Microsoft could find someone to help out with Windows integration testing
17:21:31 <icbts> #info The base Karaf windows distribution is tested prior to our releases, so issues found may be ODL specific
17:21:53 <tbachman> #info colindixon asks whether we can get a MAC and Windows machines/resources for the integration team for testing
17:21:56 <tbachman> icbts: thx!
17:22:35 <icbts> tbachman: i have karaf builds on automated nightly jenkins builds on Windows 7 & 2012 server
17:22:44 <tbachman> #action IvanWood will try to find out more information about the issues with Windows
17:23:54 <tbachman> regXboi cries?
17:24:07 <tykeal> only quietly in the corner
17:24:11 <tbachman> #info colindixon asks if we’ve started testing on stable/helium yet
17:24:12 <regXboi> tears of joy at not being "the windows guy" any longer
17:24:19 <tbachman> #info LuisGomez says this hasn’t happened yet
17:24:21 <tbachman> regXboi: ;)
17:24:22 <tbachman> lol
17:24:42 <phrobb> #action IvanWood, LuisGomez, and phrobb to get together to build a plan for Windows testing in integration (test expertise, and actual hardware and OS platform).
17:25:56 <tbachman> #topic Committer Promotions on OVSDB
17:26:43 <tbachman> #info shague and flaviof have been nominated by the OVSDB team as committers
17:27:14 * ChrisPriceAB rapturous cheers
17:27:31 <tbachman> #info colindixon asks if there’s a precedent for requiring a committer during the TSC call for committers
17:27:41 <regXboi> #link https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-October/000749.html
17:27:47 <regXboi> #undo
17:27:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2524d90>
17:27:58 <tbachman> #info phrobb says he doesn’t think there’s such a precendent, but we have emails indicating +1’s from the OVSDB committers
17:27:59 <regXboi> #link https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-October/000749.html email thread on new committers for OVSDB
17:28:26 * tbachman starts digging for spectrometer
17:28:35 <colindixon> #link http://spectrometer.opendaylight.org/?user_id=shague&metric=commits same hague on spectrometer
17:28:44 <alagalah> +1
17:28:46 <alagalah> ?
17:28:48 <regXboi> #link http://spectrometer.opendaylight.org/?user_id=ffernandes fLavio on spectrometer
17:28:56 <tbachman> #link http://spectrometer.opendaylight.org/?user_id=ffernandes Spectrometer for Flavio Fenandes
17:29:00 <tbachman> ugh
17:29:11 <tbachman> oh, I spelled it right :)
17:29:15 <tbachman> #undo
17:29:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2847d90>
17:29:19 <tbachman> regXboi: thx
17:29:47 <tbachman> phrobb: you want to handle the startvote?
17:30:37 <tbachman> #info regXboi says that flaviof  and shague are #3 and #6 on the contributors for OVSDB
17:31:23 <phrobb> #startvote Shall the TSC approve shague and flaviof as committers on the OVSDB project? -1, 0, +1
17:31:23 <odl_meetbot> Begin voting on: Shall the TSC approve shague and flaviof as committers on the OVSDB project? Valid vote options are -1, 0, +1.
17:31:23 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:31:32 <colindixon> #vote +1
17:31:33 <kwatsen> #vote +1
17:31:34 <regXboi> #vote +1
17:31:35 <ChrisPriceAB> #vote +1
17:31:40 <alagalah> #vote +1
17:31:41 <Youcef> #vote +1
17:31:43 <dmm> #vote +1
17:31:47 <IvanWood> #vote +1
17:31:50 <tykeal> colindixon: I think you got a bad character in front of that #
17:31:58 <colindixon> #vote +1
17:32:14 <phrobb> #endvote
17:32:14 <odl_meetbot> Voted on "Shall the TSC approve shague and flaviof as committers on the OVSDB project?" Results are
17:32:14 <odl_meetbot> +1 (8): regXboi, alagalah, ChrisPriceAB, dmm, kwatsen, colindixon, Youcef, IvanWood
17:32:17 <jmedved> #vote +1
17:32:19 <alagalah> Congrats flaviof shague
17:32:19 <dlenrow> #vote +1
17:32:33 <regXboi> hear, hear!
17:32:44 <tbachman> #info flaviof and shague are promoted to committers on the OVSDB project
17:32:46 <phrobb> #agreed shague and flaviof are now committers on the OVSDB project
17:32:55 <tbachman> congrats flaviof and shague !!!
17:33:22 <tbachman> #topic Hydrogen End of Life
17:33:44 <alagalah> No
17:33:57 <tbachman> #info colindixon asks if we can just vote to end of life hydrogen today
17:34:27 <tbachman> #info dlenrow says that he has received little feedback about the need for sable hydrogen
17:34:27 <alagalah> #info IMHO you can't vote on EOL or EOS without defining the terms
17:34:56 <tbachman> #info regXboi says we should set some ground rules for End of Life and End of Support
17:35:18 <tbachman> #info regXboi would favor voting End of Support today, and focus on End of Life later
17:35:21 <rovarga> I am not sure we should be removing downloads ...
17:35:59 <tykeal> at worst they download links would be removed from the download page, but they'll stay in the Nexus release repository (where our download links point)
17:36:13 <tbachman> #info jmedved asks if we can define support, as that carries certain committments
17:36:22 <tbachman> #info colindixon says the proposal on the table is no more patches
17:36:51 <tbachman> #info regXboi says that in theory someone could file a defect against Hydrogen, and we as a community ought to consider cutting a new release to address the defect(s)
17:37:30 <tbachman> #info jmedved says that even if someone in the community pushes a patch, are we going to commit resources to that release (reviewing, testing, etc.)
17:37:55 <tbachman> #info rovarga says that whether or not to take patches should be up to the project
17:38:14 <alagalah> rovarga: So that would be outside of stable/hydrogen correct ???
17:38:26 <tbachman> #info This means there are two issues: project life cycle, and support for the simultaneous release
17:38:33 <ChrisPriceAB> So are we stating: 1) we will not intend to cut a new release of hydrogen.  2) we will lock the stable branches 3) will will remove the released downloads?  (each of 1,2 3 have different meanings)
17:38:35 <alagalah> So perhaps the greater question is, will we ever have another stable/hydrogen ??
17:38:49 <colindixon> alagalah: we never had one
17:38:50 * ChrisPriceAB sorry can't follow voice
17:39:40 <regXboi> ChrisPriceAB: my sense is #1 yes, #2 no, #3 no (under EoS)
17:39:45 <tbachman> phrobb: I’m sensing a vote topic ;)
17:39:46 <tbachman> lol
17:40:04 <ChrisPriceAB> regXboi:  Ok that would make the most sense to me
17:40:07 <rovarga> regXboi: +1
17:40:09 <regXboi> ChrisPriceAB: my sense is #1 yes, #2 no, #3 no, (remove links from download page) yes (under EoL)
17:40:22 <dmm> my phone just died...
17:40:34 <regXboi> dmm: sorry :(
17:40:39 <alagalah> regXboi: So in essence if we agree to this, then we need to determine the timeframe with notification, yes ?
17:40:45 <ChrisPriceAB> ok, now I know when the vote comes, thanks regXboi
17:41:15 * ChrisPriceAB vote! vote! vote! vote! (disruptive in the face of silence)
17:41:37 <alagalah> ChrisPriceAB: If you don't have audio, there is quite a bit of discussion about the structure of the vote predicate
17:41:41 <ChrisPriceAB> dmm: welcome to my world!  (still psinning the ikea key)
17:41:59 <ChrisPriceAB> I will read the stated vote cerfully
17:42:21 <regXboi> #info proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases), projects may continue to update stable branches, and stable/hydrogen will still be available for download
17:42:44 <tbachman> no more, or “no” ;)
17:42:59 * ChrisPriceAB don't be cheeky
17:43:00 <tbachman> lol
17:43:02 <tbachman> sorry
17:43:20 <regXboi> #info proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download)
17:43:43 <colindixon> dmm and ChrisPriceAB does that sound right?
17:43:48 <colindixon> and we’ll vote
17:43:51 <regXboi> colindixon: thanks
17:43:52 <ChrisPriceAB> That sounds highly logical
17:44:05 <phrobb> #startvote proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download)? -1, 0, +1
17:44:05 <odl_meetbot> Begin voting on: proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download)? Valid vote options are -1, 0, +1.
17:44:05 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:44:18 <ChrisPriceAB> #vote +1
17:44:20 <kwatsen> #vote +1
17:44:22 <dlenrow> #vote +1
17:44:23 <alagalah> #vote +1
17:44:25 <colindixon> #vote +1
17:44:27 <regXboi> vote +1
17:44:31 <regXboi> #vote +1
17:44:32 <Youcef> #vote +1
17:44:44 <dmm> #vote +1
17:44:49 <regXboi> #info alagalah notes that there are no current bugs outstanding against hydrogen
17:44:57 <jmedved> #vote +1
17:45:01 <phrobb> #endvote
17:45:01 <odl_meetbot> Voted on "proposal for vote: should the TSC declare EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download)?" Results are
17:45:01 <odl_meetbot> +1 (9): dlenrow, jmedved, regXboi, Youcef, ChrisPriceAB, dmm, kwatsen, colindixon, alagalah
17:45:11 * ChrisPriceAB goodnight Hydrogen, you were much loved.
17:45:34 * ChrisPriceAB just putting it to sleep right ;)
17:45:45 <tbachman> #agreed EoS for Hydrogen (which means that there will be no more stable/hydrogen simultaneous releases, projects may continue [but are not required] to update stable/hydrogen branches, and stable/hydrogen will still be available for download)
17:45:55 <dmm> hard lessons well learnt
17:46:00 <tbachman> #topic Longer TSC Meetings
17:46:19 <tbachman> #info phrobb says that at the end and beginning of cycles, there are usually a lot more topics
17:46:19 <dlenrow> is learnt a word? Modern english?
17:46:21 <colindixon> dmm: we learned *so* much from Hydrogen, now we just need to make sure we actually apply those learnings
17:46:37 <tbachman> #info phrobb asks if we want to increase the meetings to 90 minutes or 2 hours over the next couple of months
17:46:37 * regXboi is happy to put that issue to rest (where is that shove and that wooden stakel) and look forward to lithium
17:46:40 <dmm> yeah, I realized that too
17:47:01 <dlenrow> it's an oregon thing
17:47:36 <alagalah> dmm: Its a real word for all intensive porpoises
17:47:42 <tbachman> #info regXboi proposes 3-4 weeks we increase, and then about 6 weeks before the Lithium release
17:47:43 <dmm> :-)
17:47:45 * ChrisPriceAB is it just me or do the TSC calls feel different when Ed is on vacation?
17:47:56 <dneary> Hi everyone by the way
17:48:04 <dneary> Listening on the call, but staying quiet
17:48:06 <regXboi> ChrisPriceAB: no comment
17:48:13 * ChrisPriceAB alagalah don't insult my dolfin!
17:48:26 <tbachman> #info kwatsen says that it seemed like we needed extra time towards the end of Helium
17:48:27 <dlenrow> dneary: We need someone to keep silent
17:48:42 <dneary> dlenrow, That's what IRC is for
17:48:45 <tbachman> #info colindixon asks whether folks prefer 90 minutes or 2hrs?
17:48:49 <alagalah> colindixon: Only if we police the time limits on the agenda
17:49:11 <tbachman> #info regXboi prefers 2hrs for now
17:49:33 * tbachman will have bulk up his scribe fingers
17:49:35 * ChrisPriceAB colindixon: that depends what I'm doing...
17:49:42 <regXboi> alagalah: +1M
17:50:27 <regXboi> #info alagalah points out that if we schedule for 2 hrs we can go short, but if we schedule for 90 minutes then we have a harder time going longer
17:50:28 <dlenrow> +1 good time management
17:50:34 <phrobb> #startvote Shall the TSC increase their weekly meetings to 2 hours while discussion topics warrant it? -1, 0, +1
17:50:34 <odl_meetbot> Begin voting on: Shall the TSC increase their weekly meetings to 2 hours while discussion topics warrant it? Valid vote options are -1, 0, +1.
17:50:34 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:50:40 <regXboi> #vote +1
17:50:41 <colindixon> #vote +1
17:50:43 <ChrisPriceAB> #vote +1
17:50:48 <dlenrow> #vote +1
17:50:50 <dmm> #voyr +2
17:50:51 <alagalah> #vote +1
17:50:55 <dmm> sighjt
17:50:57 <jmedved> #vote +1
17:50:59 <kwatsen> #vote +1
17:51:08 <dmm> #vote +1
17:51:10 <dneary> colindixon, Thanks for the info on the meeting by the way. V interesting for me
17:51:15 <dmm> (wow, that was hard)
17:51:21 <regXboi> dmm: is that some Nordic spelling of "sigh"? :)
17:51:24 <phrobb> #endvote
17:51:24 <odl_meetbot> Voted on "Shall the TSC increase their weekly meetings to 2 hours while discussion topics warrant it?" Results are
17:51:24 <odl_meetbot> +1 (8): dlenrow, jmedved, regXboi, ChrisPriceAB, dmm, kwatsen, colindixon, alagalah
17:51:24 * ChrisPriceAB makes me feel good when we finish early (did you hear that colindixon ?)
17:51:31 <dneary> dmm, Does the TSC have +2 votes?
17:51:47 <phrobb> #agreed TSC meetings are now 2 hours
17:51:49 <alagalah> dneary: It has +2 typos
17:51:51 <alagalah> :)
17:51:53 <ChrisPriceAB> special privelage for dmm
17:52:07 * ChrisPriceAB bad spelling for ChrisPriceAB
17:52:13 <tbachman> +1000 for _2
17:52:13 <phrobb> #action phrobb to change the TSC meeting invites to 2 hours
17:52:22 <regXboi> #topic debt reduction
17:52:27 <alagalah> I was gonna say ChrisPriceAB ... we needz a seshun on spellificashun
17:52:31 <colindixon> #link https://wiki.opendaylight.org/view/File:Debt-reduction-ideas.TSC-meeting.2014.10.09.pptx slides with conrcrete suggestions/ides
17:52:43 <ChrisPriceAB> alagalah: wot?
17:53:42 <tbachman> #info colindixon says a couple of people have proposed that we delay starting the Lithium release to perform concrete, time-boxed work on addressing the various debt on OpenDaylight
17:54:35 <dlenrow> +1 first project in history to attack tech debt before too late
17:54:37 <alagalah> #info regXboi points out that cdub has some strong opinions on stopping work for Tech Debt so asks if topic can be deferred until he can have input
17:54:38 <tbachman> #info regXboi notes that cdub (who couldn’t be at today’s TSC due to business travel) had a strong opinion against delaying the start of Lithium, and we may want to wait for him to return before making any decision on this
17:54:45 <tbachman> #undo
17:54:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2845550>
17:54:48 <regXboi> um
17:54:48 <tbachman> alagalah: thx!
17:55:07 <alagalah> regXboi: Did I say it wrong ?
17:55:28 <regXboi> alagalah: nope... race condition between um and undo
17:55:33 <ChrisPriceAB> when wouod we need to make a decision, by not establishing the SR program we are essentially delaying right?
17:55:55 <alagalah> ChrisPriceAB: SR ?
17:56:04 <ChrisPriceAB> simultaneous release
17:56:09 <phrobb> #info colindixon notes that he doesn't want to delay the Lithiium Release schedule if we don't have concrete, time-boxed technical debt reduction items to deliver
17:56:34 <alagalah> ChrisPriceAB: Ah, got it, the Mx gates etc
17:56:40 <ChrisPriceAB> yup
17:56:41 <tbachman> #info regXboi notes that with increased TSC time, we might be able to do this without delaying Lithium start
17:56:54 <regXboi> there is a draft litium simultaneous release plan out
17:56:56 <dlenrow> How would we quantify the amount of time to slip without scoping the work?
17:57:03 <regXboi> #info there is a draft litium simultaneous release plan out
17:57:15 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan
17:57:16 <kwatsen> the posted release plan has disclaimers all over it
17:57:25 <tbachman> #undo
17:57:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2845190>
17:57:42 <tbachman> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan draft Lithium Release Plan
17:57:43 <ChrisPriceAB> a point in note.  The TSC should likely vote for the approval of the release plan weeks in advance of the first deadline right?
17:58:34 <alagalah> colindixon: regXboi is trying to say something and I have an observation I want to make
18:00:01 <tbachman> #info kwatsen says we should re-label this to indicate that this isn’t the plan of record
18:00:13 <tbachman> #info dlenrow notes we need to address the dates as well
18:00:33 <rovarga> I think we need to also make the API/code/RC freezes
18:00:51 <rovarga> or rather reworking them
18:01:13 <tbachman> #info alagalah says that the release plan doesn’t address project dependencies
18:01:58 <tbachman> #info colindixon says that Hydrogen did have a concept of different release stages to address this
18:03:17 <alagalah> colindixon: I tried to edit... not sure if it went thru
18:03:40 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan update page with red warning
18:03:41 <regXboi> alagalah: I got it
18:03:51 <regXboi> (I think)
18:03:52 <rovarga> we need feature freeze -> API freeze -> code freeze -> RCs
18:04:10 <rovarga> we do not have feature freeze, so features are rushed in before code freeze
18:04:33 <alagalah> The point I was specifically making is that if I am dependent on someone elses API, then waiting till M4 for that isn't very nice in terms of time left over
18:04:41 <alagalah> rovarga: ACK ACK ACK
18:04:46 <alagalah> rovarga: +1
18:05:15 <regXboi> rovarga: +1
18:05:23 <dneary> Maybe I can say hi?
18:05:29 <rovarga> alagalah: yup... having alpha/beta quality APIs at feature freeze will make you happy, right? :)
18:05:33 <phrobb> #info discussion ensues on the needs for several improvements oto the Lithium Release Plan
18:05:57 * ChrisPriceAB all hail colindixon, well done and welcome to the job. ;)
18:06:07 <tbachman> #info colindixon requests that folks add requests/ideas to the bottom of the Lithium Release Plan
18:06:09 <dneary> colindixon, Thanks
18:06:17 <kwatsen> agreed, nice job Colin
18:06:37 <tbachman> #topic Introduction of Dave Neary
18:07:12 <tbachman> #info dneary will be spending ~25% of his time working with phrobb, neelajaques, et. al. on how to grow a healthy a community
18:07:30 <dneary> #info Dave is reachable at dneary@redhat.com, dneary on IRC
18:07:45 <phrobb> #endmeeting