18:00:52 <phrobb> #startmeeting tsc
18:00:52 <odl_meetbot> Meeting started Thu Dec  4 18:00:52 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:52 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:52 <odl_meetbot> The meeting name has been set to 'tsc'
18:01:20 <phrobb> #topic Rollcall - TSC members please #info in
18:01:21 <tbachman> #topic Agenda Bashing, Roll Call, Action Items
18:01:29 <tbachman> phrobb: ah, sorry ;)
18:01:31 * tbachman can’t undo
18:01:38 <phrobb> #chair tbachman
18:01:38 <odl_meetbot> Current chairs: phrobb tbachman
18:01:44 <kwatsen> #info Kent Watsen
18:01:45 <alagalah_> #info alagalah (Keith Burns) in for Jan Medved
18:02:00 <colindixon> #info colindixon
18:02:10 <dlenrow> #info dlenrow
18:02:12 <ChrisPriceAB> #info ChrisPrice text only for a short while
18:02:13 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda
18:02:15 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-11-20-18.03.html Minutes from last week’s meeing
18:02:16 <Youcef> #info Youcef Laribi
18:02:35 <tbachman> oops
18:02:36 <tbachman> :)
18:02:41 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-11-20-18.03.html two weeks ago meeting minutes (for action items)
18:02:51 <phrobb> #chair colindixon ChrisPriceAB
18:02:51 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb tbachman
18:02:57 <jburns> #info jburns
18:03:10 <LuisGomez> #info LuisGomez
18:03:30 <tbachman> jburns: which TSC chair are you representing?
18:03:51 <colindixon> #action colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
18:04:17 <colindixon> #action mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
18:04:48 <dneary> Hi
18:05:01 <dneary> I'm trying to connect to the meeting, but webex is giving me a 31001 error
18:05:07 <regXboi> #info regXboi is running late
18:05:25 <phrobb> #chair regXboi
18:05:25 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb regXboi tbachman
18:05:35 <dfarrell07> huzzah for Forge domain! /me is glad no one snatched it
18:05:36 <regXboi> #chair regXboi
18:05:36 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb regXboi tbachman
18:05:42 <regXboi> #unchair regXboi
18:05:42 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb tbachman
18:05:48 <colindixon> #action colindixon and phrobb to work with the CAPWAP team to make sure the proposal goes through
18:05:56 <regXboi> yes I unchaired myself
18:05:57 <mlemay> @colindixon I'm still at another meeting running late
18:06:06 <tbachman> regXboi after chairing ;)
18:06:08 <regXboi> I'm running late and am rebuilding my infrastructure
18:06:09 <alagalah> CHAIR FIGHT CHAIR FIGHT
18:06:44 <dneary> Anyone have the correct meeting number handy? The one in the community calendar isn't working
18:06:54 <colindixon> #action phrobb and tykeal to follow up on getting the new certifacte for nexus to make archetypes work on MacOS
18:06:57 <dfarrell07> dneary: 194 548 370
18:07:09 <edwarnicke> alagalah: Channeling Bobby Knight?
18:07:19 <alagalah> :)
18:07:24 <dfarrell07> dneary: The GCal? That's the one I gave you and the one I'm using
18:07:38 <dneary> dfarrell07, That's the one I'm using... working OK for everyone else?
18:07:42 <edwarnicke> #info edwarnicke
18:07:51 <dneary> I will just dial in
18:07:53 <dfarrell07> dneary: Yep, seems so. Hang up and try again?
18:08:02 <dneary> Was trying to connect via webex service
18:08:12 * dfarrell07 gave up on webex a long time ago
18:08:35 <colindixon> #topic VPN Service Creation Review
18:08:36 * tykeal dials in for voice and connects to webex on his tablet for any video
18:08:41 * tbachman apologizes — will be “here” soon
18:08:52 <tykeal> 7" tablets are tiny for screen sharing though ;)
18:08:52 <phrobb> #topic VPN Creation Review
18:09:08 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:VPN_Service the proposal page
18:09:10 <cdub> #info Chris Wright
18:09:21 <edwarnicke> dude... that font is *awesome*... what is it?
18:09:23 <dneary> Dave Neary here too
18:09:28 <dneary> Dialled in now
18:10:20 <colindixon> #info propsoing a model for deploying VPN services in ODL
18:10:28 * tbachman cracks knuckles
18:10:29 <tbachman> back
18:10:40 <alagalah> edwarnicke: Some form of stencil font (if you google I guess)
18:11:11 <tbachman> #info motivation is network virtualization in the data center, recognizing that interworking with traditional networking being a problem
18:11:19 <colindixon> tbachman: thanks!
18:11:22 <tbachman> #undo
18:11:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2847950>
18:11:24 <tbachman> colindixon: np
18:11:29 <colindixon> let me know if you want a hand, esp for this part
18:11:46 <tbachman> #info motivation is network virtualization in the data center, recognizing that interworking with traditional networking elements being a problem
18:12:31 <tbachman> #info Application will use the MD-SAL and GBP-PCEP
18:12:43 <colindixon> #undo
18:12:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x28064d0>
18:12:47 <tbachman> oops
18:12:48 <tbachman> :)
18:12:52 <colindixon> #info Application will use the MD-SAL and BGP-PCEP
18:12:58 <colindixon> type GBP much? :-)
18:13:01 <tbachman> lol!
18:13:03 <tbachman> a little ;)
18:13:13 <alagalah> LOLZ
18:13:23 <tbachman> #info OVSDB and OpenFlow used to interact with switches
18:13:28 <alagalah> colindixon: Yes I have some questions too :)
18:13:58 <rgowrishankar> #info The orchestrator will be OpenStack.
18:14:04 <tbachman> #info GRE tunnels will be used between the nodes and the gateway
18:14:12 <mohnish> #info mohnish
18:14:34 <tbachman> #info The data center GW doesn’t need a lot of state since they’re using “soft GRE"
18:15:47 <colindixon> #info diagram of new and existing parts of ODL in providing the service
18:15:51 <tbachman> #info New L3 components for ODL: MP-GBP, VPN Manager Service, Next-hop Manager Service, FIB Service, and Label Manager Service
18:16:04 <rgowrishankar> #info MP-BGP will use existing BGP-LS infrastructure
18:16:09 <alagalah> abhijitkumbhare: Is this an implementation of DMVPN ?
18:16:24 <alagalah> Especially with "NHRP" functionality, it twigged as being DMVPN like
18:16:28 <tbachman> rgowrishankar: thx!
18:16:44 <rgowrishankar> yw :)
18:17:44 * ChrisPriceAB lighter colours are better colours
18:18:32 <tbachman> #info edwarnicke asks if this is intended to have a “works out of the box” deployment scenario
18:19:04 <colindixon> #info edwarnicke asks what the deployment model is? right now most things “work out of the box” as long as there’s a JVM to run it in
18:19:04 <tbachman> #info Srikar says the new functions will be no different than the existing functions in ODL
18:19:19 <tbachman> colindixon: thx!
18:19:42 <tbachman> #info Srikar says there’s no component that he’s aware of that would require  a higher end machine in order to be run
18:20:16 * ChrisPriceAB using a 3pp routing implementation is an optional approach, getting the BGP capability natively in ODL will enable the single instance model.
18:21:16 <rgowrishankar> #info edwarnicke was not asking about individual components but about the overall deployment whether additional systems would be needed to set it up..
18:21:31 <colindixon> #info srikar says most components are implemented in a prototype inside Ercsson as ODL elements that work just like ODL
18:21:33 <tbachman> #chair rgowrishankar
18:21:33 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb rgowrishankar tbachman
18:21:39 <tbachman> :)
18:22:20 <alagalah> abhijitkumbhare: I just managed to get through the Proj Prop... I see its EVPN (L2) and MPLS VPN...
18:23:17 <rgowrishankar> #info using REST to configure VPN will be available as well.. using OpenStack or other component is not mandatory.
18:23:22 <abhijitkumbhare> alagalah - yes its MPLS VPN (to start), then EVPN in the future - sorry was not looking at the IRC
18:23:41 <alagalah> abhijitkumbhare: no problem, still reading up on your FIB ...
18:23:49 * alagalah wonders about scale and summarisation
18:24:54 <colindixon> #info colindixon asks what OpenStack APIs would be implemented? ML2? VPNaaS?
18:25:39 <rovarga> btw. BGPCEP already has a BGP-MP implementation
18:25:42 <rgowrishankar> #info Targeting network of 100 vswitches and 1000 VRFs as scale
18:26:00 <colindixon> #info Srikar says that the existing VPNs in OpenStack are very IPSEC-centric, there are blueprints floating around that support MPLS-BGP VPN (what is being implemented here) and they would implement the one of those that is chosen
18:26:02 <rovarga> (e.g. BGP/LS is a plugin into an BGP-MP framework)
18:26:59 <colindixon> #info rovarga says that the BGPCEP project already provides BGP-MP, e.g., BGP/LS is a plugin into a BGP-MP framework
18:27:16 <rgowrishankar> #info using softGre instead of VxLAN because lot of existing boxes that connect to WAN support softGRE and not VxLAN
18:27:27 * ChrisPriceAB There should be nothing stopping a VxLAN based solution also... step by step based on need.
18:28:33 <colindixon> #info cdub says “I don’t think you’ll find that tunnel overhead [for VxLAN] is significant”
18:28:40 <tbachman> #info rovarga asks what BGP-MP features the project is looking for
18:28:59 <tbachman> #info Srikar says it’s essentially the VPN functionality/RFCs
18:29:23 <tbachman> #info Srikar says also RFC 3107 for label propagation
18:29:48 <tbachman> #info rovarga says those could be realized as plugins to the existing BGP framework
18:31:14 <tbachman> #info There’s one tunnel from each vSwitch to the data center gateway
18:31:27 <tbachman> #info LuisGomez asks how they plan to do that for the gateway
18:32:07 <tbachman> #info It uses MPLS over softGRE which can be realized using NETCONF, where a particular subnet applies to a softGRE
18:32:31 <tbachman> #info The current plan is to us MPLS for the VPN service label, but not the tunnel, but there’s thinking about using an LSP for tunnels as well
18:33:30 <colindixon> Benny and the D4A project apparently need to drop in ~7 minutes and would like to vote on committer promotions before they have to go… I may table this really briefly to take care of that
18:33:42 <tbachman> #info Labels are distributed via BGP to a remote site
18:33:50 <colindixon> just a heads up
18:34:05 <tbachman> colindixon: thx
18:34:12 * ChrisPriceAB need a Q&A to code generator, we'd be done in no time!
18:34:24 <colindixon> ChrisPriceAB: :-)
18:34:32 <tbachman> #topic committer promotions: Defense4all
18:34:55 <abhijitkumbhare> #info Link for the presentation
18:34:59 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/File:VPN_Service.pptx
18:35:42 <tbachman> abhijitkumbhare: thx!
18:36:02 <colindixon> abhijitkumbhare: we’ll come back to the presentation in < 5 minutes
18:36:20 <abhijitkumbhare> tbachman - returning the favor of scribing on the OpenFlow plugin meetings :)
18:36:26 <tbachman> :)
18:36:37 * tbachman reminds himself to put that meeting on his calendar
18:36:39 <colindixon> #link https://lists.opendaylight.org/pipermail/defense4all-dev/2014-September/000074.html the mailing list votes for new committers
18:36:57 * dfarrell07 is looking up stats
18:36:58 <rgowrishankar> #info Defense4All lost 3 of the 5 committers
18:37:09 <colindixon> #info proposing two new committers: Gershon Soklosky and Asaf Oron
18:37:17 <edwarnicke> #link https://git.opendaylight.org/gerrit/#/q/project:defense4all
18:37:57 <dfarrell07> #link http://spectrometer.opendaylight.org/?release=all&project_type=all&metric=loc&user_id=gershons Gershon Sokolsky history
18:38:03 <tbachman> dfarrell07: thx!
18:38:04 <colindixon> #link http://spectrometer.opendaylight.org/?metric=loc&user_id=gershons Gershon’s contributions
18:38:55 <dfarrell07> Can't find history for other two
18:39:03 <colindixon> dfarrell07: correct
18:39:41 <rgowrishankar> #info D4A asked for 3 committers. Gershon has been contributing a lot of code and Asaf has been the main contact for the Helium release. Asaf has not been contributing to ODL directly. Gershon has been committing code from both of them.
18:40:32 <phrobb> #startvote Shall the TSC approve Gerson Soklosky as a committer on the Defense4All Project? -1, 0, +1
18:40:32 <odl_meetbot> Begin voting on: Shall the TSC approve Gerson Soklosky as a committer on the Defense4All Project? Valid vote options are -1, 0, +1.
18:40:32 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:40:33 <tbachman> If gershon is pushing asaf’s commits does asaf need to be a committer (i.e. will this change)?
18:40:40 <colindixon> #vote +1
18:40:41 <cdub> #vote +1
18:40:44 <ChrisPriceAB> #vote +1
18:40:46 <alagalah> #vote +1
18:40:46 <Youcef> #vote +1
18:40:49 <kwatsen> #vote +1
18:40:50 <LuisGomez> #vote +1
18:40:53 <mohnish> #vote +1
18:40:54 <dlenrow> #vote +1
18:40:58 <edwarnicke> #vote +1
18:41:07 <regXboi> #vote +1
18:41:18 <phrobb> #endvote
18:41:18 <odl_meetbot> Voted on "Shall the TSC approve Gerson Soklosky as a committer on the Defense4All Project?" Results are
18:41:18 <odl_meetbot> +1 (11): dlenrow, regXboi, alagalah, LuisGomez, ChrisPriceAB, edwarnicke, cdub, mohnish, kwatsen, colindixon, Youcef
18:41:40 <tbachman> #info colindixon asks how much oversight the TSC should exert on committer nominations
18:41:40 <phrobb> #agreed Gerson Soklosky is approved as a committer on the Defense4All project
18:41:57 <tbachman> #info cdub recommends light oversight with strong guidance
18:42:19 <cdub> tbachman: heh, you make it sound clever ;)
18:42:24 <rovarga> btw. if d4a goes for lithium, they will need a leader and can cleanup their committers afterwards
18:42:25 <tbachman> lol
18:42:31 <alagalah> cdub: "Profound"
18:42:46 <tbachman> cdub: did I get it right?
18:42:53 <cdub> tbachman: yes
18:42:58 <tbachman> <whew>
18:43:16 <abhijitkumbhare> BTW - I have uploaded a new version of the VPN service presentation (with "Ericsson Internal" removed from the footer)
18:43:25 * ChrisPriceAB prefer to wait tbh
18:43:33 <abhijitkumbhare> Please use that version instead
18:43:36 <zxiiro> When there's 2 or more developers working together on a patch, it's good practice to have the primary developer submit the patch as the author and include any additional developers via the "Also-By: First Last <email>" in the footer of the commit message.
18:44:20 <alagalah> zxiiro: Does spectrometer pic kthat up ?
18:44:31 <cdub> alagalah: patches accepted
18:44:35 <tykeal> dunno, would have to ask dtucker ;)
18:44:47 <dlenrow> I feel for you on both ends?
18:44:52 <tbachman> :o
18:44:53 <zxiiro> alagalah: i don't know much about spectrometer unfortunately
18:45:37 <tbachman> #info phrobb emplores asaf and benny to get asaf set up so that he can become a committer, as having a backup is important
18:45:41 <colindixon> +100
18:46:19 <tbachman> #info phrobb says that given asaf’s role within defense4all, it seems like he is the most likely candidate to be the project lead, and to become a project lead you need to first be a committer
18:47:10 <tbachman> #topic Creation Review for VPN Service (revisited)
18:47:40 <tbachman> #info colindixon asks what projects they imagine interacting with
18:48:11 <rgowrishankar> #info Begun interaction with OVSDB, have not reached out to BGP-pCEP team
18:48:23 <colindixon> rgowrishankar: thanks!
18:48:32 <tbachman> #info Some contribution to openflowplugin as well
18:48:45 <colindixon> #info also wanted to reach out to the sdniapp team
18:49:09 <rgowrishankar> #info any changes to the neutron API?
18:49:33 <tbachman> #info Srikar doesn’t see making any changes to the existing Neutron API, but adding functionality will be part of it
18:50:01 <tbachman> #info regXboi asks how they can add functionality without changing
18:50:51 <tbachman> #info Srikar says there are blueprints in OpenStack to add VPN as a service which would use neutron
18:51:26 <tbachman> #info regXboi asks if this would be something between ML2 and the controller
18:51:46 <tbachman> #info Srikar says it uses ML2 constructs, but has an extraneous association
18:52:19 * ChrisPriceAB I'm not sure OpenStack development has ever been in the scope of an ODL project formally
18:52:45 <abhijitkumbhare> +1 ChrisPriceAB
18:53:32 <regXboi> ChrisPriceAB: and I want to *keep* it that way :)
18:53:40 <tbachman> #info colindixon asks if we have a mechanism to modify project scope
18:54:40 <rgowrishankar> #info CDixon: add word VPN before service in the scope definition
18:54:50 <tbachman> #info colindixon asks to put the ODL usernames to help LF folks
18:54:59 <tykeal> huzzah!
18:55:06 <tbachman> :)
18:58:28 <cdub> colindixon: +1
18:58:39 * tykeal is a stickler for rules ;)
18:59:03 <colindixon> #info any vote on the proposal will be conditional on: (i) adding ODL usernames for committers, (ii) removing the tech lead section, and (iii) adding the word VPN before service in the first two paragraphs of Scope, (iv) add prem as a committer
18:59:06 * ChrisPriceAB get that ball and chain attached
18:59:10 <edwarnicke> Coud we capture those 4 in the vote?
18:59:40 <edwarnicke> phrobb: Is on *fire* :)
18:59:45 <phrobb> #startvote Shall the TSC approve the VPN Service project to Incubation – conditional on  adding Prem Sankar as a committer, removing the tech lead section from the proposal, adding “VPN” before the word “service” in the Scope section of the proposal, and finalizing Inbound Code Review? -1, 0, +1
18:59:45 <odl_meetbot> Begin voting on: Shall the TSC approve the VPN Service project to Incubation – conditional on  adding Prem Sankar as a committer, removing the tech lead section from the proposal, adding “VPN” before the word “service” in the Scope section of the proposal, and finalizing Inbound Code Review? Valid vote options are -1, 0, +1.
18:59:45 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:59:47 * ChrisPriceAB yes!
18:59:50 <colindixon> #vote +1
18:59:55 <kwatsen> #vote +1
18:59:55 <ChrisPriceAB> #vote +1
18:59:57 <dlenrow> #vote +1
18:59:57 <mohnish> #vote +1
19:00:01 <edwarnicke> #vote +1
19:00:13 <kwatsen> yes, very cool project!  :)
19:00:18 <alagalah> #vote +1
19:00:33 <LuisGomez> #vote +1
19:00:37 <phrobb> #endvote
19:00:37 <odl_meetbot> Voted on "Shall the TSC approve the VPN Service project to Incubation – conditional on  adding Prem Sankar as a committer, removing the tech lead section from the proposal, adding “VPN” before the word “service” in the Scope section of the proposal, and finalizing Inbound Code Review?" Results are
19:00:37 <odl_meetbot> +1 (8): dlenrow, LuisGomez, ChrisPriceAB, edwarnicke, mohnish, kwatsen, colindixon, alagalah
19:00:38 <cdub> #vote +1
19:00:42 <tbachman> cdub: too bad
19:00:47 * ChrisPriceAB congratulations VPN team!
19:00:47 <dlenrow> Congratulations VPN team
19:00:55 <regXboi> oops
19:00:56 <phrobb> #agreed the VPN Service Project is approved
19:01:01 * regXboi missed the boat
19:01:04 <tbachman> colindixon: keep in mind that w/Intel we now have more for a majority
19:01:10 <tbachman> (still carried)
19:01:10 * ChrisPriceAB tut tut cdub!
19:01:20 <tbachman> ah, you’re right
19:01:21 <tbachman> sorry
19:01:29 * tbachman still working on counting
19:01:51 <cdub> ChrisPriceAB: heh, too many IRC channels
19:01:54 <edwarnicke> Once more... from the top ;)
19:02:00 <colindixon> edwarnicke: :-)
19:02:07 <tbachman> #topic events
19:02:47 <tbachman> #info phrobb says that submission for the summit opens on 12/15 and closes 2/6
19:02:52 <tbachman> #undo
19:02:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x285d1d0>
19:02:54 <colindixon> tbachman: damn you
19:03:07 <tbachman> #info phrobb says that submission for papers for the summit opens on 12/15 and closes 2/6
19:03:15 <tbachman> colindixon: :)
19:04:03 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-December/002197.html Phils proposal to do weekly IRC meetings in lieu of a face-to-face meeting in January
19:04:11 <tbachman> colindixon: got me back! :P
19:04:33 <tbachman> <sound of dueling banjos in the background>
19:04:35 <colindixon> #Info one face-to-face meeting in the M4/M5 boundary later on
19:04:42 * edwarnicke suppresses the desire to suggest alternately we meet April 1...
19:04:49 <colindixon> #undo
19:04:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2757990>
19:05:02 <colindixon> #info second part of the proposal is one face-to-face meeting in the M4/M5 boundary later on
19:05:16 * ChrisPriceAB sounds like a solid play phrobb
19:05:37 <colindixon> #info edwarnicke says if we go with IRC weekly meetings, we should get them scheduled soon
19:06:05 <tykeal> what? work during a meeting?
19:06:12 <tykeal> never happens
19:06:17 * tykeal continues hacking on puppet ;)
19:06:19 <edwarnicke> tykeal: I know, I've never ever *ever* done that ;)
19:06:41 <tbachman> #info abhijitkumbhare asks if we’d have alternate time zone meetings
19:06:50 <tbachman> #info colindixon says we have to do alternate time zone meetings
19:07:04 <tbachman> #info abhijitkumbhare asks if we’re going to do 2x/day or alternate
19:07:07 <edwarnicke> #info edwarnicke opines that we need to solve the timezone issue... not certain as to the best solution
19:07:16 <tbachman> whoa
19:07:21 <cdub> netsplit
19:07:23 * ChrisPriceAB ryan what did you do???
19:07:26 <tbachman> brainsplit
19:07:35 <tbachman> lol
19:07:42 <tbachman> there it goes again
19:07:43 * ChrisPriceAB LOL
19:07:50 <tbachman> #info regXboi recommends not doing 2 meetings in a day
19:07:57 <rovarga> +1
19:08:07 * edwarnicke wonders if he is on the correct side of the partition
19:08:07 <tbachman> #info rovarg and abhijitkumbhare agreeswith regXboi
19:08:21 * tbachman has incomplete state
19:08:46 <cdub> i strongly don't object
19:09:05 <tbachman> #agreed Weekly IRC meetings will be held between M1/M2 for Lithium planning/coordination
19:09:20 <tbachman> was that it?  Weekly?
19:09:22 * ChrisPriceAB not in violent disagreement with cdub
19:09:23 <tbachman> Daily, right
19:09:25 <tbachman> ?
19:09:31 * tbachman is non-violent
19:09:35 <cdub> ChrisPriceAB: hehe
19:09:38 * ChrisPriceAB good to hear!
19:09:47 <tbachman> #undo
19:09:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2638d90>
19:09:53 <colindixon> #info note M1 to M2 is 12/11 and 2/5
19:09:56 <dneary> Agreed
19:10:00 * edwarnicke is noticing a lot of double negativity on the IRC channel
19:10:07 <dneary> Timezones and real time meetings do not mix well
19:10:09 <tbachman> #agreed Mechanism needed to deal with time zone issues for planning meetings
19:10:25 <phrobb> #action phrobb to kick off a discussion on the mailing list on how to deal with the timezone issues for these IRC meetings
19:10:31 <tbachman> phrobb: thx
19:10:38 <colindixon> #topic interns
19:10:41 <cdub> tbachman: i think you #undid the first #agree
19:10:49 <tbachman> cdub: I did — b/c I wasn’t sure it was right?
19:10:55 <dfarrell07> #link http://www.opendaylight.org/community/summer-intern-program intern page
19:10:55 <tbachman> we agreed daily?
19:10:59 <tbachman> dfarrell07: thx!
19:11:04 <alagalah> wt...
19:11:11 <colindixon> we agreed weekly
19:11:11 <alagalah> daily? I heard weekly
19:11:12 <colindixon> sorry
19:11:13 <tbachman> k
19:11:20 <phrobb> #link https://wiki.opendaylight.org/view/InternProjects:Main <- Intern page
19:11:22 <cdub> weekly + tz cleverness
19:11:29 <tbachman> out of context
19:11:31 <tbachman> but here goes
19:11:32 <tbachman> #agreed Weekly IRC meetings will be held between M1/M2 for Lithium planning/coordination
19:11:37 <alagalah> cdub: Quantum Entaglement... its the only way
19:11:48 <alagalah> cdub: Entanglement even
19:11:50 <tbachman> #info phrobb says they’ll be engaging with google summer of code org
19:12:00 <colindixon> I want a #lastinfo command that puts it in the last topic
19:12:11 <tbachman> #info phrobb says they’ll also reach out to the outreach program for women
19:12:17 <colindixon> also a #rollcall command that puts it at the top in it’s own category
19:12:19 <tbachman> colindixon: ack
19:12:36 <tbachman> #info phrobb says they have budget for up to 14 interns this year as well (~double last year's)
19:13:10 <tbachman> #info phrobb says that interns start committing themselves to programs in the December time frames; we need mentors and projects so that interns can start signing up
19:14:01 <dneary> phrobb, Do we have partnerships with some universities in the project (like GEANT, for example)? Perhaps some "professor outreach" would be useful
19:14:05 <cdub> lots of background noise
19:14:49 <colindixon> LuisGomez: I think the noise is you and me :-)
19:14:50 <cdub> LuisGomez: I think it's you not on mute?
19:14:50 <tbachman> #info dneary asks if we hvae partnerships with universities in the project
19:14:51 * edwarnicke wonders what is being built in the background
19:14:56 <tbachman> #info phrobb says nothing formally
19:15:27 <tbachman> #info colindixon says there was some technicality that dq’d us from summer of code last year; have we fixed that
19:15:56 <tbachman> #info phrobb says the template has been modified to call out more information, and this is being done significantly early, both of which resulted in dq’s last year
19:16:36 <tbachman> #info colindixon says last year almost all interns were from outside the US; is this being addressed?
19:16:38 <cdub> colindixon: iirc google soc is similar $
19:16:40 <dneary> $6000 per month for an intern!?!
19:16:54 <cdub> google soc used to be 5k
19:16:55 * dneary confirms what cdub said
19:16:55 <tbachman> #info phrobb says we want to keep parity with the google summer of code
19:17:05 <colindixon> dneary: for Google pays better
19:17:05 * ChrisPriceAB Do we base a global activity on "valley" compensation?
19:17:07 <dneary> cdub, And $500 for the org
19:17:38 <dneary> colindixon, They're intended to replace free internships or fast food jobs
19:18:01 * ChrisPriceAB lol
19:18:52 <colindixon> #action phrobb to start a thread on possibly changing compensation to attract interns more people
19:19:30 <colindixon> #Info cdub and phrobb say maybe the way to do that is through member companies instead
19:19:41 <tykeal> lol
19:19:49 <tbachman> sadist
19:19:50 <cdub> it's more "project" based
19:20:28 <phrobb> #action phrobb to kick off email thread on compensation and possible "internships" board
19:20:31 <tbachman> #topic system integration and test update
19:20:35 <tbachman> #info no update this week
19:20:41 <tbachman> #info Lithium and Stable/Helium updates
19:21:09 <tbachman> #info colindixon asks if we’re done with the version bumps for stable helium
19:21:10 <dfarrell07> tbachman: s/info/topic
19:21:27 <tbachman> lol
19:21:30 <tbachman> dfarrell07: thx!
19:21:32 <tbachman> #undo
19:21:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2481c90>
19:21:33 <tbachman> #undo
19:21:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x27285d0>
19:21:43 <tbachman> #topic Lithium and Stable/Helium updates
19:21:44 <tbachman> [2:21pm]
19:21:49 <tbachman> : #info colindixon asks if we’re done with the version bumps for stable helium
19:21:52 <tbachman> dang
19:22:08 <tbachman> what was someone saying about doing other things during meetings?
19:22:15 <tbachman> #info colindixon asks if we’re done with the version bumps for stable helium
19:22:20 <tbachman> #info zxiiro says yes they’ve been completed
19:22:24 <tykeal> tbachman: never happens ;)
19:22:27 <tbachman> lol
19:22:51 <tbachman> #info zxiiro has also been looking at the Lithium auto-build, which is currently failing due to 2 features that depend on each other
19:23:06 <tbachman> #info zxiiro thinks the stable/helium autobuilds are failing as well due to a test failure
19:23:16 <tbachman> #info colindixon says he thinks it’s in l2switch and is being looked at
19:23:18 <cdub> #info colindixon notes helium sr2 is jan 12
19:23:27 <tbachman> cdub: thx!
19:23:46 <cdub> np
19:24:10 <tbachman> #topic Infrastructure
19:24:28 <tbachman> #info tykeal says ODL forge was greenlighted and the name has been purchased
19:24:30 <rgowrishankar> #info andy is working on getting infra in place. odlforge.org has been bought
19:24:38 <tbachman> #info tykeal is looking into getting certs for ODL forge
19:24:51 <cdub> w00t!
19:24:54 <rgowrishankar> #info odlforge is coming up on l7 systems.
19:25:06 <rgowrishankar> #info EL7 systems
19:25:07 <cdub> rgowrishankar: s/l7/el7/
19:25:22 <colindixon> #undo
19:25:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x269e050>
19:25:24 <colindixon> #undo
19:25:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x258c410>
19:25:31 <cdub> tykeal: nice!
19:25:33 <colindixon> #info odlforge is coming up on EL7 systems
19:25:42 <tbachman> #info tykeal says there’s been a lot of requests for the puppet manifests; they’re starting with new manifest sets for ODL forge
19:26:02 <cdub> tykeal: sorry, i misheard...you're doing what?
19:26:05 <tbachman> #info tykeal is hoping to have ODL forge up and running by end of next week
19:26:22 <tykeal> cdub: lol
19:26:26 <cdub> ;)
19:27:59 <tbachman> #info we now have a way to retrigger jobs, thanks to zxiiro
19:28:01 <tbachman> sorry
19:28:03 <tbachman> lol
19:28:09 <tbachman> missed the mechanism
19:28:44 <tbachman> #link https://jenkins.opendaylight.org/releng/ Jenkins Job Builder link
19:28:51 <tbachman> oops
19:28:52 <tbachman> #undo
19:28:52 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x283bd10>
19:28:56 <dfarrell07> #link https://wiki.opendaylight.org/view/RelEng:Main#Builder RelEng page
19:28:57 <tbachman> you want the project proposal?
19:28:59 <tbachman> ah
19:29:03 <tykeal> thanks dfarrell07 :)
19:29:05 * tbachman is lost today
19:29:13 <colindixon> #info you can retrigger a verify by putting a comment on the gerrit with “recheck” and similar for merge with “remerge"
19:29:18 <tbachman> colindixon: thx
19:29:39 <tbachman> #info Jenkins Job Builder is now open to all projects who want to start picking it up and using it
19:30:05 <tbachman> #info tykeal notes that the dynamic slaves currently are still a little slow
19:30:08 <zxiiro> #info the README file in the root of the builder.git repo contains detailed information on how to use the releng/builder JJBs
19:30:16 <tbachman> zxiiro: thx!
19:30:47 <colindixon> #topic Internet of Things Data Management Creation Review
19:30:58 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Internet_of_Things_Data_Management_%28IOTDM%29 the project proposal
19:31:01 <dfarrell07> #link https://github.com/opendaylight/releng-builder/blob/master/README.md the README zxiiro just mentioned
19:31:32 <dfarrell07> ^^sorry for that being in wrong topic, better wrong than never I think though
19:31:39 <zxiiro> I should fix it so that it looks nicer on github
19:31:57 <colindixon> #link https://wiki.opendaylight.org/view/File:IoT_in_ODL_for_TSC.pptx the slides on the wiki
19:32:36 <tbachman> #info the IOT applications usually come packaged with the device plus the SW to manage the devices
19:32:40 <colindixon> tbachman: thanks
19:32:46 <colindixon> if you need a hand just call out
19:32:56 <tbachman> #info usually there isn’t much communication between a familiy of devices and their corresponding application
19:33:17 <tbachman> #info The goal of this project is to provide a facility that allows any application to consume ability of any device
19:33:33 <rgowrishankar> #info several efforts in inductry for middleware
19:33:46 <rgowrishankar> #info proliferation of standards
19:33:58 <rgowrishankar> #info picked one of the standards, oneM2M
19:35:18 <rgowrishankar> #info standard covers 4 categories: data exchange between iot, device mgmt, security mech, connectivity handling
19:35:35 <tbachman> rgowrishankar: beating me to the punch… thx! :)
19:36:15 <tbachman> #info the oneM2M common service functions is working on several modules
19:36:24 <tbachman> #info This project is mostly focusing on the data management and repository
19:36:52 <rgowrishankar> #info and the subscription and notification
19:37:07 <rgowrishankar> #info if the project goes well scope will be extended
19:39:08 <rgowrishankar> #info it can run on either the managed devices or the IOT servers
19:39:10 <tbachman> #info ODL was chosen as a platform for its rich features (e.g. MD-SAL which supports tree-based model)
19:39:47 * ChrisPriceAB OMG!
19:39:51 <tykeal> sounds like the toaster needs to be updated ;)
19:40:11 <tbachman> so many joke possibilities here
19:40:40 <alagalah> Internet Of Toast
19:40:41 <abhijitkumbhare> So we have new committers for the toaster :)
19:40:44 <colindixon> I’m curious if the SB protocols want to live here, particularly in the case of SB HTTP/REST, I think we have an implementation of that
19:40:53 <cdub> alagalah: rofl
19:41:42 <tbachman> #info There are specifications on how to map things like COAP, MQTT, etc for MD-SAL data store access
19:42:19 <tbachman> #info There’s also a pub/sub capabilitiy, so depending on listeners, they can deliver updates to those applications
19:42:38 <tbachman> #info Still trying to work out how the project will work with ODL’s authentication capabilities
19:42:42 <dfarrell07> :q
19:42:53 <tbachman> dfarrell07: had enough VI?
19:43:11 <dfarrell07> tbachman: That wasn't meant to be a comment on the TSC meeting ;)
19:43:20 <tbachman> :)
19:43:22 <dneary> Dropping off - thanks everyone for the meeting
19:44:14 <colindixon> from here: http://www.opendaylight.org/project/tsc/tsc-policy
19:44:25 <colindixon> “Southbound plugins to enable the controller to speak to the OpenDaylight supplied and other network elements”
19:44:28 <colindixon> as one scope of projects
19:44:50 <colindixon> #info kwatsen asks if this project is in scope
19:45:28 <colindixon> #info edwarnicke says he thinks it is because the scope of the TSC policy on projects doesn’t limit it to SDN
19:45:29 <tbachman> #info John Burns notes you can use SDN functionality to help with IOT devices — e.g. shutting down a “chatty” device
19:45:48 <colindixon> #link http://www.opendaylight.org/project/tsc/tsc-policy one of the listed project scopes is “Southbound plugins to enable the controller to speak to the OpenDaylight supplied and other network elements”
19:46:30 <kwatsen> The ODP will promote the Platform as the preferred software defined network ("SDN") platform.
19:47:51 <tbachman> #info colindixon says there are alot of SB protocols in the scope of the project prooposal, one of which already exists (SB REST); is the intent to have the implementation of those protocols as part of this project, or would they be separate things that could be spun out
19:48:20 <tbachman> #info John Burns sayd initially they’re going to initially work with COAP
19:48:26 <regXboi> kwatsen: I'd argue that IoT is not out of scope with SDN
19:48:29 * ChrisPriceAB aside from controller who is naughty, I like the idea of having a project=southbound
19:48:37 * ChrisPriceAB (sorry ed)
19:49:02 <tbachman> #info lflorit says that for COAP and MQTT there are implementations that they can bring in
19:49:17 <alagalah> ChrisPriceAB: If everyone is southbound... does northbound exist (goes to look for a tree falling in the woods)
19:49:24 <tbachman> #info colindixon asks if they’re intending the scope of the project to include those protocols in the future
19:49:38 * ChrisPriceAB alagalah: (I think it fell on me)
19:49:58 * alagalah ChrisPriceAB That "sound of one hand clapping" was actually someone slapping me in the face :)
19:50:07 * ChrisPriceAB lol ;)
19:50:28 <tbachman> #info jburns says MQTT exists today, but isn’t in ODL yet; there’s servers and client SW. An MQTT client side open source coulde be brougt in which would attach to an external MQTT server
19:50:54 <ChrisPriceAB> I am on the same page colindixon
19:51:55 <tbachman> #info colindixon says that having applications and drivers in the same project has caused problems in the past (e.g. creating dependency cycles)
19:53:10 * edwarnicke hugs ovsdb project
19:54:10 <cdub> *cough* controller *cough*
19:54:17 <tykeal> hehe
19:54:37 * ChrisPriceAB ah, enjoying the call right about now!
19:54:38 <edwarnicke> cdub: I am doing splitty things directory-wise on controller *as we speak*
19:54:48 <cdub> edwarnicke: horray!
19:54:49 <kwatsen> #info from: http://www.opendaylight.org/project/bylaws: The primary purpose of the ODP (collectively, “the Purpose”) is to (a) advance the creation, evolution, promotion, and support of an open source software defined network and network functions virtualization software platform (“Platform”), (b) support and maintain the strategic framework of the Platform through the technologies made available by the organization to ma
19:54:49 <kwatsen> ke the Platform a success, (c) support and maintain policies set by the Board, (d) promote such Platform worldwide; and (e) undertake such other activities as may from time to time be appropriate to further the purposes and achieve the goals set forth above.
19:55:21 <edwarnicke> cdub: I have done a fair bit so far
19:55:45 <ChrisPriceAB> I am happy as long as the intent is right.
19:56:08 <edwarnicke> cdub: but it seemed like it was reasonable to do it by directory-wise before we do the harder part of the splitting
19:56:08 <alagalah> regXboi: Ooooohhhhhmmmmm
19:56:21 * ChrisPriceAB I only have 3
19:56:23 <dlenrow> I thought everything was SDN now because it's good
19:56:25 <alagalah> regXboi: ...and they'd all be wrong :) Ba-boom-cha
19:56:29 * colindixon alagalah just Takei-ed regXboi
19:56:33 * ChrisPriceAB feeling inconsequential
19:56:37 <regXboi> alagalah: you are stealing my thunder :)
19:57:02 <tbachman> dockerdockerdockerSDNdockerdockerdocker
19:57:18 <phrobb> #startvote Shall the TSC approve the Internet of Things Data Management (IOTDM) project to Incubation? -1, 0, +1
19:57:18 <odl_meetbot> Begin voting on: Shall the TSC approve the Internet of Things Data Management (IOTDM) project to Incubation? Valid vote options are -1, 0, +1.
19:57:18 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:57:21 <cdub> edwarnicke: 3d graphics rendering engine w/ sensor...
19:57:25 <dlenrow> tbachman: LOL. Subliminal docker messaging
19:57:28 <alagalah> cdub: lol
19:57:28 <abhijitkumbhare> You got it right dlenrow :)
19:57:32 <edwarnicke> cdub: LOL
19:57:38 <edwarnicke> #vote +1
19:57:40 <colindixon> #vote +1
19:57:45 <alagalah> #vote +1
19:57:45 <regXboi> #vote +1
19:57:46 <LuisGomez> #vote +1
19:57:51 <dlenrow> #vote +1
19:57:54 <mohnish> #vote +1
19:57:55 <ChrisPriceAB> #vote +1
19:58:02 <cdub> #vote +1
19:58:06 <phrobb> #endvote
19:58:06 <odl_meetbot> Voted on "Shall the TSC approve the Internet of Things Data Management (IOTDM) project to Incubation?" Results are
19:58:06 <odl_meetbot> +1 (9): dlenrow, regXboi, LuisGomez, edwarnicke, ChrisPriceAB, cdub, mohnish, colindixon, alagalah
19:58:20 * ChrisPriceAB congrats IoT dudes
19:58:33 <phrobb> #agreed the IOTDM project is approved to Incubation
19:58:41 * tbachman hands out toast to all
19:58:56 <regXboi> tbachman: topic cookies!
19:59:01 <tbachman> lol
19:59:04 <tbachman> #topic cookies
19:59:04 <phrobb> #endmeeting