#opendaylight-meeting: tsc

Meeting started by colindixon at 17:57:57 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:58:03)
    1. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 17:58:45)
    2. edwarnicke (edwarnicke, 17:59:35)
    3. Chris Price (ChrisPriceAB, 18:00:08)
    4. colindixon (colindixon, 18:01:13)
    5. dlenrow (dlenrow, 18:01:18)
    6. kwatsen (kwatsen, 18:01:33)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-12-11-17.59.html last weeks meeint minutes for action items (colindixon, 18:01:37)
    8. ACTION: colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion (colindixon, 18:01:59)
    9. the CAPWAP project proposal was approved over e-mail vote (colindixon, 18:02:18)
    10. Chris Wright (cdub, 18:03:05)
    11. ACTION: phrobb and colindixon will help to clean up the non-projects from the wiki (colindixon, 18:04:20)
    12. ACTION: colindixon will try to explore the use categories which allow for easier curation of this (colindixon, 18:04:27)
    13. mohnish anumala (mohnish, 18:05:47)
    14. regXboi (regXboi, 18:05:55)
    15. ACTION: colindixon to follow up with tykeal on getting usernames for new projects (colindixon, 18:05:56)
    16. ACTION: colindixon will send mail about encouraging projects to get projects tracking what happens in the TSC (colindixon, 18:06:12)
    17. jmedved (jmedved, 18:07:36)
    18. ACTION: colindixon will track how VTN and controller are interacting on possible AD-SAL deprecation (colindixon, 18:08:11)
    19. LuisGomez (LuisGomez, 18:08:44)

  2. updates (colindixon, 18:09:59)
    1. Event updates from Phil: IRC event email sent, presentations for summit now being accepted (dfarrell07, 18:10:37)
    2. https://lists.opendaylight.org/pipermail/tsc/2014-December/002359.html IRC meetings between M1 and M2 (colindixon, 18:10:53)
    3. http://www.opendaylight.org/events/2015-07-27/opendaylight-summit CFP for ODL Summit (dfarrell07, 18:11:07)
    4. https://lists.opendaylight.org/pipermail/tsc/2014-December/002357.html conversation about f2f meetings in April (colindixon, 18:11:14)
    5. LuisGomez will remove old Hydrogen distros from stable/helium and master (dfarrell07, 18:12:01)
    6. https://lists.opendaylight.org/pipermail/tsc/2014-December/002351.html Luis will remove Hydrogen distributions unless there are any objections *today* (colindixon, 18:12:24)
    7. Li and stable/helium updates: zxiiro has made progress, more TODOs; SR1.1 security release coming out (dfarrell07, 18:13:30)
    8. tykeal is making progress on ODL Forge (dfarrell07, 18:13:44)
    9. tykeal is having to build better Jenkins Puppet modules, which is a bit of the holdup (dfarrell07, 18:14:03)
    10. tykeal predicts ODL Forge will be ready in Jan (dfarrell07, 18:14:12)

  3. Helium SR1.1 Release (dfarrell07, 18:14:49)
    1. Security vul was pointed out on mailing lists a few days ago (dfarrell07, 18:15:19)
    2. Three patches have been cherry picked into SR1 to fix them, that will be SR1.1 (dfarrell07, 18:15:42)
    3. Low risk of bugs being introduced by SR1.1 changes, LuisGomez has validated that it's fairly robust (dfarrell07, 18:16:22)
    4. https://lists.opendaylight.org/pipermail/release/2014-December/001061.html Luis says it is as good or better than SR1 (dfarrell07, 18:16:47)
    5. http://nexus.opendaylight.org/content/repositories//staging/org/opendaylight/integration/distribution-karaf/0.2.1-Helium-SR1.1/ The Helium-SR1.1 artifacts are ready to go here (dfarrell07, 18:17:08)
    6. VOTE: Voted on "Shall the TSC bless the release of SR1.1?" Results are, 1: 10 (regXboi, 18:19:10)
    7. AGREED: The TSC blessed the release of SR1.1 (dfarrell07, 18:19:42)
    8. TSC discusses SR2 release date (dfarrell07, 18:21:00)
    9. ACTION: colindixon to post SR1.1 to the security advisories mailing list and possibly to opendaylight-annoucne mailing list (colindixon, 18:21:10)
    10. SR2 release date will be taken to a thread (dfarrell07, 18:21:23)
    11. ACTION: gzhao (or colindixon) to start a thread on possibly moving SR2 further out than 1/12 (colindixon, 18:21:37)

  4. Security Response Process (dfarrell07, 18:22:10)
    1. New process has been reviewed and approved over the past few days (dfarrell07, 18:22:34)
    2. There is a security list, it will be better publicized than it was before (dfarrell07, 18:23:06)
    3. Discussion about members of security response team (dfarrell07, 18:23:32)
    4. rovarga cdub edwarnicke are up to be voted into security response team (dfarrell07, 18:24:23)
    5. regXboi has asked on-thread to be removed from team (dfarrell07, 18:24:50)
    6. https://lists.opendaylight.org/pipermail/tsc/2014-December/002281.html Thread where TSC voted on security team actions (dfarrell07, 18:27:44)
    7. VOTE: Voted on "Shall the TSC approve cdub rovarga edwarnicke David Jorm Kurt Seifried to be members of the security response team?" Results are, +1: 11 (regXboi, 18:30:10)
    8. ACTION: cdub to kick off security mechanics email discussion (cdub, 18:30:21)
    9. AGREED: The TSC approved cdub rovarga edwarnicke David Jorm Kurt Seifried to be members of the security response team (dfarrell07, 18:30:39)
    10. ACTION: Someone will test the security mailing list (cdub?) (dfarrell07, 18:32:43)

  5. CAPWAP creation review (colindixon, 18:33:04)
    1. the CAPWAP project was approved on the mailing list (colindixon, 18:33:14)

  6. Project Creation Review for Persistence Project (dfarrell07, 18:33:19)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Persistence project proposal (colindixon, 18:33:59)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000217.html proposed on 12/3/2014 (colindixon, 18:34:22)
    3. https://wiki.opendaylight.org/view/File:Peristence-Project-Proposal-TSC-Presentation.pptx slides on the wiki (colindixon, 18:36:09)
    4. the basic idea is to have a query-able, persistent data store API (and different back databases) (colindixon, 18:36:52)
    5. AAA and TSDR are projects that will look into usin this project (colindixon, 18:38:27)
    6. jmedved asks how does this persistance relate to the persistance provided by the clustered data store (colindixon, 18:44:10)
    7. answer is that this will support non-modeled data and will allow for data sets that don’t fit entirely in-memory (colindixon, 18:44:47)
    8. edwarnicke asks if there has been thought about how to handle DB schemas? (colindixon, 18:46:16)
    9. the answer is that implementations will almost certainly have to have knowleded of the particular schema of the particular database (colindixon, 18:46:48)
    10. discussing schema definition which is currently considered "left to implementations" (cdub, 18:49:42)
    11. https://wiki.opendaylight.org/view/Project_Proposals:Persistence#Schema_Definition_is_Left_to_the_Implementations_and_not_Considered_as_Part_of_the_API discussing this part of proposal (cdub, 18:50:01)
    12. edwarnicke points out that the deployment model for ODL could be greatly complicated by this project (dfarrell07, 18:50:54)
    13. regXboi notes that you really don’t want to get into storing all the data for stats in the clustered store, so TSDR desperately wantst this project (colindixon, 18:51:40)
    14. ODL also runs on tons of systems (anything that supports Java), which could be broken by deps of this project (like MySQL) (dfarrell07, 18:51:59)
    15. edwarnicke asks what the story for out-of-the-box functionality (colindixon, 18:52:05)
    16. if we instead require people to set up an external DBMS to get things work at all, this is really much harder (colindixon, 18:52:57)
    17. Liem responds saying, like AAA, this should likely work out-of-the-box with one implementation, but then can swap out the DBMS as a configuration option (colindixon, 18:54:33)
    18. lots more discussion, but the net-net seems to be that we need to figure out how to run portably across different DBs including ones that can be run out-of-the-box as well as different external ones (colindixon, 18:56:07)
    19. cdub points out that details should be fleshed out as Persistence project develops, not relevant to valid/not-valid Incubation project (dfarrell07, 18:58:28)
    20. VOTE: Voted on "Shall the TSC approve the Persistence Project to Incubation?" Results are, +1: 9 (dfarrell07, 19:00:06)
    21. AGREED: TSC approves Persistence Project to Incubation (dfarrell07, 19:00:46)

  7. Project Creation Review for SNMP Plugin Project (dfarrell07, 19:01:30)
    1. https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000222.html Proposed 12/5/2014 (dfarrell07, 19:01:59)
    2. security list test passed!!! (regXboi, 19:02:04)
    3. https://wiki.opendaylight.org/view/Project_Proposals:SNMP_Plugin SNMP Plugin Project Proposal wiki (dfarrell07, 19:02:26)
    4. the project started as just wanted to read out a single value to identify a device via SNMP, but do so in a more reusable way (colindixon, 19:05:14)
    5. Basic idea is to add a SB SNMP plugin (dfarrell07, 19:05:22)
    6. Will use MD-SAL (dfarrell07, 19:05:43)
    7. it turned out that there was an effort in Cisco to support SNMP by converting MIBs to YANG models (colindixon, 19:05:46)
    8. this project will start with and extend that code base (colindixon, 19:05:52)
    9. basic arch is to take SNMP MIBs, turn them into YANG models, and then turn that into Java code and use it it in the MD-SAL as usual (colindixon, 19:06:33)
    10. Initial committers list is better than average, tykeal may still need ODL usernames (dfarrell07, 19:09:01)
    11. cdub asks if there’s an effort to integration the SNMP efforts between this and SNMP4SDN (colindixon, 19:09:58)
    12. the answer is none so far, except that the two uses are separate for now (colindixon, 19:10:23)
    13. in the long run it would be good if the SNMP4SDN project could be migrated (in a friendly way) to using the SNMP plugin rather than just the snmp4j library (colindixon, 19:11:41)
    14. LuisGomez asks if there will be any interactions with NSFs (colindixon, 19:13:23)
    15. the answer seems to be not directly, but only by creating data in the MD-SAL, not interacting with the NSFs directly (colindixon, 19:13:51)
    16. LuisGomez asks where the MIBs will come from (colindixon, 19:15:18)
    17. answer is this will depend on who’s using it, projects will bring in their own MIBs (colindixon, 19:15:50)
    18. the answer is that you can bring along your MIBs after the fact in your own project, largely by bringing along YANG files generated from the MIBs (colindixon, 19:17:23)
    19. from MD-SAL perspective, we want to follow pretty much the same way we work with yang (rovarga, 19:17:29)
    20. which means that some use-cases need compile-time, but the runtime component is completely dynamic (rovarga, 19:17:55)
    21. VOTE: Voted on "Shall the TSC approve the SNMP Plugin Project to Incubation?" Results are, +1: 10 (dfarrell07, 19:18:43)
    22. AGREED: TSC approves SNMP Plugin Project to Incubation (dfarrell07, 19:18:51)

  8. Project Creation Review for Topology Processing Framework Project (dfarrell07, 19:19:21)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Topology_Processing_Framework Topology Processing Framework Project Proposal wiki (dfarrell07, 19:19:30)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000219.html Proposed 12/4/2014 (dfarrell07, 19:19:34)
    3. having trouble with audio of Topo folks (dfarrell07, 19:20:26)

  9. Project Creation Review for Maple Project (dfarrell07, 19:20:49)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Maple Maple Project Proposal wiki (dfarrell07, 19:21:24)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000218.html Proposed 12/4/2014 (dfarrell07, 19:21:40)
    3. https://wiki.opendaylight.org/view/File:MapleInODL.pptx slides in pptx format (colindixon, 19:21:56)
    4. https://wiki.opendaylight.org/view/File:MapleInODL.pdf slides in PDF (dfarrell07, 19:22:02)
    5. Maple as a platform for doing flow programming SDN, e.g., OpenFlow, with it’s own stand-alone controller for now (colindixon, 19:23:03)
    6. this is a proposal to port that to OpenDaylight (colindixon, 19:23:22)
    7. Maple allows people to define a single, high-level packet processing function that will be logically applied to every packet that enters the network (colindixon, 19:24:30)
    8. http://www.ece.cmu.edu/~ece739/papers/maple.pdf (mohnish, 19:24:47)
    9. this is not actually done in this way, but instead compiled into rules that are installed in the network combined with packet_in handlers (colindixon, 19:25:30)
    10. http://www.ece.cmu.edu/~ece739/papers/maple.pdf the academic paper explaining the base of the project (colindixon, 19:27:07)
    11. the packet processing function is analyzed whenever it’s run on a packet_in which gives a trace tree of know control flows through the function, the trace tree can then be turned to flows in flow tables in a very nice way (colindixon, 19:29:29)
    12. you can take multiple packet processing functions and compose them into a larger function, but you still need some top-level function (colindixon, 19:31:51)
    13. scope is to provide the Java-based programming abstraction ODL that provides the compiler, runtime, etc. to do this for OpenFlow with packet functions and maybe look at doing SFC and GBP like things on top of it as a proof-of-concept (colindixon, 19:33:56)
    14. jmedved asks what they do with runtime tracing (colindixon, 19:34:08)
    15. AndreasVoellmy says they basically capture accesses to the data that’s given to the packet processing function to know what information was used by the function to build the trace tree (colindixon, 19:35:04)
    16. jmedved asks how to debug programs like this (colindixon, 19:35:11)
    17. AndreasVoellmy responds that you could debug this in the non-flow-table space, but you’d need to trust the compiler that takes the packet processing functions to flows in flow tables (colindixon, 19:36:16)
    18. regXboi asks how do you deal with the fact that, in ODL, many projects write flows directly and how does that perturb the approach (colindixon, 19:36:50)
    19. AndreasVoellmy says that you can reverse-engineer the function from the flow table, but you lose the context and other advantages (colindixon, 19:37:16)
    20. AndreasVoellmy says that the current model is that they are the only people writing flows, but he thinks it can be extended to handle this case (colindixon, 19:37:41)
    21. appraoches to deal with maple running with other apps are the usual: e.g., address-space splitting, priority things (colindixon, 19:39:36)
    22. dbainbri asks ttempting to understand the maple use case. I get how if i wanted to create a learning switch or something where I know what i want to do ahead of time, but what about dynamic service creation such as with GBP a high level abstraction, would you have generate "Java" code that is processed by the maple processor? (colindixon, 19:39:57)
    23. AND THIS IS IMPORTANT : approval is contingent on resolving patent issues (colindixon, 19:41:26)
    24. the patent issues are that Yale owns some patents for this work and those need to be cleared (regXboi, 19:42:41)
    25. AGREED: see full logs for vote, note patent issue (dfarrell07, 19:44:35)
    26. AGREED: TSC approves Maple Project to Incubation (dfarrell07, 19:44:49)
    27. AGREED: TSC approves Maple Project to Incubation with the proviso that the Yale patents on Maple can be cleared - see full logs for vote (8/13) (regXboi, 19:45:11)

  10. Project Creation Review for Topology Processing Framework Project (dfarrell07, 19:45:22)
    1. This is try #2 for this creation review. Audio issues last time. Not sure if need to re-link slides/wiki, but will do anyway. (dfarrell07, 19:45:35)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Topology_Processing_Framework Topology Processing Framework Project Proposal wiki (dfarrell07, 19:45:39)
    3. https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000219.html Proposed 12/4/2014 (dfarrell07, 19:45:44)
    4. there are no slides (colindixon, 19:45:47)
    5. the basic idea here is that our YANG topology model supports multiple different topologies some of which can be stacked on top of each other (colindixon, 19:46:31)
    6. this project will provide tools to get views of combined and/or filtered and/or flattened topologies from this model (colindixon, 19:46:53)
    7. ACTION: oflibMichal1 to provide ODL usernames for commtters (colindixon, 19:47:56)
    8. Discussion about where this work should live. Project or in controller? (dfarrell07, 19:54:35)
    9. colindixon asks if this should be it’s own project or a part of the controller (colindixon, 19:55:23)
    10. There is a push to get things out of controller, say mlemay and edwarnicke (dfarrell07, 19:55:23)
    11. Committers/Project Leads speak up to say it shouldn't be in controller/YANG Tools, in their opinion (dfarrell07, 19:59:15)
    12. VOTE: Voted on "Shall the TSC approve the Topology Processing Framework Project to Incubation?" Results are, 0: 1, +1: 7 (dfarrell07, 20:04:56)
    13. AGREED: TSC approves Topology Processing Framework Project to Incubation (dfarrell07, 20:05:07)
    14. http://www.inkatrinaskitchen.com/wp-content/uploads/2011/04/Cookie-Monster-Cookies.jpg (tykeal, 20:05:41)


Meeting ended at 20:05:51 UTC (full logs).

Action items

  1. colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
  2. phrobb and colindixon will help to clean up the non-projects from the wiki
  3. colindixon will try to explore the use categories which allow for easier curation of this
  4. colindixon to follow up with tykeal on getting usernames for new projects
  5. colindixon will send mail about encouraging projects to get projects tracking what happens in the TSC
  6. colindixon will track how VTN and controller are interacting on possible AD-SAL deprecation
  7. colindixon to post SR1.1 to the security advisories mailing list and possibly to opendaylight-annoucne mailing list
  8. gzhao (or colindixon) to start a thread on possibly moving SR2 further out than 1/12
  9. cdub to kick off security mechanics email discussion
  10. Someone will test the security mailing list (cdub?)
  11. oflibMichal1 to provide ODL usernames for commtters


Action items, by person

  1. cdub
    1. cdub to kick off security mechanics email discussion
    2. Someone will test the security mailing list (cdub?)
  2. colindixon
    1. colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
    2. phrobb and colindixon will help to clean up the non-projects from the wiki
    3. colindixon will try to explore the use categories which allow for easier curation of this
    4. colindixon to follow up with tykeal on getting usernames for new projects
    5. colindixon will send mail about encouraging projects to get projects tracking what happens in the TSC
    6. colindixon will track how VTN and controller are interacting on possible AD-SAL deprecation
    7. colindixon to post SR1.1 to the security advisories mailing list and possibly to opendaylight-annoucne mailing list
    8. gzhao (or colindixon) to start a thread on possibly moving SR2 further out than 1/12
  3. oflibMichal1
    1. oflibMichal1 to provide ODL usernames for commtters
  4. phrobb
    1. phrobb and colindixon will help to clean up the non-projects from the wiki
  5. tykeal
    1. colindixon to follow up with tykeal on getting usernames for new projects


People present (lines said)

  1. colindixon (147)
  2. dfarrell07 (121)
  3. regXboi (64)
  4. odl_meetbot (42)
  5. cdub (37)
  6. ChrisPriceAB (22)
  7. dlenrow (20)
  8. rovarga (19)
  9. edwarnicke (19)
  10. tykeal (18)
  11. jmedved (11)
  12. mohnish (10)
  13. LuisGomez (8)
  14. alagalah (7)
  15. dneary (5)
  16. kwatsen (5)
  17. abhijitkumbhare (5)
  18. oflibMichal1 (5)
  19. RajeevK (4)
  20. phrobb (2)
  21. phudgins (2)
  22. uchau (1)
  23. dbainbri (1)
  24. Sunil_ (1)
  25. nateharmon (1)


Generated by MeetBot 0.1.4.