17:01:28 <regXboi> #startmeeting TSC 08-21-2014
17:01:28 <odl_meetbot> Meeting started Thu Aug 21 17:01:28 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:28 <odl_meetbot> The meeting name has been set to 'tsc_08_21_2014'
17:01:35 <regXboi> #chair tbachman
17:01:35 <odl_meetbot> Current chairs: regXboi tbachman
17:01:38 <dmm> #info dmm
17:01:44 <regXboi> #info regXboi
17:01:44 <kwatsen> #info kwatsen
17:01:48 <uchau> #info uchau - proxy for HP
17:01:49 <tbachman> regXboi: ;)
17:01:50 <tbachman> lol
17:01:51 <IvanWood> #info Ivan Wood for Microsoft
17:02:06 <regXboi> anybody else want a chair?
17:02:41 <ChrisPriceAB> #info Chris Price joined
17:02:44 <regXboi> #chair ChrisPriceAB
17:02:44 <odl_meetbot> Current chairs: ChrisPriceAB regXboi tbachman
17:03:28 <tbachman> #topic Agenda Bashing
17:03:43 <edwarnicke> #info edwarnicke
17:04:26 <regXboi> #topic creation reviews
17:04:31 <tbachman> lol
17:04:34 <regXboi> #info In the queue: Discovery (first possible review date: 09.04.2014)
17:04:37 <ChrisPriceAB> #info No project reviews this week.
17:04:42 <regXboi> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-August/000146.html
17:04:47 <regXboi> #link https://wiki.opendaylight.org/view/Project_Proposals:Discovery
17:04:52 <tbachman> you guys are thorough :)
17:04:54 <regXboi> #topic committer promotions
17:05:19 <ChrisPriceAB> #info /me trying to fill the whitespace Ryan leaves me.  :)
17:05:22 <regXboi> #info Maxime Millette-Coulombe and Harman Singh to committer on dlux
17:05:35 <ChrisPriceAB> #undo
17:05:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x251f9d0>
17:05:47 <regXboi> #undo
17:05:47 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x251f590>
17:05:54 <regXboi> #info Maxime Millette-Coulombe and Harman Singh to committer on dlux
17:06:02 <regXboi> #link https://lists.opendaylight.org/pipermail/tsc/2014-August/001554.html
17:06:04 <tbachman> does the unod only undo the last thing that a given person typed, or the last thing for all people?
17:06:09 <tbachman> s/unod/undo/
17:06:12 <regXboi> #undo is everything
17:06:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x251f590>
17:06:15 <regXboi> see?
17:06:16 <tbachman> lol
17:06:21 <regXboi> #link https://lists.opendaylight.org/pipermail/tsc/2014-August/001554.html
17:06:31 <regXboi> #info need committer +1s email - some discussion
17:06:49 <tbachman> #info not having committers to dlux is posing a problem for getting Helium out the door
17:06:55 <regXboi> tbachman: thx
17:06:58 <tbachman> :)
17:07:31 <tbachman> #info edwarnicke asks if it’s possible to have a majority of committers for the project
17:08:45 <regXboi> #action will punt to next week (unforuntaely)
17:08:54 <regXboi> #topic Release Readout
17:08:56 <Madhu> regXboi: +1
17:09:01 <Madhu> i really wanted to get moving on that...
17:09:06 <tbachman> #topic At-Large elections Update
17:09:11 <Madhu> edwarnicke: can u ask your folks to +1 to the email ASAP ?
17:09:12 <regXboi> #undo
17:09:12 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x275b450>
17:09:18 <tbachman> #info only one person has nominated
17:09:19 <regXboi> #action postponed
17:09:23 <regXboi> #undo
17:09:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2657b50>
17:09:24 <regXboi> #undo
17:09:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x275b450>
17:09:27 <regXboi> #action postponed
17:09:33 <regXboi> #topic at-large elections update
17:09:37 <tbachman> where are we now?
17:09:39 <tbachman> lol
17:09:40 <regXboi> #info only one persone has nominated
17:09:43 <regXboi> caught up
17:09:52 <regXboi> #info request from dmm to get more nominees
17:09:53 * ChrisPriceAB phew
17:09:53 <tbachman> :)
17:10:19 <edwarnicke> #link - https://lists.opendaylight.org/pipermail/dlux-dev/2014-August/000075.html 3rd commiter of 4 chimes in
17:10:26 <edwarnicke> On dlux committers
17:11:30 <regXboi> #topic committer promotions (redux)
17:11:50 <regXboi> #info Maxime Millette-Coulombe and Harman Singh to committer on dlux (Madhu standing in for Endre)
17:12:11 <regXboi> #info repeat link
17:12:19 <regXboi> #link https://lists.opendaylight.org/pipermail/tsc/2014-August/001554.html
17:12:24 <regXboi> #info repeat link of email
17:12:31 <tbachman> #undo
17:12:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2657d10>
17:12:32 <tbachman> #link - https://lists.opendaylight.org/pipermail/dlux-dev/2014-August/000075.html 3rd commiter of 4 chimes in
17:12:41 <regXboi> #info above is repeat link of email
17:12:44 <regXboi> :-)
17:12:46 <tbachman> (otherwise doesn’t show up in context)
17:12:59 <tbachman> I think it needs to be with the link?
17:13:08 <regXboi> maybe yes, maybe no :)
17:13:11 <tbachman> lol
17:13:17 * regXboi amazed we are keeping up :)
17:13:20 * ChrisPriceAB 0.o
17:13:45 * tbachman wonders if the spin gets faster as we progress through the periodic table
17:13:47 <dmm> request is here: #link https://lists.opendaylight.org/pipermail/tsc/2014-August/001554.htm
17:13:55 * ChrisPriceAB line up the vote Ryan.
17:14:06 <regXboi> #startvote Maxime Millette-Coulombe and Harman Singh to committer on dlux 1,0,-1
17:14:06 <odl_meetbot> Unable to parse vote topic and options.
17:14:25 <tbachman> +1 maybe?
17:14:33 <regXboi> #startvote "Maxime Millette-Coulombe and Harman Singh to committer on dlux" 1,0,-1
17:14:33 <odl_meetbot> Unable to parse vote topic and options.
17:14:34 <tbachman> or maybe a comma
17:14:53 <tbachman> #startvote Maxime Millette-Coulombe and Harman Singh to committer on dlux, 1,0,-1
17:14:53 <odl_meetbot> Unable to parse vote topic and options.
17:15:00 <regXboi> #startvote Maxime Millette-Coulombe and Harman Singh to committer on dlux +1,0,-1
17:15:00 <odl_meetbot> Unable to parse vote topic and options.
17:15:01 <CASP3R> need a ? at the end
17:15:06 <tbachman> yeah
17:15:07 <tbachman> that’s it
17:15:14 <regXboi> #startvote Maxime Millette-Coulombe and Harman Singh to committer on dlux? 1, 0, -1
17:15:14 <odl_meetbot> Begin voting on: Maxime Millette-Coulombe and Harman Singh to committer on dlux? Valid vote options are 1, 0, -1.
17:15:14 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:15:21 <tbachman> CASP3R: thx!
17:15:23 <IvanWood> +1
17:15:24 <dmm> #vote 1
17:15:24 <regXboi> CASP3R: many thanks
17:15:30 <kwatsen> #vote +1
17:15:30 <odl_meetbot> kwatsen: +1 is not a valid option. Valid options are 1, 0, -1.
17:15:30 <regXboi> #vote 1
17:15:32 <edwarnicke> #vote +1
17:15:32 <odl_meetbot> edwarnicke: +1 is not a valid option. Valid options are 1, 0, -1.
17:15:34 <ChrisPriceAB> #vote 1
17:15:37 <edwarnicke> #vote 1
17:15:39 <uchau> #vote +1
17:15:39 <odl_meetbot> uchau: +1 is not a valid option. Valid options are 1, 0, -1.
17:15:41 <kwatsen> #info 1
17:15:44 <regXboi> no +1 folks :-)
17:15:44 <IvanWood> #vote +1
17:15:44 <odl_meetbot> IvanWood: +1 is not a valid option. Valid options are 1, 0, -1.
17:15:47 * ChrisPriceAB don't use the + if it's not listed.
17:15:49 <regXboi> just 1
17:15:53 <uchau> #vote 1
17:15:57 <regXboi> #endvote
17:15:57 <odl_meetbot> Voted on "Maxime Millette-Coulombe and Harman Singh to committer on dlux?" Results are
17:15:57 <odl_meetbot> 1 (5): ChrisPriceAB, edwarnicke, uchau, dmm, regXboi
17:15:57 <tbachman> regXboi: next time, +1 :)
17:15:58 <IvanWood> #vote 1
17:16:00 <tbachman> lol
17:16:02 <regXboi> yeah yeah
17:16:12 <regXboi> #agreed Maxime Millette-Coulombe and Harman Singh to committer on dlux
17:16:21 <regXboi> #topic TSC role(s) and Project Scoping
17:16:30 <regXboi> #info OVSBB and HP openflow code
17:17:31 <tbachman> #info dmm says there is a role for project scoping, if only for the reason of only having 1 solution per problem.
17:17:31 <regXboi> #link https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-August/000648.html
17:18:35 <regXboi> #info dmm asks if this is in the critical path for helium and suggests that the OVSDB and OFplugin folks sort this out themselves and come back to the TSC with a proposed solution for the 8/28 meeting
17:18:44 <tbachman> regXboi: too fast ;)
17:18:45 <tbachman> lol
17:19:03 <regXboi> #info and the TSC will review and exercise its oversite responsibility at that meeting
17:20:53 <regXboi> #info Madhu and networkstatic ask how this request has turned into scope creep?
17:23:00 <regXboi> #info ChrisPriceAB replies that OFPlugin has been working with HP about the plugin and so the original request has friction
17:25:39 <ChrisPriceAB> #info regXboi comments that he feels the OVSDB project has a history of creeping out of the agreed project scope.
17:26:05 * tbachman wonders what would have happened if they’d just put this in a topic branch w/o the email
17:27:26 <tbachman> #info dmm recommends taking this off of the TSC meeting, and thinks the teams should sit down and talk through the differences, n account of lack of not all parties being present and lack of time on the TSC
17:27:57 <tbachman> #action dmm will find a time for all parties to get together to discuss, and will moderate
17:30:06 <tbachman> #topic ODL Forge
17:30:28 <regXboi> #info out of order because related to previous topic
17:31:08 <tbachman> #info Information needed to start ODL Forge has been provided to LF
17:31:10 <alagalah> Is there a link to the odlforge proposal or is it in email ?
17:31:33 <tbachman> It was at the end of last week’s TSC call
17:31:49 <regXboi> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-08-14-16.59.html for minutes of last week's call
17:32:12 <tbachman> #info edwarnicke says that the TSC hasn’t approved ODL Forge
17:32:12 <regXboi> #info edwarnicke claims that TSC has never agreed to this
17:32:16 <regXboi> #undo
17:32:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x24f8990>
17:32:19 <regXboi> :-)
17:32:24 <tbachman> regXboi: sorrry :)
17:32:33 <regXboi> tbachman: no worry
17:33:14 <alagalah> It looks like the odlforge meeting was a continuation of last week's TSC... and not in the TSC minutes... were there meetbot minutes?
17:33:24 <regXboi> alagalah: as far as I know - no :/
17:33:40 <tbachman> I think cdub started a new meeting?
17:33:43 <regXboi> yes
17:33:44 <alagalah> Ok so back to my original question, is there a documented proposal linked somewhere or in email somewhere ?
17:33:51 <regXboi> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/odlforge/opendaylight-meeting-odlforge.2014-08-14-18.10.html
17:33:52 <CASP3R> https://meetings.opendaylight.org/opendaylight-meeting/2014/odlforge/opendaylight-meeting-odlforge.2014-08-14-18.10.html
17:33:59 <alagalah> Thanks!
17:34:06 <regXboi> #info link is odlforge meeting minues
17:34:09 <regXboi> #undo
17:34:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x23e3e50>
17:34:15 <regXboi> #info link is odlforge meeting minutes
17:34:19 <tbachman> #info edwarnicke asks if this is how the TSC wants to spend their energy at the moment
17:34:53 <regXboi> #info dmm wonders if we aren't ready for this discussion
17:35:21 * dbainbri wonders how a forge project relates to an incubation project?
17:35:44 <tbachman> #info edwarnicke points out there are open questions that need to be brought to the TSC
17:35:46 <regXboi> dbainbri: notes of second meeting indicate forge is pre-incubation
17:35:48 <alagalah> dbainbri: There were a couple of comments about that in the minutes I just skimmed
17:36:05 <tbachman> #info kwatsen asks what the motivation is for ODL forge
17:36:15 <regXboi> tbachman: thanks
17:36:19 <tbachman> np!
17:36:28 <tbachman> #topic Karaf Updates
17:36:29 <regXboi> #action without Chris Wright, we have to push this to next week
17:36:31 <regXboi> #undo
17:36:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2529b10>
17:36:33 <regXboi> #undo
17:36:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x25294d0>
17:36:38 <regXboi> #action without Chris Wright, we have to push this to next week
17:36:43 <regXboi> #topic Karaf Updates
17:37:08 <regXboi> #info edwarnicke is sharing hot wiki page
17:37:23 <edwarnicke> #link https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#Structure_of_Karaf_so_far
17:37:55 <regXboi> #action edwarnicke to update https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#Structure_of_Karaf_so_far to be usable by the larger community
17:38:14 <regXboi> tbachman: how's that for being clever and quick :)
17:38:24 <tbachman> lol
17:40:50 <mlemay> BTW a feature crawler is coming along.. : http://odl-project-explorer.herokuapp.com/features/all
17:41:10 <mlemay> #link http://odl-project-explorer.herokuapp.com/features/all
17:41:21 <regXboi> #undo
17:41:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x249a810>
17:41:37 <regXboi> sorry mlemay, want some more context before we link that :)
17:42:16 <mlemay> regXboi: no problem
17:42:36 <regXboi> #info edwarnicke discusses how to have a test that checks karaf features file
17:43:43 <tbachman> #info there is a limitation in pax-exam 4.1 that limits it to 50 instances
17:43:52 <dmm> welcome phil
17:44:05 <regXboi> #info which causes issues with respect to recursive testing in integration
17:44:09 <tbachman> lol
17:44:11 <tbachman> beat me again
17:44:14 <regXboi> :-)
17:45:52 <regXboi> #info questions from Madhu (deferred until after the wiki page)
17:46:12 <phrobb> hi dmm
17:46:20 <regXboi> #chair phrobb
17:46:20 <odl_meetbot> Current chairs: ChrisPriceAB phrobb regXboi tbachman
17:46:24 <regXboi> :-)
17:46:36 <tbachman> #link https://wiki.opendaylight.org/view/Karaf:Hands_On_Guide#The_things.2C_where_they_are.2C_and_why link to explain reasons behind decisions in karaf
17:48:18 <tbachman> #info kwatsen expresses concern about introducing karaf this late
17:48:48 <regXboi> #info edwarnicke says this page is germane to "unit testing" feature.xml files
17:49:46 <regXboi> #undo
17:49:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x248ff90>
17:50:45 <regXboi> #info edwarnicke says this page is germane to the mechanics of making feature.xml files available to integration and "unit test" are table stakes
17:51:24 <tbachman> #info Madhu says that the AD-SAL was removed from the distribution, breaking OVSDB
17:51:35 <Madhu> #link https://git.opendaylight.org/gerrit/#/c/9861/9/opendaylight/distribution/opendaylight-karaf/pom.xml
17:51:57 <tbachman> #undo
17:51:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x258c3d0>
17:52:05 <tbachman> #link https://git.opendaylight.org/gerrit/#/c/9861/9/opendaylight/distribution/opendaylight-karaf/pom.xml gerrit where AD-SAL was removed
17:52:51 <regXboi> tbachman: thanks :)
17:52:57 <tbachman> np :)
17:56:16 <phrobb> #info Requests are made that when changes/actions are done that impact projects those causing the impact need to communicate the impact prior to causing the impact
17:58:59 <dmm> 
18:01:15 <regXboi> #info long discussion
18:01:17 <tbachman> #info kwatsen asks what all the projects have to do and by when, and when will this be communicated clearly
18:01:33 <tbachman> #action edwarnicke wil comunicate this
18:01:38 <tbachman> #undo
18:01:38 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x2638f50>
18:01:50 <tbachman> #action edwarnicke will communicate the changes needed for projects to support karaf
18:02:01 <tbachman> #info kwatsen asks if all the projects need to get on top of this within the next week
18:02:07 <tbachman> #info edwarnicke says yes
18:02:11 <regXboi> #undo
18:02:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2593b50>
18:02:17 <regXboi> #info edwarnicke says yes ASAP
18:02:51 <tbachman> lol :)
18:03:17 <regXboi> #info kwatsen says that some projects may not be able to get on top of this in the next week, so we may need an exception path
18:04:20 <regXboi> #info dmm notes that this looks like its in critical path and edwarnicke agrees
18:07:22 <regXboi> #info edwarnicke asks that George Zhao be the "project herder"
18:08:19 <phrobb> #endmeeting