16:59:26 <phrobb> #startmeeting TSC_2014-07-03
16:59:26 <odl_meetbot> Meeting started Thu Jul  3 16:59:26 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:26 <odl_meetbot> The meeting name has been set to 'tsc_2014_07_03'
16:59:51 <phrobb> #topic TSC members please #info in
16:59:56 * tbachman wonders if the July 4th weekend has anything to do with attendance ;)
17:00:25 <regXboi> #info regXboi
17:00:34 <edwarnicke> #info edwarnicke
17:00:40 <regXboi> #info dmm (proxy from regXboi)
17:00:48 <phrobb> #info dmm (Dave Meyer) is present
17:01:36 <phrobb> #chair regxboi edwarnicke colindixon
17:01:36 <odl_meetbot> Current chairs: colindixon edwarnicke phrobb regxboi
17:01:44 <colindixon> hey hey
17:01:52 <ChrisPriceAB> #info Chris Price joined
17:01:55 * regXboi throws pen at colindixon
17:02:10 * ChrisPriceAB throws his chair at him
17:03:01 <RobDolin> #info RobDolin proxy for Rajeev Nagar (MSFT)
17:03:14 <phrobb> #chair robdolin
17:03:14 <odl_meetbot> Current chairs: colindixon edwarnicke phrobb regxboi robdolin
17:03:49 <phrobb> RobDolin:  will you be joining the webex?
17:03:59 <RobDolin> Yep; just dialing-in...
17:04:03 <phrobb> cool
17:05:02 <regXboi> uhoh
17:05:56 * regXboi has some issues with computer audio
17:06:04 <phrobb> #topic Creation Review for TCP-MD5
17:06:36 <colindixon> phrobb: are you taking point on scribing?
17:06:59 <phrobb> #link https://wiki.opendaylight.org/view/Project_Proposals:TCP-MD5
17:07:11 <colindixon> thanks
17:07:16 <colindixon> I was just hunting that
17:07:17 <phrobb> colindixon:  yep, but feel free to correct/add as needed
17:07:20 <edwarnicke> #topic TCP-MD5 creation review
17:07:29 <colindixon> edwarnicke: you’re killing us
17:07:36 <edwarnicke> #link https://wiki.opendaylight.org/view/Project_Proposals:TCP-MD5 - repeated to get it under the right section
17:07:56 <phrobb> :-)
17:08:19 <dlenrow> #info Lenrow
17:08:27 <cdub> #info Chris Wright
17:09:06 <colindixon> #info rovarga_ says that BGP-PCEP needs (or just suggests?) TCP with the MD5 signature option
17:09:31 <RobDolin> Question for Robert V.: you mentioned current support for 64-bit Linux; will you be making sure the project works for Linux and Windows?
17:10:01 <regXboi> #info question from dmm: why does this need to be its own project?
17:10:28 <colindixon> #info as a conseuqnece, they’re targetting an implementation for Linux 64-bit (in C) along with JNI bindings so that people can use it
17:11:25 <regXboi> #info answer from rovarga: in working with opendaylight a project is a repository and so this is to give this code its own repository and its own version
17:11:45 <phrobb> #info rovarga_ notes that if it is a separate project it can have a separate set of committers so the people and expertise needed is different than BGP/PCEP
17:11:47 <regXboi> #info continued answer: making it its own project would allow for a separate set of committers than bgp or pcep
17:12:19 <regXboi> #info question from abhijitkumbhare: is it a good idea to have projects for common utility
17:12:40 * ChrisPriceAB or a common project for all common utilities?
17:12:48 <phrobb> #info abhijitkumbhare asks "should there be a utility project for this type of generally applicable functionality?
17:13:03 <regXboi> #info answer from colindixon: there are actually two questions: one is where should code live and two who is able to own code in the sense of reviews?
17:13:28 <regXboi> #info and while splitting a code base off is an answer for the first, but may not be an answer for the second
17:13:36 <colindixon> thanks
17:14:08 <regXboi> colindixon: take the pen... it's my turn to comment :)
17:15:01 <colindixon> #info dmm says this is part of what he wanted to get at. what are the other implications of createing projects like this, e.g., that the PTL of this project could ultimately end up on the TSC
17:15:18 <colindixon> #info colindixon points out that this is *only* if the project become core
17:16:02 <colindixon> #info regXboi says that something that might help in this kind of discussions would be to have contracts between projects that explain their relationships
17:16:15 <phrobb> #info regXboi notes a reason for a separate project is also to have projects agree and document their "contracts" between each other…  Where "contracts" mean a well-defined and slowly evolving touch points between projects so that new project can easily see how to connect and also for new alternatives to existing implementations…
17:16:52 <phrobb> #info so if creating a new project will enable that type of modularity, then it could be worthwhile, otherwise, maybe not
17:18:01 <phrobb> #info ChrisPriceAB notes that projects starting in incubation on their own allows small teams do what they need to to get started without putting at risk a larger project
17:19:20 <colindixon> that’s a really good point
17:19:25 <phrobb> #info dmm asks that "long ago", there have been talks about MD5 being deprecated, is this being done as a minimal implementation just using MD5 or is it more flexible to use other types of hashes
17:20:27 <phrobb> #info Answer: the existing code is really modeled after unix so there is jus a channel that talks to the underlying TCP layer.  For service providers it was a must to be deployable
17:20:45 <colindixon> #link http://www.kb.cert.org/vuls/id/836068 “Software developers, Certification Authorities, website owners, and users should avoid using the MD5 algorithm in any capacity. As previous research has demonstrated, it should be considered cryptographically broken and unsuitable for further use.”
17:20:57 <phrobb> #info windows nor mac support these interfaces so this is limited to linux
17:21:16 <cdub> i think it's...patches accepted ;)
17:21:50 <phrobb> #info Q: will the project commit to support windows/mac if underlying libs/function available...
17:22:39 <phrobb> #info answer is that "no" project does not have plan to support windows/mac if lib available
17:23:17 <phrobb> #info  edwarnicke noting that if someone comes with patches to support other platforms the code would be welcome.
17:23:19 <dbainbri> question, only half listening. if this does go through, what will be the behavior differences between the linux distributions and the Win/Mac distributions?
17:23:33 <colindixon> dbainbri: really good question
17:25:28 <phrobb> #info question and discussion ensue on cross-platform project requirements on existing projects and how cross platform support is to be handled
17:27:10 <phrobb> #info rovarga_ notes that the core problems are that the build environment is linux centric.  having help building on other platforms rovarga_ is willing to work to support multi platform, but that help is manditory for this project
17:27:56 <Madhu> is this getting in Helium ?
17:28:01 <colindixon> as a side note, there have been cross-platform bugs in the past which have slipped through the build system for that reason and having jenkins slaves for Mac and Windows would really help
17:28:12 <dlenrow> #info We raised issue not related to MD5 about whether we require multi-platform commitment for incubation approval. Might need separate session.
17:28:13 <colindixon> Madhu and dbainbri: we should bring these up
17:29:52 <colindixon> #info rovarga_ answers Madhu by saying the code is there in BGP-PCEP now and so it will ship with Helium if there is no action and so the answer is *yes*
17:30:46 <Madhu> so if the code is done, we can get any project into Helium at any time ?
17:31:02 <Madhu> i thought the Helium project proposals were due last month.
17:31:10 <cdub> Madhu: it's already in bgpcep project
17:31:14 <colindixon> #info rovarga_ (in response to dbainbri) is that this feature is disabled by default on all platforms, needs to be activated by config system which will cleanly fail if it’s on the wrong platform
17:31:20 <Madhu> cdub: sure.
17:31:28 <Madhu> but my question is more of project proposal.
17:31:34 <Madhu> that makes it a different repository
17:31:35 <cdub> so it'd be there for sure.  if it's broken out to a new project, well...
17:31:39 <colindixon> Madhu: I think that they would defer project creation to post-Helium if we said that we wouldn’t let this project participate in Helium on it’s own
17:31:41 <edwarnicke> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects - "Please also note that projects that may be splitting into logical parts may have those logical parts join the Simultaneous Release at any point prior to M3 provided their Release Plans are apportioned between the projects they split into." in response
17:31:41 <edwarnicke> to Madhu
17:32:05 <colindixon> thanks edwarnicke
17:32:13 <cdub> there's the link, thanks edwarnicke
17:32:18 <edwarnicke> colindixon: Madhu The TSC has already approved in the Simultenaous Release Plan Projects split from Helium project getting into Helium if done prior to M3
17:32:30 <colindixon> edwarnicke: yes
17:32:46 <Madhu> edwarnicke: thanks.
17:32:53 <Madhu> I joined late... so another question
17:32:59 <Madhu> why is this being split ?
17:33:11 <tbachman> I think so it can be shared
17:33:14 <tbachman> (across projects)
17:33:21 <cdub> i think because it's generic and therefore could be reused elsewhere
17:33:35 <phrobb> #startvote shall the TCP-MD5 project be moved to incubation? -1, 0, +1
17:33:35 <odl_meetbot> Begin voting on: shall the TCP-MD5 project be moved to incubation? Valid vote options are -1, 0, +1.
17:33:35 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:33:50 <cdub> #vote +1
17:33:53 <dlenrow> #vote +1
17:33:59 <ChrisPriceAB> #vote +1
17:34:01 <edwarnicke> #vote +1
17:34:24 <regXboi> #vote 0
17:34:26 <phrobb> #endvote
17:34:26 <odl_meetbot> Voted on "shall the TCP-MD5 project be moved to incubation?" Results are
17:34:26 <odl_meetbot> 0 (1): regXboi
17:34:26 <odl_meetbot> +1 (4): cdub, dlenrow, ChrisPriceAB, edwarnicke
17:34:27 <RobDolin> #vote 0
17:34:31 * ChrisPriceAB thinking = abstaining???
17:34:43 * regXboi no... thinking about abstaining
17:34:57 <regXboi> #info actual vote was 5 +1 as dmm was unable to register
17:35:00 <dlenrow> We're allowed to think?
17:35:02 * ChrisPriceAB I abstain from thinking...
17:35:06 <cdub> heh
17:35:17 <phrobb> #info RobDolin voted abstaining as did ChrisPriceAB
17:35:23 <colindixon> we should log what the final vote actually was
17:35:25 <colindixon> thanks phrobb
17:35:29 <ChrisPriceAB> O.o
17:35:33 <phrobb> #agreed TCP-MD5 project is moved to incubation
17:35:34 <regXboi> #agreed TCP-MD5 project to incubation
17:35:41 <regXboi> phrobb: you beat me to it :)
17:36:03 <colindixon> #topic XSQL demo
17:36:30 <colindixon> #info Sharon starts a demo of using XSQL to query the MD-SAL
17:38:36 <phrobb> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:XSQL
17:38:52 <colindixon> #link https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#July_1st.2C_2014 this was also presented at the July 1st MD-SAL weekly meeting and you can find minutes and (hopefully soon) a recording of a longer demo there
17:39:30 * regXboi thinks of changing handle to sqlBoi for a few minutes
17:39:52 <colindixon> regXpathSqlBoi?
17:40:36 <phrobb> regXboi:  when you are off mute you cause an echo… I muted you
17:40:57 <regXboi> phrobb: I'll unmute myself because I will have questions and comments
17:40:58 <regXboi> :)
17:41:08 <colindixon> #info demo shows that you can query virtual tables (read dynamically from the MD-SAL) with columns and the ability to do SQL-like things
17:43:02 <edwarnicke> #info demo shows that you can access with a jdbc interface
17:43:09 <colindixon> edwarnicke: beat me to it
17:43:18 <edwarnicke> :)
17:43:34 <cdub> this seems pretty nice
17:44:16 <phrobb> #info Q: dmm asks "what do you want to have happen with this?"
17:44:53 <phrobb> #info answer, The goal is to make things easier.  this should be usable by anything that wants to extract data from ODL
17:46:25 * regXboi raises hand
17:46:28 <phrobb> #info Q: there is nothing hardcoded here correct?
17:46:36 * regXboi so that I don't start causing echoes
17:46:44 <phrobb> #info answer, no everything is dynamically built
17:47:01 <rovarga_> I'd love to see this enabled by default :)
17:47:56 * regXboi still raises hand
17:48:07 <phrobb> yea, I'll get you in there regXboi
17:50:02 <phrobb> #info Q on access to data based on ACL?
17:50:05 <colindixon> Not that I don’t think this stuff is cool, but I wonder if this is the right venue for this kind of discussion in the future. Especially if we only have 1 hour per week.
17:50:38 <regXboi> colindixon: point - I think TWS might be more appropriate
17:50:55 <colindixon> regXboi: it *was* presented on the MD-SAL meeting
17:51:01 <phrobb> #info answer, currently in ODL there is no authentication
17:51:29 <phrobb> #info this discussion should go to TWS as more questions and discussion needed
17:51:38 <colindixon> #info the real answer is that the MD-SAL data store as of today doesn’t allow for authentication
17:52:08 <regXboi> #topic hydrogen stable release artifacts update
17:52:21 <regXboi> #info colindixon running with this
17:52:43 <regXboi> #info almost everybody has signed off on the artifacts cut on Tuesday night
17:53:42 <edwarnicke> #link https://docs.google.com/a/colindixon.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0
17:54:46 <regXboi> #action either colindixon or edwarnicke to send email to release mailing list to firm up status
17:54:51 <regXboi> did I get that right?
17:55:53 <phrobb> #action dlenrow to contact Affinity team to get clear understanding on their participation in stable release to hydrogen
17:56:15 <regXboi> #topic project template
17:56:20 <colindixon> #link https://wiki.opendaylight.org/view/Special:WhatLinksHere/Template:Project_Facts please use this
17:56:32 <colindixon> #link https://wiki.opendaylight.org/view/Template:Project_Facts the right link
17:56:44 <regXboi> #info all projects please use this!!!
17:58:38 <phrobb> #info TSC members mull the fact box template proposal over and be ready to discuss/close at next meeting
17:58:41 <colindixon> #link https://wiki.opendaylight.org/view/Table_Type_Patterns:Main this is an example of how to use the template
17:59:00 <phrobb> #endmeeting