17:00:28 <regXboi> #startmeeting TSC 7-17
17:00:28 <odl_meetbot> Meeting started Thu Jul 17 17:00:28 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:28 <odl_meetbot> The meeting name has been set to 'tsc_7_17'
17:00:33 <dmm> #info dmm
17:00:36 <regXboi> #chair colindixon
17:00:36 <odl_meetbot> Current chairs: colindixon regXboi
17:00:43 <regXboi> #info regXboi
17:00:49 <cdub_> #info Chris Wright
17:00:54 <colindixon> I’m here :p
17:01:14 <cdub_> (irc only for the moment)
17:01:25 <ChrisPriceAB> #info Chris Price
17:01:40 * ChrisPriceAB avoiding text responsilities
17:02:14 <jmedved> #info Jan Medved
17:02:29 <kwatsen> #info Kent Watsen
17:02:33 <RobDolin> #info Rob Dolin proxy for Rajeev Nagar (MSFT)
17:02:40 <regXboi> #info note: jmedved has ed's proxy this week
17:02:54 <ChrisPriceAB> I am having real issue with audio.  Packet and Circuit are broken :(
17:03:33 <uchau> #info uchau - proxy for HP
17:04:06 <ChrisPriceAB> Throw me the baton
17:04:11 <colindixon> #chair ChrisPriceAB
17:04:11 <odl_meetbot> Current chairs: ChrisPriceAB colindixon regXboi
17:04:28 <ChrisPriceAB> I can scribe as I can't speak.  :)  Intepretative license applied
17:04:29 <regXboi> this could be interesting - a scribe with no audio
17:04:46 <regXboi> #info no audio recording this week
17:04:51 <colindixon> #topic agenda bashing
17:05:26 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main the agenda can be found here (as usual)
17:05:42 * ChrisPriceAB stepping out to go back to circuit switch
17:05:51 <colindixon> #info phrobb arrives (there will actually be a recording)
17:06:03 <regXboi> #info just missing first 5+ minutes :(
17:06:38 <colindixon> #topic system testing and integration
17:07:38 <regXboi> colindixon: are you getting this?  I'm having a hard time hearing Luis...
17:07:47 <jmedved> hearing him ok
17:07:48 <colindixon> #info LuisGomez says that he Mathieu (karaf pacakging) and Paul Zimmerman (documentation) are working together to communicate to projects what they’re going to need from projects to get testing and documentation working
17:07:49 <ChrisPriceAB> I can hear OK, surprisingly
17:07:57 <regXboi> colindixon: thanks :)
17:09:01 <regXboi> #info skipping Doc topic for today
17:09:06 <colindixon> #info expect an e-mail from phrobb about this meeting to the release mailing lists; all primary contacts for projects participating in the helium release should be on that list today
17:09:14 <regXboi> #topic Committer Promitions
17:09:33 <regXboi> #info Michal Rehak to committer to OpenFlowJavaLibrary
17:09:34 <phrobb> am I #chaired, and if not could I be?
17:09:40 <regXboi> #chair phrobb
17:09:40 <odl_meetbot> Current chairs: ChrisPriceAB colindixon phrobb regXboi
17:09:45 <regXboi> you are now ;)
17:09:58 <cdub_> lots of feedback on phone
17:10:05 <colindixon> phrobb: I’m assuming you’ll man the magic voting machine
17:10:17 <phrobb> yup ok
17:10:26 <regXboi> do we have a link for any email on this thread?
17:10:46 <tbachman> cdub_: I think it’s the guy who’s speaking (needs headphones :) )
17:11:40 <hideyuki> https://lists.opendaylight.org/pipermail/tsc/2014-July/001359.html
17:12:21 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-July/001359.html the mail showing the internal vote (thanks to hideyuki)
17:12:47 <phrobb> #startvote shall Michal Rehak be promoted to committer on the OpenFlowJava Project? -1, 0, +1
17:12:47 <odl_meetbot> Begin voting on: shall Michal Rehak be promoted to committer on the OpenFlowJava Project? Valid vote options are -1, 0, +1.
17:12:47 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:12:56 <hideyuki> colindixon: Thank you. I forgot about "#link". I'll use it next time.
17:13:03 <ChrisPriceAB> #vote +1
17:13:05 <dmm> #vote +1
17:13:05 <kwatsen> #vote +1
17:13:10 <RobDolin> #vote +1
17:13:11 <jmedved> #vote +1
17:13:11 <uchau> #vote +1
17:13:11 <cdub_> #vote +1
17:13:19 <regXboi> #vote +1
17:13:34 <RobDolin> Congratulations!
17:13:36 <regXboi> #endvote
17:13:36 <odl_meetbot> Voted on "shall Michal Rehak be promoted to committer on the OpenFlowJava Project?" Results are
17:13:36 <odl_meetbot> +1 (8): cdub_, jmedved, dmm, regXboi, ChrisPriceAB, uchau, kwatsen, RobDolin
17:13:51 <phrobb> #agreed Michal Rehak has been promoted to committer
17:13:55 <colindixon> #info congrats (just as further supporing information, Micahal has 150 of 254 commits on that project)
17:13:57 <regXboi> congrats!
17:14:25 <dmm> congrats Michal Rehak!
17:14:33 <colindixon> #topic hydrogen statble release
17:15:02 <tbachman> phrobb:  can you mute Daniel?
17:15:13 <cdub_> let's not be stuck for a week
17:15:14 <tbachman> phrobb: thx :)
17:15:23 <cdub_> let's use email to validate/vote
17:15:32 <ChrisPriceAB> #info Ryan, need to re-spin stable hydrogen.
17:15:38 <dmm> cdub: yes
17:15:46 <colindixon> #info regXboi says we need to respin the release and he’s having some trouble getting it done (with the auto-release jobs) and also to make sure that we have confirmation from all projects
17:15:54 <cdub_> _or_ let's provisionally support based on all projects +1 (for example)
17:16:32 <ChrisPriceAB> #info Dave m proposed
17:16:32 <colindixon> #info cdub_ and dmm suggest that we don’t wait a whole week, maybe provide provisional support based on the current project +1s
17:17:00 <regXboi> #link https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0 is the google's doc
17:17:03 <cdub_> we can say...iff all +1, we release
17:18:29 <colindixon> #info dmm asks if we’re having trouble because the baton has been passed around or if it’s technical issues?
17:19:34 <phrobb> #info Q:  is the problem in getting the stable release done due to passing around the lead-responsibility, or are there real issues with the release?  A:  some problems in shifting leadership, some possibly on infrastructure (auto release scripts), and some on a good process to get feedback from projects promptly.
17:21:10 <colindixon> #info colindixon says one key problem which we don’t have a good way to get a response to a question from *all* projects in an efficient manner
17:21:58 <cdub_> i suggest...if you don't comply we keep note and record on the "regular release" part of ability to be promoted _and_ i propose that we focus future releases on not releasing incubated code
17:22:02 <colindixon> #info phrobb says that basically, the common pattern for that is that we get a response from ~60% in a timeline fashion and the remaining 40% takes 7-10 days to get responses from everyone by manually pinging people repeatedly
17:22:22 <colindixon> cdub_: do you want to pound info that?
17:22:43 <cdub_> #info cdub suggests...if you don't comply we keep note and record on the "regular release" part of ability to be promoted _and_ i propose that we focus future releases on not releasing incubated code
17:22:44 <colindixon> regXboi: can you summarize the current plan here?
17:23:20 <cdub_> it's somewhat radical, but we can't be hung up on lack of repsonsible owners
17:23:30 <cdub_> "you snooze, you lose" (TM)
17:23:43 * ChrisPriceAB likes this
17:23:51 <cdub_> it is intentionally controversial
17:23:56 <dmm> @cdub: yes
17:24:10 <colindixon> cdub_: can I or you action it
17:24:19 <colindixon> and have you send it to the TSC mailing list
17:24:48 <regXboi> #info plan for stable/H is to see if the current spin works - once we have a spin, to publicize it to folks and to cat herd projects to +1 the google docs
17:25:08 <regXboi> #info plan(2) is to then use TSC mailing list for approval once all projects +1 the google doc
17:25:14 <regXboi> #info or a majority
17:25:23 <regXboi> colindixon: that work?
17:25:28 <regXboi> #topic karaf update
17:25:51 <colindixon> #action cdub_ to propose his suggestion (about using failure to respond as a gate to moving out of incubation) to the TSC list and maybe have a vote on it in the future
17:25:59 <colindixon> cdub_: for what it’s worth, I’m in favor
17:26:33 <colindixon> #info LuisGomez says he is very, very much in favor of using features to help testing
17:26:43 <colindixon> regXboi: that works for me
17:26:47 * ChrisPriceAB He's a clever guy
17:27:20 <colindixon> #info dmm asks if we should set a drop dead date so that we can put some fire underneath people to make a decision
17:28:59 <colindixon> #info phrobb says mail today will send out and invite for two meetings (to accomodate all time zones) around this stuff which will be on 7/23
17:29:20 <colindixon> #info we will provide a readout of that to the TSC on 7/24
17:30:03 <colindixon> #info we will also give projects a week to react to that by the 7/30 M4 meeting which should give us a project-level readout on how we’re doing with karaf things
17:30:18 <cdub_> colindixon: sent...have to wait until next week for fireworks
17:30:36 <colindixon> #info then the TSC could provide an informed go/no-go decsion on the 7/31 meeting
17:31:27 <colindixon> cdub_: I’m with you on this given that I’ve been the cat herder more that I’d like—though certainly a lot less than poor phrobb
17:31:48 <cdub_> colindixon: feel free to +1 the email ;)
17:32:15 <colindixon> #action phrobb will send a mail with this timeline to TSC and release
17:33:03 * ChrisPriceAB wants to speak now....
17:34:02 <cdub_> ChrisPriceAB: speak now or forever hold your peace
17:34:58 <colindixon> #topic events in dusseldorf
17:35:38 <cdub_> #link http://www.layer123.com/sdn
17:35:48 <abhijitkumbhare> http://www.opendaylight.org/events/2014-10-13/opendaylight-d%C3%BCsseldorf-hackfest
17:35:56 <abhijitkumbhare> #link http://www.opendaylight.org/events/2014-10-13/opendaylight-d%C3%BCsseldorf-hackfest
17:35:59 <colindixon> thanks
17:36:06 <ChrisPriceAB> #info minisummit:  http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress
17:36:23 <ChrisPriceAB> # link http://www.opendaylight.org/events/2014-10-14/opendaylight-mini-summit-sdn-openflow-world-congress
17:36:42 <colindixon> #info if you want to help out get in touch with him or Todd or Katy (sp?)
17:36:56 <colindixon> #info ChrisPriceAB would like to use this to gett OpenDaylight better booted up in Europe
17:36:58 <cdub_> #link https://lists.opendaylight.org/pipermail/tsc/2014-July/001387.html CFP is open email
17:37:01 * ChrisPriceAB thanks colin
17:37:10 <colindixon> #topic new bylaws
17:37:32 <colindixon> can somebody summarize this? I missed some of it
17:38:28 <ChrisPriceAB> #info As the bylaws have now been approved we will soon be ready to hold at large elections across the OpenDaylight community.
17:38:46 <ChrisPriceAB> #info Phil Robb will call for these over the regular mailing lists.
17:39:05 <phrobb> #info the TSC had no objections to final by-laws sent by phrobb.  The Board is now voting on approval of the amended by-laws and TSC charter and to implement the Waiver for one year.  The Board vote will end next Wednesday 7/23 and at that point, if approved the waiver will begin to be in affect
17:39:16 <ChrisPriceAB> #info Learship in time and content!
17:39:33 <colindixon> perfect
17:39:35 <regXboi> #endmeeting