16:58:43 <phrobb> #startmeeting TSC Meeting 4/24/2014
16:58:43 <odl_meetbot> Meeting started Thu Apr 24 16:58:43 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:58:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:58:43 <odl_meetbot> The meeting name has been set to 'tsc_meeting_4_24_2014'
16:59:03 <phrobb> #topic TSC Members please #info in as you join
16:59:15 <dmm> #info dmm
16:59:29 <regXboi> #info regXboi (for vijoy today)
16:59:33 <dbainbri> #info dbainbri
16:59:36 <regXboi> still trying to get webex to start
17:00:04 <dmm> agenda #link https://wiki.opendaylight.org/view/TSC:Main
17:02:17 <cdub> #info Chris Wright here
17:02:48 <edwarnicke___> #info Ed Warnicke
17:03:10 <regXboi> ugh, this is taking *forever*
17:03:34 <colindixon> regXboi: I got a nginx bad gateway, but I'm now in
17:04:14 <RobDolin> I'm trying to get in ...
17:05:51 <RobDolin> #info RobDolin for Rajeev Nagar (Microsoft)
17:06:16 * regXboi thanks tykeal for #startvote/#vote
17:06:19 <phrobb> #chair RobDolin colindixon
17:06:19 <odl_meetbot> Current chairs: RobDolin colindixon phrobb
17:06:20 <cdub> tykeal: w00t! thanks!
17:06:52 <regXboi> #info regXboi thanks tykeal for #startvote/#vote (publically this time) :)
17:06:56 <RobDolin> #info Thanks also Andy / tykeal for helping get the Docs project set-up
17:07:05 <phrobb> #topic Release Manager
17:07:07 <regXboi> +1 to that as well
17:07:21 <cdub> tick-tock
17:08:55 <regXboi> #info successful first call with Huawei - plan for BOF meet up in Atlanta at OpenStack
17:09:07 <regXboi> is that accurate?
17:09:07 <phrobb> #topic Helium Release Plan
17:09:14 <cdub> regXboi: clse enough
17:09:17 <regXboi> :)
17:09:26 <phrobb> regXboi:  yep, thanks
17:09:29 <edwarnicke___> #info  https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan
17:09:47 <ChrsPriceAB> #info Chris Price joining
17:11:14 <alagalah> Doesn't each project have a Point Of Contact ??? Why not unicast them ???
17:11:35 <RobDolin> #info Ed Warnicke (Cisco) has heard comments that the volume on discuss is so high that people don't pay attention to it
17:11:35 <cdub> alagalah: that doesn't work for these new projects
17:12:02 <alagalah> cdub: But if they have gone through the Project Review process... ??
17:12:21 <cdub> they allegedly don't know that they need to in any specific timeframe
17:12:21 <alagalah> cdub: Or are you concerned that folks that haven't gone through that process aren't aware there's a deadline ?
17:12:51 <cdub> alagalah: i'm actually less concerned.  ed is concerned, and he keeps finding these people
17:13:29 <alagalah> cdub: Ok ... https://wiki.opendaylight.org/view/GettingStarted:Project_Main This should point this out.
17:13:36 <edwarnicke___> cdub: A lot of folks talk to me (from many companies) about wanting to bring projects... so I see it a lot
17:14:11 <regXboi> wow - finally
17:14:17 * regXboi makes the webex
17:14:27 <cdub> edwarnicke___: push them to the list
17:15:26 <phrobb> #topic Lithium Release Plan
17:16:50 <RobDolin> #info Phil: There may be an opportunity for an OpenDaylight Summit in early June at the Hyatt Santa Clara (CA, USA)
17:17:44 <RobDolin> #info Ed Warnicke suggests that may work well for design for 4th release
17:18:43 <RobDolin> Could someone please #link the text that Phil sent?
17:18:46 <regXboi> did we skip the TSC charter?
17:18:52 <regXboi> ah n/m
17:19:01 <RobDolin> #topic TSC Charter Text re: Elections
17:19:18 <dmm> @Rob: searching for it now
17:19:57 <edwarnicke___> #link https://lists.opendaylight.org/pipermail/tsc/2014-April/001089.html
17:20:04 <dmm> thnx ed
17:25:02 <RobDolin> #info Phil Robb explaining options proposed in email:
17:25:17 <RobDolin> #info Option 1 -  Remove the "If Otherwise Not Represented" clause from the
17:25:26 <RobDolin> #info Option 2 - Allow existing TSC members to run for re-election
17:25:41 <RobDolin> #info Option 3 - Do nothing; Leave everything the same and let the voting fall
17:25:48 * edwarnicke___ thinks we need #raisehand :)
17:27:03 * edwarnicke___ observes that regXboi can always talk (and thankfully for us, does :) )
17:28:14 <RobDolin> * observes that regXboi thinks he has more influence today because he has a vote; IMHO he has influence because he has wise input
17:29:43 <RobDolin> #info Ryan Moats (IBM) suggests that Option 2 may create a conflict of interest between representing company and representing committers at-large
17:29:54 <RobDolin> <- Raises hand
17:31:09 <phrobb> #info regXboi does not like option 2 because if elected from the committer base but bumped my employer's TSC rep, the elected person is in an uncomfortable position of needing to represent the community but having some need to represent the employer
17:31:29 <RobDolin> #info Dave Lenrow (HP) suggests there is a one-time offset because we don't have core project PTLs or elected at-large committers
17:33:55 <phrobb> #RobDolin notes that option one is the cleanest and simplest short term solution
17:34:36 * regXboi has to go read 501c6 :)
17:39:06 * dbainbri going to have to drop before discussion on "Root Parent", would like to put my 2 cents in for removing "repository" information from Root Pom and either put it in a settings.xml (which i think is best practice) or at least in a separate pom file from the dependencymanagement (version) information.
17:40:06 <RobDolin> @regXboi - some info on 501 (c) * organizations: http://en.wikipedia.org/wiki/501(c)_organization
17:40:09 * edwarnicke___ is sad we won't have dbainbri for the actual discussion
17:41:08 <RobDolin> #info Lots of projects being brought by non-Platinum members
17:42:46 <edwarnicke___> #raiseshand
17:43:11 <phrobb> #action phrobb to build a new list of committers and their company affiliation
17:43:13 <RobDolin> #info David Meyer askes if ready for a vote
17:43:33 <RobDolin> #info David Meyer suggests an option of including a sunset clause
17:43:51 <RobDolin> #info Ryan Moats (IBM) suggests we can also send multiple suggestions
17:45:08 <RobDolin> #info Ed Warnicke (Cisco) suggests the proposal has not be available for very long
17:46:23 <RobDolin> #info Ryan Moats agrees with Ed that we should let this percolate on the mailing list for another week
17:46:41 * edwarnicke___ Ed begins to think of coffee due to all the talk of percolation
17:47:09 <phrobb> #action regXboi to put out a mail to continue discussion on the discuss list
17:47:39 <RobDolin> #action all should read community feedback on proposal(s)
17:48:35 <edwarnicke___> Could we get a topic change?
17:48:49 <regXboi> I"m not chair - I can't help
17:48:52 <RobDolin> #topic Automated Release
17:48:56 <regXboi> thanks
17:49:03 <edwarnicke___> Thanks RobDolin  :)
17:49:05 <RobDolin> #chair regXboi
17:49:05 <odl_meetbot> Current chairs: RobDolin colindixon phrobb regXboi
17:49:12 <regXboi> oops
17:49:20 <regXboi> no good deed goes unpunished
17:49:22 <phrobb> :-)
17:49:32 <RobDolin> For sure.  Usually Ryan or Phil beat me to the topic changes ;)
17:49:34 * edwarnicke___ hides from the magic chair stick ;)
17:49:43 <regXboi> quick - chair him!
17:49:46 <alagalah> MMMUUUUUUTTTTEEEEEE
17:49:54 <RobDolin> #chair edwarnicke__
17:49:54 <odl_meetbot> Warning: Nick not in channel: edwarnicke__
17:49:54 <odl_meetbot> Current chairs: RobDolin colindixon edwarnicke__ phrobb regXboi
17:50:06 <edwarnicke___> oh noos! ;)
17:50:15 <edwarnicke___> chaired ;( ;)
17:50:29 * alagalah giggles
17:50:35 * regXboi wonders if threatening with the magic chair stick would have any effect ;)
17:50:53 <cdub> seems topic is wrong
17:51:12 <alagalah> regXboi: I'll take the same approach I take with laundry ... "Oh did I wash that brand new red shirt with the whites??? WOOOPSY! What? You never want me to do it again???"
17:51:54 <regXboi> cdub: I think the name is slightly different from the topic
17:52:19 <cdub> iow, are we not on odl root parent project creation review?
17:52:29 <edwarnicke___> cdub: Yes we are
17:52:31 <RobDolin> #topic Root Parent Project Creation Review
17:52:38 <cdub> #link https://wiki.opendaylight.org/view/Project_Proposals:ODL_Root_Parent
17:52:40 <edwarnicke___> Thanks RobDolin  :)
17:52:41 <RobDolin> (Sorry, I used the title from the slides
17:52:43 <edwarnicke___> and cdub :)
17:52:45 <regXboi> they are pretty much the same thing
17:54:39 <edwarnicke___> regXboi: I would say that the rootPom project is requisite for most of the possible ways of resolving the release automation stuff... but approving the project is not the same as the TSC imposing the solution (which I still think should come by project adoption)
17:54:59 <regXboi> point
17:55:06 <cdub> where are the slides?
17:56:05 <RobDolin> #action Root Parent team to #link in minutes
17:56:07 <cdub> slides on webex don't really exist
17:56:24 <regXboi> cdub: very good point - I should have been awake
17:56:24 <cdub> please, always have public accessible and #link here
17:56:33 <colindixon> cdub: +15 to that
17:56:53 <alagalah> cdub: Yep, just pixels
17:57:00 <regXboi> so I have a concern
17:57:02 <regXboi> :)
17:57:08 * alagalah shocked face
17:57:12 <cdub> regXboi: you?
17:57:22 <regXboi> yeah I know - big suprise
17:57:37 * edwarnicke___ is shocked ;)
17:59:39 <phrobb> #info regXboi raises concern that the project needs to document how to fully enable/educate projects how to do automated documentation building in this new structure
17:59:45 <phrobb> regXboi:  did I get that right?
17:59:50 <regXboi> yes
17:59:52 <regXboi> thanks
18:01:06 <phrobb> #edwarnicke___ asks for clarity on what is being consided… a root POM project, but the TSC is not endorsing any particular solution within each project
18:01:28 * edwarnicke___ excited to use #vote
18:01:30 <cdub> #info further details to be worked out w/in technical community
18:02:08 <RobDolin> #info David Meyer explains this is creation of the project, not which solution will be used
18:02:54 <cdub> can't get there from here...w/out this project
18:04:05 <regXboi> cdub: exactly
18:04:16 <regXboi> or at least imho I don't see how to do it without this
18:04:29 <cdub> yup
18:05:26 <RobDolin> #info Mathieu Lemay asks why we need a seprate project for this
18:05:52 <RobDolin> #info Raghurama explains this is importance for release dependencies order
18:08:17 <phrobb> #info Mlemay and madhu ask if we need a new project for this work or could it be hosted within an existing project?
18:09:07 <RobDolin> #link https://wiki.opendaylight.org/view/File:Versioning-Updated.ppt <- PPT that was presented
18:10:51 <phrobb> #info ragbhat asks "is there a concern in creating a project out of this work"?
18:11:30 <cdub> can't hear
18:13:30 <cdub> i think i'm at the other end of a busted string
18:13:36 <RobDolin> #info Chris Wright (Red Hat) volunteers to help with this project
18:13:40 <cdub> can't hear a damn thing
18:13:57 <regXboi> the question on the table is to create the root parent project
18:14:12 <phrobb> #startvote Vote to move the ODL Root Parent Project to Incubation (not how it's implented within any given project) +1, -1, 0
18:14:12 <odl_meetbot> Unable to parse vote topic and options.
18:14:12 <edwarnicke___> Could someone #info the question
18:14:26 <edwarnicke___> #vote +1
18:14:26 <cdub> you need to startvote..erk, never mind
18:14:27 <regXboi> #info the question on the table is to create the root parent project
18:14:41 <cdub> #vote +1
18:14:44 <ChrsPriceAB> #vote +1
18:14:47 <dmm> #vote +1
18:14:48 <RobDolin> #vote +1
18:14:52 <regXboi> #vote 0
18:15:04 <RobDolin> Is "0" an abstain or present ?
18:15:11 <regXboi> 0 is abstain
18:15:15 <phrobb> #endvote
18:15:23 <RobDolin> #info David Meyer clarifies "0" = Abstain
18:16:37 <phrobb> #info Vote results are 5 +1, 0 -1, 1 0
18:17:19 <regXboi> #agreed root parent project to incubation
18:17:20 <phrobb> #agreed Rott Parent Project is moved to incubation
18:17:44 * edwarnicke___ marvels at dmm's time management acumen ;)
18:17:52 <RobDolin> +1 :)
18:17:54 * regXboi also
18:17:54 <cdub> Rott, heh ;)
18:18:16 <phrobb> yea, Doh!
18:18:42 <RobDolin> #topic Stable Release
18:18:57 <RobDolin> #info Chris Wright reports the process has started
18:19:17 <RobDolin> #info Chris also reports there has not been meaningful discussion about date for converging
18:19:31 <phrobb> #info no date has been picked for the first release.  At least two projects have not yet created a branch
18:20:14 <phrobb> #info regXboi asks if we are far enough along to switch the dependencies onto the stable branch to see what breaks.
18:20:39 <Madhu> do we still follow 2 weeks from project-proposal to TSC creation review ?
18:21:22 <regXboi> Madhu: I believe so
18:21:26 <regXboi> why?
18:21:33 <dmm> @madhu yes
18:21:44 <Madhu> okay. i saw opflex in the creation review today.
18:21:50 <Madhu> in agenda
18:21:55 <regXboi> it's scheduled for 5/1
18:21:58 <regXboi> not today
18:22:06 <tbachman> Madhu: it's got a 5/1 after it
18:22:11 <regXboi> at least that's how I read the agenda
18:22:13 <dmm> @madhu: I put the date they asked for the review after it
18:22:15 * tbachman notes others have been misled there as well
18:22:33 <dmm> @tbackman: misled how
18:22:38 <phrobb> #info cdub notes that the controller and yangtools projects need to have the patches/bug-fixes on the stable branch… that is still a work in progress with some Jenkins stability slowing things down
18:22:48 <tbachman> dmm: sorry -- misled is the wrong wor
18:22:50 <tbachman> word
18:22:56 <tbachman> missed :)
18:23:04 <tbachman> they've missed the 5/1 after it, I think
18:23:08 <Madhu> thanks. wasn't paying attention to the change in date
18:23:36 <dmm> I guess I can try to note it differently, but I want to leave it in the agenda
18:23:39 <alagalah> dmm: Confused maybe a better word, mate :) I didn't understand the 5/1
18:23:51 <dmm> I'll make it explicti
18:23:54 <dmm> explicit
18:24:01 <cdub> can someone #info, cause i didn't hear anything
18:24:03 <alagalah> dmm: Thanks, I like explicit :)
18:24:46 <phrobb> #topic Can integration projects contain distributions other than Release Vehicles?
18:26:13 <phrobb> #info edwarnicke___ notes that it is implied that distributions in the integration project are 1 to 1 mapped to release vehicles… Does that have to be?
18:26:48 * regXboi <- raises hand
18:27:04 <phrobb> #info Madhu asks, since inclusion in the Integration project implies testing by integration team, is that  what is recommended here?
18:27:09 * regXboi and prepares the grenade
18:27:57 <phrobb> #info edwarnicke___ notes that the integration team would need to define any bounds/scope on distributions other than release vehicles
18:28:56 * regXboi throws the grenade
18:29:55 <phrobb> #info regXboi pulls pin on grenade….. notes one of biggest headaches is non-determinacy of OSGi… putting more into that structure (with Karafe) will require fixing of the determinism
18:30:07 * edwarnicke___ jumps in foxhole :)
18:30:50 <alagalah> Service loader ?
18:30:56 * alagalah jumps in edwarnicke___ foxhole
18:31:00 <phrobb> #info mlemay notes that this is an issue and needs to be worked… even thanks regXboi for the grenade
18:31:11 * edwarnicke___ notes that its getting crowded in here
18:32:56 <alagalah> Can someone please explain in a little more detail about what the Karaf work is for if it isn't replacing Felix/Equinox ?
18:33:15 <mlemay> it is a layer on top of felix/equinox
18:33:30 <mlemay> that provides proper bootstraping, componentisation, shell and security
18:33:51 <cdub> it makes osgi consumable to mere mortals
18:34:00 <icbts> cdub: +1 :)
18:34:38 <mlemay> one important piece is the notion of a "feature" which is logical sets of bundles this way it is easier to compose the proper controller and /or projects
18:35:27 <icbts> a follow up important piece is a much more friendly shell
18:36:18 <phrobb> #info This topic came up due to Karafe migration work proposed by mlemay.  The question was "how to do this the best way"… if a distribution within the Integration project were available, that would be the best place....
18:36:57 <phrobb> #info but currently the only thing associated with the Integration project are "release vehicles"
18:37:39 <icbts> another benefit — Pax Exam only needs to pick up the ODL features descriptor files and test if the container boots up, bundles active — simplifies your testing
18:38:05 <phrobb> #info regXboi notes that having a side conversation on "what automated release" means might be worthwhile for clarity
18:38:47 <phrobb> #info  Seeking TSC clarity that "things in the Integration Project are not necessarily a Release Vehicle"
18:41:57 <phrobb> #info It is noted that automated release will generate weekly, non-release artifacts… however this question is about having a different set of artifacts built within integration that is not part of any expected release vehicle
18:42:33 <phrobb> #info regXboi asks "should this question go to the "discuss" list
18:44:49 <phrobb> #info  Given that it doesn't seem that the Karafe activity won't be blocked in the short term,  we should put this to the Discuss list for community comment
18:46:08 <phrobb> #topic Other Topics
18:46:42 <phrobb> #info regXboi notes he has a few additional topics…
18:50:09 <phrobb> #info This will go to mailing list but the topic is on tomcat and more java/OSGi bundle loading determinism.
18:50:33 <phrobb> #action regXboi to start discussion on tomcat and bundle loading determinism
18:50:40 * cdub avoids the "distributions add no value" discussion for now
18:50:40 <phrobb> #endmeeting