17:00:59 <phrobb> #startmeeting TSC Meeting 5-29-2014
17:00:59 <odl_meetbot> Meeting started Thu May 29 17:00:59 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:59 <odl_meetbot> The meeting name has been set to 'tsc_meeting_5_29_2014'
17:01:09 <Madhu> #info Madhu Venugopal
17:01:31 <phrobb> #chair regXboi
17:01:31 <odl_meetbot> Current chairs: phrobb regXboi
17:01:44 <regXboi> coming :)
17:01:58 <phrobb> #topic TSC Members please #info into the meeting
17:02:10 <regXboi> #info regXboi still getting to webex
17:03:14 <kwatsen> #help
17:03:15 <edwarnicke> #info Ed Warnicke
17:03:25 <lenrow> #info  Lenrow Present
17:03:31 <Madhu> #info Madhu Venugopal
17:03:34 <kwatsen> help
17:03:45 <regXboi> help?
17:04:46 <kwatsen> #info Kent Watsen
17:05:00 <phrobb> #info Chris Price is here
17:05:17 <phrobb> #chair RobDolin
17:05:17 <odl_meetbot> Current chairs: RobDolin phrobb regXboi
17:05:49 <ashaikh> kwatsen:  you can see a summary of meetbot commands here: http://meetbot.debian.net/Manual.html
17:05:55 <regXboi> and made it
17:06:02 <RobDolin> #info Rob Dolin proxy for Rajeev Nagar (MSFT)
17:06:23 <phrobb> #topic Agenda bashing
17:06:37 <phrobb> #link https://wiki.opendaylight.org/view/TSC:Main
17:08:36 <regXboi> #info edwarnicke thanks auric and GiovanniMeo putting in weekly automated releases
17:08:50 <regXboi> #info Madhu points out this will be topic of next TWS call
17:09:08 <regXboi> #topic Event Updates
17:09:13 <ChrsPriceAB> #info Chris Price would like to join the committee
17:09:28 * ChrsPriceAB for the SDN WC
17:09:30 <regXboi> #info phrobb asking for volunteers for program committies for upcoming events
17:09:36 <Madhu> #info TWS agenda for next week : https://wiki.opendaylight.org/view/Tech_Work_Stream:Main
17:09:45 <regXboi> #topic SFC to join Helium Simultaneous Release
17:10:35 <regXboi> #info paulq apologizes for not realizing that there is a separate item for joining Helium Simultaneous Release
17:10:47 <regXboi> #info phrobb asks if there are questions from the TSC
17:11:10 <RobDolin> raises hand
17:11:44 <regXboi> #info Madhu has a question about whether it is possible for a new project joining now to join helium
17:12:34 <regXboi> #info ChirsPriceAB thinks that the TSC reserved the right to evaluate new projects on a case by case basis
17:12:44 <regXboi> #info phrobb concurs with that memory
17:13:10 <regXboi> #info RobDolin states this was written into the helium plan
17:13:28 <regXboi> #info Lenrow asks what are the dependencies of this module
17:13:51 <regXboi> #info ChrisPriceAB thinks there are dependencies going NB, but there are not dependencies going SB
17:14:03 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-04-17-16.56.html <— has reference to what was discussed for projects
17:14:07 <regXboi> #info Lenrow asks if this means there are no changes driven SB
17:14:33 <regXboi> #info ChrisPriceAB states there may be changes driven SB, but these need to be done in a backward compatible way
17:14:59 <regXboi> #info Madhu says his question is answered
17:16:28 <regXboi> #info more discussion of case by case
17:17:07 <regXboi> #info kwatsen says while he his is ok with this, the release plan should be updated with information on how projects join a release
17:17:12 <regXboi> #info rmoats +1
17:17:49 <regXboi> (heh)
17:18:04 <regXboi> #info that should have been regXboi +1 to kwatsen's statement
17:18:19 <regXboi> #info question on whether we can close the door or not now
17:18:42 <regXboi> #info that q was from ChrisPriceAB
17:19:07 <kwatsen> #info s/join a release/declare intent/  (on my statement captured by Ryan)
17:19:24 <regXboi> #info concern from RobDolin that closing the door would be exclusive
17:20:21 <regXboi> #info Madhu has concern with needing to gate to ensure quality of release
17:20:55 <regXboi> #info RobDolin understands the needs for a long tail but says the conversation at that point should be along the lines of the questions Lenrow asked earlier in the conversation
17:21:27 * tbachman hands RobDolin a pacifier ;)
17:21:32 * regXboi notes the 2-month old may have useful things to say!
17:21:50 <regXboi> #info phrobb asks if a vote is needed
17:22:10 <regXboi> #info regXboi asks if anybody has a reason not to let SFC into Helium
17:22:39 <regXboi> #chair ChrisPriceAB
17:22:39 <odl_meetbot> Warning: Nick not in channel: ChrisPriceAB
17:22:39 <odl_meetbot> Current chairs: ChrisPriceAB RobDolin phrobb regXboi
17:22:57 <regXboi> #chair ChrsPriceAB
17:22:57 <odl_meetbot> Current chairs: ChrisPriceAB ChrsPriceAB RobDolin phrobb regXboi
17:23:01 <regXboi> #unchair ChrisPriceAB
17:23:01 <odl_meetbot> Current chairs: ChrsPriceAB RobDolin phrobb regXboi
17:23:16 <regXboi> #agreed with no objections the TSC allows SFC into the Helium release
17:23:25 <regXboi> #topic TSC Charter Modifications
17:23:45 <phrobb> #link https://lists.opendaylight.org/pipermail/tsc/2014-May/001254.html
17:25:53 <regXboi> #info phrobb begins to explain the changes to the by laws and the TSC charter
17:26:14 <regXboi> #info these changes stemmed from the initial attempt to run an election of at-large committers
17:27:43 <regXboi> #info the TSC recommended that platinum members continue to be represented even if an at-large representative from the same platinum member company is elected
17:28:27 <regXboi> #info the board wanted to add language to remove the restriction at a particular point of time by the super majority of a board
17:29:02 <regXboi> #info so the process would be to first approve these changes to the bylaws and charter
17:29:35 <edwarnicke> regXboi: I think it was more "he board wanted to add language to remove the restriction at a particular point of time by the super majority of a board" so that it could be removed for this election.  The idea being that its the 'right' governance as is, but that we may take a little while to get there in terms of community growth.
17:29:40 <regXboi> #info and then the board would follow on by voting to remove the platinum member restriction for the purposes of this election
17:29:49 <regXboi> #chair edwarnicke
17:29:49 <odl_meetbot> Current chairs: ChrsPriceAB RobDolin edwarnicke phrobb regXboi
17:29:59 <edwarnicke> #question: Could we get the actual language before and after on the IRC channel?
17:30:00 <regXboi> edwarnicke: you can help :)
17:30:29 <RobDolin> #info Madhu asks if the at-large committers could potentially be from the same company
17:30:45 <edwarnicke> regXboi: Have I been chaired?
17:32:41 <RobDolin> #info Proposed amendments are attached to an email sent by probb@linuxfoundation.org on Mon, 5/19 around 3pm (USA Pacific time)
17:33:16 <dbainbri> so was the original restriction to prevent a single company to have much say on the TSC?
17:35:48 <regXboi> dbainbri: pretty much
17:36:32 <dbainbri> so if this was a concern originally, why is this no longer a concern?
17:37:29 <Madhu> dbainbri: good question :)
17:38:13 <regXboi> regXboi: the problem was that the original election failed because a lot of the nominees declined because of the step down provision of the language
17:38:27 <edwarnicke> dbainbri: Feel free to speak up on the call :)
17:39:50 <regXboi> #info dbainbri asked why this a concern
17:41:16 <regXboi> #info phrobb represents the original concern which was the at-large election didn't work
17:41:43 <regXboi> #info dbainbri asks why the restriction is not an issue anymore
17:42:07 <regXboi> #info phrobb explains more of the background (apologies, I can't keep up with the discussion)
17:42:19 * regXboi looks to the other chairs to help scribe!
17:43:51 <regXboi> #info phrobb explains that the waiver language was to avoid requiring changing the bylaws multiple times
17:45:17 <phrobb> I'm not hearing anything  did I lose you? or can no one hear?
17:45:30 <regXboi> phrobb: you may have dropped
17:45:53 <phrobb> I'm going to dial back in
17:45:55 <regXboi> #info kwatsen was concerned about how the original issues were rpesented
17:46:14 <regXboi> #info robdolin tries to explain how the original issues were voting
17:46:30 <dbainbri> phrobb: very hard to hear you
17:46:41 <tbachman> #info that was David Lenrow, not RobDolin, I think
17:47:13 <RobDolin> @TBachman Thanks :)
17:47:22 <tbachman> :)
17:47:23 <regXboi> #info phrobb points out that the language is set up to allow for the restriction to be removed on a case by case basis
17:47:59 <regXboi> #info kwatsen claims that is not the case - the language for an existing member stepping down has been removed
17:48:56 <RobDolin> <- Raises hand
17:48:56 <regXboi> #info phrobb agrees that the step down language needs to be reinstated
17:49:07 <regXboi> RobDolin: will get you in a second
17:49:17 <RobDolin> Thanks Ryan
17:49:47 <regXboi> #info RobDolin suggests that if we are not agreeing on language, we should break this out to a subcommittee
17:50:00 <regXboi> #info edwarnicke agrees this would be useful
17:51:24 <lenrow> Please tell me that languaging is not in the dictionary
17:52:08 <alagalah_> lenrow: lmgtfy.com
17:52:23 <alagalah_> :)
17:52:40 <regXboi> #info madhu asks where language about preventing at-large committers from the same platinum company
17:52:56 <regXboi> #info phrobb refers to section 4, buillet 3
17:53:01 <RobDolin> #info Phil Robb points-out that there is another section that suggests at-large seats must be from unaffiliated companies
17:53:04 <regXboi> #info bullet 3
17:53:39 <regXboi> #info edwarnicke points out that bullet 3 can be read to apply to the original election
17:54:44 <regXboi> #info dbainbri asked about affiliation
17:55:22 <regXboi> #info phrobb answer there is language (regXboi adds in that the language is in the by-laws)
17:57:57 <edwarnicke> #info Ed Warnicke suggests that we consider scoping the question to the languaging of previously agreed intent as a separate question from other questions being raised.
17:59:08 <edwarnicke> #info regXboi laughs hystericaly
17:59:21 * regXboi nice
18:00:08 <RobDolin> #info Subcommittee volunteers: Ed, Kent, Phil, Rob
18:00:18 <RobDolin> (And Ryan would volunteer if he had time)
18:00:32 <phrobb> #action edwarnicke RobDolin kwatsen phrobb to make a small committee to craft language edits in bylaws and tsc charter to bring back to tsc for further discussion at next week's tsc meeting
18:00:47 <RobDolin> #info Chris Price suggests we need to determine when the right of Platinum member to appoint expires
18:02:39 <RobDolin> #info Rob Dolin needs to drop off today's TSC ConCall and passes MSFT proxy to Ivan Wood
18:03:07 <edwarnicke> call dropped...be right back
18:03:14 <IvanWood> #info Ivan Wood
18:03:34 <regXboi> #info Vice Chair discussion will be deferred until dmm is back
18:04:34 <regXboi> #info kwatsen wants to split the two issues because while elections can close quickly, the VC discussion is still ongoing
18:04:53 <regXboi> #info phrobb says the language can be split if needed
18:05:13 <regXboi> #info edwarnicke distinctly remembers that the VC discussion is still open
18:05:32 <regXboi> #info phrobb says the VC language was also for review and to further discussion
18:06:30 <regXboi> #topic OpenDaylight Security Analysis
18:06:37 <regXboi> #link https://wiki.opendaylight.org/view/CrossProject:OpenDaylight_Security_Analysis
18:09:58 <regXboi> #info kwatsen asks w.r.t. load time signature checking, where will the private key be located?  what about 3P off-line projects looking to integrate
18:10:55 <regXboi> #info Madhu answers that signing can be done with various private keys and checked with public keys, with support for importing additional public keys for checking
18:12:03 <regXboi> #info edwarnicke states that he put some effort into figuring how to sign bundles that go into nexus and that's hard to do in a reasonable way.
18:12:10 <regXboi> #info Madhu asks to explain
18:12:32 <regXboi> #info edwarnicke points out that the jenkins build system has to sign the artifacts and that is non trivial
18:13:14 <phrobb> #info getting artifacts signed in jenkins in a secure and reliable way is non-trivial in an open source project and automated release processes
18:13:15 <regXboi> #info the problem is not with the mechanics of signing but with the opensource mechanics of signing
18:14:03 <regXboi> #info Madhu wants to sign the release bundles only before they are pushed into nexus
18:14:12 <regXboi> #info (I think that is)
18:18:17 <phrobb> #info regXboi notes that significant overhead may be added to the build/debug process with the addition signed bundles
18:20:18 <phrobb> #info regXboi notes "security is goodness", we need to manage the mechanics as to not add significant overhead or complexity to the developer community who doesn't know how this works
18:20:24 <regXboi> oops
18:20:50 <regXboi> apologies - I got cut off!
18:22:11 <phrobb> #info Madhu notes that SNAPSHOT creation would be done in with security turned off.  Bundle creation for end user consumption would include security/signing to give end user peace of mind in what they are running.
18:22:32 <regXboi> #info ken beck takes both sides of the discussion
18:22:44 <edwarnicke> regXboi: bring on the tomcat
18:23:02 <phrobb> #info, security also introduces bugs/errors adding complexity to the debug environment. This needs to be recognized as well.
18:23:04 <edwarnicke> I presume you mean the https stuff?
18:23:09 <regXboi> yep!
18:23:11 <edwarnicke> (the major changes stuff)
18:23:27 <edwarnicke> OK cool... your statement was kind of hyperbolic (and honestly... I am the last guy who can give you a hard time about hyperbolic)
18:24:12 <edwarnicke> *sigh*  I love Karaf... but we aren't there yet (and I have moved a lot of code to get us there)
18:24:54 <regXboi> #info discussion of karaf's remote management environment
18:25:09 <regXboi> #info madhu makes a point that some of these are available today
18:25:28 <regXboi> #info edwarnicke (personal statement) says that we aren't to karaf yet
18:25:49 <regXboi> #info madhu says we may need to enable the features in a non karaf enviro
18:26:13 <edwarnicke> #info edwarnicke also wants it noted he likes karaf and is (personal statement) supportive :)
18:26:28 <Madhu> #info +1s that :)
18:28:03 <edwarnicke> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Helium_Release_Plan - OFplugin has TLS support on its roadmap
18:28:55 <edwarnicke> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Candidate_RELEASE_Plan_2014 - as does OFjava
18:40:38 <regXboi> #info regXboi wants to thank the team for their effort - this is all *goodness* and the only question (in my mind) is how to get from here to there!
18:40:59 <regXboi> #topic helium simultaneous release logistics
18:41:10 * regXboi looks at edwarnicke
18:41:33 <phrobb> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Simultaneous_Release_Developer_Meetings
18:41:33 <regXboi> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Simultaneous_Release_Developer_Meetings
18:41:43 <regXboi> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Per_project_Simultaneous_Release_Contact
18:41:54 <regXboi> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Cross_Project_Milestone_and_Release_Candidate_Reporting
18:48:18 <regXboi> #info discussion between Madhu and edwarnicke about getting this to work
18:48:39 <regXboi> #info edwarnicke points to people implementing controller integration jobs
18:50:40 <LuisGomez> #info these are integration jobs that trigger a build in a project every time there is a merge in another project you depend on
18:50:40 <regXboi> #link https://wiki.opendaylight.org/view/GettingStarted:Jenkins_Integration_Job_Setup
18:51:36 <LuisGomez> #info this is very useful to find other projects issues
18:53:56 <phrobb> #endmeeting