17:00:28 <phrobb> #startmeeting TSC_Mtg_2014-06-19
17:00:28 <odl_meetbot> Meeting started Thu Jun 19 17:00:28 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:28 <odl_meetbot> The meeting name has been set to 'tsc_mtg_2014_06_19'
17:00:35 <IvanWood> #info Ivan Wood
17:00:39 <edwarnicke> #info Ed Warnicke
17:00:40 <dmm> #info dmm
17:00:43 <kwatsen> #info Kent Watsen
17:00:47 <regXboi> #info Ryan Moats (regXboi)
17:00:52 * tbachman notes dmm finally has good internetz :)
17:01:04 <ChrisPriceAB> Hi all, no audio today.  Will follow on IRC as best I can.
17:01:25 <ChrisPriceAB> #info Chris Price
17:02:08 <phrobb> #chair regXboi edwarnicke
17:02:08 <odl_meetbot> Current chairs: edwarnicke phrobb regXboi
17:02:26 <regXboi> #topic security response team reboot
17:03:07 <lenrow> #info Lenrow present
17:03:11 <regXboi> #info eawarnicke: there was no clear memory of the previous security response team
17:03:26 <regXboi> #info so we need a reboot
17:03:37 <GiovanniMeo> #info GiovanniMeo
17:04:56 <regXboi> #info request that folks that want to volunteer for the security response team should send email to phrobb
17:06:55 <regXboi> #action cdub gets the job of mocking up a security response page for ODL
17:07:09 <phrobb> #action along with edwarnicke and phrobb
17:07:22 <icbts> edwarnicke: Have a look at Apache’s process for CVEs http://www.apache.org/security/committers.html
17:07:37 <regXboi> #topic stable hydrogen release mechanics/logistics
17:07:54 <edwarnicke> #link  http://www.apache.org/security/committers.html - how apache does it, many thanks to icbts
17:09:04 <regXboi> #info GiovanniMeo is going through dry runs of the release mechanics, when it passes, it will be a switch flip to cut the real artifacts
17:09:34 <regXboi> #info request from edwarnicke to understand the mechanics because today, only a project could cut its own artifacts
17:11:21 <regXboi> #info GiovanniMeo the new release mechanics cuts artifacts into a staging area and from there they will be promoted into the separate areas
17:13:11 <regXboi> #info edwarnicke points out that since this is a change to the previous process of a project being the only thing that could publish artifacts, the TSC should be involved
17:13:36 <regXboi> #action GiovanniMeo agrees to send email to TSC when he's ready to go
17:13:56 <regXboi> #info edwarnicke now asks about how do we get to dates of the actual artifact cut...
17:15:45 <phrobb> #info regXboi notes email to all stable Hydrogen as next Tuesday as the date for release… but it hasn't gone out to a public list such as the "Discuss" list
17:16:04 <colindixon> somebody could chair me if they want help scribing
17:16:14 <phrobb> #info also suggested to put the notice out on the dev lists of projects involved
17:16:15 <regXboi> #action edwarnicke has the action item of sending the proposal of 6/24 as the stable-hydrogen date to -dev, discuss and tsc lists
17:16:26 <regXboi> #chair colindixon
17:16:26 <odl_meetbot> Current chairs: colindixon edwarnicke phrobb regXboi
17:16:27 <phrobb> #action edwarnicke takes the action to do both
17:16:54 <regXboi> #info question for luis on how long they will need for testing - that needs to be hashed out off line
17:16:55 * ChrisPriceAB applauds
17:16:57 <colindixon> phrobb: because actions appear at the bottom of the page w/o context, I usually like to put the actual action on the line just for posterity
17:17:21 * colindixon pokes his head up to look for Luis
17:17:22 <regXboi> #topic tsc charter update/modifications
17:17:34 * alagalah 300% made me lol
17:18:04 <kwatsen> #info CURRENT="If not otherwise represented, each Platinum member may designate a TSC member.  This is expected to be a temporary measure and will be re-evaluated by the Board every year.  Note that if a non-designated TSC member associated with a given Platinum member appears, the designated TSC member must step down immediately."
17:18:18 <kwatsen> #link http://www.opendaylight.org/project/tsc/charter
17:18:44 <kwatsen> #info PROP#1=CURRENT+", unless waived by a Super Majority vote of the Board prior to the precipitating event and for a specified amount of time, after which the designated TSC member must step down, unless the waiver is renewed."
17:19:30 <kwatsen> #info PROP#2=PROP#1+"In the case of elections, the commencement of the election is considered to be the precipitating event.  In the case of a project being promoted to core, the proposal from its committers to be promoted is considered the precipitating event."
17:19:44 <alagalah> What is a super majority ?
17:20:02 <colindixon> I was wondering the same thing
17:20:13 <regXboi> #info question: what is a super majority?
17:20:33 <regXboi> #info answer: the current by-laws state that a super majority is 2/3rds
17:20:48 <alagalah> Is there a filibuster option? (jk)
17:21:06 * regXboi goes and looks for the big club
17:22:39 <regXboi> #info discussion of what is a "precipitating event"
17:22:59 <colindixon> #link http://www.opendaylight.org/project/bylaws defines super majority in 4.10(b)
17:23:09 <regXboi> colindixon: thanks
17:23:51 <alagalah> +1 colindixon
17:24:02 <colindixon> regXboi: just let me know when/if you want me to pick up anything
17:24:19 <regXboi> colindixon: feel free to fix anything I type wrong
17:25:25 <regXboi> #action kwatsen to provide prop#1 and prop#2 as full text for review
17:26:05 <regXboi> #info point that a renewal will pierce the "veil of ignorance"
17:26:18 <regXboi> #topic committer promotions: dave tucker to ovsdb
17:26:37 <alagalah> +1000 on dave_tucker
17:27:52 <Madhu> #info Dave Tucker to be committer of OVSDB : https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-June/000481.html
17:28:20 <phrobb> #startvote shall the TSC accept Dave Tucker as committer on ovsdb? -1, 0, +1
17:28:20 <odl_meetbot> Begin voting on: shall the TSC accept Dave Tucker as committer on ovsdb? Valid vote options are -1, 0, +1.
17:28:20 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:28:28 <regXboi> #link https://lists.opendaylight.org/pipermail/ovsdb-dev/2014-June/000481.html for Dave Tucker to be committer of OVSDB
17:28:31 <dmm> #vote +1
17:28:33 <colindixon> thanks regXboi
17:28:34 <edwarnicke> #vote +1
17:28:37 <IvanWood> #vote +1
17:28:42 <lenrow> #vote +1
17:28:43 <regXboi> #vote +1
17:28:48 <kwatsen> #vote +1
17:28:57 <phrobb> #endvote
17:28:57 <odl_meetbot> Voted on "shall the TSC accept Dave Tucker as committer on ovsdb?" Results are
17:28:57 <odl_meetbot> +1 (6): lenrow, regXboi, dmm, edwarnicke, kwatsen, IvanWood
17:28:59 <edwarnicke> IvanWood: Are you holding a proxy for a TSC member?
17:29:08 <edwarnicke> (or am I otherwise confused ;) )
17:29:09 <regXboi> edwarnicke: yes
17:29:22 <edwarnicke> IvanWood: Who's proxy do you have?
17:29:23 <regXboi> IIRC, he's holding RobDolin's proxy
17:29:46 <IvanWood> Ed, yes for Rajeev Nagar (Microsoft)  Rob Dolin sent an email to TSC this morning
17:29:53 <regXboi> #agreed Dave Tucker as committer on ovsdb
17:30:21 <regXboi> #topic committer promotions: devin avery, tom pantelis, moiz raja to committer on controller
17:31:19 <regXboi> #link https://lists.opendaylight.org/pipermail/controller-dev/2014-June/005084.html proposal for these promotions
17:32:10 <colindixon> #info edwarnicke waxes poetic for a while :-)
17:32:17 <regXboi> lol
17:32:21 <alagalah> lol
17:32:38 <phrobb> #startvote shall the TSC accept Devin Avery as committers to the Controller project? -1, 0, +1
17:32:38 <odl_meetbot> Begin voting on: shall the TSC accept Devin Avery as committers to the Controller project? Valid vote options are -1, 0, +1.
17:32:38 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:32:43 <lenrow> #vote +1
17:32:44 <regXboi> #vote +1
17:32:44 <dmm> #vote +1
17:32:47 <edwarnicke> #vote +1
17:32:48 <IvanWood> #vote +1
17:32:50 <kwatsen> #vote +1
17:32:56 <ChrisPriceAB> #vote +1
17:32:58 <phrobb> #endvote
17:32:58 <odl_meetbot> Voted on "shall the TSC accept Devin Avery as committers to the Controller project?" Results are
17:32:58 <odl_meetbot> +1 (7): lenrow, regXboi, ChrisPriceAB, edwarnicke, dmm, kwatsen, IvanWood
17:33:06 <regXboi> #agreed Devin Avery to committer on controller
17:33:29 <edwarnicke> #info Congratulations to Devin Avery!
17:33:48 <phrobb> irc://irc.freenode.net:6667/#startvote shall the TSC accept Tom Pantelis as committers to the Controller project? -1, 0, +1
17:33:55 <dmm> #vote +1
17:33:58 <kwatsen> #vote +1
17:33:59 <lenrow> #vote +1
17:34:00 <IvanWood> #vote +1
17:34:05 <edwarnicke> #vote +1
17:34:09 <regXboi> #startvote shall the TSC accept Tom Pantelis as committers to the Controller project? -1, 0, +1
17:34:09 <odl_meetbot> Begin voting on: shall the TSC accept Tom Pantelis as committers to the Controller project? Valid vote options are -1, 0, +1.
17:34:09 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:34:10 <ChrisPriceAB> #vote +1
17:34:14 <edwarnicke> #vote +1
17:34:15 <regXboi> #vote +1
17:34:19 <lenrow> #vote +1
17:34:21 <dmm> #vote +1
17:34:23 <kwatsen> #vote +1
17:34:25 <IvanWood> #vote +1
17:34:28 <regXboi> #endvote
17:34:28 <odl_meetbot> Voted on "shall the TSC accept Tom Pantelis as committers to the Controller project?" Results are
17:34:28 <odl_meetbot> +1 (7): lenrow, regXboi, ChrisPriceAB, edwarnicke, dmm, kwatsen, IvanWood
17:34:37 <alagalah> dmm funny
17:34:38 <regXboi> #agreed Tom Pantelis as committers to the Controller project
17:34:43 <edwarnicke> #info Congratulations Tom Pantelis! :)
17:35:06 <regXboi> #startvote shall the TSC accept Moiz Raja as committer on the Controller Project? -1, 0, +1
17:35:06 <odl_meetbot> Begin voting on: shall the TSC accept Moiz Raja as committer on the Controller Project? Valid vote options are -1, 0, +1.
17:35:06 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:35:09 <lenrow> #vote +1
17:35:13 <edwarnicke> #vote +1
17:35:15 <regXboi> #vote +1
17:35:16 <kwatsen> #vote +1
17:35:17 <dmm> #vote +1
17:35:19 <IvanWood> #vote +1
17:35:25 <regXboi> #endvote
17:35:25 <odl_meetbot> Voted on "shall the TSC accept Moiz Raja as committer on the Controller Project?" Results are
17:35:25 <odl_meetbot> +1 (6): lenrow, regXboi, dmm, edwarnicke, kwatsen, IvanWood
17:35:27 <ChrisPriceAB> #vote +1
17:35:34 <regXboi> sorry ChrisPrice
17:35:35 <phrobb> #endvote
17:35:45 <regXboi> #agreed Moiz Raja as committer on the Controller Project
17:35:47 <lenrow> Congrats to all our new committers and thanks for your hard work
17:35:53 <edwarnicke> #info Congratulations to Moiz Raja! :)
17:35:53 <phrobb> looks like regxboi might need to endvote
17:35:54 * ChrisPriceAB hard to get the timing right without audio triggers. :)
17:36:00 <regXboi> it's already done
17:36:04 <phrobb> h
17:36:06 <phrobb> ah
17:36:14 <regXboi> #topic TSC management approach/style
17:37:38 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2014-June/002832.html the first mail in the related thread on discuss
17:38:24 <regXboi> colindixon: I give you the pen
17:38:33 <regXboi> I'm going to be talking
17:38:35 <regXboi> :)
17:39:47 <colindixon> #info lenrow (dave lenrow) comments that lots of people have pointed out that the TSC has generally taken a hands off approach to technical/architectural issues and some would like to see that be less hands off
17:40:37 * ChrisPriceAB is that in reference to the TSC members, or the formal TSC body?
17:41:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-June/001304.html this appears to be the right email https://lists.opendaylight.org/pipermail/tsc/2014-June/001304.html
17:41:30 <regXboi> ChrisPriceAB: this is for the TSC body and that's the right link now
17:41:45 <colindixon> ChrisPriceAB: that’s the thing he’s sharing via webex (ending 1304.html)
17:42:04 <regXboi> #info dmm: this needs to be discussed further on the list
17:42:11 <phrobb> lenrow:  had to put you on mute… feedback
17:42:48 <colindixon> #info lenrow asks if we want to consider having release requirements which can be used as a way to have a lever to lead/control technical and architectural issues
17:43:12 <regXboi> #info kwatsen points that best practices are within scope and so having a wiki page would be good
17:43:40 <regXboi> #info dmm there is an end user advisory council is being worked on now
17:43:52 <regXboi> #info dmm the projects are already use cases
17:44:15 <rovarga> so the infrastructure underlying the the controller/distribution has no usecases, really
17:45:07 <dmm> #info not all of the projects are use cases, but some of them are
17:45:51 <ChrisPriceAB> #info a significant shift will occur in the TSC operation as we promote technical leads and committers into the council.  I'm not sure a requirement spec will solve anything.
17:46:26 <phrobb> #info regXboi notes that this topic has optics.  For a mature community where the tsc is PTL of core projects, then the TSC for the next release can clearly articulate what is the target.  regXboi asks how much of this is because the project is still imature?
17:46:30 <edwarnicke> #info controller has responded to use cases brought to it from other project (example: GBP requirements on scale and performance for clustering)
17:46:35 <regXboi> ChrisPrice: I was saying that on the call now
17:46:51 <ChrisPriceAB> #info additionally I do agree the integration project should set (with guidance of the TSC) delivery quality metrics to be achieved to be considered releasable.
17:47:55 <phrobb> #info edwarnicke notes that the controller project have responded to GBP and OVSDB project requests on controller.
17:47:59 <rexpugh-HP> Use cases don t necessarily guide architecural goals or principles
17:48:16 <edwarnicke> #info openflowplugin has been working closely with ovsdb on meeting their requirements
17:48:16 <colindixon> I’ve lost track of why we’re talking about this
17:49:24 * ChrisPriceAB release quality & evolution I suppose
17:49:46 <rexpugh-HP> Teh intent is also to create goals and criteria for the release, stabiliyt, quality, defect density, performance, scale etc
17:50:02 <phrobb> #topic Meeting our commitments to the community re:Helium
17:50:02 <colindixon> #topic meeting community commitments in Helium
17:51:30 <colindixon> #info edwarnicke one example is that we could ask the community for ways we could improve the release process, e.g., milestones, and figure out what we could do better rather than copying and pasting
17:51:46 <phrobb> #info edwarnicke asks are there more questions we should be asking the community re the plan for Lithium?  Is a larger gap between release and M0 needed?  If so, what would be done then, etc
17:53:46 <colindixon> #info edwarnicke’s core comment is that we should ask “what could we have done better?” and could we work through them because it’s unlikely we got it all right on the first try
17:54:15 <phrobb> #info foresight for planning is needed for the dev community.  We (the TSC) hasn't yet analyzed the milestones, their length, etc, for the best release cycle
17:54:49 <colindixon> #action regXboi will send a mail to the list starting the discussion about how we might change the release process to better serve the community (starting with lithium)
17:55:07 <colindixon> #topic Things we could add to the creation review template to allow for smoother on boarding of projects
17:56:29 <colindixon> #info edwarnicke (and regXboi and tykeal) have held a lot of people’s hands as they got projects up and running, and tykeal suggested that there could be correct information in the creation review template that would ease things, e.g., initial committer lists should include their ODL user name
17:56:33 <ChrisPriceAB> #info first target simultaneous release project might be something to add.  current assption is "next release" which may not be true.
17:56:35 <phrobb> #info The initial committers of projects sometimes don't have an account on the system and/or their emails did not match accounts in the build system
17:56:47 <colindixon> +1 to this suggestion
17:56:55 <colindixon> (as a non-TSC member)
17:57:05 <phrobb> #info the ask is that committers for projects document their account and email on the project proposal page
17:57:56 <phrobb> #info dmm asks are there more items that can make the onboarding process go smoothly
17:57:57 * ChrisPriceAB I have found IRC handles useful also during the recent creation sequences.
17:58:41 <phrobb> #info regXboi suggests that we ask new opboarding committers and projects what went well, what didn't so that we can continue to refine the onboarding process
17:59:16 <phrobb> #action	regXboi to update the project proposal page with the account and email data for committers
18:02:50 <phrobb> #topic Lithium Release Logistics
18:02:58 <colindixon_> thanks phrobb I think I lost IRC for a bit
18:03:57 <colindixon_> #action regXboi will propose release vehicles for lithium to the discuss list
18:04:03 <phrobb> #info regXboi notes that there are commitments of the TSC for planning the Lithium release that need to be done
18:05:00 <colindixon_> #info edwarnicke points out one good thing to keep in mind is that in hydrogen and helium we found a good, happy place for every project
18:05:21 <colindixon_> #topic things for next week
18:05:34 <colindixon_> nm
18:05:42 <regXboi> colindixon_: thanks :)
18:06:09 <colindixon_> +1 to keeping as an hour
18:06:20 <colindixon_> thanks everyone
18:06:23 <LuisGomez> #info regarding initial question on test time for stable release, it will be < 1 hour (it is all automated)
18:06:29 <phrobb> #endmeeting