17:01:29 <phrobb> #startmeeting TSC Weekly Meeting
17:01:29 <odl_meetbot> Meeting started Thu Jun  5 17:01:29 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:29 <odl_meetbot> The meeting name has been set to 'tsc_weekly_meeting'
17:01:39 <edwarnicke> dbainbri: +10000
17:01:44 <regXboi> #info regXboi
17:01:47 <edwarnicke> #info Ed Warnicke
17:02:03 <kwatsen> #info Kent Watsen
17:02:12 <regXboi> #info dmm is on phone, not on IRC
17:02:15 <phrobb> #chair regXboi edwarnicke
17:02:15 <odl_meetbot> Current chairs: edwarnicke phrobb regXboi
17:02:19 <dbainbri> #info David Bainbridge
17:02:36 <regXboi> #info now recording
17:02:38 <edwarnicke> #link https://meetings.webex.com/collabs/meetings/join?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB - webex
17:02:43 <regXboi> #topic agenda bashing
17:03:24 <regXboi> #info light meeting - aiming to end after 60 minutes today
17:03:55 <cdub> #info chris wright
17:04:06 <regXboi> #info TSC Charter Update pushed to next week: no update
17:04:35 * cdub isn't on phone yet
17:04:35 <regXboi> #topic network management using hierarchical domains
17:04:48 <regXboi> #link http://www.google.com/patents/US8078707
17:05:21 <regXboi> #undo
17:05:21 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x250e0d0>
17:05:25 <regXboi> #undo
17:05:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x26234d0>
17:06:19 <regXboi> #info question about programming languages? answer: kept to more general architectural discussions
17:06:35 <regXboi> #topic network management using hierarchical domains patent
17:06:44 <regXboi> #link http://www.google.com/patents/US8078707
17:07:45 <regXboi> #info kwatsen is declaring potential IPR here
17:08:21 <regXboi> #info proposal is for the LF's counsel to look at this to see how it impacts the project
17:08:59 <regXboi> #info edwarnicke discusses the difference between ietf and ODL and how this declaration is a really *good* thing
17:09:02 <RobDolin> #info Rob Dolin proxy for Rajeev Nagar (Microsoft)
17:09:05 <phrobb> #action phrobb to discuss patent and it's impact on ODL development
17:10:48 <regXboi> #info lenrow asks what to do about proceeding
17:11:04 <regXboi> #info dmm's personal opinion is to keep on keeping on
17:11:22 <regXboi> #info regXboi +1's that
17:11:33 <edwarnicke> #info edwarnicke +1
17:11:48 <regXboi> #info lenrow +1
17:11:54 <phrobb> #chair robdolin
17:11:54 <odl_meetbot> Current chairs: edwarnicke phrobb regXboi robdolin
17:12:34 <regXboi> #topic OF-1.3 AD-SAL plugin
17:12:40 <regXboi> #link https://lists.opendaylight.org/pipermail/discuss/2014-June/002801.html
17:13:51 <regXboi> #info the question from dmm is what type of oversight should the TSC provide
17:16:00 <dbainbri> #raise hand
17:16:11 <phrobb> #info regXboi notes that this is open source and if someone wants to write and AD-SAL support for OF1.3, then it will happen
17:18:50 <lenrow> OF 1.3 ADSAL: This is the "user space" openflow driver?
17:19:24 <cdub> lenrow: it's openflowj w/ 1.3 support connected to adsal interface
17:19:34 <lenrow> understand
17:19:34 <cdub> lenrow: not sure what "user space" means here?
17:19:43 <lenrow> Was suggesting analogy..
17:20:26 <cdub> #info adsal of1.3 grew out of sdn hub desire to make odl accessible to application developers (e.g. base for hackfest activities)
17:20:50 <cdub> lenrow: i don't think analogy holds
17:21:29 <cdub> lenrow: more like 2 implementations of both interface and driver
17:21:49 * lenrow OK
17:23:07 <regXboi> phrobb: grabbing the pen back :)
17:23:13 <phrobb> #info edwarnicke would like to have a focused effort on MD-SAL painpoints to make them better
17:23:33 <edwarnicke> apologies for dbainbri for talking before he got to talk
17:23:54 <regXboi> #info dbainbri points out that while there are things that let the resources flow where they may, but other things where there needs to be direction
17:24:01 <lenrow> +1 SAL is mission/critical
17:24:37 <regXboi> #info dbainbri says SAL is something where there needs to be direction
17:25:06 <lenrow> separate question from whether TSC has authority to mandate anything
17:25:50 <regXboi> #info mlemay gives a +1
17:26:20 <phrobb> #dbainbri understands that "code follows interest", etc but for core plumbing, it is confusing and drives people away if there are ongoing multiple different methods of doing things
17:26:58 <cdub> #info relevant TSC Charter: "the TSC is responsible for simultaneous release dates, release quality standards,  technical best practices (including the Development Process), monitoring technical progress, mediating technical conflicts between Committers and project leads, and organizing inter-project collaboration."
17:27:04 <cdub> lenrow: ^^
17:27:35 <lenrow> cdub: I need to do homework on that doc...
17:27:38 <dbainbri> I would say the MD-SAL could be considered in the technical best practice area.
17:28:02 <phrobb> #info dmm suggests that we need to find consensus what the long term direction for core functions are and if people want to work on that, they will, but if others want to pursue a different path, they can
17:28:47 <cdub> we have latitude to express best practice and inter-project collaboration (sal is inter-project)
17:29:27 <lenrow> cdub: Express == mandate? suggest? suggest firmly? With extreme prejudice?
17:29:47 <cdub> i'd say latter firmly or with extreme prejudice
17:30:23 <cdub> mandate is within scope, but only from the "what we release"
17:31:08 <lenrow> cdub: that's the "hook" that enables strong steering. Thanks!
17:34:14 <phrobb> #info dmm and regXboi note that currently the ADSAL and MDSAL are better at different tasks
17:36:58 <lenrow> topic for this call: What actual remedies are "in scope" for TSC (strong) steering?
17:37:17 <regXboi> lenrow: dmm isn't on the IRC
17:37:18 <phrobb> #info Madhu notes that ADSAL is easier to use for app-type devs and the MDSAL is richer and more appealing to core ODL developers
17:37:24 <regXboi> so you'll have to bring that up on the call
17:38:24 <regXboi> #info lenrow wants to understand what actual remedies are "in scope" for TSC strong steering?  i.e. when should the TSC mandate...
17:38:35 <phrobb> #info Lenrow asks for a TSC topic of "what guidance the TSC can or cannot give to the community"
17:39:25 <regXboi> who is that?
17:40:18 <cdub> regXboi: Thomas Kee (pcmm dev)
17:40:50 <regXboi> #info thomas kee describing his experience with doing a PoC in AD-SAL and then moving to MD-SAL
17:41:26 <regXboi> #action continue this discussion on the mailing list for another week because no consensus has emerged.
17:41:57 <phrobb> #info dmm notes that there is no clear consensus on this topic, so more discussion on the list is needed
17:42:42 <phrobb> #info dbainbri asks can we get to consensus with just more discussion on the list?  How can we drive to closure?
17:43:00 <cdub> phrobb: you mean clojure?
17:43:03 * cdub ducks
17:43:18 * mlemay_ laughs
17:43:20 <phrobb> #info :-)
17:44:00 <edwarnicke> cdub: I am not sure I agree with introducing clojure into the TSC ;)
17:44:02 <phrobb> cdub: .. it is very late/early here… not sure what I mean to type :-)
17:44:16 * regXboi glares at cdub
17:44:24 <cdub> phrobb: ugh, right...tz trouble
17:44:29 <dbainbri> if we don't come to clojure, it may become a complete haskel (wow that was bad)
17:44:40 <cdub> dbainbri: heh ;)
17:44:44 <edwarnicke> dbainbri: That comment my be functional, but perhaps less than helpful ;)
17:44:45 <phrobb> lol
17:44:53 * regXboi looks for sharp objects to start throwing at puns
17:45:32 <edwarnicke> regXboi: C# objects?
17:45:45 * regXboi goes running screaming into the night
17:46:01 <dbainbri> he needs a "swift" response.
17:46:13 * phrobb tosses regXboi a floodlight
17:46:20 <edwarnicke> dbainbri: And I though you were Objective ;)
17:46:26 <tbachman> OMG
17:46:38 <tbachman> lol
17:46:43 <dbainbri> sorry this list of puns is getting to, er, lang (long)
17:47:16 <regXboi> ok... I give
17:47:32 <regXboi> we need to go forth and deal with the confusing cobol - ds
17:48:10 <phrobb> #info all recognize that MDSAL is very complex for new app devs wanting to build something for ODL
17:50:22 <Madhu> +1 cdub
17:50:29 <phrobb> #info cdub notes that we have incubated code and that is what we are releasing and we should consider the release process and what we (the TSC) recommend what goes into them
17:52:29 <Madhu> omg. i missed the nerd puns as well. But perfect for this discussion :)
17:52:48 <Madhu> great job cdub dbainbri edwarnicke regXboi . had a good laugh.
17:53:39 <regXboi> madhu: the were all pretty basic
17:53:55 <Madhu> regXboi: there u go.. u too :) didn't expect that from u
17:54:09 <Madhu> oh my god.. did i just say "expect"
17:54:23 <regXboi> oh no, I'm an incorrigible punster (do not incorrige :) )
17:55:43 <dbainbri> while all these puns are pure bliss i do have to go to another meeting now, i shell return if i can, but will keep quiet as don't want to bash anyone ...
17:56:08 <cdub> going downhill
17:56:36 <phrobb> #info dmm suggests getting people together for release-guidelines (possibly for post Helium or later) to explore what those guidelines would be
17:56:53 <Madhu> dbainbri: C ya ;)
17:57:24 <cdub> we are not the TSC, we are the TRSC
17:57:41 <cdub> s/steering/rubber stamping/
17:57:45 <tbachman> We have a rich language to work from: http://en.wikipedia.org/wiki/List_of_programming_languages
17:57:55 <tbachman> Pun-away ;)
17:58:09 <kwatsen> cdub: yes, that's how it seems to me
17:58:33 * regXboi awks
17:58:50 <phrobb> #endmeeting