17:04:06 <phrobb> #startmeeting TWS
17:04:06 <odl_meetbot> Meeting started Mon Jul 14 17:04:06 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:06 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:06 <odl_meetbot> The meeting name has been set to 'tws'
17:04:23 <phrobb> #chair colindixon
17:04:23 <odl_meetbot> Current chairs: colindixon phrobb
17:10:39 * icbts I’m here, just a bit slow today (spent last night with my father in emergency ward for kidney stones)
17:11:01 <phrobb> #link https://wiki.opendaylight.org/view/CrossProject:Helium_Release_Vehicle_Brainstorming:Pure_Karaf
17:13:15 <phrobb> #link https://lists.opendaylight.org/pipermail/discuss/2014-July/003142.html
17:13:54 <phrobb> #info the two links are the Karaf Brainstorming and the email from Luis G. on Testing needs for Karaf Release of ODL
17:14:38 <icbts> #link https://wiki.opendaylight.org/view/CrossProject:Helium_Release_Vehicle_Brainstorming:Pure_Karaf#Testing_Strategy
17:14:42 <icbts> strategy sample
17:14:48 <phrobb> #info do we have PAX-EXAM templates?… Yes we do
17:15:08 <phrobb> #chair icbts
17:15:08 <odl_meetbot> Current chairs: colindixon icbts phrobb
17:17:52 <phrobb> Karaf also accomodates linux specific pkging for rpms etc
17:18:39 <phrobb> Q: Jan asks "what is the ETA for the karaf distribuions, and what are the deliverables?
17:20:06 <phrobb> A: most of the feature files are there, a few bugs in the code for karaf based container… JMX needs to be fixed, it will be an hour or so fix.. Otherwise all of the patches are in.
17:21:25 <phrobb> A: for ETA… "all the patches do exist, it is a matter of testing"…  Mathieu wants to run toaster and ovsdb testing before  confidence is high
17:30:38 <phrobb> LuisGomez:  does mlemay think feature defintion and testing can be defined by M4?
17:31:16 <phrobb> #mlemay believes that it is possible but there is some unknowns on projects that mlemay is less familiar with
17:32:08 <phrobb> #info even for small projects will mlemay help them one by one, or some other way?… mlemay is expecting  to do it one by one
17:33:39 <phrobb> #action mlemay and phrobb to contact each project for offering help in getting karaf set up for them… mlemay to provide a skeleton feature patch and pax-exam setup for each project
17:35:45 <phrobb> #info Q;  to come up with a feature template, we need to know the dependencies?  Bundle-level dependency vs feature-level dependency.  For karaf, we need to understand the feature dependencies.
17:36:20 <phrobb> #info Need to get tooling to help with cross-project dependencies beyond what we have now
17:37:21 <phrobb> #info one of the hardest parts thus far has been to understand and document all of the dependencies… there are 35 to 40 features defined within the controller currently
17:41:53 <phrobb> #info Q;  What will the interface look like when the user cherrypicks the features they want?… A: there are a few ways to do it; there is online/offline, there is a dlux interface (for features within controller), define a config profile, etc.
17:42:42 <phrobb> #info, two distinctions:  What is installed, vs what is available to be installed
17:43:18 <phrobb> #info having a stablility-based repo would also be very advantageous… stable, unstable, experimental, etc…
17:44:03 <phrobb> #info mlemay notes having a stability lifecycle for each feature would b every helpful
17:45:09 <phrobb> #info Conflicting feature testing… for ones already known, the projects can define.  Integration testing with putting everything together will find [many] more conflicting issues.
17:46:02 <phrobb> #info conflict mgmt will be managed by adding metadata to each feature to call out learned conflicts
17:46:54 <phrobb> #info luis proposes a weekly update on Karaf progress
17:48:27 <phrobb> #info Brent asks that we have a weekly Karaf sync at the TWS meeting
17:53:19 <phrobb> #info there has been a change in how OF1.0 and OF1.3 are specified in the run.sh file.  For Helium, OF1.3 is the default.  If you want OF1.0, then you must specify of1.0 on the run.sh CLI
18:03:07 <phrobb> #endmeeting