#opendaylight-meeting: TWS

Meeting started by phrobb at 17:01:23 UTC (full logs).

Meeting summary

  1. agenda (colindixon, 17:03:32)
    1. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main the agenda can be found here (colindixon, 17:03:58)
    2. we’re moving to a new model where we’re trying to post topics on that link and pick one by end of the meeting, you should look at them or add ones that you’d like (preferably with you name and a time estimate) (colindixon, 17:06:08)

  2. testing for projects in helium (colindixon, 17:06:20)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations#Testing this is the curent landing page for testing expecations for each project in Helium (colindixon, 17:07:26)
    2. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Testopia some documentation on Testopia which enables interaction with bugzilla (colindixon, 17:09:30)
    3. https://bugs.opendaylight.org/ to access testopia go here, log in and then go to the “product dashboard” on the left (colindixon, 17:10:34)
    4. you can then expand “Unclassified” and click on “integration” and then “test plans” to see the example which LuisGomez has set up (colindixon, 17:11:38)
    5. each project *should* create tests for every feature they’re providing (colindixon, 17:13:01)
    6. you can create a new test plan (with lots of different types, e.g., system, performance, integration) by going to File => New Test Plan (colindixon, 17:15:58)
    7. each test plan have have multiple test cases, to see them you can click on the number (ID) of the test plan and then click on the test cases tab in the detail page for the plan (colindixon, 17:16:42)
    8. Testopia is actually just a way to document the test plans and cases rather than to automate testing (colindixon, 17:19:43)
    9. colindixon asks if there is a plan to automate the system testing (colindixon, 17:22:02)
    10. LuisGomez responds that the usual way to (1) document the test process, (2) manually go through the test, (3) then automate the test (colindixon, 17:22:53)
    11. Madhu asks about the Test Runs and Builds tabs (colindixon, 17:23:06)
    12. LuisGomez explains that Test Runs is for reporing a single execution (manual or automated) from a Test Plan (colindixon, 17:23:52)
    13. Madhu says he *really* likes the real-time feedback from the jenkins pattern we have now, and wonders how useful some documentation-only tool like Testopia is (colindixon, 17:27:35)
    14. there is a long discussion about how to automate this testing so that we can have things stay more in-sync (colindixon, 17:36:44)
    15. regXboi also asks how to spin up and down VMs to do more extensive testing and can we deal with that (colindixon, 17:37:41)
    16. tykeal says that with the exception of three projects (integration, ovsdb, and controller) we have all projects fully moved into rackspace (colindixon, 17:38:48)
    17. that means that projects other than those can actually be given the ability to spin up and down VMs as part of tests (colindixon, 17:39:13)
    18. http://www.rackspace.com/blog/installing-rackspace-private-cloud-in-20-minutes-or-less/ - rackspace seems to detail installing an Ubuntu image... (edwarnicke, 17:39:24)
    19. tykeal says that if people reach out to the linux foundation and let them know what you need from VMs (colindixon, 17:41:19)
    20. : This may also help: https://developer.rackspace.com/blog/vagrant-now-supports-rackspace-open-cloud/ (edwarnicke, 17:41:35)
    21. migrating VMs into rackspace is error prone and booting custom VMs seems to take a long time in the linux foundations experience (colindixon, 17:44:41)
    22. ACTION: some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace (colindixon, 17:45:29)
    23. colindixon asks LuisGomez what *exactly* the integration project is asking the other projects to do? (colindixon, 17:46:40)
    24. Luis and Integration team need two things: 1 - need documentation from projects for what they are doing for own unit and integration tests. Second, for those projects that want something in System test, they need to work with the Integration project to document the test plan for the project within a system test. (phrobb, 17:47:28)

  3. the integration project’s requests from other projects (colindixon, 17:52:10)
    1. there are two requests (colindixon, 17:52:19)
    2. something like this : http://maven.apache.org/surefire/maven-surefire-report-plugin/usage.html (Madhu, 17:52:58)
    3. the first is that projects need to document the existing tests they run in a place that integration can easily find without having to go through each project individually (colindixon, 17:53:31)
    4. the second is that projects that want tests to be run when their features are loaded into a full distribution need to reach out to integration to talk about the tests (colindixon, 17:54:10)
    5. ACTION: LuisGomez and Madhu to come up with good way for projects to provide useful docuementation of their testing to the integration project (colindixon, 17:57:45)

  4. (colindixon, 17:57:52)
  5. other issues in testing (colindixon, 17:57:59)
    1. ACTION: edwarnicke to send out an email around his wants/needs when it comes to combined reporting of test health from all projects (colindixon, 17:58:41)


Meeting ended at 18:06:03 UTC (full logs).

Action items

  1. some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace
  2. LuisGomez and Madhu to come up with good way for projects to provide useful docuementation of their testing to the integration project
  3. edwarnicke to send out an email around his wants/needs when it comes to combined reporting of test health from all projects


Action items, by person

  1. edwarnicke
    1. some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace
    2. edwarnicke to send out an email around his wants/needs when it comes to combined reporting of test health from all projects
  2. Madhu
    1. some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace
    2. LuisGomez and Madhu to come up with good way for projects to provide useful docuementation of their testing to the integration project
  3. regXboi
    1. some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace
  4. tykeal
    1. some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace


People present (lines said)

  1. colindixon (37)
  2. regXboi (9)
  3. phrobb (6)
  4. odl_meetbot (5)
  5. Madhu (4)
  6. tykeal (2)
  7. tbachman (2)
  8. edwarnicke (2)
  9. CASP3R (2)


Generated by MeetBot 0.1.4.