17:00:56 <colindixon> #startmeeting tws
17:00:56 <odl_meetbot> Meeting started Mon Aug 11 17:00:56 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:56 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:56 <odl_meetbot> The meeting name has been set to 'tws'
17:01:01 <colindixon> #topic agenda bashing
17:01:33 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Upcoming_Meeting_Agendas today’s agenda
17:02:25 <colindixon> #chair Madhu
17:02:25 <odl_meetbot> Current chairs: Madhu colindixon
17:05:45 <Madhu> #topic IT good practices followed in OVSDB project
17:05:51 <hideyuki> #link https://wiki.opendaylight.org/view/OVSDB:Continuous_Integration
17:05:57 <Madhu> #link https://wiki.opendaylight.org/view/OVSDB:Continuous_Integration overview of the CI
17:07:28 <Madhu> #link https://jenkins.opendaylight.org/ovsdb/job/ovsdb-ovs-integration/ is a multi-configuration matrix jenkins job
17:07:40 <colindixon> #info right now ovsdb runs ovsdb-verify and ovsdb-ovs-integration whenever a patch is submitted
17:08:00 <Madhu> #link the above ovsdb-ovs-integration job is used as verify job to run every commit across various versions of OVS
17:08:41 <Madhu> #link https://github.com/dave-tucker/docker-ovs the Optimized Docker container with OVS user-space mode
17:09:05 <Madhu> #link with this user-space OVS, we are able to run many many OVS versions in a single VM.
17:09:11 <Madhu> #undo
17:09:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x26214d0>
17:09:18 <Madhu> #info with this user-space OVS, we are able to run many many OVS versions in a single VM.
17:09:41 <tbachman> #info yes, that’s ~30MB in size :)
17:09:54 <Madhu> #link http://buildroot.uclibc.org/ is used to build a super-optimized for our use-case.
17:10:20 <Madhu> #info the super-optimized user-space OVS is between 26MB - 35MB
17:11:33 <Madhu> #info multi-configuration matrix jenkins job will run every version of OVS version configured for
17:12:01 <Madhu> #link https://jenkins.opendaylight.org/ovsdb/job/ovsdb-ovs-full-integration-daily/ runs daily and we test across 16 versions of OVS
17:17:36 <colindixon> #info the key way to adopt this is to start figuring out how to build your own optimized docker images for things you need
17:18:04 <colindixon> #info it took dave_tucker and Madhu two weeks or so to get their OVS docker image up, working and minified
17:20:03 <colindixon> #info dave_tucker says that docker works best with things that have 2-3 processes (not many more)
17:20:20 <colindixon> #info for things with more processes, using a vagrat VM is more useful
17:20:24 <colindixon> #topic sonar job
17:20:51 <colindixon> #info this runs on code being mreged (alongside the normal merge job)
17:21:00 <Madhu> #link https://jenkins.opendaylight.org/ovsdb/job/ovsdb-code-coverage/ ovsdb code-coverage job
17:21:59 <Madhu> #lilnk https://sonar.opendaylight.org/dashboard/index/14975?did=1 ovsdb sonar coverage
17:23:02 <Madhu> #info Sonar overall-reporting is misleading because it doesn't include IT coverage if the bundle dent do UT
17:23:34 <Madhu> #link https://git.opendaylight.org/gerrit/gitweb?p=ovsdb.git;a=blob;f=commons/parent/pom.xml;h=2e7805d5f90afb7f2af54f055ab6f9204fbff787;hb=refs/heads/master OVSDB pom.xml which takes care of all the required UT, IT and jacoco configuration
17:24:15 <Madhu> #link https://git.opendaylight.org/gerrit/#/c/9482/2 Fix for including PAX-Exam in Sonar Coverage
17:25:01 <Madhu> #link the issue with PAX-Exam coverage issue was due to the missing common base coverage directory
17:25:33 <colindixon> #info part of getting accurate sonar code coverage is specifying some extra parameters, e.g., specifying the root directory to be able to catch the cross-bundle code coverage from integration tests
17:26:30 <Madhu> #info jacoco maven plugin that is used for code-coverage reports
17:27:19 <Madhu> #info Sonar reports both the IT test-cases and UT Test-cases under the UT coverage
17:27:31 <colindixon> #info some configuation of jacoco for specifiy the report file and the append=true part
17:28:31 <colindixon> #info to get IT results in the same place as UT, you need a configuration from the failsafe plugin to put the report in the same place as surefire-reports
17:29:17 <Madhu> #info We are running Sonar 4.3.2
17:30:41 <colindixon> Madhu: I’ll let you #link that in
17:31:05 <Madhu> #link https://github.com/dave-tucker/sonar-vagrantbox Sonar lite version
17:32:26 <colindixon> #Info somebody asks whether you need sonar? dave_tucker says that you get a report, but it’s harder to interpret them without help
17:33:07 <Madhu> #info though surefire reports are useful
17:33:11 <Madhu> #undo
17:33:11 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2739550>
17:33:38 <Madhu> #info though surefire reports are useful, Sonar does a good job in aggregating the reports and provide a much better coverage report and details
17:33:56 <tbachman> was this meeting recorded?
17:34:00 <tbachman> (is)
17:34:01 <colindixon> tbachman: yes
17:34:03 <colindixon> it is
17:34:05 <tbachman> nice :)(
17:34:06 <tbachman> :)
17:34:07 <tbachman> thx
17:34:13 <colindixon> at least Madhu said it was :p
17:34:24 <Madhu> yes
17:34:38 <Madhu> #topic Test Documentation
17:34:57 <Madhu> #info Integration project team was looking for test case documentation from each project.
17:35:31 <Madhu> #info Testopia is certainly an option. But it doesn't follow the Code closely. So we agreed on using Javadoc
17:37:18 <colindixon> #info right now, the ovsdb team documents the tests in the code whereyou can see them from the sonar screen
17:38:34 <Madhu> #info we can do inline Javadoc for the tests so that Integration team and others can understand what each test case is covering
17:38:41 <colindixon> #info in the future, the hope is to be able to add a javadoc tab in sonar that provides just documentation
17:51:15 <colindixon> https://wiki.opendaylight.org/view/Tech_Work_Stream:Main
17:52:37 <colindixon> #action colindixon to document how to easily enable checkstyle for your project/bundle
17:55:42 <Madhu> #info please let us know if you are interested in hearing about any specific topic
17:55:44 <Madhu> #endmeeting