17:01:58 <regXboi> #startmeeting TWS Call
17:01:58 <odl_meetbot> Meeting started Mon Jun  2 17:01:58 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:58 <odl_meetbot> The meeting name has been set to 'tws_call'
17:02:07 <regXboi> #chair Madhu
17:02:07 <odl_meetbot> Current chairs: Madhu regXboi
17:02:57 <regXboi> #chair networkstatic
17:02:57 <odl_meetbot> Current chairs: Madhu networkstatic regXboi
17:03:02 * tbachman raises hand
17:03:06 <Madhu> #topic Karaf in OpenDaylight & Hands-On demo on developing ODL components for Karaf Runtime - Mathieu Lemay
17:03:08 <regXboi> #chair tbachman
17:03:08 <odl_meetbot> Current chairs: Madhu networkstatic regXboi tbachman
17:03:09 <tbachman> (to volunteer)
17:03:10 <tbachman> :)
17:04:48 <regXboi> #info we are working in the background to get mlemay's slides onto the wiki and the #link into the meeting minutes
17:05:04 <regXboi> #info regXboi thanks networkstatic for running with that item
17:05:35 <networkstatic> yessir, will get it posted in two mikes boss
17:05:41 <regXboi> :)
17:06:14 <tbachman> #info will cover Karaf, the ODL karak distribution, and hands-on demo & tips
17:06:25 <tbachman> #info s/karak/karaf/
17:06:40 <regXboi> kayak?
17:06:46 <tbachman> lol
17:07:23 <tbachman> #info recap that Karaf is a bunch of “goodies and utiliities around an OSGi container”
17:07:32 <regXboi> #info karaf being a set of tools (console, logging, deployer, provisioning, admin, blueprint) on top of OSGi
17:08:04 * regXboi realizes some questions around logging may come down the pike later on :)
17:08:56 <regXboi> #info karaf allows for bundles to be grouped into functional units
17:09:31 <tbachman> #info It is a replacement for the distribution folders currently being used in all the projects
17:09:37 <regXboi> #info as an alternative to a param pom
17:09:45 <regXboi> #info s/param/parent/
17:11:03 <regXboi> #info question is the code snippet part of a specific file or is it an example
17:11:25 <regXboi> #info answer: this is just an example to illustrate versioning and dependencies between features
17:11:41 <tbachman> #info Features have their own versioning
17:11:48 <regXboi> #info and how bundles are pulled together into a feature
17:11:57 <icbts> #link http://karaf.apache.org/manual/latest/users-guide/provisioning.html  documentation on features
17:12:00 <regXboi> #info question: so where is this feature file from?
17:12:24 <regXboi> #info mlemay answers his preference to build it manually...
17:12:37 * regXboi now that's funny
17:12:46 * tbachman finds it midly entertaining to see his stuff in mlemay’s webex :)
17:13:00 * icbts that’s general practice for feature files
17:13:06 * regXboi resists temptation.... :)
17:13:10 <tbachman> lol
17:13:49 <regXboi> #info question: how to use karaf in a specific case (ovsdb I think)
17:14:08 <networkstatic> #link Mathieu Lemay Karaf presentation https://wiki.opendaylight.org/images/7/7e/Karaf-Discussion-TWS-June2-2014-Lemay.pdf
17:14:28 <colindixon> #link https://wiki.opendaylight.org/images/7/7e/Karaf-Discussion-TWS-June2-2014-Lemay.pdf slies that mlemay is using
17:14:46 <colindixon> (the URL has to immediately follow the #link)
17:14:48 <regXboi> #chair colindixon
17:14:48 <odl_meetbot> Current chairs: Madhu colindixon networkstatic regXboi tbachman
17:14:56 <networkstatic> ahh thanks guys
17:15:07 <regXboi> and thank you for posting, networkstatic
17:15:13 <networkstatic> wonder how long i have been screwing that up
17:15:19 <networkstatic> so many links
17:15:27 <regXboi> did anybody get the answer to Madhu's q?
17:15:30 <regXboi> I didn't parse it
17:15:33 <icbts> #link http://karaf.apache.org/manual/cave/latest/overview.html Cave overview for OBR
17:15:49 <colindixon> regXboi: nor did I
17:15:54 <networkstatic> here it comes
17:15:55 <icbts> #info API vs Impl versioning
17:16:11 <regXboi> thanks icbts
17:16:22 <icbts> #info feature dependencies vs bundle dependencies
17:16:51 <regXboi> #info can a bundle depend on a feature?  answer: not clear how to do bundle-to-bundle dependencies
17:17:18 <icbts> Bundles depend on packages as per usual OSGi
17:17:32 <networkstatic> what i was thinking too
17:18:05 <icbts> ie. Bundle ABC requires JPA, you can deploy JPA feature, but its still going to need normal OSGi package wirings
17:19:18 <regXboi> #info followup Q.  If one wanted to do an OVSDB feature, it could depend on other features and bundles and when the OVSDB feature is installed, then all get installed
17:19:21 <Madhu> #question if we have to use OBR, it pulls in only the API dependency bundle but not Implementation bundles. will Features help in pulling in both the API and Impl bundles
17:19:45 <networkstatic> #info feature dependencies option 1. the feature file (xml) you can "deploy" to deploy folder at runtime to take effect
17:19:45 <networkstatic> #info feature dependencies option 2. you prepackage your feature file as part of ODL (Karaf) distribution by placing it into Karaf system folder under your package. this way you can add your feature for featuresBoot. this way it will be started automatically when ODL / Karaf starts
17:19:45 <networkstatic> #info feature dependencies option 3. you load your feature file from Karaf console or via Client command from Maven repo or File
17:20:06 * icbts a features file should be written to include the API and imple bundles - or feature for API and feature impl bundles
17:21:02 <regXboi> icbts: please feel free to speak up on the call
17:21:38 <colindixon> is #question a command? regXboi, do you know?
17:21:49 <regXboi> #question
17:22:02 <regXboi> let me check the log
17:22:31 <readams> Note that in the common case, there's only ever one implementation
17:22:56 <readams> Or if there's more than one, there's likely to be a "real" implementation and a "test" implementation
17:23:11 <readams> Manually having to specify a whole dependency chain is unnecessarily painful and error-prone
17:23:21 <regXboi> #help
17:23:23 <Madhu> readams: +1
17:23:30 <regXboi> #help question
17:23:35 <regXboi> not clear colindixon
17:23:54 <colindixon> k
17:23:58 <colindixon> we’ll work it out later
17:24:11 <regXboi> let's try it both ways and see what happens
17:24:31 <readams> Valid commands for participants for meetbot are info, action, idea, help, and link
17:24:44 <readams> For chairs there's start/end meeting, topic, and agreed
17:24:55 <tbachman> and vote
17:25:27 <readams> We're using the openstack meetbot fork, which adds the vote feature
17:26:09 <Madhu> #info OBR doesn't provide automatic Feature dependency resolution. it is bundle by bundle.
17:27:45 <networkstatic> dont say "functional" today edwarnicke! you will start a religious war.
17:28:21 * regXboi notes we so need to port scan the controller
17:28:28 <networkstatic> haha
17:28:56 <networkstatic> did u see dfarrell07 messages in #opendaylight today on nmap?
17:29:05 <regXboi> no...
17:29:16 <networkstatic> he filed a bug, will link u bro
17:29:32 <regXboi> found it
17:29:34 <networkstatic> https://bugs.opendaylight.org/enter_bug.cgi?product=controller
17:29:38 * regXboi starts laughing
17:29:38 <networkstatic> oops
17:29:44 <networkstatic> bad link
17:29:45 <networkstatic> lol
17:29:58 <readams> Arbitrary code execution via unauthenticated remote socket.  It's a feature?
17:30:04 <networkstatic> hahaha
17:30:45 <networkstatic> its all OOB anyways :)
17:31:19 <Madhu> #info the management features SSH console & JMX is also available in the non-karaf version using the gogo and JXM access.
17:31:27 <readams> Yes, it's important to ensure that merely gaining access to the management network instantly means complete control over everything
17:31:29 <regXboi> hard coded security?
17:31:31 <Madhu> #info but Karaf comes prepackaged with all these.
17:32:12 <networkstatic> readams lol
17:32:27 <readams> Should I start working on my ODL injectable man-in-the-middle plugin?
17:32:47 <Madhu> readams: not necessarily. RBAC is supported i believe.
17:33:06 <networkstatic> I can add some ACLs that only block TCP_SYNs to boot
17:33:18 * networkstatic wishes he was kidding
17:33:24 <regXboi> #info question: how to change users/groups/roles on the fly
17:33:25 <networkstatic> stupid state
17:33:26 <Madhu> networkstatic: man u have to sleep :)
17:33:28 <networkstatic> haha
17:33:43 <Madhu> u r sleep walking TCP flags now.
17:33:47 <regXboi> #info answer is that it either comes from the shell or via JAAS infra
17:34:01 <networkstatic> neg, now reg_load sir :)
17:34:20 <cdub> "talk a bit about ODL dependency, oh my god that's unreadable" <-- ODL dependency issues in a nutshell
17:34:34 <regXboi> cdub: +1
17:34:45 <imcharly> cdub: +1
17:35:01 <readams> We need to _simplify_, not add new layers and increase complexity
17:35:24 <cdub> readams: indeed!
17:35:55 <regXboi> colindixon: are you accusing me of being able to project?
17:35:58 <Madhu> #info. colindixon : its deafening when networkstatic and regXboi talks ;)
17:36:02 <networkstatic> hahahaha
17:36:09 <networkstatic> u know im fragile colin
17:36:15 <networkstatic> I will never talk again
17:36:18 <networkstatic> lol
17:36:35 <colindixon> it’s all good, I’ve got two ears :p
17:36:39 <networkstatic> haha
17:38:14 <networkstatic> lenrow hey sir, u still up for chatting on TWS today?
17:39:39 <regXboi> #info edwarnicke question: projects find the ability to try things out via a distribution directory.  what is the correct way to maintain that ability within karaf?
17:39:48 <readams> The fact that each project needs its on distribution directory is a GIANT RED FLAG, not a feature to be preserved.  It means that our module management scheme is UTTERLY BROKEN
17:40:03 <regXboi> #info answer: define a feature with a dependency on the base distro
17:40:54 * tbachman is very glad regXboi has excellent hearing :)
17:41:01 <regXboi> #info answer: alternatively, one can depend on a lightweight distribution
17:41:38 <Madhu> readams: agreed. it is causing headaches already.
17:41:56 * regXboi has his phone volume on max :)
17:42:20 <regXboi> #info more followup Qs and As on this, but nothing that appears to change the base statement
17:42:44 <edwarnicke> Madhu: Good time management :)
17:42:58 <regXboi> what's the new topic?
17:43:03 <tbachman> tenants
17:43:13 * regXboi runs screaming for the exits
17:43:39 <tbachman> I think we just lost our scribe :(
17:43:42 <tbachman> lol
17:44:24 <colindixon> sorry :p
17:44:42 <colindixon> #info networkstatic suggestsion making videos showing how to migrate to karaf
17:44:51 <colindixon> #action mlemay says he’d love to
17:44:52 <regXboi> #topic discussion of tenants
17:45:10 * colindixon just barely got that last one in (although without enough context)
17:45:32 <Madhu> mlemay: sorry about the axe :)
17:45:39 <regXboi> colindixon... #link?
17:45:39 <tbachman> #info dlenrow giving presentation on strawman proposal for tenants
17:45:56 <networkstatic> #link https://git.opendaylight.org/gerrit/#/c/6756/ Ed's Karaf commit for openflowjava
17:45:56 <colindixon> regXboi: good Q, 2 secs
17:45:59 <mlemay> Madhu: no worries.. have to be on schedule... will do screencast instead
17:46:14 <Madhu> mlemay: that would be hugely helpful
17:47:09 <regXboi> NVaaS
17:47:12 <tbachman> #info Base Assumptions: ODL should present a tenant-aware NBI, and ODL should provide NVaaS
17:47:30 <tbachman> #info NVaas: Network Virtualization as a Service
17:48:15 <tbachman> #info cdub asks about difference between proposal and Neutron API
17:48:23 <regXboi> #info Question: how is NVaaS different from neutron?
17:48:29 <tbachman> #info colindixon notes that Neutron might be a good starting point for this.
17:49:08 <regXboi> #info point of this presentation is to set down some ideas of what a tenant means
17:49:27 <regXboi> #info push back that neutron is IT centric view...
17:49:35 <tbachman> #info edwarnicke notes that tenant means different things to different people
17:50:02 <colindixon> #link https://wiki.opendaylight.org/view/File:TWS-ODL-tenancy-2014-06-02.pptx the slides being used
17:50:08 <tbachman> colindixon: thx!
17:50:13 <regXboi> thanks, colindixon
17:50:51 <tbachman> #info Tenancy in this context is an overlay
17:51:56 <readams> Do you really want to use the word "overlay" here?  That sounds sounds like a uniquely poor choice of words
17:52:01 <readams> I assume you don't really mean overlay?
17:53:16 <cdub> readams: yeah, it's confusing at the least
17:53:25 <tbachman> We can call it Node insteadl
17:53:27 <tbachman> jk
17:53:37 * tbachman ducks
17:55:33 <networkstatic> overlay segments are shared in Neutron also. reality is its just a combination of various fields.
17:55:54 <networkstatic> implementation details..
17:56:00 <regXboi> please - somebody else scribe !
17:56:03 <regXboi> I'm going to be talking
17:56:07 <colindixon> yeah
17:56:13 <cdub> tenant is an overlay -> tenant is an abstraction?
17:56:19 <readams> Every single term of art in this presentation is misused
17:56:27 <colindixon> #info regXboi raises the question as to how this will play into the current “tenancy” and network virtualization solutions at the bottom, e.g., OpenDOVE, VTN, OVSDB
17:56:55 <tbachman> #info Madhu asks if we can use a different word than overlay
17:57:33 <cdub> that's RBAC
17:58:18 <colindixon> #info the answer w.r.t. existing tenant-oriented things is that this is more to try to have a unified construct to talk about tenants beyond virtual networks (Neutron)
17:58:56 <colindixon> cdub: RBAC isn’t hierachical
17:59:26 <readams> RBAC by itself doesn't give you what you want
17:59:35 <cdub> well, that's called hierarchical RBAC ;)
17:59:53 <readams> You need owners of resources here, which implies not pure RBAC
18:00:13 <readams> It more like an ACL or posix-style
18:00:23 <tbachman> #info colindixon notes that the way that this is different from existing tenant notions is that those are about virtual networks,
18:01:08 <tbachman> #info colindixon notes that we need a way of talking about tenancy from other perspectives, such as in the context of AAA
18:01:17 <colindixon> tbachman: thanks!
18:01:35 <cdub> #info and (for above) in the _helium_ timeframe
18:02:07 <regXboi> is AAA only northbound?
18:02:17 <regXboi> please tell me AAA isn't only northbound!
18:02:46 <edwarnicke> readams: +100000
18:03:23 <networkstatic> +1 tenant is a hash of multiple resources
18:03:32 <networkstatic> up to implementation
18:03:34 <colindixon> ok
18:03:35 <networkstatic> leave it generic
18:03:38 <readams> I think a useful definition of northbound is that AAA applies
18:03:39 <colindixon> I need to drop
18:03:41 <edwarnicke> networkstatic: Yes, of which networks may only be one example
18:03:47 <networkstatic> roger
18:04:18 <cdub> s/a hash of/a context for/
18:06:42 <readams> regXboi: You're not going to get a complete trust model for your whole system out of a AAA subsystem
18:08:35 <regXboi> all... I need to trop
18:08:42 <regXboi> er drop ... somebody else gets to close meeting
18:09:10 <networkstatic> cya regXboi thanks buddy
18:10:37 <Madhu> #endmeeting