17:02:31 <Madhu> #startmeeting TWS call
17:02:31 <odl_meetbot> Meeting started Mon Jul 21 17:02:31 2014 UTC.  The chair is Madhu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:31 <odl_meetbot> The meeting name has been set to 'tws_call'
17:02:58 <Madhu> #chair phrobb regXboi
17:02:58 <odl_meetbot> Current chairs: Madhu phrobb regXboi
17:03:33 <Madhu> #chair edwarnicke
17:03:33 <odl_meetbot> Current chairs: Madhu edwarnicke phrobb regXboi
17:06:19 * colindixon arrives
17:06:22 <Madhu> #chair colindixon
17:06:22 <odl_meetbot> Current chairs: Madhu colindixon edwarnicke phrobb regXboi
17:07:42 <colindixon> has somebody done the #topic to set it to “hydrogen stable release” update?
17:07:45 <colindixon> or should I?
17:08:17 <Madhu> #topic discussion on stable/hydrogen release
17:08:23 <colindixon> ok
17:08:24 <colindixon> thanks
17:08:43 <colindixon> #info the auto-release code is used for weekly releases as well as the hydrogen stable release
17:08:48 <Madhu> colindixon: do u have the link to the google docs that Ryan put together ? can u #info it ?
17:08:58 <colindixon> yeah
17:09:00 <colindixon> got it
17:09:48 <colindixon> #link https://docs.google.com/a/colindixon.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0 this is the google doc tracking the hydrogen stable release
17:09:54 <Madhu> #info discussion on https://lists.opendaylight.org/pipermail/release/2014-July/000089.html
17:09:54 <colindixon> on it
17:10:21 <Madhu> colindixon: the above link takes care of it :)
17:10:30 <colindixon> yup
17:11:34 <cdub> heh, as in, it comes w/ a big eraser or bottle of whiteout
17:12:13 <Madhu> #info the current autorelease provides a way for staging it
17:12:26 <colindixon> #info the auto-release project pushes artifacts to a staging nexus which nobody directly relies on, so it can be blown away, doesn’t break anything, and doesn’t require project permissions for every project to run (this is all good)
17:12:33 <GiovanniMeo> #link https://bugs.opendaylight.org/show_bug.cgi?id=1402
17:14:43 <colindixon> #link https://github.com/giovannimeo/autorelease currently, this is the autorelease code which is hosed in GiovanniMeo’s github rather than inside ODL because there’s not a logical home for it at the moment
17:18:42 <Madhu> #info Git Bundle : http://git-scm.com/docs/git-bundle
17:19:42 <edwarnicke> GiovanniMeo: It makes sense to me too... but its not the first time I've heard it :)
17:20:30 <Madhu> #info the odlautorelease job doesn't push the tags to all the projects participating in that auto release
17:20:50 <colindixon> Madhu: if you want things to show up as a link in the logs, you need to do #link and then immediately the URL and then any comments
17:20:51 <Madhu> #info the tag is not pushed because the user running the odlautorelease may not have the privileges
17:21:05 <Madhu> colindixon: thanks :)
17:21:39 <edwarnicke> #info - there is one other issue here
17:22:05 <edwarnicke> #info - when we do *releases* the *release* tag probably shouldn't be pulled to the git repo until its *actually* the release
17:22:12 <hideyuki> does odlautorelease automatically update versions for each project from 0.1.0.1-SNAPSHOT to 0.1.0-2-SNAPSHOT?
17:22:23 <colindixon> hideyuki: that’s a good question
17:22:24 <GiovanniMeo> hideyuki
17:22:29 <GiovanniMeo> it can
17:22:35 <GiovanniMeo> but currently are not doing it
17:22:39 <GiovanniMeo> for two reason
17:22:42 <GiovanniMeo> one
17:22:54 <GiovanniMeo> the next dev is calculated automatically as
17:23:00 <GiovanniMeo> 0.1.1-SNAPSHOT
17:23:38 <edwarnicke> GiovanniMeo: I think hideyuki's point is... once we do a release, where do we get the Gerrit to bump to the next SNAPSHOT version?
17:26:13 <colindixon> #info git bundle, listed above, makes it possible to ship the entire git repository as a single file and this can be pushed into the nexus—this allows us to get around the fact that we can’t push tags into projects, but still record the exact state of the repo that produced and autorelease
17:26:26 <GiovanniMeo> edwarnicke
17:26:46 <GiovanniMeo> there is a tag saved in the
17:26:51 <GiovanniMeo> git bundle with the next rev
17:27:00 <GiovanniMeo> tag pointing to it
17:27:45 <edwarnicke> Ah... so someone could pull that and push it to Gerrit automatically
17:28:42 <edwarnicke> #info mlemay asks about the build order
17:28:46 <Madhu> #info the build order is currently hard-coded in the odlautorelease.
17:28:55 <edwarnicke> #info GiovanniMeo build order is manual
17:29:23 <hideyuki> GiovanniMeo: edwarnicke: Thank you for answering.
17:30:43 <dbainbri> we have worked around the local distribution by using maven profiles
17:31:07 <dbainbri> so if you want it you can include the profile (depending if it is a active profile by default or not)
17:31:42 <Madhu> #info hideyuki : does odlautorelease automatically update versions for each project from 0.1.0.1-SNAPSHOT to 0.1.0-2-SNAPSHOT?
17:32:02 <edwarnicke> dbainbri: My thought exactly
17:32:16 <hideyuki> Madhu: sorry, I have a typo.
17:32:17 <edwarnicke> A release profile
17:32:22 <edwarnicke> 'release'
17:32:45 <hideyuki> #info hideyuki : does odlautorelease automatically update versions for each project from 0.1.0-1-SNAPSHOT to 0.1.0-2-SNAPSHOT?
17:34:37 <Madhu> #info GiovanniMeo's answer : for master this version bump is done automatically by maven-version plugin. while the stable/hydrogen branch needs some work and can be patched by a minor fix.
17:34:47 <Madhu> thanks hideyuki
17:35:21 <regXboi> #info regXboi really wants this to become it's own project with a release team to provide extra hands and eyes ...
17:35:45 <Madhu> #info GiovanniMeo suggests to keep it as a system script and handled by LF (tykeal) :-)
17:36:57 <abhijitkumbhare> This link edwarnicke https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0
17:37:09 <colindixon> #info Madhu asks when are we actually going to release the hydrogen stable release? We’ve been slipping for weeks and things seem to be stalled.
17:37:26 <Madhu> #info we are looking for +1 from projects in : https://docs.google.com/spreadsheets/d/13MBWx3kcevlGGla0zIYS312xvjnJHH2i5X2fGOYMesw/edit#gid=0
17:37:27 <abhijitkumbhare> I have updated OF-plugin to +1 today morning
17:40:45 <cdub> email
17:42:24 <regXboi> abhijitkumbhare: thanks
17:42:27 <abhijitkumbhare> Emailed
17:43:40 <cdub> i added "ACTION REQUIRED" and it's directly "To:" primary contact
17:44:14 <cdub> To vs. Cc won't change if release will tag it
17:44:53 <cdub> colindixon: indeed
17:45:41 <abhijitkumbhare> cdub, colindixon & edwarnicke - I think this "ACTION REQUIRED" is a good format
17:46:02 <cdub> abhijitkumbhare: ok, good to know.  thanks for feedback
17:46:07 <edwarnicke> abhijitkumbhare: I like [ACTION REQUIRED] as long as its addressed 'To' release
17:46:14 <Madhu> #topic Helium documentation
17:46:25 <colindixon> I’m working on a #action for me (with help from ed)
17:46:26 <abhijitkumbhare> edwarnicke - OK
17:46:40 <edwarnicke> cdub: abhijitkumbhare I think the key thing is just getting clear expectations
17:47:03 <cdub> yeah
17:47:17 <abhijitkumbhare> yes
17:47:36 <colindixon> #action colindixon to work with ed warnicke to document best practices around notifying projects of required responses (and possibly some other things that will help smooth releases). Some suggestions are specifying exactly what primary contacts need to pay attention to and the expected response time. Also suggestions around words in subject lines that will attract attention.
17:48:17 <colindixon> edwarnicke: I intentionally left your IRC handle split so it will log things as my action item not yours
17:48:17 <cdub> colindixon: one thing to note: mailman has a dangerous setting (often default) here
17:48:30 <colindixon> cdub: listens
17:48:42 <edwarnicke> colindixon: Many thanks
17:48:43 <cdub> colindixon: which is the "don't cc me if i'm on the list" where it actively edits the Cc line
17:49:20 <cdub> colindixon: so if you reply to release list, the Cc list on the email may be truncated
17:49:56 <cdub> colindixon: which means it shows up in someone's inbox only as delivered to 'release' not delivered to them directly
17:49:58 <colindixon> cdub: got it, so, we need to be aware the cc (for individuals) is unreliable
17:50:21 <edwarnicke> cdub: *aha*
17:50:23 <cdub> colindixon: yes, for follow-ups, and it should be disabled as default setting for list
17:50:43 <cdub> it's terrible, terrible, terrible, evil way to hack the Cc list
17:51:28 <cdub> (ok, last part is my strongly opinionated rant, the rest is unbiased reality ;)
17:51:34 <edwarnicke> cdub: I don'
17:51:50 <edwarnicke> mind responses so much... I also visually scan for [release] and pay closer attention there
17:52:01 <colindixon> #info Mathieu Lemay talks about how to get documentation back on track
17:52:30 <Madhu> #info we need atleast 1 responsible person from each project to signup for project docs.
17:52:54 <Madhu> #info Mathieu will send out a small guide and go over that in the Docs meeting to happen on Wednesday 07/23
18:02:14 <regXboi> endmeeting time?
18:02:26 <regXboi> #endmeeting