#opendaylight-meeting: TWS call

Meeting started by alagalah at 17:03:16 UTC (full logs).

Meeting summary

  1. MD-SAL "Consumability" work (alagalah, 17:05:02)
    1. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review (alagalah, 17:05:38)
    2. Ramkumar need to document when and where the Config Subsystem configuration is warranted, and where it might be used under the covers. Is the config subsystem going to be the one and only way of configuring modules... is there a process to make a decision? (alagalah, 17:11:11)
    3. ACTION: alagalah : dbrainbri brings up how do we get a stated direction on the config subsystem and ensure its part of this documentation process. action- alagalah (alagalah, 17:11:58)
    4. ram notes that the ping example from devin avery is in limbo but is a very realistic example and should be included. (alagalah, 17:13:12)
    5. https://git.opendaylight.org/gerrit/#/c/7249/ (flaviof, 17:13:13)
    6. ACTION: rgowrishankar take action from ping example linked by flaviof above (alagalah, 17:13:30)

  2. Clustering update from Moiz (alagalah, 17:14:06)
    1. moiz points out that this conversation is not about the AD-SAL/Infinispan clustering but MD-SAL/Akka based clustering (alagalah, 17:16:47)
    2. https://wiki.opendaylight.org/view/File:Lithium_Enhancements_141013.pptx Preso (alagalah, 17:17:06)
    3. Notes that persistence in Li will be configurable (alagalah, 17:18:38)
    4. notes also persistence will be Helium 1.0 (alagalah, 17:19:06)
    5. Notes that no operational data should be persisted (alagalah, 17:19:18)
    6. dbainbri mentions that one consideration might be the age of the operational data (alagalah, 17:22:47)
    7. moiz notes that turning off the level of persistence will improve performance (based on the example dbainbri brought up of a controller in a cable env with hundeds of Ks of user CPE trying to register) (alagalah, 17:25:19)
    8. dbrainbri notes it would be useful to get the timestamp of the data from the operational/config store to decide if the data is useful (fresh) or not (stale) (alagalah, 17:25:52)
    9. moiz points out we want to do a test of every integration build with clustering turned on (currently seeking resources from linux foundation to support this) (alagalah, 17:26:45)
    10. moiz also points out that nightly automated build testing is a target for clustering (alagalah, 17:27:10)
    11. moiz notes that there is a utility for clustering deployment in the integration repo: Search: Cluster-deployer in the integration repo (alagalah, 17:28:00)
    12. Bugs: All bugs targeted for Helium1 fix are tagged appropriately in bugzilla with the target fix release (alagalah, 17:28:59)
    13. Lithium Enhancements: programmatic creating shards: new application had its own module anddata running in a cluster, if you want to create a shard dynamically for a module (currently static in He) for the case when we are dynamically creating modules... this wil be via API (alagalah, 17:30:04)
    14. Lithium Enhancements: Finer grained sharding. Everything is sharded on project. May want to break things down into smaller chunks. (alagalah, 17:30:40)
    15. https://github.com/opendaylight/integration/tree/master/test/tools/cluster-deployer (flaviof, 17:31:42)
    16. Lithium Enhancements: (cont) only way to find leader of a shard is via JMX. This may be an enhancement request for an API/notifier (alagalah, 17:31:56)
    17. ACTION: alagalah add FR: Lithium Enhancements: (cont) only way to find leader of a shard is via JMX. This may be an enhancement request for an API/notifier (alagalah, 17:33:23)
    18. moiz notes that there is a Feature Request to rebalance Leader shards, espec. in the case of a 2 node cluster (Performance enhancement) (alagalah, 17:35:00)
    19. Lithium Enhancements: Querying... : ie there is a listener for say the Inventory shard, listening on every instance on that cluster. Shard only notifies the local listener, not all nodes in the cluster. This way all instances of an application doesn't get all notifications and act on it. Li enhancement is to make this configurable to be [local|all] (alagalah, 17:36:29)
    20. Lithium Enhancements: Querying: This enhancement not just data notifications but also YANG notificatoins (alagalah, 17:36:50)
    21. alagalah is a doofus and Querying (above) should be Enhanced Notification delivery (alagalah, 17:37:20)
    22. Lithium Enhancements: 2node cluster: moiz points out that current implementation requires that a write be to a MAJORITY before its quiesced. In a 2 node cluster a majority is 2 nodes. This is being addressed (alagalah, 17:40:11)
    23. Lithium Enhancements: Querying (for real) ... enhancements to the DOM data store are required for this. (alagalah, 17:40:40)
    24. https://meetings.webex.com/collabs/#/meetings/detail?uuid=MALTOMIMY5WPSZORCBFJSNI22V-9VIB&rnd=533135.16576 Clustering meeting (alagalah, 17:41:55)
    25. https://bugs.opendaylight.org/buglist.cgi?list_id=18545&query_format=advanced&resolution=---&short_desc=Clustering&short_desc_type=casesubstring Bugzilla (alagalah, 17:42:05)
    26. https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:Clustering 8am Tue Pac meeting (alagalah, 17:42:20)
    27. flaviof asks what is happening with AD-SAL clustering (alagalah, 17:44:07)
    28. moiz points out there used to be a clustering service in AD-SAL but it requires applications need to be clustering aware (alagalah, 17:44:42)
    29. moiz points out that he is not aware of anyone working on AD-SAL clustering. dbainbri mentions perhaps the TSC may want to wade in on this (alagalah, 17:47:37)

  3. Future topics (alagalah, 17:53:19)


Meeting ended at 17:57:20 UTC (full logs).

Action items

  1. alagalah : dbrainbri brings up how do we get a stated direction on the config subsystem and ensure its part of this documentation process. action- alagalah
  2. rgowrishankar take action from ping example linked by flaviof above
  3. alagalah add FR: Lithium Enhancements: (cont) only way to find leader of a shard is via JMX. This may be an enhancement request for an API/notifier


Action items, by person

  1. alagalah
    1. alagalah : dbrainbri brings up how do we get a stated direction on the config subsystem and ensure its part of this documentation process. action- alagalah
    2. alagalah add FR: Lithium Enhancements: (cont) only way to find leader of a shard is via JMX. This may be an enhancement request for an API/notifier
  2. flaviof
    1. rgowrishankar take action from ping example linked by flaviof above


People present (lines said)

  1. alagalah (40)
  2. flaviof (4)
  3. odl_meetbot (3)


Generated by MeetBot 0.1.4.