#opendaylight-meeting: TWS call Devin Avery leading a discussion on the MD-SAL

Meeting started by phrobb at 17:04:41 UTC (full logs).

Meeting summary

    1. Key underlying theme is to increase the transparancy of the MD-SAL (phrobb, 17:10:34)
    2. Transparency = Whats working, Whats not working, Whats the current status, (Madhu, 17:11:12)
    3. Sharing the knowledge is critical to get the community around MD-SAL development. (Madhu, 17:12:19)
    4. make the backlog publicly visible for everyone from the community to contribute. (Madhu, 17:15:19)
    5. IDEA: weekly dedicated md-sal status call. (Madhu, 17:15:45)
    6. proposal : Identify Feature gap. (Madhu, 17:17:11)
    7. proposal : Prioritize the features, bugs, enhancements into public backlog which is reviewed weekly. (Madhu, 17:17:48)
    8. dlenrow: question existing design and decide as a community if some design needs attention and maybe replace with better ones ? (Madhu, 17:20:43)
    9. Continued and deeper sharing of knowledge of the MD-SAL's inner workings is needed (phrobb, 17:20:48)
    10. IDEA: sometime ago, we had talked about conducting a md-sal workshop. Couple of days dedicated to vision/status/planning of md-sal. Some how it fizzled out. If there is interest,we should look at that (raghu67, 17:21:02)
    11. md-sal workshop is a good idea to begin with. But this needs to be an ongoing community driven activity. (Madhu, 17:22:56)
    12. if we have to have a 2-3 day in-person workshop for people to get involved in MD-SAL, that’s a bad sign (colindixon, 17:25:31)
    13. it’s not necessarily a bad idea, but we need to find a way for people to get into the MD-SAL on an ongoing basis, which is what this call is about (colindixon, 17:26:09)
    14. networkstatic says that he’d love to see more examples than toaster, the toaster example always rang a big hollow to him (colindixon, 17:27:26)
    15. devinavery says they’re working on such examples now, which is really good (colindixon, 17:28:30)
    16. folks who'd contributed longer term to MD-SAL were being quieter on the call because we wanted to *listen*, not because we were not engaged :) (edwarnicke, 17:30:47)
    17. Q: Yang Tools and MD-SAL are at various ponts of development, what are the MD-SAL committers feelings toward accepting in and mentoring new developers into the internals of the MD-SAL (phrobb, 17:32:55)
    18. A: edwarnicke would throw a parade for new folks coming to work on the internals of MD-SAL. (phrobb, 17:33:27)
    19. request is to slow down to let the community catch up ? (Madhu, 17:35:20)
    20. rob adams : Request is to pause & look at usability aspects of MD-SAL. (Madhu, 17:37:20)
    21. wants to look at async nature of rpc invocations (edwarnicke, 17:37:59)
    22. rob adams asks to address the MD-SAL to allow for solid unit testing / usability / supportability (phrobb, 17:38:44)
    23. readams has specific recommendations for improving testability (edwarnicke, 17:38:46)
    24. Devin asks that the MD-SAL status meeting have all developers on/around the MD-SAL to report "this is what we did", "This is what we're doing", and "This is what we are blocked-on".. recent issues, need/call-for help, etc (phrobb, 17:44:00)
    25. IDEA: in the long-run TSC should become a place where we drive the architecture for ODL core components (Madhu, 17:45:39)
    26. readams notes the TSC should become more of a call to push forward the architecture of the overall project… goals for the system what the project needs overall to create a robust, and usable controller platform (phrobb, 17:45:39)
    27. debugability is critical for MD-SAL deployment (Madhu, 17:49:10)
    28. ACTION: wiki page to track the issues, feature requests, feature gaps, work being done, status, etc.. (Madhu, 17:49:53)
    29. debugability is both developer level _and_ operator level (tracing/auditing, etc) (cdub, 17:49:58)
    30. meeting_notes | 0,$s/core/critical/g (Madhu, 17:58:12)
    31. : when filing bugs for what you are working on, please also set a deadline (when you expect to have results) (rovarga, 18:01:25)
    32. Devin Avery will be running the weekly status calls (Madhu, 18:01:32)


Meeting ended at 18:02:23 UTC (full logs).

Action items

  1. wiki page to track the issues, feature requests, feature gaps, work being done, status, etc..


People present (lines said)

  1. edwarnicke (33)
  2. Madhu (27)
  3. alagalah (25)
  4. rovarga (22)
  5. dbainbri (19)
  6. colindixon (12)
  7. phrobb (11)
  8. cdub (10)
  9. regXboi (10)
  10. lenrow (8)
  11. odl_meetbot (4)
  12. flaviof (2)
  13. raghu67 (2)
  14. readams (2)
  15. ghall (1)
  16. dvorkinista (1)
  17. icbts (1)
  18. GiovanniMeo (1)
  19. tbachman (1)
  20. dave_tucker (1)
  21. phudgins (1)


Generated by MeetBot 0.1.4.