16:06:30 <colindixon> #startmeeting Weekly MD-SAL Call
16:06:30 <odl_meetbot> Meeting started Tue Jun  3 16:06:30 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:06:30 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:06:30 <odl_meetbot> The meeting name has been set to 'weekly_md_sal_call'
16:06:34 <colindixon> #chair edwarnicke
16:06:34 <odl_meetbot> Current chairs: colindixon edwarnicke
16:07:08 <edwarnicke> #chair devinavery
16:07:08 <odl_meetbot> Current chairs: colindixon devinavery edwarnicke
16:07:30 <colindixon> #topic status update
16:07:56 <liemmn> Is there a webex link for md-sal call?  The linky on the wiki is stale.
16:08:41 <devinavery> WebEx: https://meetings.webex.com/collabs/#/meetings/detail?uuid=MCQK23GTHZNO7LDV6UWT6KLYPV-9VIB&rnd=497132.35684
16:08:47 <liemmn> thx
16:10:19 <colindixon> I’m working on it
16:10:46 <readams> 3, sir!
16:12:47 <colindixon> #info all the data store improvements are checked in from rovarga_
16:14:01 <Madhu> can u guys hear Tony ? :)
16:14:08 <colindixon> very, very, quietly
16:14:21 <colindixon> #info Moiz says that work continous on PoC on Akka clustered data store, they would like to present again next week
16:14:42 <colindixon> #info jquery for MD-SAL is ongoing with colindixon and Neel_B
16:18:39 <edwarnicke> #raiseshand... at some point I'd like to go through the controller Release Plan and see where we stand for Monday's M2 Milestone... since I will need to report out on that... but devinavery can put it in the agenda where ever it fits
16:20:13 <Madhu> edwarnicke: do u think we will need a TWS slot next monday to track M2 milestones ?
16:20:22 <colindixon> #info looking through bugs that have been merged, this includes 1120, 724, (others in the minutes)
16:20:54 <edwarnicke> Madhu: I think that is a good idea... but the report of record is email to discuss (in part to be timezone sensitive).
16:21:51 <Madhu> sure. just making sure... if we need a slot, we can make it available edwarnicke
16:22:21 <colindixon> #info a discussion of what should happen to get a patch merged goes on, the consensus is that you need to add a committer as a reviewer to get their attention, currently that is edwarnicke, ttkacik, and rovarga_ (it seems)
16:24:37 <flaviof> ins't this why we should use the DRAFTS branches? I understand that DRAFT is private, but I would love to make DRAFTS public by default. Make sense?
16:25:17 <colindixon> #info edwarnicke says to whack him upside the head if there’s a patch that seems to be atrophying
16:26:17 <flaviof> how about 2 types of drafts (shy vs non-shy mode)?
16:26:24 <colindixon> #info flaviof asks is drafts are better than “DO NOT MERGE” patches, but edwarnicke and colindixon note that drafts are not visible except to people who are directly added as reviewers, so they’re different
16:28:18 <moizer> we should also probably have a proof-of-concept repository where we can push code and collaborate with others more easily
16:28:25 <colindixon> #action edwarnicke to start a thread on the mailing list about how to get your patches in (or delegate it)
16:29:15 <colindixon> moizer: there is something edwarnicke calls forge that we keep talking about, but it’s moved slowly, you should reach out to cdub and edwarnicke about it if you’re willing to help push it
16:29:27 <colindixon> #topic big things coming up
16:30:38 <colindixon> #info people (rovarga_ and ttkacik) are removing more xtend from things and people are reviewing them
16:31:52 <devinavery> I can hear you guys
16:36:17 <colindixon> devin is trying to call in using Skype to get audio back
16:36:34 <colindixon> #topic conversation about use of Akka
16:36:47 <colindixon> #info Madhu asks if Akka is a must (as was stated on the mailing list) or merely a good choice
16:37:08 <colindixon> #info people say that it’s just a really good fit/choice for the cluster/persistence
16:37:16 <flaviof> hm... how about git branch 'akka' ?
16:37:44 <colindixon> flaviof: we’re trying avoid branches if at all possible, but that’s a whole other thing
16:37:56 <flaviof> colindixon: understood.
16:38:01 <colindixon> that’s a different discussion though
16:38:27 <colindixon> #topic bug scrub
16:40:55 <flaviof> I asked DanF to join in the meeting. he logged the bug
16:43:07 <colindixon> #info see bug lists for results (we went through ones for md-sal, netconf, and yangtools)
16:45:05 <edwarnicke> #link https://bugs.opendaylight.org/show_bug.cgi?id=1125 - just added this into the pile.  Its a nice small good example of how to dig into something and chase it down.
16:46:55 <dfarrell07> You all have moved on, but bug 1124 guy here
16:47:04 <colindixon> #link https://bugs.opendaylight.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&bug_status=VERIFIED&component=General&component=mdsal&component=netconf&product=controller&product=yangtools&query_format=advanced&resolution=---&order=bug_id%20DESC&query_based_on= the bug list (I think)
16:47:24 <colindixon> dfarrell07: we just noted that it needed to be broken up into at least netconf and openflow plugin parts
16:47:39 <dfarrell07> colindixon: kk, can do, thanks for info
16:47:49 <colindixon> dfarrell07: it should be noted in the bug
16:47:52 <edwarnicke> Would request that we flip to a quick walk through of controller release plan at 10 till
16:50:19 <colindixon> #topic wrap-up
16:50:45 <colindixon> #info devinavery notes the bug scrub didn’t quite work as well as we might have hoped (we only made it through 2-3 bugs)
16:50:52 <colindixon> #info edwarnicke asks if IRC would be better
16:51:06 <colindixon> #info we’ll see what works for next week
16:51:28 <colindixon> #topic review of controller release plan M2 deliverables
16:54:20 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Helium_Release_Plan edwarnicke walks through this to figure out what M2 deliverables are there
16:56:10 <colindixon> #action edwarnicke will aggregate these results and present/note them later
17:05:25 <colindixon> #endmeeting