16:57:41 <phrobb> #startmeeting Weekly TSC Meeting
16:57:41 <odl_meetbot> Meeting started Thu May  1 16:57:41 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:57:41 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:57:41 <odl_meetbot> The meeting name has been set to 'weekly_tsc_meeting'
16:58:09 <phrobb> #topic TSC Members Please #info in upon arrival (roll call)
16:58:16 <dmm> #info dmm
16:58:22 <regXboi> #info regXboi (IBM today)
16:58:39 <phrobb> #chair regXboi
16:58:39 <odl_meetbot> Current chairs: phrobb regXboi
16:58:46 <regXboi> NOOOOOOO!!!!!!!!
16:58:51 <phrobb> :-)
16:59:24 <phrobb> TSC Member, Mentor, and meeting chair, it's your lucky day regXboi
16:59:54 <phrobb> regXboi:  == scribe
17:00:26 * regXboi thinks I need to negotiate better
17:00:52 <cdub> #info Chris Wright
17:01:05 <mrberner-mobile> Hello all!
17:01:31 <dmm> agenda: #link https://wiki.opendaylight.org/view/TSC:Main
17:02:00 <dmm> #link https://wiki.opendaylight.org/view/TSC:Main
17:02:05 <regXboi> #info the above is the agenda link for the minutes
17:02:36 <edwarnicke> #info Ed Warnicke
17:03:22 * regXboi notes that there may be an ulterior motive to making him a scribe - then he has to go on mute! :-)
17:03:38 <alagalah> LOL
17:04:08 * alagalah Serenity now
17:04:09 <alagalah> :)
17:04:53 <phrobb> #chair RobDolin
17:04:53 <odl_meetbot> Current chairs: RobDolin phrobb regXboi
17:05:14 * alagalah We all live in a yellow submarine
17:05:36 * regXboi imagines the "opendaylight coder's drinking song" (sung to MP's philosopher's drinking song)
17:05:42 <alagalah> :)
17:06:02 <phrobb> #topic Agenda Bashing
17:06:23 <RobDolin> #link https://wiki.opendaylight.org/view/TSC:Main <- Agenda on wiki
17:07:14 <cdub> yes, text after works
17:07:24 <phrobb> #topic Release Manager
17:08:05 <RobDolin> #info Phil Robb reported that there are a couple of folks from Huawei who are interested in helping with Release Management
17:08:19 <regXboi> #info planning a f2f on 6pm Tuesday at the OpenStack summit
17:08:29 <regXboi> #info phrobb will make information public when available
17:08:44 <regXboi> #topic Helium Simultaneous Release Plan
17:09:18 <edwarnicke> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Helium_Release_Plan#Participating_Projects
17:09:20 <alagalah> Re: Helium release plan item 2.2 "OSGI bundles should be reasonably granular"
17:09:36 <alagalah> What is "reasonably"??
17:10:10 <cdub> "exercise left to reader"
17:10:19 <regXboi> #info 4/30 deadline for new projects was yesterday - leading to a not-unexpected flurry of new projects
17:11:13 <regXboi> #info next milestone: 5/12 (M1) projects to have release plans and declare intent to participate
17:11:43 <regXboi> #info robdolin asked about the race condition of 5/12 for M1 vs 5/14 for project approval
17:12:08 <regXboi> #info edwarnicke answered that the TSC would exercise their discretion to make the race condition go away
17:12:13 <RobDolin> #info Dave Lenrow asked about the race condition.
17:12:26 <regXboi> thanks - didn't recognize the voice
17:12:58 <RobDolin> @regXboi No worries, I've gotten to know his voice from the ONF NBI WG
17:13:41 <lenrow> #info AAA Service would like to be project reviewed on 5/15 TSC call. Will Email list.
17:15:56 <regXboi> #info note to TSC members to plan travel around 5/15 meeting as there will be creation reviews
17:16:14 <regXboi> #info because of it being the week of OpenStack
17:16:40 <RobDolin> #info TSC members encourages project proposers to attend the TSC meeting when their project will be reviewed
17:17:01 <regXboi> #topic Lithium Release Plan/Venues
17:17:32 <kwatsen> #info Kent Watsen
17:17:39 <RobDolin> #info Phil Robb - Ran into a conflict with June _2015_ date
17:17:55 <regXboi> #info phrobb reports that the summit date is changing from 6/7/2015 to a new target of the week of 6/15/2015
17:18:23 <regXboi> #info looking to lock down the Santa Clara Hyatt for that target week
17:18:30 <abhijitkumbhare> Hi - for some reason webex is not allowing me to speak - or be heard - however question regarding the 4/30/2014 date for participating in Helium - I wanted to confirm that the 4/30 date is only for new projects - not existing projects like openflowplugin, etc. Correct?
17:18:57 <regXboi> #topic Integration Projects containing distributions other than Release Vehicles
17:19:52 <phrobb> #info That is correct Abhijit.  The 4/30 is for new projects to come forward for the two week period before their creation review
17:19:54 <abhijitkumbhare> Correct - that was my question
17:20:01 <edwarnicke> #link https://lists.opendaylight.org/pipermail/discuss/2014-April/002205.html - Discussion about integration keeping distributions other than Release Vehicles.
17:20:07 <abhijitkumbhare> Thanks!
17:20:07 <regXboi> we try to help :)
17:20:43 <abhijitkumbhare> For some reason webex has joined me as “mute” :-)
17:21:05 <phrobb> I can unmute you if you can't abhijitkumbhare
17:21:24 <abhijitkumbhare> sure - but I don’t see myself as “mute”
17:21:37 <abhijitkumbhare> just the voice not going thru
17:22:10 <abhijitkumbhare> its OK - my question has been answered
17:22:25 <phrobb> OK
17:24:47 <ChrsPriceAB> #info Chris Price joined
17:24:51 <phrobb> #info regXboi suggests, that if we change release vehicles for Helium should we take the existing release editions for Hydrogen as a place for them
17:25:13 <phrobb> welcome ChrsPriceAB
17:25:30 <regXboi> #info regXboi thinks that "hydrogen_release" might be even better
17:28:01 <cdub> this is probably best for the list
17:28:11 <alagalah> +1
17:28:15 <regXboi> +1 to cdub
17:28:39 <regXboi> #info this discussion is probably best to go back to the list
17:28:53 <alagalah> regXboi: Discuss ? or controller-dev ?
17:28:54 <phrobb> #info discussion ensues on how best to manage distributions, release vehicles, and releases (New and stable/maintenance).
17:28:55 <regXboi> #info as there are mulitple ways to "skin the cat"
17:29:06 <regXboi> discuss - that's where it started?
17:30:12 <regXboi> #info Madhu comments about release vehicles versus stable branches versus
17:31:17 <regXboi> #info edwarnicke drags the question back to the TSC issue
17:31:41 <edwarnicke> #info issues kicks and screams in response
17:31:52 <regXboi> #info which is that this is up to the integration project
17:34:29 * cdub refrains from mentioning that distributions don't make sense
17:34:38 <cdub> oh...whoops
17:34:54 <edwarnicke> cdub: Appears to be thinking really loudly :)
17:35:03 <mlemay> +1 on that
17:35:44 <cdub> time check
17:36:00 <cdub> we have simple questino posed for TSC
17:36:01 <regXboi> we are way over
17:36:15 <regXboi> cdub: are you not able to speak on the phone?
17:36:27 <regXboi> if so, I'm happy to be your voice
17:36:35 <Madhu> sorry guys. i #shutup now
17:37:54 <ChrsPriceAB> +1
17:38:33 <cdub> regXboi: i can, but prefer IRC as meeting...for one...it forces terseness ;)
17:38:51 <alagalah> cdub: Adn
17:38:58 <alagalah> cdub: And minimises verbosity
17:38:58 <regXboi> #info dmm says we need to have more discussion
17:39:21 <regXboi> #info edwarnicke says that's around the minuta but not around the basic question
17:39:56 <regXboi> #info madhu is concerned about a particular user's request for a new distribution and who decides whether it gets in or not
17:41:02 <regXboi> #info dmm says let's move this to the TSC mailing list
17:41:17 <alagalah> +1
17:41:25 <cdub> propose: integration has leeway, we request integration to maintain clarity re: which are "blessed"
17:41:30 <cdub> end-of-story
17:41:46 <mlemay> +1
17:41:50 <alagalah> +1
17:41:55 <regXboi> cdub - is what ed saying is what you want?
17:42:10 <cdub> pretty much
17:43:03 <rovarga> so here's the thing
17:43:16 <rovarga> can we just say that the integration needs to carry release vehicles
17:43:23 <rovarga> but is free to maintain other packagings?
17:44:02 <cdub> propose: integration has leeway, we request integration to maintain clarity re: which are "blessed", tsc arbitrates release vehicles (latter part is what we already do afaik)
17:46:12 <phrobb> #info propose: integration has leeway, we request integration to maintain clarity re: which are "blessed", tsc arbitrates release vehicles (latter part is what we already do afaik)
17:46:33 <cdub> phrobb: nice, thanks ;)
17:47:03 <phrobb> #agreed on the proposal above
17:47:39 <regXboi> #topic TSC charted text re:elections
17:48:17 <regXboi> #topic TSC charter text re:elections
17:48:25 <regXboi> #info fixing the typo
17:50:59 <RobDolin> #link https://lists.opendaylight.org/pipermail/tsc/2014-April/001089.html <- Phil Robb's email
17:51:11 <edwarnicke> Thanks RobDolin  :)
17:53:20 <dmm> #link https://lists.opendaylight.org/pipermail/tsc/2014-April/001089.html (Phil's email)
17:55:35 <RobDolin> #info Ryan Moats (IBM) recommends "Option 1" with a proviso that Platinum member seats go away sometime in 2015
17:56:14 <ChrsPriceAB> The sunset clause should not be so strict that new platinum members are not able to proceed through this transition.
17:56:27 <cdub> yes, it should
17:56:34 <ChrsPriceAB> :)
17:56:43 <edwarnicke> I would suggest that perhaps we should separate these questions as I think they are separable?
17:56:56 <cdub> platinum == board rep...TSC == technical...we need a real sunset
17:57:03 <RobDolin> What about a sunset after the lithium (3rd) or (4th) release?
17:57:15 <RobDolin> We'll need some time for projects to get to "core"
17:57:26 <edwarnicke> #info Please also note that the TSC does not have the power to rewrite this part of governance, but merely to send options to the board
17:58:05 <RobDolin> an alternative way to "sunset" would be to wait until we have X projects at the "core" state
18:00:38 <edwarnicke> RobDolin: That's an interesting idea... especially since for a project to be 'Mature' it first has to have a history of following the Mature Release project... not sure if we can get anyone there until after Lithium Releases
18:01:09 <edwarnicke> (Mature is the prerequisite state of core)
18:02:05 <cdub> #info phrobb notes that we don't have any core projects and therefore not a good way to build PTLs + developer representation on TSC, and unlikely to have significant change by apr 2015
18:02:36 <RobDolin> <- Raises hand
18:02:42 <phrobb> #info dmm notes that he is conflicted on this issue.  As a non-developer dmm would not be on TSC other than as a platinum designate (as the rules are currently written).
18:03:39 <kwatsen> Option #1 seems OK to me, I trust the community will not try to game the TSC.  But I don't think non-developer PTL TSC members should get bumped or dropped
18:04:14 <edwarnicke> Could we get a read into the record of Option 1?
18:04:15 <readams> Can we create non-voting memberships?
18:04:22 <ChrsPriceAB> likes the idea of using # of Core projects to sunset
18:04:33 <cdub> ChrsPriceAB: me too
18:04:45 <cdub> ChrsPriceAB: and refocuses us on needing to build Core projects
18:05:03 <phrobb> #info, dmm notes that the TSC has been asked to provide guidance on this topic.  Suggests that option 1 (removal of the "if not otherwise represented" clause) has the most support currently
18:05:17 <regXboi> #info Project Technical Leaders (PTLs) for projects within OpenDaylight that are "Core" projects as defined by the Project Lifecycle [3] shall each have a seat on the TSC.  Note that it does not matter what organization any of the PTLs come from.  If the person is a PTL on a "Core" project, then they have a seat on the TSC regardless of company affiliation.  There is only one PTL per project.
18:05:26 <regXboi> oops
18:05:29 <regXboi> wrong option 1
18:05:30 <regXboi> darn
18:05:45 <regXboi> #info 1) So the first discussion/decision is to determine if there is a way to increase and improve the diversity of the technical community  representation on the TSC, as is intended by the At-Large Committer positions, while preserving the strong leadership base already present within the existing TSC.
18:06:01 <regXboi> #info that's that correct option 1
18:06:16 <ChrsPriceAB> also feels some form of "sponsor on boarding" needs to be in place to support the sponsoring community.
18:06:33 <phrobb> #info Option 1 -  Remove the "If Otherwise Not Represented" clause from the By-Laws and Charter document as it relates to Platinum Member designates to the TSC
18:06:55 <phrobb> sorry regXboi, too many options in my mail
18:07:26 <ChrsPriceAB> - next time would like one option to choose from ;)
18:07:35 <regXboi> hahahahahaha!
18:07:38 <RobDolin> Proposal: adopt option 1 with a recommendation to sunset sometime around fall 2015 (4th SR) and 2016 (5th SR); or minimum # projects to core.
18:08:06 <phrobb> #info suggestion made to trigger sunset of platinum designates on TSC - some number of Core projects in existence.
18:09:06 <phrobb> ChrsPriceAB:  I can do that ;-p
18:09:19 <RobDolin> Idea: Option 1 <period> and can recommend sunset at a future meeting
18:09:36 <ChrsPriceAB> #info needs to step away for a few minutes
18:11:02 <cdub> done with, or started?
18:11:33 <kwatsen> to prevent gaming the TSC, we could have a constraint that no one company can ever have more than some % representation, where % must be something less than 50%
18:13:11 <ChrsPriceAB> #info back.
18:13:17 * cdub is cool w/ that
18:14:16 <RobDolin> @regXboi - Do you want to state your proposal?
18:15:32 <regXboi> #info proposal: take option 1 to board with the previso that platinum member seats be sunseted by a yet TBD trigger to allow the TSC to be more representative of the technical commnuity
18:15:56 <kwatsen> agree with Ed
18:16:41 <phrobb> #startvote Agree on Option 1 -  Remove the "If Otherwise Not Represented" clause from the By-Laws and Charter document as it relates to Platinum Member designates to the TSC  +1, -1, 0
18:16:41 <odl_meetbot> Unable to parse vote topic and options.
18:17:01 <dmm> #vote +1
18:17:01 <ChrsPriceAB> #vote +1
18:17:02 <RobDolin> +1
18:17:03 <kwatsen> #vote +1
18:17:07 <cdub> #vote +1
18:17:11 <edwarnicke> +0
18:17:13 <regXboi> #vote -1
18:17:16 <edwarnicke> #vote +0
18:17:53 <phrobb> #info vote results are 5 +1, 2 0, and 1 -1 : the vote carries
18:18:11 <cdub> phrobb: 1 0
18:18:14 * tbachman notes edwarnicke just gamed the system ;)
18:18:23 <edwarnicke> tbachman: How?
18:18:24 <RobDolin> 5 yes (Dave, CP, Rob, Kent, CW), 1 no (Ryan), 1 abstain (Ed)
18:18:34 <phrobb> Thanks cdub
18:18:35 <tbachman> lol - was just kidding.. b/c you only had one #
18:18:56 * cdub looks for jason nordstrom
18:19:01 <edwarnicke> tbachman: more accurate: "edwarnicke has difficulty with typing" ;)
18:19:04 <tbachman> lol
18:19:06 <regXboi> #topic Creation Reviews: OpFlex
18:19:08 <RobDolin> #info Corrected vote results: 5 yes (Dave, CP, Rob, Kent, CW), 1 no (Ryan), 1 abstain (Ed)
18:19:12 <phrobb> cdub:  hahaha
18:19:18 <edwarnicke> "Who is Jason Norstrand" ;)
18:19:18 <dkehnx> https://wiki.opendaylight.org/view/Project_Proposals:OpFlex
18:19:27 <RobDolin> @cdub LOL ;)
18:19:37 <dmm> #link https://wiki.opendaylight.org/view/Project_Proposals:OpFlex
18:20:12 <phrobb> #topic Creation Review - OPFLEX
18:20:26 <regXboi> phrobb: I already did that!!!
18:20:27 <phrobb> sorry regXboi didn't read back far enoug
18:21:21 <alagalah> Double the Topic, double the power
18:22:16 <dmm> @alagalah: twice the pride double the fall
18:23:01 <alagalah> dmm: What?? Pride isn't like hit points that let you take more punches??? (shocked face)
18:23:26 <RobDolin> @dkehnx - Kudos on the diversity of committers
18:23:33 <phrobb> #info Q The policy agent written in C, why was it chosen?… A:  because it may run in a switch or other types of devices
18:23:44 <abhijitkumbhare> What are the observer & endpoint registry blocks in the diagram?
18:23:53 <dmm> @alagalah -- Count Dooku
18:24:24 <tnadeau> i thought we were only going with java/etc...-based projects?
18:24:53 <abhijitkumbhare> https://wiki.opendaylight.org/view/File:OpFlex_Policy_Agent_Proposal.png
18:25:04 <readams> endpoint registry would be contained in the group based policy plugin
18:25:06 <regXboi> #info question: What are the observer & endpoint registry blocks in the diagram?
18:25:24 <abhijitkumbhare> OK
18:25:32 <regXboi> #info answer: these come from the ietf draft referred to in the proposal
18:25:58 <kwatsen> my question wasn't why in C, but if it will contain a pluggable backend - the answer was yes
18:26:55 <Madhu> minor nit guys.
18:26:56 <phrobb> #startvote OpFlex to incubation 1, -1, 0
18:26:56 <odl_meetbot> Unable to parse vote topic and options.
18:27:04 <Madhu> pls change the scope to say The OpFlex protocol library
18:27:58 <readams> Just the first line of the scope; "Opflex protocol" -> "Opflex protocol implementation"
18:28:24 <edwarnicke> Madhu: Good catch :)
18:28:26 <regXboi> #action mestery to update scope from opflex protocol to opflext protocol library/impelmentation
18:28:26 <Madhu> readams: thanks
18:28:39 <mestery> regXboi: Action complete!
18:28:40 <Madhu> edwarnicke: just paranoid ;)
18:28:50 <RobDolin> #startvote OpFlex to Incubation
18:28:50 <odl_meetbot> Unable to parse vote topic and options.
18:28:56 <edwarnicke> Madhu: Paranoid or not... correctness is good :)
18:29:06 <dmm> #vote +1
18:29:08 <regXboi> #vote +1
18:29:09 <edwarnicke> #vote +1
18:29:15 <RobDolin> #vote +1
18:29:21 <kwatsen> #vote 1
18:29:22 <cdub> #vote +1
18:29:22 <ChrsPriceAB> #vote +1
18:29:39 <regXboi> #agreed opflex to incubation
18:29:40 <phrobb> #endvote
18:29:41 <alagalah> W00t!
18:29:53 <regXboi> #topic Hydrogen Stable Release
18:30:02 <RobDolin> Vote tally: 7 Yes (Dave, Ryan, Ed, Rob, Kent, CP, CW)
18:30:17 <dmm> @Rob: thnx
18:30:36 <RobDolin> :)
18:31:00 <dmm> Congrats OpFlex team!
18:31:10 <regXboi> #info defense4all and snmp4sdn are not currently part of the hydrogen.1 release work - defense4all is not available, snmp4sdn is radio silent
18:31:52 <regXboi> #info projects are moving through the process, but there is a blocker in controller pom files that needs to be resolved so dependent projects can update version numbers
18:32:23 <regXboi> #info bgp-pcep has a patch dependency on controller (patch identified) and ovsdb has one as well (patch not identified)
18:32:50 <regXboi> #info conversation about release date went nowhere (i.e. no feedback)
18:32:59 <regXboi> #info target date looks to be out a week
18:33:01 <edwarnicke> #info we also have dependency issues from controller to yangtools and ofplugin to controller I believe
18:33:05 <phrobb> #info no time yet determined for when would be a good release date.  cdub suggests we need at least a couple of weeks yet to get more consensus
18:34:39 <regXboi> #info open question for discussion on list: the current approach is to rev *all* artifacts, but an alternative approach is to rev only artifacts that changed
18:35:08 <phrobb> #info dmm asks since Hydrogen was a bit unique as the "first" release, how replicable is the stable release process/tooling for Helium and beyond?
18:35:38 <regXboi> #info dmm asks how replicatable is the hyrdogren approach - cdub says what's there is not applicable, especially if the root parent pom project is in use in helium
18:35:46 <phrobb> #info, cdub notes that this version of Stable branch creation is mostly a one-off
18:37:54 <cdub> #link https://lists.opendaylight.org/pipermail/discuss/2014-April/002162.html <-- Hydrogen Stable Relase Date discussion
18:38:39 <regXboi> #endmeeting