14:03:53 <edwarnicke> #startmeeting HoneyComb Overlay Layer and App Coexistence
14:03:53 <odl_meetbot> Meeting started Thu Aug 13 14:03:53 2015 UTC.  The chair is edwarnicke. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:03:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:53 <odl_meetbot> The meeting name has been set to 'honeycomb_overlay_layer_and_app_coexistence'
14:04:01 <edwarnicke> #topic Waiting for folks to drift in...
14:04:18 <gzhao> #info gzhao
14:04:58 <edwarnicke> #topic Rollcall - Please #info in
14:05:02 <edwarnicke> #info edwarnicke
14:05:16 <colindixon> #info colindixon
14:05:16 <gzhao> #info gzhao
14:05:35 <edwarnicke> #chair gzhao colindixon shague vina_ermagan
14:05:35 <odl_meetbot> Current chairs: colindixon edwarnicke gzhao shague vina_ermagan
14:05:54 <edwarnicke> #topic Agenda Bashing
14:05:58 <vina_ermagan> #info vina_ermagan
14:06:37 <gzhao> #info Eric Multren, Yapeng Wu, Sam Hague, Sharad are on the phone.
14:07:37 <gzhao> #info perm, hemath
14:09:42 <vishnoianil> #info vishnoianil
14:10:07 <edwarnicke> #topic Honeycomb
14:10:38 <vishnoianil> is it IRC meeting or is there any webex?
14:12:04 <yapeng> vishnoianil: webex link: https://meetings.webex.com/collabs/meetings/join?uuid=MDHJCXR45WFFOUDWYX9FPOR0VK-9VIB
14:12:05 <snackewm> https://meetings.webex.com/collabs/meetings/join?uuid=MDHJCXR45WFFOUDWYX9FPOR0VK-9VIB
14:14:16 <vishnoianil> snackewm, yapeng, thanks
14:21:29 <colindixon> #info edwarnicke asks who is interested in doing concrete work on honeycomb related stuff
14:21:40 <colindixon> #info colindixon says there’s a difference between “interested” and “having cycles to do it"
14:22:03 <colindixon> #Info edwarnicke says he’s been playing with how to tune down the memory usage of OpenDaylight
14:22:17 <edwarnicke> target/assembly/bin/setenv
14:23:40 <colindixon> #info if you want to tweak the amount of RAM it’s located at target/assembly/bin/setenv
14:24:20 <colindixon> #info edwarnicke says his experience is that he was able to get things down to 256 MB of RAM without problems as far as he could tell
14:25:11 <colindixon> #info colindixon says that this is likley to affect peformance, Java tends to have worse performance and less predictable performance when running with limited memory largely due to more frequent and challenging garbage collections
14:25:25 <edwarnicke> #link https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Tutorials:Netconf_Mount#Testing_against_ODL_itself_.28MD-SAL_netconf_northbound_loopback_mount.29
14:26:21 <edwarnicke> #link https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Application_Development_Tutorial
14:26:43 <colindixon> #info colindixon, vina_ermagan, and vishnoianil say they’re interested, but may or may not have tons of cylces
14:27:16 <colindixon> #info it sounds like sharad has done some real things on testing honey comb
14:27:21 <vishnoianil> colindixon, wooh, no it was not me :) although it's interesting topic but i am out of cycles for alteast 1 month
14:27:30 <colindixon> #undo
14:27:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x189f090>
14:27:31 <colindixon> #undo
14:27:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x189fa50>
14:27:37 <colindixon> #info it sounds like sharad has done some real things on testing honeycomb
14:27:52 <colindixon> #info colindixon, vina_ermagan, and Anil (but not vishnoianil) say they’re interested, but may or may not have tons of cylces
14:30:23 <colindixon> #topic overlay layer
14:30:25 <colindixon> #info colindixon, vina_ermagan, and Anil (but not vishnoianil) say they’re interested, but may or may not have tons of cylces
14:31:13 <colindixon> #info edwarnicke says if your overlay layer only handles tunnels, but doesn’t handle things like just delivering something out a port, it’s likely to make things less useful
14:31:32 <colindixon> #info this is something alagalah origially brought up
14:32:12 <colindixon> #info vina_ermagan asks if the overlay layer should include renderers or not?
14:32:28 <colindixon> #info edwarnicke says that it should be done so that it’s not “welded” to any given rednerer or southbound
14:36:13 <colindixon> #info florinc and prem both want to participate in the overlay layer as well
14:37:38 <colindixon> #action colindixon and vina_ermagan will touch base offline with others that are interested to try to prepare for future discussoins
14:37:49 <edwarnicke> #info vishnoianil is also interested in overlay layer
14:37:55 <edwarnicke> #topic App Coexistence
14:43:10 <colindixon> #Info there’s a lot of discussion here, not all of it is caputued in IRC, ther will be a WebEx recording
14:43:46 <colindixon> #info edwarnicke talks about ways to do this, says that alagalah suggested the idea of using metadata to allow different apps to get their own namespace in each switch
14:44:25 <colindixon> #info colindixon says there are two things we want to talk about here: (1) how we will actually realize app compisition in switches and (2) how we will provide abstractiosn for app compisition to apps
14:44:42 <colindixon> #info in colindixon’s opinion, the metadata appraoch is one good idea for (1), but likely not (2)
14:45:17 <colindixon> #info colindixon also says their are implications of using metadata because OF only allows you to forward in table numbers, so you may only be able to be processed by one app per pass through a switch, which has implications
14:48:57 <colindixon> #info Pre asks some questions about this approach and other things, including what we mean by metadata
14:49:26 <colindixon> #info edwarnicke and colindixon say that we mean metadata in the OF spec sense as a 64-bit (I think) matchable and settalbe value that follows a packet, but isn’t in the packet itself
14:51:12 <colindixon> #info Prem asks what about targeting particular implementatsions of services, I think in the context of being OF specific
14:51:45 <colindixon> #info edwarnicke says we’ve tried to avoid being implementation specific
14:52:10 <colindixon> #info Andre asks how he things things like Neutron and OVSDB NetVirt fit into all of this
14:52:27 <colindixon> #info edwarnicke says he hasn’t thought about it very much, but asks shague if he has
14:52:59 <colindixon> #info shague says that he hasn’t been able to quite grok the current approach enough to be able to have good, well-informed opinions here
14:54:58 <colindixon> #info edwarnicke says he thinks that Neutron doesn’t map directly or compeltely onto an overlay layer, it’s just doing more than that
14:55:11 * colindixon notes he has to leave at the top of the hour
14:55:28 * edwarnicke notes we should wrap up at the top of the hour anyway :)
15:00:00 <colindixon> #info colindixon notes that he missed lots of notes here, but there was a comment that he and vina_ermagan had discussed maybe have one common sort of layer that spans overlay, policy, and sfc that migth be able to be arbitrarily composed
15:00:15 * colindixon runs off
15:04:17 <alagalah> wow
15:05:30 <alagalah> "one common sort of layer that spans overlay, policy, and sfc that migth be able to be arbitrarily composed" One Ring to Bind them All !!!
15:05:32 <alagalah> woot!
15:06:38 <edwarnicke> #endmeeting