#opendaylight-meeting: Lithium M1/M2
Meeting started by phrobb at 15:00:05 UTC
(full logs).
Meeting summary
- RollCall TSC members and Project Leaders/Contacts Please #info in (phrobb, 15:00:26)
  - regXboi (TSC and all around gadfly)
    (regXboi,
    15:00:38)
- alagalah (GBP) (alagalah,
    15:01:23)
- edwarnicke (edwarnicke,
    15:01:32)
- lori (lispflowmapping) (lori,
    15:01:42)
- colindixon (TSC, TTP, Docs) (colindixon,
    15:01:42)
- mlemay (Docs, Reservation) (mlemay,
    15:01:44)
- liemmn (AAA) (liemmn,
    15:01:47)
- Venkat (LACP) (Venkat_,
    15:02:04)
- Hideyuki Tai (VTN) (hideyuki,
    15:02:08)
- ankit (plugin2oc) (ank,
    15:02:11)
- Vijay for SNBI (vjanandr,
    15:02:34)
- ttkacik for controller and yangtools
    (ttkacik__,
    15:03:00)
- ebrjohn (Brady Johnson) for SFC (ebrjohn,
    15:03:04)
- ttkacik__ for controller and yangtools
    (ttkacik__,
    15:03:18)
- bennyr for Defense4All (bennyr,
    15:03:31)
- abhijitkumbhare for OpenFlow Plugin
    (abhijitkumbhare,
    15:03:36)
- dneary (dneary,
    15:03:38)
- edwarnicke just for fun ;) (edwarnicke,
    15:03:42)
- oflibMichal for openflowjava (oflibMichal,
    15:04:35)
- alagalah (OpFlex POC) (should have put that on
    the first one) (alagalah,
    15:04:36)
- oflibMichal for topoprocessing (oflibMichal,
    15:04:44)
- Rajesh (LACP) (Rajesh__,
    15:04:47)
- Ravi (LACP) (Ravi,
    15:05:15)
- The purpose of this meeting is to have a place
    where project can ask questions of one another, and announce any
    interesting or/or change in plans (phrobb,
    15:05:44)
- Thanh (Releng) (zxiiro,
    15:05:55)
- Dana for bgpcep (dkutenic,
    15:06:54)
- fabiel.zuniga for PErsistence Data Store
    (Fabiel,
    15:07:45)
- ChristineH for snmp4sdn (ChristineH,
    15:08:29)
 
 
- Any questions from one project to another (phrobb, 15:09:23)
  - Do any project leaders have requests or
    informational questions to any other projects for the Lithium
    Release? (phrobb,
    15:09:58)
- https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Plan#Requests_from_Other_Projects
    (colindixon,
    15:12:56)
- https://wiki.opendaylight.org/view/Simultaneous_Release:Per-Project_Lithium_Release_Plan_Template#Requests_from_Other_Projects
    the rough process and template to make a request on another project
    is here (colindixon,
    15:14:03)
- liemmn is asking for dlux to switch to using
    token-based authentication since it’s an application (and not a
    human user), which should make it easier (colindixon,
    15:14:41)
- ACTION: liemmn to log
    the request on dlux’s release plan as well as reach out to them as
    described in the process above (colindixon,
    15:16:03)
- https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Plan#Requests_from_Other_Projects
    this is the section to formally log the request (colindixon,
    15:16:30)
- https://wiki.opendaylight.org/view/OpenDaylight_Controller:Lithium:Release_Plan#Requests_from_Other_Projects
    Controller Request section (ttkacik__,
    15:17:25)
- colindixon notest that the formal documenting
    the request on the release plan is designed to provide a summary of
    what is hopefully a longer discussion between the two projects that
    need not be fully logged on the wiki (although a pointer to mailing
    list threads would be good) (colindixon,
    15:17:44)
- vishnoianil (vishnoianil,
    15:18:02)
- ttkacik__ notes that the controller and
    yangtools are asking people to also file bugs for requests so that
    they can be tracked with dependencies (colindixon,
    15:18:23)
- Sachi (plugin2oc and GBP oc Renderer)
    (Sachi,
    15:18:37)
 
 
- Project Announements (phrobb, 15:19:57)
  - https://git.opendaylight.org/gerrit/#/c/13879/1
    (vishnoianil,
    15:21:02)
- vishnoianil working on moving nsf to
    openflowplugin - has pushed the initial patch to
    openflowplugin (abhijitkumbhare,
    15:21:33)
- https://git.opendaylight.org/gerrit/#/c/13879/1
    (abhijitkumbhare,
    15:21:45)
- NSFs affected     statistics-manager/forwarding
    rule manager/inventory manager etc (abhijitkumbhare,
    15:22:16)
- edwarnicke says he’d like to see us move to
    using the clustered md-sal-broker by default at some point soon, it
    should be transparent, but people should be aware (colindixon,
    15:24:38)
- https://bugs.opendaylight.org/show_bug.cgi?id=1674
    for LBaaS need to be fixed. This will be needed for plugin2oc
    implementation (deepankar,
    15:25:08)
- edwarnicke will be sending email for these
    things to the lists as well (its nice to talk in IRC, but we should
    get it out to email too) (edwarnicke,
    15:25:19)
- sheena_ asks about how to move the MD-SAL and
    still use INeutronAware (colindixon,
    15:26:11)
- edwarnicke notes that phrobb said something
    about something (edwarnicke,
    15:26:25)
- edwarnicke says that INeutronAware has been
    moved to be not AD-SAL dependent, but merely OSGi bundles
    (colindixon,
    15:27:24)
- regXboi says as far as INeutronAware is
    concerned that is how it should be (regXboi,
    15:27:52)
- https://wiki.opendaylight.org/view/OpenDaylight_Controller:Neutron_RESTCONF
    colindixon notes that there has been some work on building an MD-SAL
    native Neutron bindings (colindixon,
    15:28:08)
- alagalah suggests that for future meetings we
    use a wiki page to generate an agenda ahead of time so that we can
    aggregate similar concerns and to let people review them to be
    better prepared (colindixon,
    15:32:00)
- ACTION: alagalah to
    take stab at making agenda wiki page for M1 cross-project meetings
    (working with phrobb) (regXboi,
    15:32:07)
- ACTION: colindixon to
    set up a thread/meeting with stakeholders from Neutron related
    projectecs about the proposed MD-SAL neutron interface (colindixon,
    15:34:01)
 
 
- Any Questions on what should, or should not be in your Lithium Release Plan (phrobb, 15:36:42)
  - projects are encouraged to review other
    projects release plans to look for places where cross-project
    friction might occur (regXboi,
    15:43:12)
- , it will be very important for cross-project
    tracking that all projects read and understand the release plans of
    projects within their "dependency path"  Also, any features or bugs
    that need to be implemented/fixed should be documented in the
    dependent release plans so that everyone knows, and can track those
    items. (phrobb,
    15:44:18)
- abhijitkumbhare suggest in the action items
    tracked for each project we should have one whether dependencies on
    other projects have been conveyed and have been acked (gzhao,
    15:45:50)
- alagalah asks: colindixon: gzhao I would ask
    that this time for the dependency tree its in google draw (ie
    edittable) (alagalah,
    15:50:44)
 
 
- Meeting Cadence and Schedule for next Cross-Project IRC Meeting (phrobb, 15:51:44)
  - patch for the proposed neutron yang model:
    https://git.opendaylight.org/gerrit/13970 (edwarnicke,
    15:52:56)
- ACTION: phrobb to
    make a condorcet poll for meeting timing (phrobb,
    16:06:39)
 
Meeting ended at 16:09:46 UTC
(full logs).
Action items
  - liemmn to log the request on dlux’s release plan as well as reach out to them as described in the process above
- alagalah to take stab at making agenda wiki page for M1 cross-project meetings (working with phrobb)
- colindixon to set up a thread/meeting with stakeholders from Neutron related projectecs about the proposed MD-SAL neutron interface
- phrobb to make a condorcet poll for meeting timing
Action items, by person
  -  alagalah 
    - alagalah to take stab at making agenda wiki page for M1 cross-project meetings (working with phrobb)
 
-  colindixon 
    - colindixon to set up a thread/meeting with stakeholders from Neutron related projectecs about the proposed MD-SAL neutron interface
 
-  liemmn 
    - liemmn to log the request on dlux’s release plan as well as reach out to them as described in the process above
 
-  phrobb 
    - alagalah to take stab at making agenda wiki page for M1 cross-project meetings (working with phrobb)
- phrobb to make a condorcet poll for meeting timing
 
People present (lines said)
  - phrobb (61)
- regXboi (57)
- edwarnicke (56)
- colindixon (54)
- alagalah (34)
- abhijitkumbhare (28)
- vishnoianil (20)
- ttkacik__ (17)
- dneary (12)
- gzhao (12)
- liemmn (9)
- ebrjohn (6)
- rovarga (5)
- mlemay (5)
- deepankar (5)
- odl_meetbot (4)
- lori (4)
- zxiiro (4)
- Venkat_ (4)
- YuLing (3)
- Sachi (3)
- bigalh (3)
- sheena_ (3)
- oflibMichal (2)
- ank (1)
- hideyuki (1)
- hchen_ (1)
- Rajesh__ (1)
- Fabiel (1)
- bennyr (1)
- vjanandr (1)
- mohnish (1)
- ChristineH (1)
- Ravi (1)
- dkutenic (1)
Generated by MeetBot 0.1.4.