#opendaylight-meeting: md-sal interest call

Meeting started by colindixon at 16:03:50 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:03:58)
    1. we’ll cover quick look at bugs, pending changes, etc. (colindixon, 16:04:34)
    2. anton wants to talk about YANG tools MAC address and performance (colindixon, 16:04:55)
    3. we’ll do them in the opposite order doing the status update parts at 15 minutes before the top of the hour (colindixon, 16:05:17)

  2. covering bugs/patches in controller/yangtools (colindixon, 16:07:26)
    1. (colindixon, 16:07:33)
    2. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cresolution%2Cshort_desc%2Cchangeddate%2Ccf_target_milestone&f1=cf_target_milestone&f2=days_elapsed&list_id=25751&o1=substring&o2=lessthaneq&order=bug_status%20DESC%2C&product=controller&query_format=advan (colindixon, 16:07:34)
    3. there’s a bug where you can’t read the root fo the data tree from the clustered data tree (colindixon, 16:12:54)
    4. this is because that will span shards and cross shard reads aren’t allowed at the moment (I think) (colindixon, 16:13:16)
    5. it’s affecting NETCONF NB and everyone else if they use this and since the clustered datastore is on by default now, it’s affecting everyone (colindixon, 16:13:48)
    6. there’s a different bug where data change notifications with ONE as the notification not working right because of issues with respect to lists (I think) (colindixon, 16:14:43)
    7. the workaroudn is to use subtree (colindixon, 16:14:49)

  3. moving to Anton’s covering of YANG tools MAC address issues (colindixon, 16:15:36)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=2825 this is the link for the bug (colindixon, 16:16:23)
    2. there’s been lots of discussion on the maling list and the bug itself (colindixon, 16:16:52)
    3. ACTION: devinavery to post the presetnations (colindixon, 16:18:45)
    4. https://lists.opendaylight.org/pipermail/controller-dev/2015-March/008622.html mailing list thread starts here (colindixon, 16:19:33)

  4. next week (colindixon, 16:21:04)
    1. we’ll cover Anton’s stuff next week (colindixon, 16:21:13)
    2. we’ll also cover the ongoing Andrews “thing formerly know as the message bus" (colindixon, 16:21:28)

  5. anything major coming down the pipe (colindixon, 16:21:46)
    1. rovarga says that given we’ve passed M4, not much will hit us (colindixon, 16:22:07)
    2. the most major thing is making clustering default (colindixon, 16:22:15)
    3. rovarga says that there’s new integer validation stuff (colindixon, 16:22:30)
    4. ttkacik there’s new DOM committer cohort that would allow applications to reject commits even if they’re valid (colindixon, 16:23:23)
    5. ttkacik and rovarga both say that this might be a dangerous feature to put into Lithium at this poing and so we might hold it off until (at least) clustering default had been around for a bit longer (colindixon, 16:24:46)
    6. ttkacik and rovarga point out that *any* application can bring down the controller or reduce performance to near 0 by doing things wrong, so we should worry (colindixon, 16:25:50)
    7. the goal is to only allow stateless validation, but historically, in Hydrogen have used it for Data Change Notifications and mutating the data and all sorts of other things (colindixon, 16:26:43)
    8. rovarga says that, in his mind, this should eventually not be used and we should do (almost) all validation in YANG specifications (colindixon, 16:29:22)
    9. it sounds like this shoudl be a topic for a future time as well (colindixon, 16:29:46)
    10. pantelis says there’s a new Data Tree Change Listener API pending (colindixon, 16:30:22)
    11. this is a response to the fact that data change listeners did a lot of unnecessary work to compute changes and most applications threw most of this out (colindixon, 16:32:03)
    12. the idea of this API was to give a cursor/iterator to allow for lazy evaluation of changes (colindixon, 16:32:26)
    13. ttkacik says the APIs have already been merged, what pantelis is talking about are implementions and minor changes to the APIs to make them easier to use (colindixon, 16:34:27)
    14. the outstanding patches are actually Binding Aware interfaces on top of the Binding Independent implementations (that were already merged and are used by BGP) (colindixon, 16:35:15)
    15. catohornet asks if we shoudl talk about Karaf 3.0.3 (colindixon, 16:37:16)
    16. consensus seems to be yes, but where (colindixon, 16:37:25)


Meeting ended at 16:37:28 UTC (full logs).

Action items

  1. devinavery to post the presetnations


Action items, by person

  1. devinavery
    1. devinavery to post the presetnations


People present (lines said)

  1. colindixon (43)
  2. odl_meetbot (5)
  3. devinavery (0)


Generated by MeetBot 0.1.4.