16:01:36 <devinavery> #startmeeting MD-SAL interest call
16:01:36 <odl_meetbot> Meeting started Tue Apr 21 16:01:36 2015 UTC.  The chair is devinavery. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:36 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:01:43 <devinavery> #chair colindixon
16:01:43 <odl_meetbot> Current chairs: colindixon devinavery
16:05:20 <devinavery> #topic bug scrub into
16:06:07 <devinavery> #info Carol is presenting bugzilla - looking to clean up the categories into ad-sal vs md-sal
16:06:53 <devinavery> #info carol notice clustering bugs were being filed under MD-SAL so proposing to move remaining clustering bugs out
16:08:16 <devinavery> #info Proposing karaf, mdsal, adsal, config, netconf, restconf would be the top level items, and rest would move to one of the other headers
16:09:05 <colindixon> devinavery: I’m around if you want to hand things over
16:10:10 <colindixon> #info colindixon, tony and pantelis__ seem to be leaning toward having a clustering component as well as things
16:11:04 <colindixon> #info tony says that config is the config subsystem and configuration should drift to the AD-SAL
16:12:51 <colindixon> #info colindixon notes that if it’s easier, we could just rename the deprecated components to zarchived-${name}
16:13:05 <colindixon> #action tony says he’ll help doing the component cleanup
16:15:16 <devinavery> I am gone
16:15:57 <devinavery> Sorry folks - I needed to drop off - Colin Dixon has host permissions if anything comes up.
16:16:07 <colindixon> #topic bug scrub
16:17:13 <colindixon> #info tony says that there are 102 bugs in config, mdsal, netconf, other, and restconf that target Lithium right now
16:18:12 <colindixon> #info pantelis__ notes that some of them appear grey (meaning they’re enhancements) and thus might or might not be aplicable
16:18:19 <ttkacik1> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_severity%2Ccf_issue_type%2Cshort_desc%2Cbug_status%2Cpriority%2Cdeadline%2Ccf_target_milestone&component=config&component=mdsal&component=netconf&component=other&component=restconf&f1=cf_target_milest
16:19:26 <colindixon> #info note that incoming bugs usually don’t have a target milestone and tony usually gives them one in the morning (there are usually 3-4 such bugs per day)
16:20:27 <colindixon> #info there are 30 bugs in yangtools that target Lithium
16:21:06 <ttkacik1> #link https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_severity%2Ccf_issue_type%2Cshort_desc%2Cbug_status%2Cpriority%2Cdeadline%2Ccf_target_milestone&component=config&component=General&component=mdsal&component=netconf&component=other&component=restconf&f
16:21:37 <colindixon> #info the above link is 132 bugs spanning yangtools and controller that we’re trying to fix
16:23:58 <colindixon> #info catohornet asks what it means if the assignee is bugs@lists.opendaylight.org, tony says that’s basically “unsassigned” as it’s the default valu
16:23:59 <colindixon> #undo
16:23:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1942750>
16:24:00 <colindixon> #info catohornet asks what it means if the assignee is bugs@lists.opendaylight.org, tony says that’s basically “unsassigned” as it’s the default value
16:25:17 <colindixon> #info catohornet also asks how determine the severity, ttkacik1 (tony) says that generally they don’t change them and just trust the reporter to have it right
16:25:42 <colindixon> #info ttkacik1 says he’d like to use the first 20-30 minutes of this MD-SAL weekly call to do bug scrubbing
16:26:27 <colindixon> #info ttkacik1 says he’d also like to do a Thursday meeting to do bug scrubs
16:27:47 <colindixon> #Info colindixon notes that based on the combined ODL calendar, there are no meetings after the TSC meeting on Thursday, but that there are meetings from 8-11a pacifc (integration, aaa, dlux, sfc, and tsc)
16:28:14 <colindixon> #topic performance/bugs in addresses in controller/yantools
16:29:11 <colindixon> catohornet: I have to walk away from the keyboard (still on audio) for 2 minutes if something needs to be written down
16:29:32 <colindixon> #info Anton starts presenting around 24:30 in the recording for those who want to start here
16:30:34 <colindixon> #info anton notes that addresses (showing IPv6 right now) are stored in the form of the text entered, which means that there can be two addresses that match the regex and are different strings, but represent the same address
16:30:48 <colindixon> #info that includes IPv6, mac, IPv6 address, etc.
16:35:28 <colindixon> #info beyond that, there’s some issues where in the java code we try to convert IPv6 addresses to IPv4 addresses if they look like IPv4 addresses
16:36:31 <colindixon> #info from the performance side, we are converting everything to strings which takes ~60 microseconds of latency (and also cpu) per handling of such addresses, which can add up
16:37:47 <colindixon> #info Anton proposes that we store such addresses in a canonicalized format and use hand written code to do things quickly and correctly
16:38:00 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/18450/ this is the patch that contains the code
16:39:17 <colindixon> #info Anton notes that he’s bringing this up because he knows that it will break things
16:40:19 <colindixon> #info Anton says he’s testing openflow{plugin,java}, controller, and bgpcep with and without this code
16:43:59 <colindixon> #Info Anton notes that most projects don’t have enough unit tests to reasonably guess as to whether or not he’s broken things
16:45:19 <dbainbri> I think the concern is that submitting this patch may cause dependent projects to fail and we have no way to really test this without pushing the patch
16:45:43 <colindixon> dbainbri: yeah
16:45:48 <colindixon> we do have ways to do that
16:47:34 <colindixon> #info rovarga and colindixon offer ways to build all projects with the modified yangtools
16:51:21 <colindixon> #link https://wiki.opendaylight.org/view/String_data_normalization_and_alternative_storage a design effort provided by rovarga on the same topic
16:53:10 <colindixon> #info there is some debate between anton and rovarga about how to properly get codecs for this
16:54:08 <colindixon> #info rovarga wants to have the generated code stay generated and refer to hand-written code in a known way (this is currently done for unions)
16:55:12 <colindixon> #info tony and rovarga note that this handwritten code won’t help for the BindingIndependent format for anything since the only modifications are to the BindingAware code
16:58:54 <colindixon> #topic wrap up
16:59:42 <colindixon> #Info colindixon says it seems we have two questions: (1) do we fix this in Lithium, and (2) do we fix it using BindingAware, BindingIndependent, or both
16:59:52 <colindixon> #info colindixon says it seems we have two questions: (1) do we fix this in Lithium, and (2) do we fix it using BindingAware, BindingIndependent, or both
17:00:47 <colindixon> #info Anton says that, in his opinion, we can’t claim IPv6 compatibility for Lithium if we don’t fix it in Lithium
17:01:17 <colindixon> #info Anton says he thinks that fixing the BindingAware will help fix a lot of the bugs now even if it’s not ideal
17:02:13 <colindixon> #action anton to try to look into dealing with BindingIndependent solutions (and what the polymorphic solution) would look like
17:02:50 <colindixon> #action anton and/or rovarga to send this to the mailing list to figure out how to proceed w.r.t. to the two above questions
18:38:41 <colindixon> #endmeeting