#opendaylight-meeting: MD-SAL interest call

Meeting started by colindixon at 16:02:22 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:02:25)
    1. https://wiki.opendaylight.org/view/MD-SAL_Weekly_Call#Agenda the agenda in it’s usual place (colindixon, 16:03:53)
    2. the plan is to do a bug scrub first and then cover a few topics carol posted ot the wiki (colindixon, 16:07:30)

  2. bug scrub (colindixon, 16:07:56)
    1. using the same search query as last week (colindixon, 16:08:45)
    2. https://lists.opendaylight.org/pipermail/controller-dev/2015-April/009187.html this e-mail has the bug lists we’re looking at (colindixon, 16:15:04)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=2976 this bug seems have an issue which is happens when you restart the controller (colindixon, 16:18:24)
    4. Tom Pantelis points out that this means it’s very hard to to upgrades, which is something that he cares about and things the project as a whole should worry about (colindixon, 16:19:04)
    5. rovarga says that in his mind, getting migratoin to work in code is going to be hard, but instead we need some kind of migration script and an integration test to check it (colindixon, 16:19:43)
    6. the key issue seems to be that there is a conflict between stored config and initial config and resolving it is painful… (colindixon, 16:22:10)
    7. icbts talks about how karaf features configs work in general, and the claim is that they work by watching the /etc config files and changing it for features (colindixon, 16:29:34)
    8. icbts points out some more details about how karaf works (see the full logs for some more details) (colindixon, 16:32:51)
    9. Tom Pantelis points out that part of the problem is that we’re conflating wiring with more traditional config, the wiring part being in the config and thus not redone on upgrade is what’s causing the problems, while traditional config seems to have sane solutions (colindixon, 16:34:49)
    10. there is some agreement that we have (at least) 3 layers of config: *developer* done when code is built, *packager/system integrator* done when assembling different parts, and *user* done once it’s installed and running (colindixon, 16:38:47)
    11. the key issue is that we don’t have differnet ways to manage these parts of the config with different lifecyles even though they cleary have different lifecycles (colindixon, 16:40:45)
    12. for example, when upgrading, you might want to “blow away” the developer and packager config so that it’s reloaded, but you want to keep (or migrate) the user config (colindixon, 16:41:49)

  3. allowing for upgrade from Helium to Lithium (colindixon, 16:46:52)
    1. Tom Panteils, Tony, LuisGomez and others talk about how to do an upgrade from running Helium to running Lithium (via a reboot) (colindixon, 16:47:31)
    2. Tony asks about upgrading from Karaf 3.0.1 to 3.0.3 and icbts says you stop Karaf and lay down the new files over it and reboot (colindixon, 16:48:23)
    3. Tony says the specific bug (2976) should be fixable in Lithium pretty easily by RC0 (colindixon, 16:50:44)
    4. for migrating from Helium to Lithium will likely involve setting up an integration test and then ask invididual projects to provide scripts to upgrade the config files as appropriate (colindixon, 16:52:46)
    5. ACTION: colindixon to raise a bug about Helium to Lithium migration and schedule time on the TSC (and maybe TWS) discuss this (colindixon, 16:56:18)
    6. ACTION: colindixon and LuisGomez to touch base about how to reach out to projects in general about upgrading (colindixon, 17:02:08)


Meeting ended at 17:04:58 UTC (full logs).

Action items

  1. colindixon to raise a bug about Helium to Lithium migration and schedule time on the TSC (and maybe TWS) discuss this
  2. colindixon and LuisGomez to touch base about how to reach out to projects in general about upgrading


Action items, by person

  1. colindixon
    1. colindixon to raise a bug about Helium to Lithium migration and schedule time on the TSC (and maybe TWS) discuss this
    2. colindixon and LuisGomez to touch base about how to reach out to projects in general about upgrading


People present (lines said)

  1. colindixon (37)
  2. icbts (18)
  3. odl_meetbot (5)
  4. tbachman (0)
  5. rovarga (0)


Generated by MeetBot 0.1.4.