#opendaylight-meeting: MD-SAL Interest Call

Meeting started by colindixon at 16:07:58 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:08:03)
    1. last week we talked about one bug and then we went into how do the upgrade process (colindixon, 16:09:07)

  2. upgrading (colindixon, 16:12:37)
    1. colindixon says that the he feels like being able to upgrade from Helium to Lithium with somewhat predicitble outcomes at least for “key” projects (colindixon, 16:13:14)
    2. but nobody has stepped forward to do that yet (colindixon, 16:13:24)
    3. tony says that if this is *the* most important thing people can work on it, but it will lower the bug fix rate for other critical fixes (colindixon, 16:14:06)
    4. colindixon says that if the implication is that we will not be able to fix all the critcal bugs by the time Lithium ships, that’s a different problem (colindixon, 16:16:11)
    5. tony says that’s not necessarily true, but his experience is that between RC0 and RC1 he expects to see a lot of blocking bugs (colindixon, 16:16:43)
    6. ACTION: colindixon to keep discussion about upgrading going on the mailing list (colindixon, 16:16:56)
    7. pantelis says one idea would be pushing this support for upgrading from Helium to Lithium to being a Lithium-SR1 feature (colindixon, 16:18:43)
    8. tony says first things first, we need to do the Karaf upgrade and the controller and from that we’ll have a better idea of what other projects might have to care about (colindixon, 16:19:27)
    9. pantelis asks if we can ask projects to enumerate what they think their upgrade issues are, e.g., data model changes, config yang changes, etc. (colindixon, 16:20:20)
    10. ACTION: colindixon to find a place on the wiki/bug to track progress as we discover the scope and issues (colindixon, 16:20:53)
    11. https://bugs.opendaylight.org/show_bug.cgi?id=3160 this is the bug in question (colindixon, 16:20:58)

  3. how/when are bugs closed (colindixon, 16:22:05)
    1. catohornet asks when/how are bugs closed? should we update them during the meeting? (colindixon, 16:22:18)
    2. tony says that, in general, older bug number it’s something which is deemed to be “easy” and/or less critical to the release (colindixon, 16:26:38)
    3. two bugs that are easy for people are: 568 and 1510 (colindixon, 16:27:44)
    4. more complex ones, but still easier than most are the restconf ones that are somewhat less involved (colindixon, 16:29:02)

  4. bug scrub (colindixon, 16:29:05)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=2970 is critical, and will we worked on Tony, Robert, Moiz or pantelis (colindixon, 16:30:37)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=2521 - SImple, mentor Vaclav Demcak or Tony Tkacik (ttkacik2, 16:35:19)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=2816 - Restconf or Yangtools yang-data-codec-gson - throw correct exception - simple one (ttkacik2, 16:37:24)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=2819 - Simple, just proper log / report exception in controller/netconf (ttkacik2, 16:40:02)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=2375 - Trivial if Tony Tkacik is mentor - it is just introduction of caching to one operation (ttkacik2, 16:51:46)
    6. Mentor : Tony Tkacik <ttkacik@cisco.com> ttkacik[0-9]? on IRC (ttkacik2, 17:22:04)


Meeting ended at 18:18:00 UTC (full logs).

Action items

  1. colindixon to keep discussion about upgrading going on the mailing list
  2. colindixon to find a place on the wiki/bug to track progress as we discover the scope and issues


Action items, by person

  1. colindixon
    1. colindixon to keep discussion about upgrading going on the mailing list
    2. colindixon to find a place on the wiki/bug to track progress as we discover the scope and issues


People present (lines said)

  1. colindixon (26)
  2. odl_meetbot (5)
  3. ttkacik2 (5)
  4. catohornet (1)


Generated by MeetBot 0.1.4.