16:08:02 <colindixon> #startmeeting MD-SAL interest call
16:08:02 <odl_meetbot> Meeting started Tue Jun 16 16:08:02 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:08:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:08:02 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:08:07 <colindixon> #topic yang extensions bug
16:08:38 <colindixon> #info shaleen saxeena says he’s run into a bug with parsing yang extensions
16:10:22 <colindixon> #info shaleen asks if there’s a test case he can modify to try to check how things work
16:11:01 <colindixon> #info ttkacik says that he suggests looking at yang-parser-impl
16:11:07 <colindixon> #topic new bug states
16:11:30 <colindixon> #info greg hall says that he’s in the process of gettina MORE_INFO_NEEDED bug state
16:12:15 <colindixon> #info he also suggests that we turn off the automatic state for CONFIRMED, and we’d like like to make things land in the UNCONFIRMED state so that we can better do triage
16:12:27 <colindixon> #info ttkacik says as long as we can do that for the controller and yangtools without affecting other projects, we should
16:13:02 <colindixon> #action greg hall will file a ticket now to make that change assuming that we can do it only for controller, mdsal, netconf, and yangtools
16:13:36 <colindixon> #toplc Lithium-blocking bugs
16:13:46 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675
16:14:10 <colindixon> #info it looks like there are no Lithium-blocking bugs in controller/yangtools
16:14:38 <colindixon> #topic questions about NETCONF
16:15:06 <colindixon> #info catohornet says that internally she’s trying to use PUT in Ltihium and finding that it doesn’t work
16:16:00 <colindixon> #info ttkacik says that it depends, there was a bug in Helium and it was fixed and if you were exploiting that behavior, it might not work in Lithium despite working in Helium
16:16:39 <colindixon> #info ttkacik says that PUT didn’t behave in Helium like it was defined in the spec
16:17:03 <colindixon> #action catohornet will provide more details
16:17:07 <colindixon> #undo
16:17:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1b6fb90>
16:17:15 <colindixon> #action catohornet will provide more details about how PUT is failing with NETCONF in Lithium
16:17:52 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-June/009557.html the mail with bugzilla queries
16:23:19 <hideyuki> ttkacik:   Could you give me links to documents which explains "faster data change APIs" of MD-SAL?
16:38:31 <colindixon> #topic topics for the Design summit
16:39:37 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-June/009683.html thread on the topic
16:43:28 <ttkacik> hideyuki: I am not sure if there is tutorial / explanation for them yet
16:43:40 <ttkacik> hideyuki: but openflow plugin is using them
16:45:04 <hideyuki> ttkacik: I see.
16:45:30 <hideyuki> ttkacik: Could you give me the package name or class names of the APIs?
16:46:18 <colindixon> #topic cookies
16:46:22 <colindixon> #endmeeting