#opendaylight-meeting: MD-SAL interest call

Meeting started by colindixon at 16:01:27 UTC (full logs).

Meeting summary

  1. agenda bashing (colindixon, 16:01:30)
    1. topic today is to cover the migration from inventory to topology and then possibly to a new topology model (colindixon, 16:03:17)
    2. https://github.com/opendaylight/controller/blob/master/opendaylight/model/model-inventory/src/main/yang/opendaylight-inventory.yang inventory model (colindixon, 16:04:30)
    3. https://github.com/opendaylight/yangtools/tree/master/model/ietf/ietf-topology/src/main/yang the “current” topology models (colindixon, 16:05:24)
    4. https://git.opendaylight.org/gerrit/#/c/23735/ the change that would add the “new” topology model (colindixon, 16:05:44)

  2. background (colindixon, 16:07:59)
    1. ttkacik says that since the beginning of OpenDaylight we have had two models: inventory and topology, many people used the inventory model becasue it more closesly matched the AD-SAL (among other things) (colindixon, 16:09:17)
    2. over time we’ve found that the topology model is more interesting, rich and useful, e.g., we have multiple topologies which can be (but don’t have to be) overlays or underlays of each othe (colindixon, 16:11:48)
    3. it also turns out that the network topology model is expired (the draft which proposed it) and the new model is substantively differnet with two parts (colindixon, 16:13:35)
    4. look above for links (colindixon, 16:13:47)
    5. the new one has two parts: (a) the network model which is close to our inventory and (b) the topology model which adds in links and terminate points (colindixon, 16:14:42)
    6. vishnoianil_ says so right now we have two models for topology: one which is expired and another which is not yet approved, should we worry about that? (colindixon, 16:15:21)
    7. rovarga_ and ttkacik say that even RESTCONF isn’t standardized yet (colindixon, 16:15:34)

  3. planning for the migration (colindixon, 16:15:46)
    1. vishnoianil_ asks where they should migrate in the openflow plugin: should they move to the expired draft or the new I2RS-based draft? (colindixon, 16:16:17)
    2. rovarga_ says his take is that because the expired draft is used nearly everywhere in ODL, it might make the most sense to move to the expired draft first (colindixon, 16:16:56)
    3. in part this is because he thinks the topology processing framework project might be able to help with migration from one topology model to the next (colindixon, 16:17:23)
    4. abhijitkumbhare asks if it would be easier for everyone to migrate to the new model (colindixon, 16:17:59)
    5. rovarga_ says that just has the risk that moving *everyone* (inventory and topology) users would be a bigger undertaking than just moving the inventory folks (colindixon, 16:18:34)
    6. colindixon notes that since we will have to support the deprecated models, if we moved through the expired draft model, it would (potentially) incerase the number of compatibility translators we’d need (colindixon, 16:21:14)
    7. Michal Polkorab says that the OpenFlow plugin already have some code which helps to merge the data from inventory into the topology as well (or vice versa) (colindixon, 16:23:13)
    8. rovarga_ and ttkacik note that this is easy if you use groupings since you just augment the models to inject (the same) groupings in both places (colindixon, 16:23:49)
    9. it sounds like there’s some tricks that are being done for topology processing frame work to semi-automate the translation (colindixon, 16:24:12)
    10. vishnoianil_ says that he worries a little bit about the appearance of ODL continously deprecating things, so if we know where we want to be, we might as well corectly signal how we’re going to move (colindixon, 16:25:51)
    11. colindixon says if we’re sure that we’re going to deprecate the expired draft, maybe we should do it *now* so that we can best signal to people what we’re planning to do (colindixon, 16:28:44)
    12. rovarga_ says he mostly agrees, but likes to avoid deprecating things until there is an alternative with a migration plan (which we don’t really have right now) (colindixon, 16:29:18)
    13. abhijitkumbhare asks if we have a comparison of the 2-3 options we’re talking about (colindixon, 16:29:41)
    14. rovarga_ says we don’t really have one right now, and he’s not sure we have the cycles to do it (colindixon, 16:29:53)
    15. colindixon previously noted that there are two orthogonal questions here: (a) what APIs we mark as deprecated and eventaully phase out and when and (b) what models we internally use as backing implementations (colindixon, 16:31:23)
    16. this is becuase we have to make translators for backward compatibility anyway (colindixon, 16:31:50)

  4. internal vs. external consumers of our APIs (colindixon, 16:33:28)
    1. colindixon asks if we have a list of who’s using the topology and inventory APIs (at least internal projects) (colindixon, 16:33:54)
    2. moiz asks what about external conusmers (colindixon, 16:34:53)
    3. colindixon notes that we have committed to provide the same APIs for at least a whole release as deprecated before we can remove it (and even then, we don’t have to remove it immediately) (colindixon, 16:37:31)

  5. developer effort of migrating (colindixon, 16:37:46)
    1. people ask how long migration would take (colindixon, 16:37:57)
    2. colindixon says that his guess would be about a week of effort to inject the same augmentations into topology as well as inventory and then change which ones you populate (colindixon, 16:38:26)
    3. vishnoianil_ also notes that migration integration tests will be some work (colindixon, 16:38:35)
    4. there’s also a note about that assumes using the topology processing framework for automated populating of multiple models with the given augmentations (colindixon, 16:39:00)
    5. ACTION: colindixon will produe a list of what projects are using these models so that we can use that inform our decisions (colindixon, 16:40:19)
    6. ACTION: colindixon to add this as (at least a 5 minute) topic on the TWS next week (colindixon, 16:40:35)

  6. questions going forward (colindixon, 16:44:38)
    1. we WILL deprecate inventory in Be (colindixon, 16:44:46)
    2. it’s unclear if we we will depcrate the expired draftt model for network-topology (colindixon, 16:45:50)
    3. in theory we coudl deprecate it as late as M4, but that might be mean (colindixon, 16:46:14)
    4. the second set of questions is how our implementation works (colindixon, 16:47:16)
    5. it sounds like plan A is for the topology processing framework to provide tooling to make it easy to provide translators that copy data between multiple such models (colindixon, 16:48:42)
    6. this would make the choice of what model to base your implementation on somewhat a project-by-project issue (colindixon, 16:49:20)
    7. rovarga_ notes that there will be performance implications if a cosumer reads from/writes to a different model than an implemenation is based in (colindixon, 16:49:47)
    8. each project would still need to decide which model to base themselves on, when to move, and how to communicate the move with any implications to their consumers (colindixon, 16:50:42)

  7. openflow plugin (like the most affected proejct here) (colindixon, 16:51:38)
    1. colindixon asks michal and abhijitkumbhare what they’re leaning towards (colindixon, 16:52:12)
    2. abhijitkumbhare says they’ll need to talk about it internally (colindixon, 16:52:21)
    3. abhijitkumbhare says there is a meeting tomorrow at 8a pacific for the OpenFlow plugin and they’ll plan to discuss this there (colindixon, 16:53:39)
    4. ACTION: abhijitkumbhare to email odl-casey to set up a one-off webex for 8a pacific tomorrow (colindixon, 16:54:55)

  8. IETF standardizations (colindixon, 16:56:13)
    1. vishnoianil_ asks how long does it take for a IETF draft to become official (colindixon, 16:56:38)
    2. rovarga_ and ttkacik say this part has been going on for 3 years (colindixon, 16:56:49)
    3. rovarga_ says the stateful PCEP took 5 years (colindixon, 16:57:16)
    4. colindixon notes that we have think about how and when we adopt changest from upstream organizations and have some ideas why we do what we do (colindixon, 16:59:40)


Meeting ended at 17:00:33 UTC (full logs).

Action items

  1. colindixon will produe a list of what projects are using these models so that we can use that inform our decisions
  2. colindixon to add this as (at least a 5 minute) topic on the TWS next week
  3. abhijitkumbhare to email odl-casey to set up a one-off webex for 8a pacific tomorrow


Action items, by person

  1. colindixon
    1. colindixon will produe a list of what projects are using these models so that we can use that inform our decisions
    2. colindixon to add this as (at least a 5 minute) topic on the TWS next week


People present (lines said)

  1. colindixon (71)
  2. odl_meetbot (8)
  3. hideyuki (2)
  4. rovarga_ (0)
  5. phrobb- (0)


Generated by MeetBot 0.1.4.