#opendaylight-meeting: MD-SAL interest call

Meeting started by colindixon at 16:04:24 UTC (full logs).

Meeting summary

  1. agenda (colindixon, 16:05:49)
    1. Stephen Kitt's e-mail on what happened this week in code (colindixon, 16:06:17)
    2. Real world NETCONF device in Beryllium (colindixon, 16:06:26)
    3. Jersey Upgrade: Bug 4502 odl-tsdr-cassandra-persistence depends on non-odlparent guava version (colindixon, 16:06:40)

  2. jersey upgrade (colindixon, 16:06:48)
    1. rgouiding found a bug with guava/cassadra versions in TSDR making upgrading jersery hard, he's working on it (colindixon, 16:07:32)
    2. version missmatch (on guava) when installing the feature, may require upgrading the cassandra plugin (colindixon, 16:07:59)
    3. it's delaying the jersey upgrade (colindixon, 16:08:14)

  3. stephen kitt's weekly summary of code changes (colindixon, 16:10:57)
    1. https://lists.opendaylight.org/pipermail/dev/2015-October/001333.html (colindixon, 16:11:19)
    2. two things for YANG tools seem maybe relevant (colindixon, 16:11:37)
    3. 1. Leaf references no longer have a default value, as per RFC 6020. (colindixon, 16:11:53)
    4. 2. Mis-matched module/submodule revisions no longer cause a NullPointerException (but you should still fix the revisions!). (colindixon, 16:12:17)
    5. rovarga says that (1) above was removing pre-hydrogen code that didn't completely work and thus people couldn't have been using it (colindixon, 16:13:34)

  4. real world NETCONF devices aren't mounting in Berryllium (colindixon, 16:15:09)
    1. ghall says that he's working with a lot of people who are using ODL to mount NETCONF devices to call RPCs, etc. and write apps using that (colindixon, 16:15:54)
    2. ghall is running into issues that real devices that claim to support NETCONF don't always follow the spec perfectly, and even when they do sometimes interpret the spec the same way that ODL does (colindixon, 16:16:30)
    3. ghall says he'd like to see us be tolerant of non-strict yang (colindixon, 16:16:45)
    4. https://lists.opendaylight.org/pipermail/netconf-dev/2015-October/000066.html thread on the netconf-dev list raising this issue (colindixon, 16:17:12)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=4492 this is the related bug (colindixon, 16:19:06)
    6. ghall and maros seem to be saying having a passthrough to get the data back from a NETCONF device without parsing it (at least strictly) assuming we can mount it (colindixon, 16:20:05)
    7. rovarga asks how this would work for things other than RESTCONF, e.g., reading from Binding Aware types (colindixon, 16:22:53)
    8. rovarga notes that there are individual ways to to fix up individual models and that might be a better overall way to approach things (colindixon, 16:23:28)
    9. https://git.opendaylight.org/gerrit/#/c/28511/ a (partial) patch to start fixing some of the issues (colindixon, 16:25:18)
    10. ghall is looking for a way to mount semi-compliant devices in the Beryllium time-frame, e.g., we should try to parse and deliver what data we can (maybe dropping just the yang which is invalid) (colindixon, 16:26:42)
    11. ghall says that in this case and many other cases this is clearly a bug with vendor code, in the idea world we would file the bug, get the bug fixed, and then end-users would upgrade before testing or using it with opendaylight (colindixon, 16:29:35)
    12. ghall says in the real world, that's not going to happen and we should figure out how much we want to inconvenience end-users who happen to have devices that aren't totally supporting NETCONF to the same strictness that OpenDaylight does (colindixon, 16:30:41)
    13. ghall says in practice this is causing him additional problems with values on a device being set outside their range in the YANG file (colindixon, 16:31:15)
    14. colindixon suggests that a good litmus test would be to ask "are we unnecessarily punishing end-users for their vendors poor behavior?" (colindixon, 16:33:37)
    15. if the answer is yes, then we should do our best to avoid doing that (colindixon, 16:33:51)
    16. it seems like at least allowing a user to choose (globally, per-model, per-something-else?) whether to allow for sloppy vs. strict enforcement so that they can do what a manually constructed NETCONF call could do would be a maybe a reasonable approach (colindixon, 16:37:33)
    17. ghall notes that right now in his day-to-day development effort he's able to do things with ncclient and get his work done there in a way he can't with NETCONF mounts in ODL (colindixon, 16:38:21)
    18. the discussion seems to revolve around the issue that if we allow sloppy mounting for devices, that potentially risks how apps and users perceive the system by compromising the strictness which the MD-SAL currently provides (colindixon, 16:39:27)
    19. ttkacik and rovarga ask if we allow a get-config to work despite not parsing strictly, will we allow a edit-config to allow for them to pass the same data back? (colindixon, 16:41:07)
    20. ghall says that he doesn't quite understand why we're even parsing when we make RESTCONF calls to YANG mounts (colindixon, 16:41:28)
    21. ttkacik says that's not quite true, you have to parse it to provide RESTCONF features, e.g., converting to JSON (colindixon, 16:41:56)
    22. ghall asks if we were asking for XML and XML only, could we allow for just a passthrough, ttkacik says yes, but that might confuse users by not allowing for RESTCONF JSON (colindixon, 16:42:40)
    23. colindixon says his take is that we're really talking about having a way to do a sloppy mount over NETCONF and provide the information to anyone who wants that it's a sloppy mount and could provide a reasonable trade-off between device compatibly and user/app expectations (colindixon, 16:46:23)
    24. rovarga says that this should all be doable today in the NETCONF project if we wanted to, he'd want to make sure that we track what things we've violated in the process of doing a sloppy mount (colindixon, 16:47:01)
    25. colindixon disagrees that we necessarily need a list of violations to have it be useful, a simple sloppy bit would be enough, but he's willing to agree to disagree (colindixon, 16:50:45)
    26. ghall says he'd like to work on this at the hackfest 11/9 and 11/10 (colindixon, 16:52:57)
    27. rovarga asks if he can move BUG 4492 to the netconf project instead of yangtools, his take is that the issues raised can be fixed there (colindixon, 16:53:27)
    28. ghall says sure "as longs as we're happy returning a supposedly mounted, but useless NETCONF devices on an NPE" (colindixon, 16:54:33)
    29. ghall says basically there are still bugs in YANG tools to at least provide more meaningful error messages (colindixon, 16:56:11)
    30. ACTION: ghall to rework his patch to allow for better errors and/or better mounting in YANG tools (colindixon, 16:59:14)

  5. hackfest (colindixon, 16:59:18)
    1. ghall asks who from the MD-SAL core team will be there (colindixon, 16:59:33)
    2. none planning to come now (colindixon, 16:59:45)
    3. colindixon asks what would help them attend, rovarga asks for a concrete agenda and work items (colindixon, 17:00:07)
    4. ACTION: phrobb to work with rovarga and ghall and others to develop a better agenda (colindixon, 17:00:31)


Meeting ended at 17:00:34 UTC (full logs).

Action items

  1. ghall to rework his patch to allow for better errors and/or better mounting in YANG tools
  2. phrobb to work with rovarga and ghall and others to develop a better agenda


People present (lines said)

  1. colindixon (54)
  2. odl_meetbot (4)
  3. phrobb_ (1)


Generated by MeetBot 0.1.4.