16:03:33 <phrobb> #startmeeting nic
16:03:33 <odl_meetbot> Meeting started Fri Jan 30 16:03:33 2015 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:33 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:33 <odl_meetbot> The meeting name has been set to 'nic'
16:04:00 <phrobb> #chair alagalah
16:04:00 <odl_meetbot> Current chairs: alagalah phrobb
16:04:11 <alagalah> happy to help
16:04:21 <phrobb> you're already signed up :-)
16:05:39 <alagalah> #topic project startup logistics
16:06:15 <ShaunWackerly> #link https://wiki.opendaylight.org/view/GettingStarted:Project_Main#New_Project_Checklist
16:06:37 <alagalah> Thanks ShaunWackerly
16:08:50 <phrobb> #chair ShaunWackerly
16:08:50 <odl_meetbot> Current chairs: ShaunWackerly alagalah phrobb
16:09:03 <phrobb> @ ShaunWackerly: no good deed goes unpunished :-)
16:11:14 <alagalah> #info dlenrow discusses various approaches such as 1. RP Lithium - whats achievable 2. Potentially push to Be and focus on the architecture
16:11:23 <alagalah> phrobb: Did I capture that correctly ?
16:11:31 <ShaunWackerly> haha
16:11:45 <phrobb> alagalah:  yes
16:11:47 <ShaunWackerly> Yes, sounds accurate
16:12:09 <phrobb> @ShaunWackerly: your typing is a bit loud, you may want to mute when not talking
16:12:34 <alagalah> #info dlenrow proposes 3 deliverables for Li
16:12:51 <ShaunWackerly> @phrobb: Sorry about that, my headset was muted so I don't know how webex was picking up sound
16:13:05 <alagalah> dlenrow: Should this be a vote ?
16:13:31 <dlenrow> Do we have any voting process or authority at this poijnt?
16:13:47 <phrobb> #info dlenrow asks "should the NIC project consider joining the Li release or should we wait until Beryllium?
16:13:48 <dlenrow> Making up the concensus building process on the fly here
16:14:06 <alagalah> dlenrow: Well there's a voting process... there's nothing that says its binding
16:16:05 <phrobb> #info dlenrow asks for someone to own process of shepherding on the ML and then to a google doc a draft release plan that people can review and comment on (like by Tuesday of next week)
16:17:52 <phrobb> #action uchau duane Mentze volunteer to lead the creation of a  strawman NIC release plan for Li by next Tuesday (2/3)
16:18:57 <gzhao> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan <-- NIC release plan draft
16:19:17 <tbachman> #link https://wiki.opendaylight.org/view/Network_Intent_Composition:Lithium_Release_Plan <-- NIC release plan draft
16:19:25 <tbachman> gzhao: had an extra space there ;)
16:19:48 <phrobb> #dlenrow suggests creating a PoC for intent-based SFC.  In addition a more generalized implementation will be done, but an initial prototype for SFC for early concept evaluation would be a good thing
16:20:11 <gzhao> tbachman: thanks
16:20:15 <tbachman> np!
16:22:09 <phrobb> #info mlemay asks "how can we ensure a reliable end product of code?.. this is bigger than the NIC project
16:22:44 <phrobb> #info dlenrow agrees that ensuring quality is an ODL-wide concern to be addressed
16:23:14 <alagalah> #info uchau suggests we start breaking out into milestones internal from the simultaneous release
16:23:33 <alagalah> #info dlenrow suggests creation of internal project plan
16:24:25 <phrobb> #info dlenrow notes that early on we need a program manager type to stay on top of project internal plans
16:26:03 <phrobb> #info dlenrow asks the group how we will "manage" the NIC project?
16:26:06 <gzhao> hideyuki listed action items in this email https://lists.opendaylight.org/pipermail/nic-dev/2015-January/000068.html
16:27:54 <phrobb> #info uchau recommends Devon Dawson to be the program mgr and the crowd goes wild
16:28:03 <tbachman> phrobb: lol
16:28:11 <tbachman> phrobb: color commentary
16:28:16 <phrobb> :-D
16:28:31 <uchau> phrobb: i think it's more a situation of the crowd all steps back :)
16:28:31 <phrobb> #chair tbachman
16:28:31 <odl_meetbot> Current chairs: ShaunWackerly alagalah phrobb tbachman
16:28:34 <tbachman> :)
16:28:50 <tbachman> uchau: common reaction when looking for leadership :o
16:28:52 <tbachman> lol
16:29:02 <tbachman> “not it”
16:29:02 <phrobb> uchau:  I wanted Devon to feel proud when he reads the minutes :-)
16:29:15 <alagalah> #info dlenrow asks if folks want to edit a UML model in the team meeting or do it offline ?
16:29:17 <uchau> :)
16:29:58 <tbachman> #info mlemay says he’d like to discuss the architecture before going into the UML
16:30:19 <tbachman> #info mlemay would do this discussion through various collaboration tools (google hangout, docs, etc.)
16:30:23 <gzhao> uchau: so you will take the action that ask Devon to send email to nic-dev to volunteer to be PL role?
16:30:33 <phrobb> #info mlemay suggests discussing the overall architecture before putting too much into UML.
16:30:38 <tbachman> #info dbainbri asks what mlemay means by arch
16:30:39 <uchau> yes
16:30:58 <tbachman> #action uchau to ask Devon to send email to nic-dev volunteering for PL role
16:31:15 <phrobb> tbachman:  now on chair means I no longer type fast enough :-)
16:31:26 <tbachman> phrobb: lol!
16:31:56 <gzhao> I would suggest dlenrow to be project contact, since he is the one to glue everyone together for this project
16:31:58 <tbachman> #info ShaunWackerly says that once we figure what the APIs are, we can work on the implementation behind that interface
16:32:38 <tbachman> #info mlemay says that some folks at the intent summit talked about DSL or process ID or languages vs. API — something that’s more run-time processing language (“maple-ish”). There are different approaches on what the NBI should be
16:33:03 <tbachman> #info fschneider says that clarity on multiple levels of info modeling behind data is important before fixing functional blocks in between
16:33:28 <tbachman> #info dlenrow asks if there’s a middle ground on this
16:34:04 <tbachman> #info ShaunWackerly asks if the runtime language is in the gdoc that Cathy sent out
16:34:23 <tbachman> #info mlemay says he doesn’t know if that was captured, but he knows some folks talked about it (ESNet, et. al.).
16:34:47 <tbachman> #info dlenrow says the maple folks weren’t able to present at the Intent summit — maybe can invite them to speak at this meeting
16:35:14 <tbachman> #info mlemay says coming up with the proper primitives and how to provide a proper runtime set of functionality for these primitives
16:35:34 <tbachman> #info The primitives can be pushed down into a more formal model of a service request within the controller
16:35:46 <tbachman> #info mlemay says group can continue with UML model if they want
16:36:06 <tbachman> #info dlenrow asks mlemay to take a first whack at the straw-man/block-diagram
16:37:04 <tbachman> #info fschneider asks if we can agree on one meeting to drive this forward (ONF vs. this one)
16:38:54 <tbachman> #info dlenrow says another thought is that the ONF and similar organizations are good at use case documentation, and ODL is good at building stuff. Given that, what do folks think of take the info modeling work and use one of the ONF/NBI calls as an interactive session for the  info model, and save this call for arch/implementation.
16:39:36 <tbachman> #info ShaunWackerly didn’t kown there was an ONF meeting on this subject; asks if dlenrow can forward the information for the ONF meeting
16:40:23 <tbachman> #info dlenrow says he’s chair of the NBI working group, which has several sub-groups, is working on making this accessible
16:41:45 <tbachman> #info uchau says as long as we have one forum where we’re pulling things in — we just want to make sure we have a place where we consolidate the arch with the implementation
16:41:56 <tbachman> #info uchau recommends using the ODL NIC meeting to pull it all together
16:45:35 <ShaunWackerly> Devon's email address is devon.dawson@hp.com
16:47:58 <phrobb> #info colindixon asks if the purpose of the Li release plan is to identify a model that can be understood by other projects with other feature aspirational, is that the plan?
16:49:01 <alagalah> #info alagalah asks if there are any IPR rules with using the ONF as a forum to develop IP
16:49:58 <phrobb> #info dlenrow notes that the release plan does not require specific features.  colindixon notes that the plan does need to call out features that could be leveraged by other projects and it will important to put those in the plan for Li
16:50:01 * tbachman watches colindixon stand up JJB for NIC, real-time :)
16:50:07 <colindixon> :-)
16:50:14 <tbachman> #manofaction
16:50:17 <tbachman> your new tagline
16:50:18 <tykeal> the merge is happening now ;)
16:51:41 <phrobb> #info dlenrow suggests that we have Devon act as the project contact at least until a PTL is elected
16:53:59 <phrobb> #info colindixon notes that if we want to be an offset-2 project and "keep up", we may want to tease out what is a "must" for the release plan and get that down on release plan.  Any additional items can be on the internal NIC action plan and not in the release plan.  That way we minimize the tasks for the Li release plan
16:54:42 <alagalah> #info colindixon states that a goal maybe to provide functionality to other projects
16:54:43 <dbainbri> there is a question on chat about IPR and development using ONF forum
16:55:41 <phrobb> dbainbri:  which chat?
16:55:53 <dbainbri> this one, from alagalah
16:56:06 * gzhao saw JJB set up for nic :)
16:56:06 <dbainbri> it was #info-ed
16:56:12 <dbainbri> (alagalah asks if there are any IPR rules with using the ONF as a forum to develop IP)
16:56:14 <phrobb> alagalah:  that's an interesting question.
16:57:28 * phrobb raises hand to ask alagalah's question on IPR to the voice call
16:58:28 <ShaunWackerly> anyone: What is IPR?
16:58:37 <tbachman> Intellectual Property
16:58:38 <phrobb> Intellectual Property rights
16:58:40 <ShaunWackerly> ah
16:58:45 <ShaunWackerly> thanks!
16:59:43 * tbachman notes that colindixon’s binary exponential backoff is very efficient :)
17:02:33 <phrobb> #action phrobb to work with Rick Bauer of ONF to discover any IPR topics that need to be addressed on the NIC work and it's relationship to ONF
17:03:07 <tbachman> #endmeeting