18:00:55 <phrobb> #startmeeting TSC
18:00:55 <odl_meetbot> Meeting started Thu Jan  8 18:00:55 2015 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:55 <odl_meetbot> The meeting name has been set to 'tsc'
18:01:17 <dlenrow> #info dlenrow
18:01:26 <phrobb> #topic rollcall TSC members please #info in
18:01:33 <colindixon> #info colindixon
18:01:38 <dlenrow> #info dlenrow
18:01:46 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda agenda in it’s normal place
18:01:55 <phrobb> #chair colindixon tbachman gzhao
18:01:55 <odl_meetbot> Current chairs: colindixon gzhao phrobb tbachman
18:01:59 <dneary> Hi all
18:01:59 <tbachman> :)
18:02:09 <colindixon> oooooh it’s a tbachman
18:02:11 <dfarrell07> huzzah @ tbachman being back :D
18:02:13 <tbachman> lol
18:02:25 <mohnish> #info mohnish anumala
18:02:34 <kwatsen> #info kwatsen
18:02:40 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-12-18-17.57.html minutes from last TSC meeting
18:02:52 <tykeal> we're not worthy to be scribes in your absence tbachman ;)
18:02:55 <colindixon> #action colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
18:03:01 <edwarnicke> #info edwarnicke
18:03:02 <tbachman> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda link to TSC agenda
18:03:05 <tbachman> tykeal: lol!
18:03:09 <jmedved> 3info jmedved
18:03:14 <jmedved> #info jmedved
18:03:15 <tbachman> jmedved: try again ;)
18:03:15 <dfarrell07> cdub is traveling, idk if he'll be able to join, he hasn't appointed me to stand in (idk if he talked to shague? flaviof?)
18:03:17 <tbachman> :)
18:03:20 <phrobb> #chair dfarrell07
18:03:20 <odl_meetbot> Current chairs: colindixon dfarrell07 gzhao phrobb tbachman
18:04:11 <jmedved> tbachman: my typing skills deteriorated over the Christmas break from an already low level :-(
18:04:15 <tbachman> #info edwarnicke asks if autorelease should be on the agenda
18:04:40 <tbachman> #info colindixon says there was an email to the list, and since autorelease wasn’t creating artifacts for itself, it didn’t need to participate in the release
18:04:52 <zxiiro> I agree, autorelease doesn't have artifacts to ship so I don't think officially needs to participate in a simultanious release train
18:04:56 <ShaunWackerly> #info ShaunWackerly
18:05:08 <dfarrell07> #info phrobb looked into non-project wikis, didn't find many, looks pretty good
18:05:09 <tbachman> ShaunWackerly: are you a TSC member?
18:05:23 <colindixon> #action colindixon will send mail about encouraging projects to get projects tracking what happens in the TSC
18:05:27 <tbachman> fwiw, the #info’s with names are meant to track the TSC chairs taht are in attendance
18:05:34 <ShaunWackerly> No, I assumed I was supposed to type #info. My mistake. I heard Colin mention "infoing in"
18:05:43 <tbachman> ShaunWackerly: no worries :)
18:05:47 <colindixon> #action colindixon will track how VTN and controller are interacting on possible AD-SAL deprecation
18:06:08 <jmedved> right
18:06:22 <tbachman> #info edwarnicke says that there’s been ongoing confusion about the  neutron service — it’s no longer an AD-SAL service
18:06:26 <dlenrow> tbachman: I thought anyone could become a TSC member by typing "#info" :)
18:06:43 <colindixon> dlenrow: :-)
18:06:49 <tbachman> dlenrow: lol!
18:07:04 * tbachman has rusty fingers
18:07:09 <alagalah> ShaunWackerly: Can you go on mute?
18:07:12 * tykeal realizes that his phone (voip) had disconnected with out realizing it (it was too quiet!)
18:07:39 <alagalah> ShaunWackerly: Thanks mate
18:07:43 <gzhao> zxiiro: we still need approval for autorelease to create those infrastructures, I agree that auto-release doesn't need to participate SR.
18:08:04 <zxiiro> gzhao: that's right
18:08:20 <tbachman> #info colindixon says the SR1.1 security release was announced
18:08:32 <ShaunWackerly> alagalah: I have been muted since I joined the call ...
18:08:33 <tbachman> #info cdub created a secuity mailing list discussion
18:08:47 <alagalah> ShaunWackerly: Weird, it kept popping up with your name
18:08:57 <alagalah> (meaning it was picking up your audio somehow)
18:09:14 <LuisGomez> #info LuisGomez
18:09:30 <tbachman> colindixon: negative
18:09:38 <RajeevK> Rajeev is here
18:09:47 <RajeevK> #info
18:09:59 <RajeevK> #info RajeevK
18:10:02 * tbachman sees an anees :)
18:10:07 <ShaunWackerly> Should I leave the irc channel and then join back in, so I'm not info'ed in?
18:10:10 <regXboi> #info regXboi
18:10:15 <tbachman> ShaunWackerly: no, that’s fine
18:10:16 <colindixon> ShaunWackerly: no worries
18:10:17 <regXboi> #info <running late>
18:10:18 <tykeal> ShaunWackerly: it won't matter ;)
18:10:19 <tbachman> you’re good :)
18:10:31 <ashaikh> whenever i can :-)
18:10:41 <regXboi> ashaikh: yo!
18:11:19 <gzhao> can we add autorelease to review if time permits to agenda
18:11:36 <tbachman> gzhao: colindixon added it, we’ll try to get to it
18:11:41 <tbachman> #topic updates
18:11:48 <gzhao> tbachman: thanks
18:11:53 <tbachman> gzhao: np!
18:12:11 <Youcef> #info Youcef Laribi
18:12:11 <dfarrell07> #info Currently in the CFP period for ODL Summit, closes at end of Feb
18:12:13 <tbachman> #info phrobb says we’re in the middle of CFP for the ODL summit - closes at the beginning of Feb (please submit)!
18:12:34 <dfarrell07> #info Hack fest in mid April being looked into by LF, phrobb
18:12:40 <tbachman> #info hackfest on April 14th as we close around M5 — venue possibilities should be available sometime this week
18:12:48 <tbachman> dfarrell07:  you’re too fast! :)
18:13:06 <dfarrell07> tbachman: I for one don't mind the two perspectives on the notes :)
18:13:09 <tbachman> #info phrobb says that we don’t have project ideas for potential interns — please submit ideas ASAP
18:13:41 <tbachman> #info phrobb says they’re working on getting export classification through the govt., and have an outside group going through the code
18:13:57 <tbachman> #info phrobb says there are 6 active projects that have encryption technology in it
18:14:13 <tbachman> #info phrobb is reaching out to those projects
18:14:45 <tbachman> #info phrobb says one of the projects is the netvirt platform (original platform submitted by BigSwitch Networks), which raises the question back to the TSC of whether to archive some code
18:15:06 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/project:net-virt-platform note that it has now been exactly 12 months since there was any commit activity
18:15:06 <dfarrell07> #info phrobb suggests that TSC may need to start thinking about archive projects, like on contributed by Big Switch that has no active committers (but encryption tech)
18:15:30 <tbachman> #info phrobb says another issue related to export is VMs — have to go through all of the source and identify any encryption pieces that require approval for export
18:15:51 <tykeal> it's 1.5 years
18:16:27 * dfarrell07 is surprised that there are such things as export restrictions on encryption
18:16:54 <alagalah> dfarrell07: Oh, indeed
18:17:00 <tbachman> #info The requirement for Termination is no commits in 18 months
18:17:09 <colindixon> #link https://wiki.opendaylight.org/view/InternProjects:Main interns projects
18:17:18 <kwatsen> #info http://www.opendaylight.org/project-lifecycle-releases  (18 months)
18:17:35 <tbachman> colindixon: exact text “Can be initiated by TSC or PMC of containing project if there are either no remaining committers for the project or there have been no commits to the SCM in 18 months"
18:17:42 <gzhao> one minor thing, can we officially remove ODP name or change it to ODL in opendaylight bylaws
18:17:49 <dfarrell07> #info No updates from LuisGomez on Infra and Test
18:18:19 <gzhao> http://www.opendaylight.org/project/bylaws <== bylaws
18:18:25 <tbachman> #info gzhao says that the stable/helium 2.0 is taking over 2hrs, and therefore isn’t available for approval on today’s TSC call
18:18:32 <hideyuki> A test of BGPCEP project stalls.
18:19:40 <tbachman> #info colindixon says we should consider moving the stable/helium release out by a week
18:20:10 * tbachman senses a TSC vote
18:20:33 <tbachman> (and steps out of the way for phrobb to queue such things up)
18:20:43 <dfarrell07> #info gzhao suggests bumping two weeks, as no urgent bug fixes atm
18:21:32 <tbachman> #agreed The Stable/Helium SR2 date has been moved to January 26, 2015
18:21:33 <dfarrell07> #agreed The SR2 release date has been moved to Jan 26th 2015 (two weeks out)
18:21:45 <tbachman> #topic Infrastructure
18:22:35 <tbachman> #info colindixon says that if you are a project that’s not listed on the Li tracking document, then you should contact gzhao to make sure you’re in that document
18:22:51 <tbachman> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=0 Document for tracking proejcts that are part of the Li simultaneous release
18:22:58 <colindixon> #action gzhao will try to make sure sure the list of participating projects on the wiki matches what people have send to the release list
18:23:19 <tbachman> is it a wiki?  Or that gdoc?
18:23:48 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Participating_Projects the list of participating projects is here on the wiki
18:23:49 <tbachman> edwarnicke: I think colindixon just actioned gzhao for this :)
18:24:24 <gzhao> https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 <== tracking all the projects.
18:24:31 <tbachman> #info The release mailing list is the official record for submitting intention to participate in teh Lithium stable release
18:24:33 <gzhao> I will update wiki page as well
18:24:48 <phrobb> #info sending mail to "release@lists.opendaylight.org" is the official indication of simultaneous release participation
18:24:53 <tbachman> phrobb: thx!
18:25:07 <zxiiro> #link https://lists.opendaylight.org/pipermail/discuss/2014-November/004024.html
18:25:45 <tbachman> #info zxiiro says that sonar uses the artifact ID from the pom that you pass to maven as the name that will appear in sonar
18:26:06 <tbachman> #info zxiiro recommends deciding on a proper naming scheme for these
18:26:27 <tbachman> #info zxiiro provided some ideas for this in the email provided in the link above
18:26:55 <tbachman> #info colindixon says the short names are already guaranteed to be unique, so he recommends using the short names if that makes sense (i.e. repo name)
18:27:42 <tbachman> #info rovarga asks if there’s a way to maintain the history if we rename the projects
18:27:48 <colindixon> #action zxiiro will reach out to projects to rename soar jobs
18:27:58 <tbachman> #action zxiiro to investigate if there’s a way to maintain the history if we rename the projects
18:28:20 <tbachman> #info tykeal says odlforge is still making headway — puppet module has been released to puppet-forge
18:28:33 <tbachman> #info tykeal says odlforge should be up in the next couple of weeks, depending on workload
18:28:50 <tbachman> #topic Creation Reviews
18:29:23 <tbachman> #info colindixon says one creation review (intent) has been posted to the wiki for more than 2 weeks, but the mail to announce it wasn;
18:29:25 <tbachman> #undo
18:29:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2591910>
18:29:45 <tbachman> #info colindixon says one creation review (intent) has been posted to the wiki for more than 2 weeks, but the mail to announce it was within the last week
18:29:58 <dfarrell07> tbachman: mind if I set a more specific topic once we start talking about projects?
18:30:06 <tbachman> dfarrell07: go for it
18:30:12 <dfarrell07> tbachman: thanks :)
18:30:17 <tbachman> dfarrell07: we’re open :)
18:30:21 <rexpugh> rex pugh turned off his PC for vacation before the outbox emptied :(
18:30:30 <rexpugh> on Dec 22
18:32:36 <tbachman> #info colindixon notes that the TSC has made exceptions to projects that are posted beyond the specified date, given the circumstances, and this may fall under that
18:32:54 <tbachman> dfarrell07: queue up your topic ;)
18:33:08 <dfarrell07> #topic Device Identification and Driver Management (DIDM) project creation review
18:33:13 <tbachman> dfarrell07: nice! :)
18:33:31 <dfarrell07> tbachman: have all of them queued up since before the meeting ;)
18:33:37 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Device_Identification_And_Driver_Management project proposal
18:33:49 <tbachman> colindixon: thx!
18:34:00 <mohnish_> edwarnicke: I have updated the wiki page to add lacp and tsdr
18:34:01 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000221.html re-proposed on 12/5/14
18:34:08 <edwarnicke> Many thanks :)
18:34:17 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-October/000176.html originally proposed 10/21/14
18:34:17 <edwarnicke> Also... I seem to have lost your phone number, mine is 919-621-0958
18:34:30 <edwarnicke> wrong window...
18:34:44 <regXboi> edwarnicke: oops
18:35:54 <tbachman> Do we need to provide spectrometer for initial committers?
18:35:57 <tbachman> problaby not, right?
18:36:02 <edwarnicke> regXboi: If there is anyone in odl who *doesn't* have my phone number already, I'd be shocked ;)
18:36:08 <regXboi> :)
18:36:09 <tbachman> edwarnicke: lol
18:36:17 <colindixon> tbachman: what about spectrometer?
18:36:45 <tbachman> initial committers — we don’t need spectrometer for that, right?
18:36:47 <tbachman> Just promotions
18:36:52 <tykeal> tbachman: just promotions
18:36:54 <tbachman> k
18:36:55 <tbachman> thx
18:37:06 <tykeal> I'll make note that spectrometer seems to be broken at present and I haven't figured out why :(
18:37:10 <tbachman> ah
18:37:13 <tbachman> good to know
18:37:17 <tykeal> it's only showing 6 projects
18:37:34 <colindixon> tykeal: it’s only showing 6 projects for reviews
18:37:52 <colindixon> it shows 29 for commmits
18:37:55 <tykeal> colindixon: interesting
18:37:56 <dfarrell07> tykeal: Ignore it and focus on the Forge ;)
18:38:01 <tykeal> lol
18:38:40 <edwarnicke> dfarrell07: Second :)
18:38:54 <colindixon> #info slides will be posted after the call, but see the recording starting around 30 minutes for the start of the slides
18:41:17 <colindixon> #info asks about whether there are other things they want to look at like things UPnP (he says PnP for plug and play, but I think he meails UPnP)
18:41:49 * tbachman had fallen asleep at the wheel
18:42:06 <tykeal> spectrometer lulled you to sleep
18:42:40 <tbachman> lol
18:42:58 <RajeevK> #info wondering if YANG is in scope for device data models
18:43:45 <tbachman> #info alagalah asks if this has any overlap with TTP
18:43:56 <alagalah> tbachman: no I wasn't actually
18:44:04 <alagalah> tbachman: Its how they work together,
18:44:06 <colindixon> #info the core idea of the project is to have a component that tries to identify the kinds of devices by whatever means it can and then note what the device type is along with what you can do with it given the type
18:45:02 <tbachman> #info colindixon says that this is the framework that could take a feature like TTP and do something useful with the information that it got from it
18:45:12 <dfarrell07> colindixon: the agenda has Network Intent Composition marked as proposed on 1/5/2014 (should be 2015). About to change that, FYI
18:45:55 <tbachman> #info sdean778 says they’ll deliver documentation and a sample driver, along with possibly some abstract classes
18:46:18 <colindixon> #info past that, they also want to provide initial drivers that adapt some functionality based on the kind of device
18:46:18 <tbachman> #info sdean778 emphasizes they’re using standard MD-SAL mechanisms to invoke the drivers (RPCs or invoked via data change notifications)
18:46:34 <tbachman> #info sdean778 says identification requires a framework component that orchestrates this process
18:46:52 <tbachman> #info sdean778 says that standard MD-SAL mechanisms could be used for synchronization and driver registration
18:47:12 * tbachman hopes that sdean778 is indeed the Steve Dean that’s presenting :)
18:47:17 <tbachman> dlenrow: on a call ;)
18:47:47 <tbachman> #info dependencies include a credential manager that reuires AAA, and the SNMP plugin project
18:47:53 <colindixon> thanks for all the scribing tbachman
18:48:00 <tbachman> colindixon: np! :)
18:48:10 <tbachman> #info jmedved asks if there are any dependencies on the NETCONF connector
18:48:23 <tbachman> #info sdean778 says they don’t see that for the first phase
18:48:27 <colindixon> #info jmedved asks if there will be dependencies on the netconf connector
18:48:30 <colindixon> #undo
18:48:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2806e10>
18:48:31 <dfarrell07> tbachman: I have all of the #topic, #vote, #agreed and #links for proposal wikis/dates queued up, FYI
18:48:36 <dneary> For those of us who can't see slides on webex, is there a copy of the deck I can download?
18:48:43 <colindixon> dfarrell07: thanks
18:48:47 <tbachman> dfarrell07: you rock!
18:48:48 <dfarrell07> dneary: I haven't found a link
18:49:01 <tbachman> dneary: they weren’t provided ye
18:49:02 <colindixon> dneary: there is no link at the moment, sadly
18:49:02 <tbachman> yet
18:49:09 <dneary> Thanks
18:49:18 <colindixon> dneary: I asked at the beginning, it will be posted later
18:49:29 <dneary> I get the infamous and usual (as of ~4 months ago) error code 31001
18:49:39 <dneary> Dialled in to the bridge, but no visuals
18:49:57 <tbachman> #info There are some MD-SAL enhancement reqeuests: ability to control how much processing is given to a plugin, and finer filter of data change notifications (e.g. only if augmentation equals a specific value)
18:50:13 <tykeal> dneary: I had that on my android tablet at one point and had to reboot it
18:50:24 <edwarnicke> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Lithium:Release_Plan#Requests_from_Other_Projects - please record controller requests so they don't get lost: https://wiki.opendaylight.org/view/OpenDaylight_Controller:Lithium:Release_Plan#Requests_from_Other_Projects :)
18:50:32 <dneary> If I reboot my phone I'll drop off the call :-)
18:50:36 <tbachman> edwarnicke: thx!
18:50:36 <tykeal> lol
18:51:01 <colindixon> edwarnicke: thanks!
18:51:29 <RajeevK> jmedved: +1 on YANG
18:51:41 <colindixon> #info jmedved asks if it makes sense to introduce the feature models being introduced to the IETF to get more peer review
18:51:59 <colindixon> #info sdean778 says he hadn’t thought about it, but it’s an interesting idea
18:52:40 <tbachman> #info dbainbri says they’re planning on adding the MD-SAL enhancements as enhancement requests in bugzilla
18:53:07 <dfarrell07> colindixon: we're at 20 mins right now, fyi
18:53:55 <tbachman> #info colindixon says that the problem with just bugzilla or just the wiki is that there’s no guarantee of bi-directional communication
18:54:25 <tbachman> #info sdean778 says they’ll update bugzilla, update the wiki, and send emails for the feature requests.
18:54:40 <colindixon> #action sdean778 and david bainbridge to list any changes they want from MD-SAL/controller on their project plan, talk via e-mail, and file buzilla bugs
18:54:41 <rexpugh> awesom dr seuss reference
18:55:08 <tbachman> dlenrow: go on mute ;)
18:55:31 * ChrisPriceAB please limit chanting on the call...
18:55:40 <colindixon> ChrisPriceAB: :-)
18:55:41 <tbachman> ChrisPriceAB: lol!
18:56:27 <tbachman> #link https://wiki.opendaylight.org/view/DIDM:Lithium Proposed release plan for DIDM
18:57:04 <tbachman> #info LuisGomez says you may want to consider NETCONF over SNMP, as NETCONF is more mature in ODL
18:57:38 * ChrisPriceAB the challenge would then be external dependencies
18:57:44 <rexpugh> From a deployment standpoint we need to release the SNMP implemementation forst thats why HP resources prioritized it first
18:58:03 <rexpugh> As steve said, would love netconf committers ;)
18:58:04 <dfarrell07> #info LuisGomez makes it clear that he's talking about maturity of ODL projects, no the protocols generally
18:58:13 <dfarrell07> #undo
18:58:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x26956d0>
18:58:16 <abhijitkumbhare> Its good that we have SNMP support being added as well
18:58:16 <dfarrell07> #info LuisGomez makes it clear that he's talking about maturity of ODL projects, not the protocols generally
18:59:18 <tbachman> #info dbainbri says that he’s discussed merging discovery and DIDM projects, but there’s no official policy in ODL for doing this
18:59:50 <tbachman> #info colindixon says that the biggest obstacle here is the committer list
19:00:05 <dlenrow> dear community, Sorry to have broadcast my conversation about getting my son to basketball practice :)
19:00:31 <dfarrell07> dlenrow: lol, it happens, no worries :)
19:00:59 <tbachman> #link http://www.opendaylight.org/project-lifecycle-releases#ProjectTypes Wiki page describing project types and life cycles, including project termination
19:01:08 <edwarnicke> #link http://www.opendaylight.org/project-lifecycle-releases ODL lifecycle, for docs on termination review
19:01:18 <tbachman> (section 2.3.5)
19:01:22 <tbachman> edwarnicke: jinx ;)
19:01:55 <rexpugh> process getting in the way of parcticality
19:02:48 <rexpugh> sorry for the post-holiday poor types-manship
19:03:04 <dfarrell07> #vote Shall the TSC approve the Device Identification and Driver Management (DIDM) project to Incubation? -1, 0, +1
19:03:10 <colindixon> #voite +1
19:03:12 <edwarnicke> #vote +1
19:03:14 <jmedved> #vote +1
19:03:14 <dlenrow> #vote +1
19:03:17 <mohnish_> #vote +1
19:03:17 <RajeevK> #vote +1
19:03:18 <LuisGomez> #vote +1
19:03:18 <tbachman> colindixon: correction
19:03:19 <Youcef> #vote +1
19:03:20 <ChrisPriceAB> #vote +1
19:03:21 <kwatsen> #vote +1
19:03:26 <colindixon> #vote +1
19:03:28 <regXboi> #vote +1
19:03:30 <dlenrow> Colin got the french vote in
19:03:35 <tykeal> lol
19:03:37 <tbachman> dlenrow: lol!
19:03:40 <dfarrell07> #endvote
19:03:45 <dfarrell07> #agreed The Device Identification and Driver Management (DIDM) project is approved to Incubation
19:03:46 <edwarnicke> rexpugh: congratulations! :)
19:03:47 <tbachman> hmmm
19:03:50 <tbachman> endvote didnt work
19:03:53 <dfarrell07> lag
19:03:57 <tbachman> the vote didn’t actuall start
19:04:03 <tbachman> hmmmm
19:04:11 <dneary> dlenrow, The French for "vote" is "vote"
19:04:12 <dfarrell07> is that syntax right?
19:04:17 <dfarrell07> ahhh, sorry!
19:04:28 <rexpugh> sdean778: CONGRATULATIONS
19:04:36 <dfarrell07> #info I messed up #vote syntax, see logs for info
19:04:39 <dlenrow> Well done DIDM team
19:04:49 <tykeal> dfarrell07: '#startvote <vote_question>? <comma_separated_options>' ;)
19:04:50 <dfarrell07> #topic Application-Layer Traffic Optimization (ALTO) project creation review
19:04:51 <mohnish_> sdean778: congrats!
19:05:01 <tbachman> #info DIDM project approved, 12 votes +1, 0 votes 0, 0 votes -1
19:05:02 <dneary> dlenrow, Which must be henceforth pronounced "diddum"
19:05:08 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Alto Project proposal wiki
19:05:16 <tbachman> opos
19:05:18 <tbachman> 11 votes
19:05:20 <tbachman> I can’t count
19:05:24 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000220.html Proposed 12/4/2014
19:05:26 <tbachman> (actually, I counted voite and vote)
19:06:32 <tbachman> #info ALTO is RFC 7285, defines high-level abstractions and services to provide network information to applications
19:06:45 <tbachman> #info It defines an abstract network maps and cost maps
19:06:56 <tbachman> #info It provies a map filtering servie
19:07:05 <tbachman> #info It provides an Endpoint Properties Service
19:07:17 <tbachman> #info It provides an Endpoint Cost Service
19:07:29 <tbachman> #info It provides an Information Resource Directory Service
19:07:32 <gzhao> sdean778: you may want to declare intention to participate Lithium for DIDM
19:07:38 <tbachman> #info additional services such as network graphs are WIP
19:07:52 <tbachman> #info RFC7285 is a RESTful design with JSON encoding
19:08:47 <tbachman> #info Goals of the ALTO-ODL project include integration the ALTO abstractions into ODL, facilitating ALTO devlopment, and using ODL infrastructure to support the implememtnation of scalable, reliable ALTO servers
19:08:50 <colindixon> #link https://wiki.opendaylight.org/view/File:Alto-odl-creation-review-slides.pptx slides are here
19:08:55 <tbachman> colindixon: thx!
19:09:40 <tbachman> #info Uses MD-SAL data store to store ALTO data instances (yang models for ALTO network maps, cost maps, and endpoint properties)
19:10:02 <tbachman> #info Derive ALTO data from ODL data whenever possible in particular from Inventory, Host Tracker, and Topology Manager
19:10:24 <tbachman> #info Revise statically provisioned ALTO data with ODL data (e.g. update ALTO cost maps upon topology changes, flow rule updates)
19:12:35 <tbachman> #info NB API to Applications: provide the standard ALTO RESTful/JSON API to ALTO clients, and allow local access through the MD-SAL data store
19:14:36 <tbachman> #info Architectural components: ALTO Configuration Manager, configured from Coniguration Settings; ALTO Protocol Manager, which depends on ALTO Data (persited data), which provides data to the RFC7285 ALTO Clients; Related ODL Data provides input to ALTO Data and ALTO Configuration Manager; ODL Components both provide and recieve info with ALTO
19:15:48 <tbachman> #info Deliverables inclue: define YANG models for all basic ALTO data; provide ALTO Configuration Manager as a provisioning interface to configure ALTO data instances; Iimplement ALTO Protocol Manager to provide RFC7285 access to ALTO clients; Desogn initial interactions with basic ODL components; Provide an ODL multi-flow scheduling app to demonstrate the use of ALTO data in ODL
19:16:16 <tbachman> #info optional deliverables include incremental updates for cost maps (draft-roome-incr) and define and implement ALTO network graphs
19:17:17 <tbachman> #info project lead and contact is Y. Richard Yang; test contact is Xiao Shi
19:18:20 <colindixon> #info jmedved says this look like a good and useful project
19:18:26 <tbachman> #info rovarga asks if they plan to do any interop testing
19:18:48 <tbachman> #info rovarga asks if they will be automating the interactions inside the integration project with some other implementation
19:19:07 <tbachman> #info Y. Richard says they are definitely going to do interop
19:19:54 <tbachman> #info RajeevK asks if there is any information flow from ALTO to ODL
19:20:33 <tbachman> #info Y. Richard says there is some feedback, where ALTO information is sent to a client, and the client then does the routing; the client then goes to ODL to set up the flow tables
19:21:04 <tbachman> #info Y. Richard says there is also some information provided to other components (e.g. multi-flow scheduler)
19:21:41 <tbachman> #info kwatsen asks if the NB plugin would have both the RESTCONF API as well as the ALTO API
19:22:01 <colindixon> kwatsen: if they store the information in the MD-SAL, there will be both
19:22:15 <colindixon> kwatsen: all YANG modeled data gets RESTCONF
19:22:22 <tbachman> #info Y. Richard says that it’s an ALTO API, but colindixon notes that since it’s MD-SAL, there will be RESTCONF
19:23:07 <tbachman> #info LuisGomez asks if the plugin is also part of the scope for the project
19:23:12 <tbachman> #info Y. Richard says it is
19:23:15 <dfarrell07> #startvote Shall the TSC approve the Application-Layer Traffic Optimization (ALTO) project to Incubation? -1, 0, +1
19:23:15 <odl_meetbot> Begin voting on: Shall the TSC approve the Application-Layer Traffic Optimization (ALTO) project to Incubation? Valid vote options are -1, 0, +1.
19:23:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:23:19 <colindixon> #vote +1
19:23:19 <regXboi> #vote +1
19:23:21 <Youcef> #vote +1
19:23:25 <edwarnicke> #vote +1
19:23:26 <RajeevK> #vote +1
19:23:27 <LuisGomez> #vote +1
19:23:29 <mohnish_> #vote +1
19:23:29 <kwatsen> #info +1
19:23:32 <jmedved> #vote +1
19:23:40 <dfarrell07> 8
19:23:43 <alagalah> kwatsen: you #info'd
19:23:47 <ChrisPriceAB> #vote +1
19:24:03 <tbachman> kwatsen: do #vote
19:24:04 <dfarrell07> #endvote
19:24:04 <odl_meetbot> Voted on "Shall the TSC approve the Application-Layer Traffic Optimization (ALTO) project to Incubation?" Results are
19:24:04 <odl_meetbot> +1 (9): jmedved, regXboi, ChrisPriceAB, LuisGomez, edwarnicke, RajeevK, colindixon, mohnish_, Youcef
19:24:07 <tbachman> ah, too late
19:24:12 <dfarrell07> #agreed The Application-Layer Traffic Optimization (ALTO) project is approved to Incubation
19:24:14 <tbachman> dfarrell07: phrobb owes you a beer, btw ;)
19:24:15 <tbachman> lol
19:24:17 <dfarrell07> We had enough
19:24:35 <dfarrell07> #topic Controller Core Functionality Tutorials project creation review
19:24:43 <dfarrell07> #link https://wiki.opendaylight.org/view/Controller_Core_Functionality_Tutorials:Project_proposal Project proposal wiki
19:24:45 * edwarnicke suggests that we limit the acceptable flux of thank you beers lest we start drowning really helpful community members by mistake ;)
19:24:48 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000248.html Proposed 12/4/2014
19:24:52 <tbachman> lol
19:25:54 <tbachman> #info alagalah says there was discussion on the MD-SAL hackers call on features for MD-SAL, config subsystem, etc., which led to questions of the features that we currently have and tutorials on how to use them; the need for these things kicked off the creation of this project
19:27:52 <tbachman> #info alagalah says that the group came up with the idea of using tutorials in repos that would go through the example step-by-step; at the same time, the scope grew to cover things like inventory, openflowplugin, etc.
19:28:12 <dneary> As a general question, is this specifically developer tutorials, or user tutorials?
19:28:23 <colindixon> dneary: currently for developer tutorials
19:28:30 <dneary> Thanks colindixon
19:28:39 <colindixon> at least that’s my understanding
19:29:07 <dneary> I share alagalah's desire to get beyond project-focussed docs & tutorials, and focus on use-case-focussed docs & tutorials
19:29:40 <kwatsen> pure goodness
19:29:40 <edwarnicke> dneary: *Yes* :)
19:29:48 <dlenrow> +1 vote now
19:29:48 <mohnish_> colin: +1
19:29:53 <RajeevK> +1
19:30:01 <tbachman> people are already voting :)
19:30:04 * edwarnicke regrets that he has but one vote to give...
19:30:12 <tbachman> edwarnicke: sounds like a soap ;)
19:30:13 <dneary> alagalah, Do you have a mailing list I can join?
19:30:22 <tbachman> dneary: once it beomces a project
19:30:25 <edwarnicke> dneary: We will have one once the project gets approved :)
19:30:37 <dneary> (or we could use the docs mailing list)
19:30:37 <dfarrell07> #startvote Shall the TSC approve the Controller Core Functionality Tutorials project to Incubation? -1, 0, +1
19:30:37 <odl_meetbot> Begin voting on: Shall the TSC approve the Controller Core Functionality Tutorials project to Incubation? Valid vote options are -1, 0, +1.
19:30:37 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:30:41 <ChrisPriceAB> #vote +1
19:30:43 <dlenrow> #vote +1
19:30:43 <edwarnicke> #vote +1
19:30:43 <regXboi> #vote +1
19:30:44 <jmedved> #vote +1
19:30:44 <Youcef> #vote +1
19:30:44 <LuisGomez> #vote +1
19:30:46 <kwatsen> #vote +1
19:30:46 <colindixon> #vote +1
19:30:47 <RajeevK> #vote +1
19:30:52 <mohnish_> #vote +1
19:30:52 <dfarrell07> 9
19:30:56 <dneary> edwarnicke, If we can avoid an extra mailing list, I'm all for that :-)
19:31:09 <dfarrell07> #endvote
19:31:09 <odl_meetbot> Voted on "Shall the TSC approve the Controller Core Functionality Tutorials project to Incubation?" Results are
19:31:09 <odl_meetbot> +1 (11): dlenrow, jmedved, regXboi, LuisGomez, ChrisPriceAB, edwarnicke, kwatsen, colindixon, mohnish_, Youcef, RajeevK
19:31:12 <phrobb> #agreed the Controller Core Functionality Tutorials project is approved to incubation
19:31:33 <gzhao> Will CCFT be in Lithium SR?
19:31:51 <tbachman> gzhao: I don’t think this will be part of the artifacts
19:31:52 <edwarnicke> gzhao: Good question... I think it would be good if it were...
19:32:01 <tbachman> oh
19:32:09 <tbachman> I stand corrected :)
19:32:24 <gzhao> tbachman: I think it will be good idea we can ship tutorial as well
19:32:25 * edwarnicke is not in a position to correct tbachman ;)
19:32:25 <dneary> Can we get the best of both worlds and have an asciidoc wiki?
19:32:56 * edwarnicke thinks darkly of markdown
19:33:07 <tbachman> #action DIDM and ALTO to get release plans out as soon as possible
19:33:09 <dneary> edwarnicke, It's pronounced "diddum" :-)
19:33:25 <edwarnicke> dneary: brilliant :)
19:33:34 <dneary> :-)
19:33:40 <alagalah> Thanks all
19:33:45 <tbachman> alagalah: congrats!
19:34:06 <dfarrell07> #topic Release Engineering - Autorelease project creation review
19:34:10 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Release_Engineering_-_Autorelease Project proposal wiki
19:34:58 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-November/000202.html Proposed 11/20/2014
19:35:51 <tbachman> #info gzhao says that autorelease doesn’t generate any artifacts, so won’t participate in the simultaneous release
19:36:17 <tbachman> platypus-like-objects?
19:36:28 * ChrisPriceAB better than a drop-bear like object!
19:36:40 <dneary> edwarnicke, alagalah: There is also https://github.com/github/gollum
19:36:44 <dfarrell07> A great axiom ODL follows: always make tykeal and zxiiro's lives as easy as possible
19:36:51 <tykeal> heh
19:36:53 <tbachman> dfarrell07: +1k
19:37:04 <zxiiro> :)
19:38:32 * colindixon notes that we failed to list ODL ids
19:38:35 * colindixon fail!
19:39:14 <edwarnicke> tykeal: My odl userid is eaw ;)
19:39:44 <dneary> Incidentally, wiki namespace proliferation makes it very hard to figure out where new pages should go.
19:40:07 <alagalah> dneary: +1
19:40:30 <tbachman> #info regXboi asks if the project proposal includes “god powers”
19:40:37 <dneary> If only there were a "Main" namespace that all the pages could be added to :-)
19:40:39 <tbachman> #info colindixon says this was deferred, due to lack of agreement
19:40:45 <gzhao> #action gzhao to generate release plan for auto-release
19:40:46 <dfarrell07> #startvote Shall the TSC approve the Release Engineering - Autorelease project to Incubation? -1, 0, +1
19:40:46 <odl_meetbot> Begin voting on: Shall the TSC approve the Release Engineering - Autorelease project to Incubation? Valid vote options are -1, 0, +1.
19:40:46 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:40:56 <colindixon> #vote +1
19:40:57 <kwatsen> #vote +1
19:40:58 <edwarnicke> #vote +1
19:41:01 <dlenrow> #vote +1
19:41:02 <mohnish_> #vote +1
19:41:02 <Youcef> #vote +1
19:41:08 <regXboi> #vote +1
19:41:12 <dfarrell07> 7
19:41:15 <RajeevK> #vote +1
19:41:20 <dfarrell07> last call
19:41:25 <dfarrell07> #endvote
19:41:25 <odl_meetbot> Voted on "Shall the TSC approve the Release Engineering - Autorelease project to Incubation?" Results are
19:41:25 <odl_meetbot> +1 (8): dlenrow, regXboi, edwarnicke, RajeevK, kwatsen, colindixon, mohnish_, Youcef
19:41:27 <phrobb> #agreed the Release Engineering - Autorelease project is approved to incubation
19:41:29 <jmedved> #vote +1
19:41:33 <tykeal> http://cdn.fashionablygeek.com/wp-content/uploads/2010/09/calorie-grenade-shirt-590x462.jpg?22a92a ?
19:41:39 <LuisGomez> #vote +1
19:41:42 <LuisGomez> (late)
19:41:52 <dfarrell07> #topic Network Intent Composition (NIC) project creation review
19:41:52 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Network_Intent_Composition Project proposal wiki
19:41:55 <regXboi> @tykeal: now that is funny
19:42:01 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-January/000249.html Proposed 1/5/2015
19:42:26 <colindixon> #info NOTE: this is not a creation review
19:42:36 <colindixon> #info WE WILL NOT BE VOTING ON THIS TODAY
19:43:17 <dfarrell07> LuisGomez, jmedved: Sorry guys, hope I didn't rush that vote too much, just a lot to get done today
19:43:32 <tbachman> #info Network Intetent Overview: what, now how; Portable across any/all infra; Intent is a form of policy, but not all plicy networking is intent; Intent is completely abstract and contains no references to instances of network resources or to vendor/media/protocol specifics; A pure intent project provides no control
19:43:53 <colindixon> dfarrell07: it’s always there in the logs
19:44:18 <tbachman> #info Scope is to create an implementation of an intent-based NBI; interact with existing ODL modules as needed to translate pure intent via NBI, into allocated and configured network services and protocol/vendor/device specific network state
19:45:00 <dbainbri> what is the relationship between this and GBP project which has similar goals?
19:45:21 <tbachman> #info (Scope: cont.) develop logic to identify and correct conflicting intent requests and to ensure conflict-free overall network configuration; develop environment for extending Intent “language” in a way that preserves resource sharing/cooperation; Create language, compiler, and similar tooling to optimize intent translation
19:46:08 <tbachman> #info Intent is a proposed solution to multiple write problem by becoming the only writer
19:46:21 <colindixon> #info dlenrow notes that this is a somewhat radical idea
19:46:55 <tbachman> #info thesis is that anything that can be conveyed to the controller via prescription can instead be described as intent
19:48:19 <regXboi> colindixon: is this a creation review or not?
19:48:22 * colindixon notes that ti’s been 6 minutes
19:48:26 <colindixon> regXboi: noted
19:48:33 <regXboi> colindixon: I have comments
19:48:38 <tbachman> #info Role of standards in SDN and NFV: Members of ETSI and ONF include SDN consumers interested in standards-based solutions; open source projects generally have no committment to working with standards orgs and don’t want to be burdened by this overhead
19:48:42 <colindixon> regXboi: it is not, but you should speak up
19:48:43 <regXboi> but if this isn't a creation review I can hold off
19:48:49 <dbainbri> and i have my question from up above
19:48:50 <colindixon> regXboi: no vote will happen today
19:48:53 <colindixon> it can’t
19:49:18 <colindixon> dbainbri: in the short version, I think they have similar goals with different underlying implementations based on my understanding
19:49:36 <tbachman> #info What is unique about this project: founded with goal of using intent to achieve multi-service SDN cooperation; founded iwth goal of working closely with and creating a reference implementation of NBI definitions from ONF NBI WG and ETSI NFV
19:49:56 <tbachman> #info founded to build infra to detect and resolve intent conflicts and to minimize changes to network state in response to changes in intent
19:50:21 <tbachman> #info emphasis on ease of use and extending “programming the network” to non-expert users and admins
19:50:22 <dbainbri> would neutron API eventually decompose down to intents (future) ?
19:51:00 <tbachman> #info regXboi says that by saying it’s the only writer forces it to be it’s own distribution
19:51:06 <dbainbri> colindixon: do we need two different implementations? can we get them together?
19:51:09 <regXboi> dbainbri: that's not for us to decide
19:51:15 <colindixon> dbainbri: good question
19:51:21 <regXboi> dbainbri: and right now, it certainly doesn't look like it
19:51:38 <colindixon> dbainbri: my gut reaction is that the GBP NBI is different enough that likely not
19:51:56 <alagalah> Are the slides posted ?
19:52:08 <tbachman> #info colindixon says that the project proposal has to happen next week to allow for the proper 2-week review
19:52:18 <tbachman> #action dlenrow to post slides for the intent project to the mailing list
19:52:44 <dmentze> we have given some thought about how to allow intent and other north bounds exist for areas of the network
19:52:52 <regXboi> +1 to shorter meeting now
19:52:57 <dneary> +1 from me
19:52:57 * dfarrell07 doesn't know what to call this new topic
19:53:03 <RajeevK> +1 for 1 hr
19:53:08 <edwarnicke> +1 to 1 hr
19:53:15 <dneary> dfarrell07, "Discussion of meeting length"
19:53:15 <jmedved> +1 for 1 hr
19:53:17 <tbachman> #info colindixon says TSC needs to decide whether to allow the intent project given that it’s technically late
19:53:18 <tbachman> #info colindixon asks TSC whether we should switch back to 1hr meetings now that the creation reviews are complete
19:53:19 <Youcef> +1 for 1h
19:53:25 <dfarrell07> #topic Meeting length
19:53:43 <mohnish_> +1 for 1hr
19:53:43 <phrobb> #agreed the TSC meeting is reduced to 1 hour weekly
19:53:46 <tykeal> why would we object to shorter meetings!?
19:53:48 * tbachman does a dance
19:53:52 * regXboi dances on the pin of the calorie grenade
19:53:53 <alagalah> dbainbri: To answer your question, I'd be up for discussion on a common NB API
19:53:56 <dneary> edwarnicke, How much of the future is foreseeable?
19:53:58 <tbachman> regXboi: lol!
19:53:59 <zxiiro> yay
19:54:01 <alagalah> dbainbri: Guess we take it to the mailer
19:54:06 <dfarrell07> #topic Java 8
19:54:11 <tbachman> dfarrell07: thx!
19:54:13 <regXboi> tbachman: we need to #topic cookies at the end
19:54:16 <regXboi> :)
19:54:19 <tbachman> regXboi: ack :)
19:54:40 <dfarrell07> #info Various projects want to move to Java 8
19:54:49 <tbachman> #info colindixon asks rovarga what issues projects should be aware of when moving to Java 8
19:55:00 <dfarrell07> #info There's a thread on odl-discuss about moving to Java 8
19:55:13 * dfarrell07 is looking for thread link
19:55:14 <tbachman> #info rovarga says karaf 3.0.1 is not compatible with Java 8, b/c it doesn’t export a platform service that’s needed
19:55:15 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2015-January/004196.html
19:55:21 <tbachman> colindixon: thx!
19:55:21 <colindixon> dfarrell07: got it
19:55:26 <dfarrell07> ^^that was super fast
19:55:34 <dbainbri> is openjdk 8 available on all supported platforms?
19:55:38 * tbachman notes colindixon is like that ;)
19:55:42 <tbachman> (super-fast)
19:55:42 <dfarrell07> lol
19:55:53 <tbachman> ludicrous speed, since that’s popular these days
19:56:20 <tykeal> dbainbri: it's on on EL7 yet. It's in EL7.1
19:56:29 <tykeal> eh... not on that is ;)
19:56:34 <tbachman> #info edwarnicke notes that the last update for Java 7 is targeted for March, so the need for Java 8 is becoming more important
19:56:35 <dfarrell07> I've seen a fairly large number of questions on ask.odl about issues with Java versions that would be solved by working with Java 8, btw
19:56:46 <dbainbri> ubuntu?
19:56:48 <tbachman> #info dbainbri asks if openjdk is available on all supported platforms
19:57:00 <tbachman> #info tykeal says it’s on EL7.1
19:57:05 <tykeal> I believe it's in ubuntu but I don't run ubuntu
19:57:14 <dfarrell07> Thanks :)
19:57:25 <tbachman> #info dfarrell07 notes that he’s seen a fairly large number of questions on ask.odl about issues with Java versions that would be solved by working with Java 8
19:57:37 <tbachman> #info dbainbri asksi if it’s supported in ubuntu
19:57:44 <tbachman> #info tykeal and mlemay say that it is
19:57:49 <regXboi> did colin misspeak?
19:57:59 <alagalah> regXboi: re: Java8 being dead ?
19:57:59 <regXboi> did colindixon say the end of java 8 is in 6 months??? :)
19:58:07 <alagalah> regXboi: heheheh mebbe
19:58:11 <regXboi> alagalah: good - you heard it too :)
19:58:13 <dbainbri> any thoughts about when j8 features canbe utilized?
19:58:17 <alagalah> :)
19:58:34 <tbachman> #info rovarga says that he believes the Lithium release will be able to support Java 8
19:59:26 <tbachman> #info dbainbri asks when we’ll have a milestone for when Java 8 capabilities can be used
19:59:32 <colindixon> tbachman is also fast
19:59:53 <tbachman> #info rovarga says that for yangtools and MD-SAL, we won’t be able to do the binding specification 2, we’ll probably look to do these in the Beryllium time frame
20:01:11 <dlenrow> edwarnicke: Don't call me Frankly
20:01:32 <tbachman> dlenrow: I thought it was Surely?
20:01:35 <dfarrell07> We should #action some people to look into this
20:01:36 <edwarnicke> AcceptableDLenrowNames.remove("Frankly");
20:01:47 <dbainbri> guess i picked the wrong week to stop drinking
20:01:50 <dfarrell07> #action colindixon will add Java 8 to TSC topics for next week
20:01:54 <tykeal> opendaylight cookies? http://cookieconnection.juliausher.com/fileSendAction/fcType/0/fcOid/330761585002590616/filePointer/330761585002749293/fodoid/330761585002749283/imageType/LARGE/inlineImage/true/Happy%20Sun%20Cookies%20-%20Yankee%20Girl%20Yummies%20-%202.JPG
20:01:55 <tbachman> dfarrell07: beat me to it ;)
20:01:58 <dfarrell07> #endmeeting