#opendaylight-meeting: tsc

Meeting started by phrobb at 18:00:39 UTC (full logs).

Meeting summary

    1. dlenrow (dlenrow, 18:01:09)

  1. Roll Call TSC members please #info in (phrobb, 18:01:10)
    1. dlenrow (dlenrow, 18:01:15)
    2. colindixon (colindixon, 18:01:18)
    3. regXboi (regXboi, 18:01:23)
    4. Chris Wright (cdub, 18:01:25)
    5. Youcef Laribi (Youcef, 18:01:28)
    6. Chris Price (ChrisPriceAB, 18:01:28)
    7. edwarnicke (edwarnicke, 18:01:39)
    8. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agend in it’s usual place (colindixon, 18:01:43)
    9. LuisGomez (LuisGomez, 18:01:47)
    10. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-01-22-18.00.html last weeks meeting agend for action item (colindixon, 18:01:59)
    11. kwatsen (kwatsen, 18:02:42)
    12. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (colindixon, 18:03:16)
    13. ACTION: colindixon and TSC to elaborate on proper procedure for removal of committers from a project (colindixon, 18:03:28)
    14. ACTION: phrobb will send results from the condorcet poll on service releases (colindixon, 18:06:12)
    15. mohnish anumala (to replace) (regXboi, 18:06:13)

  2. updates (colindixon, 18:06:26)
    1. jmedved (jmedved, 18:06:27)
    2. The CFP for the ODL summit is next friday (2/6), we currently have only 6 submissions (colindixon, 18:07:12)
    3. ACTION: all people should submit more things if they have good/interestion ones (colindixon, 18:07:36)

  3. Helium-SR2 release (colindixon, 18:08:29)
    1. https://www.irccloud.com/#!/ircs://irc.freenode.net:6697/%23opendaylight-meeting (gzhao, 18:09:38)
    2. the build is out and we called for people to test (colindixon, 18:09:53)
    3. https://nexus.opendaylight.org/content/repositories/staging/org/opendaylight/integration/distribution-karaf/0.2.2-Helium-SR2/ (gzhao, 18:10:02)
    4. no negativee reporting (colindixon, 18:10:05)
    5. LuisGomez said that we found some new bugs, but the projects were notified and chose not to fix them in the release (colindixon, 18:10:43)
    6. otherwise, there are no regressions (colindixon, 18:10:57)
    7. LuisGomez says that one clustering test is running today in integration (tbachman, 18:11:06)
    8. edwarnicke asks if the tests are passing (tbachman, 18:11:11)
    9. LuisGomez says it’s passing but isn’t stable (?) (tbachman, 18:11:30)
    10. https://lists.opendaylight.org/pipermail/release/2015-January/001261.html thread with responses about testing (colindixon, 18:11:38)
    11. colindixon calls for the TSC to "sort of bless" the helium SR2 artifacts (regXboi, 18:12:41)
    12. AGREED: the TSC the artifacts in the link above will be published as helium SR2 artifacts (regXboi, 18:13:08)
    13. ACTION: gzhao to work with tykeal to promote the correct set of artifacts (regXboi, 18:13:25)

  4. lithium and stable helium - other issues (regXboi, 18:13:49)
    1. zxiiro removed packetcable from the autorelease b/c it was failing the build (tbachman, 18:14:09)
    2. there is now a working Lithium daily auot release, but had to remove packetcable (colindixon, 18:14:16)
    3. there are test failures, that haven’t been explored yet (colindixon, 18:15:03)
    4. gzhao has not yet been contacted by person identified to take over packetcable project (tbachman, 18:15:46)
    5. ACTION: gzhao colindixon to work out what the next Helium SR and the target dates (colindixon, 18:15:49)
    6. packetcable is the only Helium project not yet joined Lithium (gzhao, 18:16:31)
    7. colindixon asks which projects voted (ChrisPriceAB, 18:16:50)
    8. ACTION: phrobb to figure which projects (if any) didn’t respond and of the ones that did which ones say they woudln’t want to support at least one release (colindixon, 18:18:10)
    9. colindixon asks who voted for only the current release, which would be Lithium (tbachman, 18:20:33)

  5. System Integration & Test (colindixon, 18:22:22)
    1. phrobb says Persistence, PacketCable, and OpenFlow Plugin (tbachman, 18:22:22)
    2. the last two days (Tue and Wed) were an integration meeting (colindixon, 18:23:35)
    3. integration project gathered to discuss the strategy for the current release. (ChrisPriceAB, 18:23:56)
    4. there were 10-12 attendees each day, talked about the key areas for this release (colindixon, 18:23:56)
    5. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Lithium_Test_Strategy artifact created during Integration Gathering this week (dfarrell07, 18:24:26)
    6. also finalized the integration release plan (colindixon, 18:24:46)

  6. Infrastructure (colindixon, 18:25:49)
    1. phrobb reports all projects have been migrated to rackspace (regXboi, 18:26:25)
    2. we’re working on getting everyone (ideally) into JJB (regXboi, 18:27:07)
    3. 28 projects have migrated to JJB (tbachman, 18:27:10)
    4. phrobb wants to know if there are things that we should be doing beyond getting people to JJB, also should we reach out to others (colindixon, 18:28:58)
    5. edwarnicke says that JJB has been pretty smooth sailing even from some very complicated projects (colindixon, 18:29:41)
    6. abhijitkumbhare asks if migration to JJB can be a TWS topic (tbachman, 18:30:01)
    7. ACTION: zxiiro to work with alagalah to schedule a TWS call on moving to JJB (colindixon, 18:30:19)
    8. https://wiki.opendaylight.org/view/RelEng:Jenkins#Basic_Job_Configuration the wiki page documenting JJB using (colindixon, 18:31:13)
    9. regXboi says he missed when we switched from JJB being optional to what sounds like a requirement for Lithium (tbachman, 18:31:35)
    10. colindixon says that no project is required to move to JJB; no one has said no to migration, tho (tbachman, 18:31:54)
    11. if your build is really just “mvn clean install”, the section above will work really, really well and take < 30 minutes (colindixon, 18:33:03)
    12. LuisGomez sent a mail to clarify M2 question for projects: “Project will use OpenDaylight CI Infrastructure?” should say: “Project will use OpenDaylight CI Infrastructure for their System Test?” (LuisGomez, 18:35:40)
    13. ACTION: zxiiro will create patches for project than haven’t haven’t moved and gzhao would help shepherd people (colindixon, 18:36:59)
    14. on the monday TWS call, Ed demoed some cool stuff demoing with archetypes that rely on having a settings.xml file (colindixon, 18:38:01)
    15. so far, our infrastructure didn’t have that, but now it does so that projects generated with these archetype will work in our build infrastructure (colindixon, 18:38:47)
    16. it also seems like to get into maven central, we need to remove the <repository> tags in their pom files anyway, so we’d have to move in this direction if we want to publish stuff into maven central (colindixon, 18:40:07)
    17. https://lists.opendaylight.org/pipermail/release/2015-January/001264.html more details including how to get a settings.xml file on your computer (colindixon, 18:40:50)
    18. LuisGomez says that there is a very real possibility that we might need ~40 or even more VMs to handle tests on bursts (colindixon, 18:42:16)
    19. tykeal says that our current VM max is 250, we’ve bursted as high as 90 VMs (colindixon, 18:42:49)
    20. tykeal we are now allowed to use up to 768 GB of RAM (!!!!) because we were going over 0.5 TB (colindixon, 18:43:17)
    21. that is across all slaves, not per VM (colindixon, 18:43:59)
    22. the largest slave comes up with 8 GB of RAM for a VM (colindixon, 18:44:21)

  7. committer promotions (colindixon, 18:46:14)
    1. Brady Johnson as a committer on SFC (colindixon, 18:47:10)
    2. https://lists.opendaylight.org/pipermail/sfc-dev/2015-January/000748.html by my count earlier 10/12 current committers to SFC voted +1 (colindixon, 18:47:26)
    3. https://git.opendaylight.org/gerrit/#/q/status:merged+project:sfc+owner:%22Brady+Johnson+%253Cbrady.allen.johnson%2540ericsson.com%253E%22 - Brady's merges to SFC (edwarnicke, 18:47:59)
    4. uuuuugh (ChrisPriceAB, 18:49:43)
    5. VOTE: Voted on "Shall the TSC approve Brady Johnson as a committer on the SFC project?" Results are, +1: 10 (phrobb, 18:49:43)
    6. congratulations (regXboi, 18:49:59)
    7. AGREED: Brady Johnson is approved as a committer on the SFC project (phrobb, 18:50:12)

  8. creation reviews (regXboi, 18:50:19)
    1. intent is requesting to join Lithium as an offset 2 project by providing a final release plan by the 2/5 deadline (regXboi, 18:52:46)
    2. VOTE: Voted on "irc://irc.freenode.net:6667/#shall the TSC approve the NIC project to join the Lithium simultaneous release as an offset 2 project?" Results are, +1: 11 (regXboi, 18:54:02)
    3. AGREED: NIC can join lithium (regXboi, 18:54:15)
    4. https://lists.opendaylight.org/pipermail/project-proposals/2015-January/000251.html this project proposal wants to be reviewed on 2/12 to joint lithium as a spin-out project before M3 (colindixon, 18:55:30)
    5. the controller project has bee consulted and covered very politely and happil (colindixon, 18:56:01)

  9. Java 8 (colindixon, 18:56:29)
    1. it turns out to get Java 8 to work, we need to upgrade from Karaf 3.0.1 to 3.0.2 or later (colindixon, 18:56:55)
    2. they are working on that and dealing with a few hiccups (colindixon, 18:57:14)
    3. projects should use karaf parent to simplify the process. (ChrisPriceAB, 18:57:27)
    4. this will be much easier if projects use karaf-parent (which requires settings.xml) as the parent for their local karaf distributions (colindixon, 18:57:53)

  10. COOKIES (phrobb, 18:58:40)


Meeting ended at 18:58:49 UTC (full logs).

Action items

  1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
  3. phrobb will send results from the condorcet poll on service releases
  4. all people should submit more things if they have good/interestion ones
  5. gzhao to work with tykeal to promote the correct set of artifacts
  6. gzhao colindixon to work out what the next Helium SR and the target dates
  7. phrobb to figure which projects (if any) didn’t respond and of the ones that did which ones say they woudln’t want to support at least one release
  8. zxiiro to work with alagalah to schedule a TWS call on moving to JJB
  9. zxiiro will create patches for project than haven’t haven’t moved and gzhao would help shepherd people


Action items, by person

  1. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
    3. gzhao colindixon to work out what the next Helium SR and the target dates
  2. gzhao
    1. gzhao to work with tykeal to promote the correct set of artifacts
    2. gzhao colindixon to work out what the next Helium SR and the target dates
    3. zxiiro will create patches for project than haven’t haven’t moved and gzhao would help shepherd people
  3. phrobb
    1. phrobb will send results from the condorcet poll on service releases
    2. phrobb to figure which projects (if any) didn’t respond and of the ones that did which ones say they woudln’t want to support at least one release
  4. tykeal
    1. gzhao to work with tykeal to promote the correct set of artifacts
  5. zxiiro
    1. zxiiro to work with alagalah to schedule a TWS call on moving to JJB
    2. zxiiro will create patches for project than haven’t haven’t moved and gzhao would help shepherd people


People present (lines said)

  1. colindixon (71)
  2. tbachman (59)
  3. regXboi (47)
  4. ChrisPriceAB (31)
  5. odl_meetbot (23)
  6. dfarrell07 (14)
  7. phrobb (14)
  8. cdub (14)
  9. edwarnicke (9)
  10. gzhao (8)
  11. tykeal (8)
  12. dlenrow (6)
  13. LuisGomez (6)
  14. abhijitkumbhare (6)
  15. bigalh (5)
  16. vishnoianil (5)
  17. ebrjohn (4)
  18. hideyuki (4)
  19. kwatsen (3)
  20. Youcef (3)
  21. mohnish (3)
  22. Neelajacques (2)
  23. jmedved (2)
  24. uchau (1)
  25. RajeevK_ (1)
  26. zxiiro (1)


Generated by MeetBot 0.1.4.