18:00:18 <colindixon> #startmeeting tsc
18:00:18 <odl_meetbot> Meeting started Thu Feb  5 18:00:18 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:18 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:22 <colindixon> #topic roll call and agenda
18:00:38 <colindixon> #chair alagalah regXboi edwarnicke tbachman alagalah dfarrell07
18:00:38 <odl_meetbot> Current chairs: alagalah colindixon dfarrell07 edwarnicke regXboi tbachman
18:00:39 <alagalah> #info alagalah for jmedved
18:00:43 <colindixon> #info colindixon
18:00:47 <edwarnicke> #info edwarnicke for fun
18:00:47 <regXboi> #info regXboi <- only IRC for now
18:00:54 <tbachman> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda Today’s TSC agenda
18:00:54 <regXboi> #unchair regXboi
18:00:54 <odl_meetbot> Current chairs: alagalah colindixon dfarrell07 edwarnicke tbachman
18:01:07 <alagalah> regXboi: is the anti-chair
18:01:08 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place
18:01:13 <kwatsen> #info kwatsen
18:01:18 <regXboi> colindixon: I'm going to try and multiplex, but it means I'll be IRC only - making me chair makes no sense
18:01:19 <tbachman> #https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-01-29-18.00.html Last week’s meetin gminutes
18:01:25 <LuisGomez> #info LuisGomez
18:01:26 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-01-29-18.00.html last week’s minutes for action items
18:01:39 <colindixon> #chair phrobb
18:01:39 <odl_meetbot> Current chairs: alagalah colindixon dfarrell07 edwarnicke phrobb tbachman
18:01:44 * tbachman notes that regXboi either has a lot of meetings, or a few meetings that happen to be at the same time ;)
18:01:44 <tbachman> lol
18:01:49 <Youcef> #info Youcef Laribi
18:01:58 <regXboi> tbachman: this is an emergency things
18:02:01 <dlenrow> #info dlenrow
18:02:01 <tbachman> ah
18:02:03 <tbachman> sorry to hear
18:02:08 <regXboi> and I do mean an things
18:02:08 <colindixon> #action colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
18:02:16 <colindixon> #actoin colindixon and TSC to elaborate on proper procedure for removal of committers from a project
18:02:23 <tbachman> oops
18:02:27 <colindixon> #action gzhao colindixon to work out what the next Helium SR and the target dates
18:02:35 <tbachman> #undo
18:02:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ab0710>
18:02:37 <tbachman> #undo
18:02:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19b8890>
18:02:39 <tbachman> oops
18:02:52 <tbachman> #action colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
18:03:01 <tbachman> #action colindixon and TSC to elaborate on proper procedure for removal of committers from a project
18:03:08 <tbachman> #action gzhao colindixon to work out what the next Helium SR and the target dates
18:03:16 <tbachman> meetbot no-likey actoin
18:04:12 <tbachman> colindixon: you have 7
18:04:32 <colindixon> #topic updates
18:04:55 <tbachman> #info phrobb says deadline for CFP is tomorrow, 2/6/2015
18:05:04 <tbachman> #info there are 20 submissions so far
18:05:18 * dfarrell07 will work on submission today, last second as always
18:05:25 <colindixon> dfarrell07: me too
18:05:31 <dfarrell07> tbachman: is rocking the minutes :)
18:05:32 <tbachman> #info phrobb says we’re locked down for the  Marriott Santa Clara for April 15/16 for Lithium Milestone sync up
18:05:40 <colindixon> tbachman is epic
18:05:41 <tbachman> colindixon: dfarrell07: me three
18:05:45 <tbachman> colindixon: lol
18:05:46 <abhijitkumbhare> #info abhijitkumbhare for Chris Price
18:05:46 <dfarrell07> lol
18:05:56 <mohnish> #info mohnish anumala
18:06:13 <tbachman> #info CFP is for the main conference tutorials
18:06:17 <tbachman> oops
18:06:19 <tbachman> #undo
18:06:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab09d0>
18:06:28 <tbachman> #info edwarnicke asks how we’re doing on the tutorials
18:06:32 <tbachman> #info phrobb wasn’t sure about those yet
18:06:50 <colindixon> continue without me if you can function
18:07:21 <tbachman> sound of elevator music playing
18:07:43 <tbachman> and now back to our regularly scheduled programming
18:07:44 <tbachman> we’re at 8
18:08:07 <tbachman> ah, 10
18:08:08 <tbachman> lol
18:08:09 <dlenrow> Yeah, I'm super snobby about not doing tourist stuff like bus tour (I'm not japanese). Understand why you would with a kid though...
18:08:17 <tykeal> tbachman: off by 2 error
18:08:20 <tbachman> lol
18:08:24 <tbachman> better than my usual ;)
18:08:50 <tbachman> I think that was just echo colindixon
18:09:00 <cdub> #info chris wright
18:09:25 <tbachman> #topic Lithium and Stable Helium updates
18:09:34 <tbachman> #info zxiiro says we’re still in the process of tagging SR2
18:09:36 <alagalah> The TSC goes all the way to 11
18:09:47 <colindixon> now with cdub we’re at 11 out of 13
18:10:03 <colindixon> #info we’re missing 2 projects that just need to tag and 5 other projects that need to merge SR2 stats
18:10:06 <tbachman> #info gzhao says that we have 43 projects in Lithium, 3 offset 0, 16 in 1, the rest in offset 2
18:10:29 <tbachman> #info gzhao says 4 projects are in yellow status — two are missing questions SDNi and OpenContrail
18:10:52 <tbachman> #info SXP hasn’t set up JJB and hasn’t finalized release plan, and SNBI hasn’t finalized their release plan
18:10:54 <cdub> Flakey WiFi so more like 10.5
18:11:14 <tbachman> #info gzhao says SNBI will finalize release plan on February 13th
18:11:18 <tbachman> #info colindixon asks if they are an offset 1 or 2
18:11:26 <tbachman> #info gzhao says SNBI is an offset 1 project
18:12:07 <tbachman> #action gzhao to look at dependency spreadsheet to see if SNBI has any dependencies, and communicate with SNBI about this
18:12:51 <gzhao> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Offset_1_Projects <-- offset 1 status
18:13:41 <tbachman> #info gzhao says we have only one project — SXP — doesn’t support clustering
18:13:48 <colindixon> if anyone else on the TSC wants to comment on this, would it would be welcome
18:13:49 <dlenrow> There are many things I would like to express, but most are highly inappropriate :)
18:14:09 <tbachman> #info gzhao says 4 projects has special requirements for CI, and 3 projects won’t use LF CI for testing
18:14:24 <tbachman> #info gzhao is working on the dependency diagram, as per action item from prior TSC
18:14:26 <colindixon> #action gzhao will follow up with the SNBI project to have them convey to the release staff and TSC any impact if any their delay will have on other projects and a plan to to get them back on track
18:14:31 <gzhao> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Project_Dependency_Diagram < -- WIP dependency diagram
18:14:39 <dfarrell07> Thank you for all that great work, gzhao :)
18:14:48 <tbachman> dfarrell07: +1k
18:14:49 <gzhao> dfarrell07: thanks
18:15:18 <colindixon> gzhao: same
18:15:25 <tbachman> #info phrobb asks what does the TSC want to do with IRC meetings in the future — do we want to do them the week before the milestone?
18:16:57 <tbachman> #info colindixon says it’s useful to get folks together on IRC, asks if every other week, every week <insert option here> is best?
18:17:20 <tbachman> #info abhijitkumbhare asks for every week
18:17:51 <tbachman> #info LuisGomez likes the sync up
18:18:11 <tbachman> #info edwarnicke likes to have these kept on the google calendar, so whatever is decided, asks to have it updated there
18:18:24 <tbachman> #info colindixon recommends 1/2-hour meeting every week; if it seems excessive, we’ll modify
18:18:41 * ebrjohn laughing at imagining Ed "Wandering about..."
18:18:43 <tbachman> #info mohnish asks if we can slide it a bit later
18:19:09 <tbachman> #info colindixon asks if there are other opinions on the time change
18:19:44 <edwarnicke> ebrjohn: You imply that I am ever doing anything more defined than Wandering :)
18:19:49 * tykeal suddenly has the soundtrack from Les Mis running through his head "rise up!"
18:20:00 <tbachman> #info rovarga says they’d probably be okay with 1/2 slide (7:30 am PST)
18:20:01 * edwarnicke notes that as rovarga does not sleep, he may not be the best representative of his geography ;)
18:20:16 <tbachman> edwarnicke: I’ve always suspected that of rovarga
18:20:20 <tbachman> and you ;)
18:20:22 * tykeal figures that edwarnicke knows this since he doesn't sleep either
18:20:23 * rovarga notes edwarnicke has a twisted perception of reality :)
18:20:28 <edwarnicke> tykeal: is there anyway to get #barracades for meetbot and #storm ?
18:20:35 <tykeal> lol
18:20:49 <tbachman> #agreed The weekly IRC meeting for Lithium sync up will be 7:30 am PST
18:21:24 <tbachman> #topic System Integration and Test
18:21:42 <tbachman> #info LuisGomez reminds projects to move to SR2 tagging and version bumping, as this affects integration testing
18:21:58 <dlenrow> register richardi
18:22:19 <tykeal> *cough* dlenrow change your password and do that in private ;)
18:22:20 * tbachman wonders if dlenrow is programming in mnemonic assmembly
18:22:45 <dlenrow> I thought this was asm for dummies
18:22:51 <tbachman> #info colindixon asks if we can set this up as an opt-in or opt-out fashion
18:22:53 <dlenrow> woops
18:23:05 <tbachman> dlenrow:  lol
18:23:24 <snoble> I am running SR2 for all of my work, any reason I shouldn't?
18:23:46 <tbachman> #info edwarnicke says the history is that people tend to opt-in
18:24:22 * edwarnicke thinks deep thoughts about libertarian paternalism
18:24:44 * tbachman is lost on all this history
18:24:59 <edwarnicke> #link http://en.wikipedia.org/wiki/Soft_paternalism
18:25:06 <dfarrell07> snoble: Always use the latest release, imho :)
18:25:29 <tbachman> #action colindixon to send email to allow projects to opt-out rather than opt-in for version bumping process
18:27:06 <colindixon> #undo
18:27:06 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19bc310>
18:27:09 <tbachman> lol
18:27:21 <tbachman> got colindixon’s attention ;)
18:27:30 <colindixon> #action colindixon to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
18:27:33 <colindixon> #undo
18:27:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19bc310>
18:27:45 <colindixon> #action colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
18:27:57 <tbachman> colindixon: thx!
18:28:31 <tbachman> #topic Infrastructure
18:28:48 <tbachman> #info zxiiro says that there are about 32 projects in JJB
18:28:58 <tbachman> #info zxiiro is working with hideyuki to get VTN at the moment
18:29:10 <tbachman> #info zxiiro is waiting to hear from the remaining projects
18:29:11 <colindixon> thanks zxiiro, this is hugely helpful
18:29:37 <hideyuki> zxiiro helps me a lots around JJB!
18:30:05 <tbachman> #info tykeal says that odlforge is being affected by the addition of projects
18:30:07 <colindixon> #info VPN service project has resources, yay! We’re still waiting on MAPLE for IPR reasons
18:30:09 <edwarnicke> hideyuki: zxiiro helps everybody out around a lot of things :)
18:30:18 <tbachman> edwarnicke: +1k to that as well
18:30:27 <hideyuki> edwarnicke: :)
18:30:46 <tbachman> #topic Creation Reviews
18:31:09 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-February/002499.html PCMM would like permission to join the Lithium release late
18:31:47 <tbachman> #info colindixon prefers not to vote on this without any attendance of contributors or committers from the PCMM project
18:31:51 <tbachman> #info edwarnicke agrees
18:32:35 <zxiiro> #info odl-patches.sh script now available in scripts/odl-patches in the releng/autorelease repo
18:32:43 <tbachman> #agreed Action item to review addition of PCMM to Lithium release is pushed out a week, due to no one from PCMM in attendance
18:32:54 <tbachman> #topic Helium Lifetime Poll results
18:33:22 <edwarnicke> zxiiro: colindixon who is actioned to send out the email to see if project leads have opinions about the patching of release stuff?
18:33:29 <tbachman> #info phrobb says that there was confusion in the poll about what the “current” release; in his mind, that would be what has been released, meaning “Helium"
18:33:32 <colindixon> edwarnicke: that’s me
18:33:43 <colindixon> edwarnicke: unless you want to do it :-)
18:33:56 <edwarnicke> colindixon: Cool :)  You felt appropriate to me for that, but I'm starting to feel guilty about your AI count ;)
18:34:04 <edwarnicke> colindixon: Not that guilty :)
18:34:14 * colindixon is the Coordinator in Chief
18:34:32 * edwarnicke suppresses a large number of feline related comments
18:34:44 <tbachman> #info phrobb says there were a large quantity fo projects that didn’t respond, and sent a clarification of what the current release is to projects this a.m., and asks what they think they can support
18:35:02 <zxiiro> To be clear my patch currently creates all the commits in all the repos giving a directory that contains the patches produced but autorelease-worker job. I still have to go in and "git push origin HEAD:refs/for/master" all the patches to Gerrit but that's an in progress automation step
18:36:03 <phrobb> audio went dark again for me… anyone else?
18:36:04 <tbachman> #info colindixon wants to schedule more stability releases for Helium until we get past the Lithium release, and has worked with phrobb to come up with dates that wouldn’t stall Lithium
18:36:10 <tbachman> phrobb: okay for me
18:36:23 <tbachman> phrobb: colorado snow again? ;)
18:36:31 <edwarnicke> zxiiro: Would you pushing in that manner cause the firing of the appropriate jobs in Jenkins for verify and merge?
18:36:32 <colindixon> #action phrobb will send out sample dates for later Helium SRs that try to avoid critical dates in Lithium
18:37:02 * tbachman worries when he can’t hear phrobb laugh
18:37:06 <phrobb> nice getting an action item while I couldn't defend myself :-D
18:37:08 <zxiiro> edwarnicke: i'm going in through the standard interface that people submit patches today. A committer still needs to click teh "review" and "submit" button, and yes verify and merge still needs to be run
18:37:10 <tbachman> lol
18:37:29 <edwarnicke> zxiiro: I mean if projects were to opt into allowing releng to push the version bump stuff
18:37:30 <zxiiro> edwarnicke: we're just asking for permission to allow us to be allowed to click the "review" and "submit" button on behalf of projects who are slow on doing it :)
18:37:42 <edwarnicke> zxiiro: Cool, that answers my question :)
18:37:47 <tbachman> #info rovarga says the decision to schedule the next SRs should have come before SR2 went out; when SR2 was frozen, they thought that was it for the stability branch, and now they have to look at whether they can backport patches from master
18:37:59 <tbachman> #info colindixon says that was part of the intent of the poll
18:38:16 <tbachman> #info colindixon asks if rovarga feels this is the wrong thing to do
18:38:24 <tbachman> #info rovarga advises to be more explicit next time around
18:38:40 <zxiiro> edwarnicke: yep, so everything will work the same as it does today, i'm not bypassing any steps. We just want to help speed up the part that currently requires the project committers to click the buttons in Gerrit.
18:38:59 <edwarnicke> zxiiro: Cool, just wanted to get it clear in my head :)  I appreciate your clarification :)
18:39:14 <tbachman> was that cdub?
18:39:19 <tykeal> tbachman: yes
18:39:23 <tbachman> #info cdub agrees with colindixon
18:39:25 <tbachman> lol
18:40:08 <tbachman> #info colindixon encourages PL’s to express opinions on the continued stable releases for Helium
18:41:37 <tbachman> #info rovarga prefers that the release after Lithium is out to become the official code freeze, and not to expect anything more from that service release
18:41:47 * regXboi thanks tbachman for the useful minutes as he is still IRC only
18:41:57 <tbachman> regXboi: my pleasure!
18:42:41 <tykeal> tbachman: gives gold star service http://www.katiyana.com/Logos/GoldStarService.jpg ;)
18:42:51 <tbachman> #info colindixon says that we’re not sure whether we’re in agreement on what the code freeze should be, based on the poll (and confusion around “Current”)
18:43:22 <tbachman> #topic Use Cases
18:43:57 <tbachman> #info colindixon says that there’s been a lot of talk in the Board meetings for ODL to meet Use Cases, rather than be just a collection of code
18:44:35 <tbachman> #info colindixon says mohnish, mlemay, mcohn, dmm, dlenrow, et. al. have been discussing this so that ODL can do something out of the box to meet a use case
18:45:05 <tbachman> #info colindixon says that even when there’s agreement on things that matter, such as neutron, in the past it’s been difficult to get resources to commit in order to move these things forward
18:45:20 <regXboi> colindixon: is there agreement on neutron?
18:45:27 <tbachman> #info  The board is trying to find a way to encourage such participation, possibly through use cases
18:45:33 * regXboi doesn't think he understands what a "neutron" use case means
18:45:40 <tbachman> regXboi: I think this is more general
18:45:41 <rovarga> regXboi: +1
18:46:02 <tbachman> neutron is just a favorite ;)
18:46:02 <regXboi> I understand what service chaining/nfv *might* mean
18:46:10 <rovarga> neutron-on-top-of-what? :)
18:46:10 <regXboi> but neutron is too broad for a single use case
18:46:21 <regXboi> rovarga: +1 !!!! exactly !!!!
18:46:39 <tbachman> #info edwarnicke says using the distribution question to address the use case question is going about it wrong
18:46:57 <rovarga> honestly, what we need is cookbooks
18:47:00 <tbachman> #info colindixon says maybe we should declare that 1 or 2 use cases per release are things that we’d like to target
18:47:06 <tbachman> rovarga: Joy of Cooking?
18:47:19 * tbachman looks up recipe for “cookies"
18:47:20 <rovarga> tbachman: roasting.. various protocols :-D
18:47:27 <tbachman> tykeal: that one was for you
18:47:30 <tykeal> Julie Childs take on how to use ODL?
18:47:31 <tbachman> rovarga: lol
18:47:31 * edwarnicke has an excellent recipe for chocolate
18:47:46 <regXboi> edwarnicke: does it involve smuggled butter?
18:47:52 <regXboi> :-)
18:47:53 <tykeal> s/Julie/Julia/
18:48:01 <cdub> Java has julia childs "clean as you go" model
18:48:10 <tykeal> heh
18:48:16 <tbachman> #info edwarnicke says he feels we’re better off just having a single feature tied to a single use case, rather than a distribution question
18:48:33 <tbachman> #info colindixon says the question as to whether it’s a feature or a distribution is fine
18:48:53 <rovarga> well... the problem is that usually use cases need to be customized... which requires more of a hands-on tutorial of customization
18:48:55 <tbachman> #info colindixon asks if we can agree on some common goals for Lithium
18:49:20 <tbachman> #info edwarnicke says there are goals that we’ve targeted before, but haven’t been properly realized
18:49:41 <edwarnicke> #info edwarnicke actually said that for most common goals, we *have* pulled together in the past
18:49:47 <edwarnicke> #info but perhaps not at other times
18:49:51 <tbachman> #info RajeevK likes the idea of common goals, where ODL stands behind a few use cases; asks how we can get to those use cases
18:49:57 <tbachman> edwarnicke: thanks, and sorry for the mis-statement
18:50:41 <tbachman> #info edwarnicke says this goes to the question that people ask is how the TSC directs resources; notes the TSC can’t direct resources
18:51:08 <tbachman> #info colindixon says would creation of use cases encourage them to participate to make that happen
18:51:17 * regXboi wonders if the board understands that fact
18:51:32 <colindixon> regXboi: I routinely remind them of that
18:51:44 <regXboi> colindixon: that doesn't mean they *understand* that fact
18:51:57 <regXboi> :-(
18:52:09 <colindixon> #infor RajeevK asks what uses cases we would focus on, how many, and how would we track progress
18:52:16 <tbachman> colindixon: thx!
18:52:22 <dfarrell07> Speaking as the Integration committer who's driving (as of very recently) Neutron integration stuff, we
18:52:22 <colindixon> #info RajeevK asks what uses cases we would focus on, how many, and how would we track progress
18:52:31 <tbachman> echo?
18:52:32 <dfarrell07> we're already down for committing resources
18:52:44 <tbachman> ah
18:52:46 <tbachman> infor
18:52:59 <RajeevK> +
18:53:25 <dlenrow> Freedom != anarchy;. Collective good != fascism
18:54:34 <rovarga> the use cases are nice, but unless we get deployment scenarios ("How do I"), I don't think they are that useful
18:54:35 <alagalah> dlenrow: Fish != Grateful Dead
18:54:44 <dlenrow> Jerry!!!!!!
18:54:48 <alagalah> :)
18:54:49 <tbachman> #info colindixon summarizes someone’s statement,  says we should also track what we are doing, so that we drive advice and insight as to what ODL is good at beyond what we call attention to
18:54:51 * regXboi thinks he is missing discussion
18:54:58 <alagalah> Old and In the Way :)
18:55:08 <dlenrow> what did you call me?
18:55:10 <edwarnicke> Would it make sense to in Beryllium start asking projects the use cases they are trying to solve and their deployment snares?
18:55:13 <edwarnicke> senarios
18:55:14 <alagalah> dlenrow: lolz
18:55:14 <tbachman> dlenrow: Way
18:55:15 <dlenrow> :)
18:55:21 <mohnish> tbachman: someone=mohnish. :-)
18:55:25 <tbachman> mohnish: thx!
18:55:28 <edwarnicke> That preserves bottom up, but provides the visibility you are suggesting
18:55:30 <rovarga> colindixon: unfortunately it is quite hard to document something which has not been coded up
18:55:32 <tbachman> I couldn’t tell — you must be caller 9?
18:55:34 <alagalah> edwarnicke: The problem is that would be per-project, not controller wide (multiproject)
18:55:45 <tbachman> #undo
18:55:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19b8490>
18:55:48 <edwarnicke> alagalah: I see no reason that projects couldn't collaborate on use cases
18:55:53 <edwarnicke> alagalah: In fact I think that's ideal :)
18:55:54 <tbachman> #info mohnish   says we should also track what we are doing, so that we drive advice and insight as to what ODL is good at beyond what we call attention to
18:55:59 <alagalah> edwarnicke: Neither do I but that isn't what you said mate
18:56:02 <ShaunWackerly> Wouldn't use case automation and documentation be along the lines of a deliverable for the integration project?
18:56:12 * edwarnicke is not always good with his words :)
18:56:26 * alagalah I'm in a bit of a glass-house for wordification
18:56:35 <tbachman> #info colindixon suggests the first use case would be neutron with network virtualization, as there are already tests and CI infrastructure from openstack that would allow us to get that up and running quickly
18:56:56 <regXboi> so I have very strong opinions about that
18:57:01 <regXboi> and they aren't positive ones
18:57:04 <alagalah> colindixon: Is OPNFV at a state we can integrate with ?
18:57:05 <tbachman> #info edwarnicke asks if we can throw this out to the project leads
18:57:19 <cdub_> alagalah: what does that mean?
18:57:28 <RajeevK> OPNFV - may be not yet
18:57:30 <dfarrell07> ShaunWackerly: To some extent, yes, I think so. I also think that's a nuanced question and would need a discussion to really answer it
18:57:43 <cdub_> alagalah: OPNFV isn't a thing, it's integration, and odl is part of the opnfv integration w/ openstack
18:57:46 * tykeal is pretty certain the OPNFV is not at a state for integration. They don't have build infra online yet even as they've been wrangling that
18:57:47 <alagalah> cdub_: Is the OPNFV project at say API freeze for arguements sake so it maybe a use case... maybe Be
18:57:55 <tbachman> #info colindixon agrees with edwarnicke on contacting the project leads
18:57:56 <alagalah> cdub_: I see, thanks
18:57:58 <dlenrow> OPNFV will suck down LIthium and try to make it do something good
18:57:59 <dfarrell07> alagalah: We're working on that *right now*
18:58:02 <cdub_> alagalah: there's no API freeze
18:58:12 <alagalah> Thanks all :)
18:58:16 <dlenrow> R1 pulls LIthium and integraTES
18:58:22 <regXboi> #info regXboi expresses doubts about the suggested first use case
18:58:40 <cdub_> we have a chicken and egg w/ users
18:58:50 <tbachman> cdub: are we back to cooking?
18:58:51 <edwarnicke> cdub_: Are you proposing bacon?
18:59:00 * edwarnicke mmm... delicious bacon
18:59:06 <cdub_> we can't clearly tell our users what we do, so it's hard to get user input
18:59:11 <RajeevK> I wouldn't put OPNFV in the same bucket as Neutron and SFC ;)
18:59:17 <cdub_> tbachman: unintentionally!
18:59:26 <tbachman> lol
18:59:29 <dlenrow> cdub: we do SDN (sarcasm)
18:59:37 <edwarnicke> #info I think that NFV is a critical use case for us in Lithium :)
18:59:39 <RajeevK> NetVirt, SFC are good ones IMO
18:59:41 <cdub_> dlenrow: cool, i have a slide on that
18:59:49 * phrobb notes that cookbooks as gifts at the summit is now a contender… every recipe with bacon….
18:59:57 <tbachman> phrobb: and cookies!
18:59:57 <tbachman> lol
19:00:00 * regXboi goes ugh
19:00:03 <cdub_> (SDN means anything to anybody)
19:00:06 <tbachman> #info bacon cookies, in fact
19:00:08 <phrobb> bacon infused cookies
19:00:09 <regXboi> cdub_: +1
19:00:10 <dlenrow> cdub_: I suggested to the ironic team that the createed a project called sarcastic
19:00:16 <regXboi> phrobb: that was why the ugh
19:00:17 * tbachman had to info that last one
19:00:18 * edwarnicke *loves* the ODL cookbook swag idea
19:00:18 <abhijitkumbhare> +1 to RajeevK (NetVirt & SFC)
19:00:21 <cdub_> dlenrow: haha
19:00:22 <alagalah> Bacon cookies are over-rated :(
19:00:26 * edwarnicke notes we need to also work in unicorns and rainbows
19:00:31 <cdub_> i worked on a project called sardonic
19:00:42 <tbachman> cdub_: how was the morale?
19:00:42 <dlenrow> perfect
19:00:46 <regXboi> are we done? - i.e. can I run to another meeting?
19:00:56 <tbachman> regXboi: judging by this IRC, maybe
19:01:08 <tykeal> bacon cookies? http://www.joeydevilla.com/wordpress/wp-content/uploads/2007/12/bacon_chocolate_chip_cookies_with_maple_cinnamon_glaze.png
19:01:16 <regXboi> tbachman: I got my info in on the whole use case proposal
19:01:22 <regXboi> so it's in the minutes
19:01:34 <tbachman> colindixon: that was a while ago?
19:01:34 <tykeal> lol
19:01:36 <tbachman> Oh
19:01:38 <cdub_> sardonix actually
19:01:53 <cdub_> tbachman: it was bitter (project failed ;)
19:01:53 <colindixon> #action colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
19:02:02 <rovarga> evolve the toaster to an oven and theen ... :)
19:02:09 <tbachman> colindixon: thx
19:02:13 <tbachman> beat me to it
19:02:20 <edwarnicke> rovarga: I bet we could make cookies in a toaster ;)
19:02:21 <tbachman> cdub_: lol
19:02:38 * rovarga is willing to review patches towards that :)
19:02:43 * tbachman wonders how these minutes will appear to the outside
19:02:55 <RajeevK> SHOULD in RFC verbiage
19:03:02 <tykeal> tbachman: the minutes probably fine, the full logs though...
19:03:04 <edwarnicke> tbachman: hopefully delicuous :)
19:03:23 * tykeal notes he didn't stick any of the picture links in as #info lines
19:03:30 <tykeal> or #link lines for that matter
19:04:18 <dlenrow> edwarnicke: that higher level structure is called system architecture and we need it badly
19:04:40 <tbachman> #endmeeting