#opendaylight-meeting: tsc

Meeting started by colindixon at 18:01:45 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 18:01:53)
    1. colindixon (colindixon, 18:02:13)
    2. dfarrell07 for cdub and Red Hat (on TSC mailing list) (dfarrell07, 18:02:26)
    3. edwarnicke for fun (edwarnicke, 18:02:30)
    4. sdean778 asked for us to add a topic on how to hanlde vendor-specific code, it’s on the agenda (colindixon, 18:02:44)
    5. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-02-19-18.00.html minutes from last week’s meeting (tbachman, 18:03:14)
    6. regXboi (regXboi, 18:03:48)
    7. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (colindixon, 18:04:44)
    8. kwatsen (kwatsen, 18:05:09)
    9. ACTION: colindixon and TSC to elaborate on proper procedure for removal of committers from a project (colindixon, 18:05:13)
    10. ACTION: colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags (colindixon, 18:05:21)
    11. ACTION: colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list (colindixon, 18:05:26)
    12. Chris Price (late again) (ChrisPriceAB, 18:05:56)
    13. Youcef Laribi (Youcef, 18:06:13)
    14. gzhao still hasn’t received response from Maple and Defense4All (tbachman, 18:07:06)
    15. phrobb is still trying to work out IPR issues with Maple project (tbachman, 18:07:16)
    16. ACTION: phrobb to keep working with Maple (he is “cautiously pessimistic”) (colindixon, 18:07:33)
    17. ACTION: phrobb to reach out to Rob Sherwood about closing down net-virt-platform (colindixon, 18:08:19)
    18. LLDP with Auto-Attach project was approved by the TSC into incubation via the mailing list last week (tbachman, 18:08:27)
    19. ACTION: phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration (colindixon, 18:08:32)
    20. ACTION: phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases) (colindixon, 18:09:24)
    21. colindixon asks if we got feedback on new tentative dates for new SR’s for Helium (tbachman, 18:09:49)
    22. jmedved (jmedved, 18:10:02)
    23. https://lists.opendaylight.org/pipermail/release/2015-February/001461.html < proposed Helium SR3 & SR4 (gzhao, 18:10:03)

  2. Updates (tbachman, 18:10:07)
    1. phrobb says that everything moving along for April Hackfest — encourages folks to register (tbachman, 18:10:28)
    2. CFP has closed, received 90 submissions; notifying speakers week after next for those that were accepted (tbachman, 18:10:48)
    3. phrobb says that the CFP for the event in India has opened (tbachman, 18:11:07)

  3. lithium and stable/helium (tbachman, 18:12:03)
    1. colindixon asks how we’re doing with picking SR3/SR4 dates (tbachman, 18:12:14)
    2. https://lists.opendaylight.org/pipermail/release/2015-February/001461.html < proposed Helium SR3 & SR4 (tbachman, 18:12:20)
    3. Proposed dates are March 26th and July 17th for SR3 and SR4, respectively (tbachman, 18:13:12)
    4. regXboi says there was a hackfest to try to get the openstack CI test jobs for ODL to work (tbachman, 18:13:42)
    5. regXboi says this involves patching stable helium; came across issues with UserManager (tbachman, 18:14:03)
    6. LuisGomez (LuisGomez, 18:17:02)
    7. RajeevK_ (gzhao, 18:18:10)
    8. VOTE: Voted on "Shall Helium SR3 release be on March 26th and tentatively SR4 be July 16th?" Results are, +1: 9 (phrobb, 18:19:36)
    9. AGREED: Helium SR3 release will be on March 26th and tentatively SR4 be July 16th (phrobb, 18:20:05)
    10. ACTION: gzhao to put SR3, SR4 tentative date to Helium release plan (gzhao, 18:20:23)
    11. regXboi notes that as a committer in neutron, he can’t merge backports to stable/helium, since it’s in the controller (tbachman, 18:21:40)
    12. regXboi and edwarnicke note that getting the fixes for Neutron for SR3 done will involve porting patches from Neutron to Controller and that will have complexities (colindixon, 18:21:50)
    13. gzhao says that defense4All and Maple are the only 2 projects with M2 status (tbachman, 18:22:43)
    14. gzhao says the Neutron project is still working on M2, but they are spinout so not due until M3 (tbachman, 18:22:57)
    15. gzhao says offset 1 projects have M3 status due next Thursday (tbachman, 18:23:14)
    16. gzhao encourages all offset 1 and 2 projects to attend next Monday’s TWS, on integration project’s testing requirements (tbachman, 18:23:36)
    17. https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 < -- single feature test tracking (gzhao, 18:24:22)
    18. gzhao says that the spreadsheet provided in the link; AAA needs to submit a patch to turn on the single-feature-test (tbachman, 18:25:12)
    19. ACTION: ALL PROJECTS need to make sure your single feature test is turned on and running (colindixon, 18:27:48)
    20. https://lists.opendaylight.org/pipermail/release/2015-February/001488.html the mail ddescribing the issue and how to fix it (colindixon, 18:28:37)
    21. https://git.opendaylight.org/gerrit/#/c/15773/ (rovarga_, 18:30:27)
    22. rovarga_ asks for odlparent to merge two patches outstanding: one which fixes eclipse and one which makes the feature test run faster (colindixon, 18:30:27)
    23. ACTION: dfarrell07 to get cdub to review and merge odlparent patches (colindixon, 18:30:48)

  4. System integration and Test (tbachman, 18:31:29)
    1. LuisGomez asks what to do when there are projects that block integration and are unreachable (tbachman, 18:31:45)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-February/002643.html Email from LuisGomez on this issue (tbachman, 18:32:58)
    3. colindixon says he feels that it’s within integration’s scope to remove a project from integration build if they don’t respond within 48 business hours in order to move forward (tbachman, 18:34:57)
    4. LuisGomez asks if it would be possible to label/mark the projects “we know” nobody maintains/supports anymore (OSCP, Affinity, etc…) (tbachman, 18:35:32)
    5. https://wiki.opendaylight.org/view/Project_list this list says nothing about how “maintained” a project is, LuisGomez would like to add information about certain projects being abandoned, e.g., affinity and OSCP (colindixon, 18:36:27)
    6. rovarga_ says there are about 16 projects still using yangtools features-test, by his count (applied towards previous topic) (tbachman, 18:36:47)
    7. edwarnicke suggests that we maybe reach out to aks projects to terminate themselves if projects seem like they shoudl abe archived (colindixon, 18:38:04)
    8. ACTION: colindixon to send a mail to the list and (possibly) put it on the agenda for next week about ways to trackwhich projects are active (colindixon, 18:41:02)

  5. Vendor Specific Code (tbachman, 18:41:47)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-February/002618.html the thread that sparked this topic (colindixon, 18:42:10)
    2. sdean778 asks what the TSC’s opinion is on this (tbachman, 18:42:42)
    3. regXboi asks what the code license is (tbachman, 18:42:55)
    4. colindixon says this is to submit code under the eclipse license (tbachman, 18:43:31)
    5. regXboi says it should be split into a legal and a technical part, on the legal side the code must be able to be EPL code if we’re going to host it in ODL repos (colindixon, 18:44:50)
    6. edwarnicke says from a technical perspective, he cares more that things can be side loaded without changes to the repo than anything else (colindixon, 18:45:46)
    7. is this "vendor specific code" being provided as free and open source code for ODL? That can be developed beyond "vendor specific"? (ChrisPriceAB, 18:46:49)
    8. sdean778 asks if we want the distribution to support vendor devices out-of-the-box (tbachman, 18:46:54)
    9. phrobb asks if there’s a construct in our repo and test environment to enable this — we need the vendor devices to do this (tbachman, 18:47:16)
    10. ashaikh wonders if there’s a way to indicate that this isn’t licensed the same way (tbachman, 18:47:51)
    11. colindixon says there’s the question of licensing, but also how to do we make sure it’s tested (tbachman, 18:48:25)
    12. abhijitkumbhare says it doesn’t have to be a separate licesnse (tbachman, 18:48:45)
    13. regXboi says licensing is where you get tripped up (tbachman, 18:49:06)

  6. Best Practices (tbachman, 18:51:47)
    1. https://wiki.opendaylight.org/view/Developer_Best_Practices Developer Best Practices wiki page (tbachman, 18:52:12)
    2. https://wiki.opendaylight.org/view/Logging_Best_Practices Logging Best Practices wiki page (tbachman, 18:52:27)
    3. https://wiki.opendaylight.org/view/General_Style_Guidelines General Style Guidelines wiki page (tbachman, 18:52:43)
    4. https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Main Housekeeping Best Practices wiki page (main) (tbachman, 18:53:05)
    5. https://lists.opendaylight.org/pipermail/controller-dev/2014-July/005766.html email describing commiter checklist (tbachman, 18:53:38)
    6. ACTION: colindixon to start a discussion for the TSC to agree on a variant the statement “the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model” on the mailing list (colindixon, 19:02:53)
    7. ACTION: colindixon start a thread to have some kind fo subgroup deal with other best practices (colindixon, 19:03:15)

  7. Cookies (phrobb, 19:03:36)


Meeting ended at 19:03:40 UTC (full logs).

Action items

  1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
  3. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
  4. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
  5. phrobb to keep working with Maple (he is “cautiously pessimistic”)
  6. phrobb to reach out to Rob Sherwood about closing down net-virt-platform
  7. phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration
  8. phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases)
  9. gzhao to put SR3, SR4 tentative date to Helium release plan
  10. ALL PROJECTS need to make sure your single feature test is turned on and running
  11. dfarrell07 to get cdub to review and merge odlparent patches
  12. colindixon to send a mail to the list and (possibly) put it on the agenda for next week about ways to trackwhich projects are active
  13. colindixon to start a discussion for the TSC to agree on a variant the statement “the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model” on the mailing list
  14. colindixon start a thread to have some kind fo subgroup deal with other best practices


Action items, by person

  1. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
    3. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
    4. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
    5. colindixon to send a mail to the list and (possibly) put it on the agenda for next week about ways to trackwhich projects are active
    6. colindixon to start a discussion for the TSC to agree on a variant the statement “the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model” on the mailing list
    7. colindixon start a thread to have some kind fo subgroup deal with other best practices
  2. dfarrell07
    1. dfarrell07 to get cdub to review and merge odlparent patches
  3. gzhao
    1. gzhao to put SR3, SR4 tentative date to Helium release plan
  4. phrobb
    1. phrobb to keep working with Maple (he is “cautiously pessimistic”)
    2. phrobb to reach out to Rob Sherwood about closing down net-virt-platform
    3. phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration
    4. phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases)
  5. zxiiro
    1. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags


People present (lines said)

  1. tbachman (98)
  2. colindixon (40)
  3. ChrisPriceAB (20)
  4. odl_meetbot (17)
  5. gzhao (13)
  6. regXboi (12)
  7. tykeal (11)
  8. dfarrell07 (10)
  9. rovarga_ (7)
  10. abhijitkumbhare (7)
  11. RajeevK_ (7)
  12. phrobb (6)
  13. alagalah (6)
  14. edwarnicke (4)
  15. LuisGomez (2)
  16. Youcef (2)
  17. ashaikh (2)
  18. zxiiro (2)
  19. jmedved (2)
  20. kwatsen (1)
  21. Prem_ (1)
  22. nathanharmon (1)
  23. snoble (1)


Generated by MeetBot 0.1.4.