#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:53 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 18:00:59)
    1. colindixon (colindixon, 18:01:01)
    2. https://wiki.opendaylight.org/view/TSC:Main#Agenda Today’s agenda (tbachman, 18:01:04)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-02-26-18.01.html Minutes from last week’s meeting (tbachman, 18:01:16)
    4. edwarnicke is having fun (edwarnicke, 18:01:24)
    5. dlenrow (dlenrow, 18:01:36)
    6. abhijitkumbhare for Chris Price (abhijitkumbhare, 18:02:00)
    7. regXboi (regXboi, 18:02:36)
    8. LuisGomez (LuisGomez, 18:03:05)
    9. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (colindixon, 18:03:39)
    10. mohnish anumala (mohnish, 18:04:24)
    11. ACTION: colindixon, zxiiro will set mail about setting up opt-in/opt-out automatic version bump patches and tags this week (colindixon, 18:04:42)
    12. https://lists.opendaylight.org/pipermail/tsc/2015-March/002663.html Email fro colindixon on various action items from last week’s meeting (e.g. committer removal) (tbachman, 18:04:51)
    13. ACTION: colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list (colindixon, 18:04:52)
    14. ACTION: phrobb to keep working with Maple (he is “cautiously pessimistic”) (colindixon, 18:05:25)
    15. ACTION: phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases) (colindixon, 18:05:59)
    16. gzhao put tentative dates for SR3 and SR4 into Helium release plan (tbachman, 18:06:39)
    17. ACTION: colindixon start a thread to have some kind fo subgroup deal with other best practices (colindixon, 18:07:02)
    18. https://lists.opendaylight.org/pipermail/tsc/2015-March/002681.html Email from colindixon on tracking active projects (tbachman, 18:07:10)
    19. https://lists.opendaylight.org/pipermail/tsc/2015-March/002682.html Email from colindixon on archiving OSCP project (tbachman, 18:08:29)
    20. RajeevK (RajeevK, 18:08:53)

  2. Stable Helium & Lithium (tbachman, 18:09:29)
    1. gzhao says there are 6 out of 17 offset 1 projects that have reported M3 status (tbachman, 18:09:41)
    2. so far (regXboi, 18:09:52)
    3. gzhao says PCMM hasn’t finalized the release plan (tbachman, 18:10:16)
    4. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the project status tracking spreadsheet (colindixon, 18:11:16)
    5. colindixon asks if we’re in contact with projects that haven’t reported or are red (tbachman, 18:11:51)
    6. gzhao says he’s in contact with Defense4All, but it’s not clear where they are (colindixon, 18:12:51)
    7. ACTION: phrobb- and colindixon to reach out to ALTO and MAPLE to figure what’s going on (colindixon, 18:13:12)
    8. ACTION: colindixon, phrobb-, and gzhao to work with Defense4All to figure out what their options are (colindixon, 18:13:44)
    9. jmedved (jmedved, 18:13:50)
    10. zxiiro says that every project generates javadocs in a different way; need to get all projects doing it the same way (tbachman, 18:15:16)
    11. https://lists.opendaylight.org/pipermail/discuss/2015-March/004759.html Thanh got the lithium autorelease working (with some issues) (colindixon, 18:15:25)
    12. the Helium-SR3 RC will be cut two weeks from tomorrow, please get patches in by then (colindixon, 18:17:56)

  3. System Integration and Testing (tbachman, 18:18:06)
    1. we seem to be doing better now that we have a formal policy about being able to (temporarily) kick projects out of the build if they break it for everyone (colindixon, 18:18:38)
    2. LuisGomez says that all integration and system test jobs are now in JJB (colindixon, 18:19:15)
    3. https://jenkins.opendaylight.org/releng/view/CSIT-Jobs/ (LuisGomez, 18:19:34)

  4. Updates (tbachman, 18:19:41)
    1. phrobb encourages folks to sign up for the mid-April hackfest (tbachman, 18:19:56)
    2. ODL Summit speakers will be notified soon (dfarrell07, 18:20:31)
    3. phrobb says they’ve had 27 submissions for the forum this April in India (tbachman, 18:20:43)
    4. phrobb says they’re running a technical track at NFV world in May and ONS summit in June (tbachman, 18:21:12)
    5. phrobb has some folks creating training content; first plan of action is to turn that content into a tutorial (tbachman, 18:22:31)
    6. for the tutorial session at ONS is to use traning content that the LF has people building, but there will be a tutorial (during Sunday) at the ONS (colindixon, 18:22:44)
    7. the tutorials are for ONS, and will also be done at the ODL summit (tbachman, 18:23:11)
    8. phrobb says anyone on the call who wants to submit something for tutorials, reach out to phrobb (tbachman, 18:23:51)
    9. https://events.linuxfoundation.org/events/opendaylight-summit the ODL summit in June (colindixon, 18:24:32)
    10. https://events.linuxfoundation.org/cfp/cfp-add the submission page to submit tutorials (colindixon, 18:24:51)
    11. http://www.opendaylight.org/news/events events for future reference (colindixon, 18:25:08)

  5. Committer Promotion for SFC (tbachman, 18:25:37)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-March/002678.html the request (colindixon, 18:25:56)
    2. https://lists.opendaylight.org/pipermail/sfc-dev/2015-March/000958.html the thread showing 7 +1 votes (colindixon, 18:26:15)
    3. https://git.opendaylight.org/gerrit/#/q/owner:%22Andrej+Kincel+%253Cakincel%2540cisco.com%253E%22+status:merged Andrej’s merged patches on SFC (colindixon, 18:26:27)
    4. https://git.opendaylight.org/gerrit/#/q/reviewer:%22Andrej+Kincel+%253Cakincel%2540cisco.com%253E%22 Andrej’s reviews on SFC (colindixon, 18:26:39)
    5. ebrjohn says Andrej has been involved in the SFC since December working with Reinaldo Penno as his mentor and they’d be lucky to have him as a commiter (colindixon, 18:27:45)
    6. VOTE: Voted on "Shall the TSC approve Andrej as a committer to SFC?" Results are, +1: 7 (dfarrell07, 18:29:11)
    7. AGREED: The TSC approves Andrej as a committer to SFC (dfarrell07, 18:29:46)
    8. colindixon requests that TSC members look for [vote] topics on TSC mailing list, so that certain items can be handled there rather than on the TSC call (tbachman, 18:30:32)

  6. Signing Artifacts (tbachman, 18:30:47)
    1. tykeal says there are two types of signing that we need to do: GPG signing and certificate signing (tbachman, 18:31:15)
    2. colindixon asks tykeal to explain why we need code signing (tbachman, 18:31:39)
    3. tykeal says code signing is done during the build process — we add a cryptographic signature so that downstream users can verify the artifacts (tbachman, 18:32:16)
    4. GPG keys can be used to validate the public portion against the private portion used to sign the artifacts (tbachman, 18:32:31)
    5. The other way is to purchase an SSL cert that adds the signing component to the jar via standard SSL validation mechanisms (tbachman, 18:32:52)
    6. both can be used by end users to verify artifacts (tbachman, 18:33:05)
    7. http://maven.apache.org/guides/mini/guide-central-repository-upload.html <- PGP signing is required (which I believe is the same as GPG signing) (edwarnicke, 18:33:06)
    8. tykeal says GPG == PGP in this case (colindixon, 18:33:36)
    9. tykeal says the ODL web of trust key ring was started at they first ODL summit (tbachman, 18:34:03)
    10. tykeal is looking to do another web of trust key ring signing at the next summit (tbachman, 18:34:33)
    11. tykeal says the GPG key ring will be disseminated to key servers, so that folks can use it (tbachman, 18:35:06)
    12. tykeal says they still have to test how this can be done programmatically; suggests doing it only from the auto-build process (tbachman, 18:35:27)
    13. tykeal says he doesn’t want to manage private keys on multiple different silos, as it’s unsafe (tbachman, 18:35:46)
    14. colindixon asks at a key signing event, what are the implications of what it is that we’re saying? (tbachman, 18:37:04)
    15. tykeal says that you have either met or believe that the person stating they have this key is who they say they are (tbachman, 18:37:23)
    16. colindixon says you’re connecting a private key with a human, and also a private key with a set of software (tbachman, 18:37:51)
    17. LuisGomez asks if we need users of the signed artifacts to be part of this key ring (tbachman, 18:38:09)
    18. tykeal says we’d publish the public portion of the key on our website (tbachman, 18:39:40)
    19. tykeal says that allows folks who aren’t part of the web of trust can verify that the artifacts have been signed by the public key (tbachman, 18:40:06)
    20. LuisGomez asks if this precludes anyone from using the artifacts (tbachman, 18:40:26)
    21. tykeal says that shouldn’t happen unless someone implements something in java to reject things that aren’t signed by the key (tbachman, 18:40:51)
    22. LuisGomez asks how you’d verify the artifacts are genuine, tykeal says he’s not sure how that happens in maven or Java, but he assumes it’s possible (colindixon, 18:41:33)
    23. tykeal says the only location that signing happens is on the ODL servers (tbachman, 18:41:36)
    24. edwarnicke says he believes the GPG signing just results in an extra file (tbachman, 18:42:21)
    25. colindixon says that b/c this is being done in the releng job, projects don’t need to take any action to enable this (tbachman, 18:43:16)
    26. tykeal says he still has a bit of digging to make sure — worst case is some pom file modifications (tbachman, 18:43:29)
    27. ACTION: dfarrell07 will make sure there's a key signing at the hack fest (dfarrell07, 18:45:57)

  7. Best practices for easy cross-platform deployability (tbachman, 18:46:22)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html e-mail to TSC with revised language on best practices (tbachman, 18:46:52)
    2. colindixon says the key changes is the language that allows projects to include external apps, but can’t require them. (tbachman, 18:48:02)
    3. mohnish says in TSDR, it makes sense to have an internal database for demos, but for production deployments, would need an external dependency (tbachman, 18:48:29)
    4. mohnish asks if we just document dependencies, and automation/scripts can be provided, then this should be okay (tbachman, 18:49:03)
    5. colindixon asks if the text as written is agreeable to mohnish (tbachman, 18:49:16)
    6. mohnish says yes (tbachman, 18:49:26)
    7. VOTE: Voted on "Shall the TSC approve the method described here: https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html as best practice for cross platform deployments?" Results are, +1: 8 (phrobb, 18:53:31)

  8. Setting dates for Lithium stability updates (tbachman, 18:53:53)
    1. AGREED: best practice for cross platform deployments documented here: https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html has been approved. (phrobb, 18:54:34)
    2. colindixon asks if we want to continue stability releases until Beryllium is released (tbachman, 18:55:04)
    3. colindixon asks if we want to continue stability releases on Lithium until Beryllium is released (tbachman, 18:56:24)
    4. dneary says he believes that you’d want fixes for the last stable branch - Lithium after release - and maintain security updates only until M1 of the next unstable release (tbachman, 18:56:37)
    5. regXboi asks what other communities are doing for this (tbachman, 18:56:47)
    6. colindixon asks if anyone knows what openstack does for this (tbachman, 18:56:57)
    7. dneary says he thought M1 would be enough to allow people to upgrade to the next stable version (tbachman, 18:57:33)
    8. edwarnicke says you continue to support Lithium until Beryllium SR1 comes out (tbachman, 18:57:57)
    9. colindixon says in the long run, he believes a goal could be to support two stable releases, but in the short term, may be a bit ambitious (tbachman, 18:58:31)
    10. ACTION: colindixon to bring dates for stable release updates for Lithium to next week’s TSC meeting (tbachman, 18:59:05)
    11. rovarga asks if that includes fixes to deprecated APIs (tbachman, 18:59:25)
    12. regXboi is no longer here (regXboi, 18:59:39)
    13. colindixon says you do need to support deprecated APIs for some amount of time, as you transition between stable releases (tbachman, 19:00:39)
    14. ACTION: colindixon to start mailing list thread on the dates and deprecated APIs issues for Stable releases (tbachman, 19:01:05)

  9. cookies (tbachman, 19:01:24)
  10. COOKIES (phrobb, 19:01:29)


Meeting ended at 19:01:31 UTC (full logs).

Action items

  1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  2. colindixon, zxiiro will set mail about setting up opt-in/opt-out automatic version bump patches and tags this week
  3. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
  4. phrobb to keep working with Maple (he is “cautiously pessimistic”)
  5. phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases)
  6. colindixon start a thread to have some kind fo subgroup deal with other best practices
  7. phrobb- and colindixon to reach out to ALTO and MAPLE to figure what’s going on
  8. colindixon, phrobb-, and gzhao to work with Defense4All to figure out what their options are
  9. dfarrell07 will make sure there's a key signing at the hack fest
  10. colindixon to bring dates for stable release updates for Lithium to next week’s TSC meeting
  11. colindixon to start mailing list thread on the dates and deprecated APIs issues for Stable releases


Action items, by person

  1. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon, zxiiro will set mail about setting up opt-in/opt-out automatic version bump patches and tags this week
    3. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
    4. colindixon start a thread to have some kind fo subgroup deal with other best practices
    5. phrobb- and colindixon to reach out to ALTO and MAPLE to figure what’s going on
    6. colindixon, phrobb-, and gzhao to work with Defense4All to figure out what their options are
    7. colindixon to bring dates for stable release updates for Lithium to next week’s TSC meeting
    8. colindixon to start mailing list thread on the dates and deprecated APIs issues for Stable releases
  2. dfarrell07
    1. dfarrell07 will make sure there's a key signing at the hack fest
  3. gzhao
    1. colindixon, phrobb-, and gzhao to work with Defense4All to figure out what their options are
  4. phrobb
    1. phrobb to keep working with Maple (he is “cautiously pessimistic”)
    2. phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases)
    3. phrobb- and colindixon to reach out to ALTO and MAPLE to figure what’s going on
    4. colindixon, phrobb-, and gzhao to work with Defense4All to figure out what their options are
  5. zxiiro
    1. colindixon, zxiiro will set mail about setting up opt-in/opt-out automatic version bump patches and tags this week


People present (lines said)

  1. tbachman (124)
  2. colindixon (40)
  3. regXboi (29)
  4. odl_meetbot (26)
  5. dfarrell07 (19)
  6. edwarnicke (11)
  7. tykeal (11)
  8. abhijitkumbhare (10)
  9. dneary (7)
  10. phrobb (7)
  11. mohnish (7)
  12. rovarga (6)
  13. dlenrow (5)
  14. gzhao (5)
  15. alagalah (4)
  16. LuisGomez (3)
  17. RajeevK (3)
  18. zxiiro (3)
  19. ebrjohn (2)
  20. jmedved (2)
  21. Neelajacques (1)
  22. phrobb- (0)


Generated by MeetBot 0.1.4.