#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:05 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:13)
    1. colindixon (colindixon, 17:00:16)
    2. https://wiki.opendaylight.org/view/TSC:Main#Agenda Today’s agenda (tbachman, 17:00:34)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-03-19-17.00.html Last week’s meeting minutes (tbachman, 17:00:45)
    4. dfarrell07 for cdub and Red Hat (dfarrell07, 17:02:11)
    5. Chris Price (almost on audio) (ChrisPriceAB, 17:02:21)
    6. LuisGomez (LuisGomez, 17:02:29)
    7. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (colindixon, 17:03:07)
    8. ACTION: colindixon keep the thread on best practices alive (colindixon, 17:03:13)
    9. edwarnicke (edwarnicke, 17:03:51)
    10. ACTION: dlenrow to follow up on the mail about how to procede with persitence (colindixon, 17:03:55)
    11. regXboi (partly here) (regXboi, 17:04:16)
    12. jmedved (jmedved, 17:04:18)
    13. mohnish (mohnish, 17:04:25)
    14. ACTION: LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist (colindixon, 17:04:39)
    15. ACTION: rovarga (and/or Thanh) to add an something to a backlog somewhere about measuring latency between merge and CSIT completely finishing (colindixon, 17:08:08)
    16. LuisGomez says that this may be easier in Beryllium assuming we move Zuul (colindixon, 17:08:43)

  2. updates (colindixon, 17:09:33)
    1. ACTION: zxiiro to create revert patches for autorelease <relativePaths> and abandon existing patches. Will resolve <relativePaths> inside of autorelease scripts instead. (zxiiro, 17:09:59)
    2. wojciech would like to add discussing the AAA project to the agenda (tbachman, 17:10:30)
    3. colindixon will cover requests to the TSC from the board (colindixon, 17:10:57)
    4. edwarnicke requests to cover the weather briefly (colindixon, 17:11:05)

  3. Events (colindixon, 17:11:07)
    1. phrobb says that the hackfest is coming up 4/15-4/16; 49 people are registered; those who want to start with action items to work on should start to formulate what that looks like and send an agenda (tbachman, 17:11:13)
    2. phrobb says for the ODL summit in July: notifications to speakers are going out now (not all out yet — in process today and tomorrow) for accepted presentations and tutorials (tbachman, 17:11:56)
    3. http://www.opendaylight.org/news/events ODL Events web page (tbachman, 17:12:24)

  4. Lithium and Stable/Helium (tbachman, 17:12:52)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-March/002769.html summary from phrobb (colindixon, 17:13:22)
    2. gzhao is still waiting for 5 offset 2 projects to report (tbachman, 17:13:42)
    3. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the project stats spreadsheet (colindixon, 17:13:49)
    4. reservation says they’ll report soon; core tutorials not as concerned about; 2 other projects still to report (tbachman, 17:14:14)
    5. colindixon says the most concerning one is AAA, which is on the agenda (tbachman, 17:15:02)
    6. gzhao says discovery is also in red (tbachman, 17:15:08)
    7. zxiiro says there are 5 projects still to complete the SR3 merging/tagging (tbachman, 17:15:27)
    8. Youcef Laribi (Youcef, 17:15:29)
    9. zxiiro says l2switch can merge, which is holding up other projecgts (tbachman, 17:15:46)
    10. colindixon asks if there’s anything else around projects moving to JJB, etc. (tbachman, 17:16:17)
    11. zxiiro says Defense4All has moved to JJB; just plugin2oc is left (tbachman, 17:16:31)
    12. tykeal points out that OpFlex is also not in JJB, but they’re working with them already (tbachman, 17:17:13)
    13. ACTION: LuisGomez to start a thread about how to unblock integration testing until patches are merged (colindixon, 17:18:14)

  5. System Integration and Test (tbachman, 17:18:27)
    1. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Performance_Test:Results Performance Test results in lab by Integration group (tbachman, 17:19:03)
    2. LuisGomez says they’ll be measuring performance from now on and will be reporting in this wiki, and will report bugs (tbachman, 17:19:23)
    3. LuisGomez says he’ll keep track of the bugs and bring them up if they’re not being filed by developers (tbachman, 17:20:12)
    4. mohnish says longevity is also important — asks if it’s also being tested (tbachman, 17:20:56)
    5. LuisGomez says they’re working on setting up longevity testing, but nothing currently; Spirent may also help with this effort (tbachman, 17:21:20)
    6. jmedved asks if LuisGomez is using the scripts he provided a while back (tbachman, 17:21:46)
    7. LuisGomez says they’re using the scripts for some things (tbachman, 17:21:57)
    8. jmedved says the codecs for REST have changed recently — should retest to see if there’s significant performance improvements (tbachman, 17:22:47)

  6. Infrastructure (tbachman, 17:24:09)
    1. the sandbox has been having issues because of how much stuff has been going through releng (colindixon, 17:24:35)
    2. tykeal says odlforge has been put on the backburner until releng stuff gets worked out (tbachman, 17:25:18)

  7. AAA status (tbachman, 17:25:25)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-March/002775.html the status from AAA (colindixon, 17:26:07)
    2. Wojciech says that the token caches looks like it will make it (colindixon, 17:27:36)
    3. Wojciech said they had a dependency on the persistence project, which also has resource changes, which puts this in jeopardy (tbachman, 17:27:37)
    4. Wojciech says there are only three people currently on the project; there is a choice of an MD-SAL AAA keystore, or completeing the keystone project (notes MD-SAL AAA would be “experimental") (tbachman, 17:28:35)
    5. Mahesh (from HP) asks for using MD-SAL for AAA — with in-memory data store, is that sufficient? (tbachman, 17:29:13)
    6. colindixon says we’re going to enable the clustered data store by default, but without clustering (i.e. single-node), so it will be persistent by default for Lithium (tbachman, 17:29:39)
    7. Mahesh asks if AAA can then use the MD-SAL and meet the Lithium goals (tbachman, 17:30:05)
    8. Wojciech says he doesn’t feel comfortable committing to this deliverable by Lithium — though they can make progress there (tbachman, 17:30:30)
    9. colindixon asks who is dependent on delivery of these features (e.g. SNMP for keymanager)? (tbachman, 17:31:01)
    10. Wojciech says other than the general public interested in deploying AAA in clusters, he’s not aware of any (tbachman, 17:31:21)
    11. Wojciech says SNMP is no longer dependent as they’ve gone with a very simple mechanism for storing their credentials (tbachman, 17:31:39)
    12. colindixon asks why keystone federation was critical for Lithium? (tbachman, 17:32:35)
    13. edwarnicke says we need to make sure we have something that works following the standard “out of the box” deployment model — keystone radically changes this model (tbachman, 17:33:12)
    14. edwarnicke says that mestery says it’s super-important to talk sooner rather than later to openstack keystone folks in order to make sure there aren’t any issues there (tbachman, 17:33:40)
    15. ACTION: regXboi, Wojciech. edwarnicke, and Mahesh to organize meeting to talk about AAA keystone federation (tbachman, 17:35:09)
    16. Wojciech asks for guidance from TSC on “chicken-and-egg” problem (tbachman, 17:35:31)
    17. ACTION: edwarnicke, rovarga, and ttkacik1 to look into bootstrapping AAA (tbachman, 17:35:46)
    18. Mahesh said for AAA, there was a dependency on SQLite, which is not present on all the platforms; asks if we’re removing that dependency (tbachman, 17:36:51)
    19. edwarnicke says that there’s a patch that mlemay has provided that *almost* works when using H3 (tbachman, 17:37:09)
    20. there’s a patch that mlemay provided that will help us to move to Karaf to 3.0.3 (colindixon, 17:37:17)
    21. edwarnicke says it would be huge if someone can pick that patch up and complete it (tbachman, 17:37:33)
    22. Mahesh said HP will try to pick up this item (tbachman, 17:37:43)

  8. Weather (by edwarnicke) (tbachman, 17:37:58)
    1. https://wiki.opendaylight.org/view/Weather#Clustered_Data_Store_Switch_over Clustered Data Store Switchover on Weather page (tbachman, 17:38:26)
    2. edwarnicke says there’s one change that’s positive that folks need to be aware of — controller restarts will come up with persisted data, by default (tbachman, 17:38:52)
    3. rovarga says the BGP-PCEP project currently won’t work with the clustered data store (tbachman, 17:40:01)
    4. ACTION: rovarga to add the fact that BGP-PCEP currently won’t work with clustered data store to weather page (tbachman, 17:40:33)

  9. Board Requests for the TSC (tbachman, 17:41:13)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-March/002806.html the board requests of the TSC (colindixon, 17:41:27)
    2. colindixon says there are 6 requests from the TSC in that email (tbachman, 17:41:47)
    3. ChrisPriceAB asks who sets the requirements on projects (tbachman, 17:45:21)
    4. colindixon says he hopes its a combination of the TSC and projects (tbachman, 17:45:35)
    5. edwarnicke says that can get political. You need a consistent measure of performance and stability that can be tracked (tbachman, 17:45:59)
    6. edwarnicke says it’s not clear that there are clear definitions for how you measure performance and stability (tbachman, 17:46:16)
    7. ChrisPriceAB says that instead of setting a bar at the outset as far as a use case being achieved in some way, can we set up a set of metrics (tbachman, 17:46:49)
    8. ChrisPriceAB asks if we’re being to approve requests that we don’t yet know what they are (tbachman, 17:47:47)
    9. colindixon says we’ve been tasked to meet these requests, and explain how we will meet them. (tbachman, 17:48:09)
    10. VOTE: Voted on "Shall the TSC have a two hour meeting next week (4/2) given the addition discussions needed?" Results are, +1: 6, -1: 3 (phrobb1, 17:55:23)
    11. abhijitkumbhare asks about project maturity — expresses concern that very few projects will be mature in the Beryllium time frame (tbachman, 17:55:31)
    12. ChrisPriceAB asked about the difference between items one and five (tbachman, 17:57:11)
    13. colindixon says one is about lifecycles and five is about execution (tbachman, 17:57:24)
    14. regXboi_committer says the whole set of requirements is “borderline poison” (tbachman, 17:58:42)
    15. regXboi says if this comes from the community, that’s good; but coming from top-down, it’s an anathema to open-source (tbachman, 17:59:12)
    16. regXboi says items #2 and #3 declare winners and losers, and do so in a sneaky, underhanded way (tbachman, 17:59:32)
    17. Uri recommends consulting board members who were involved in the discussion, as there was a long discussion around these items (tbachman, 18:00:07)
    18. Uri says there was only an intent to provide focus and direction and drive deliverables — can’t be open-ended, b/c no investment can be completely open-ended (tbachman, 18:00:36)
    19. colindixon encourages folks to go to the mailing list to discuss these items (tbachman, 18:00:52)
    20. phrobb1 says the next board meeting is next Wednesday, April 1st (tbachman, 18:01:11)
    21. colindixon says we’re unlikely to have a response in time for the next board meeting (tbachman, 18:01:25)
    22. colindixon says his ask of TSC members and committers is to not knee-jerk react to these, but come with the “best” interpretation that can help move the project forward (tbachman, 18:02:00)

  10. cookies (tbachman, 18:02:57)
    1. edwarnicke points out that the extra hour for TSC members who do development is extra painful (tbachman, 18:04:01)


Meeting ended at 18:04:06 UTC (full logs).

Action items

  1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  2. colindixon keep the thread on best practices alive
  3. dlenrow to follow up on the mail about how to procede with persitence
  4. LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
  5. rovarga (and/or Thanh) to add an something to a backlog somewhere about measuring latency between merge and CSIT completely finishing
  6. zxiiro to create revert patches for autorelease <relativePaths> and abandon existing patches. Will resolve <relativePaths> inside of autorelease scripts instead.
  7. LuisGomez to start a thread about how to unblock integration testing until patches are merged
  8. regXboi, Wojciech. edwarnicke, and Mahesh to organize meeting to talk about AAA keystone federation
  9. edwarnicke, rovarga, and ttkacik1 to look into bootstrapping AAA
  10. rovarga to add the fact that BGP-PCEP currently won’t work with clustered data store to weather page


Action items, by person

  1. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon keep the thread on best practices alive
  2. edwarnicke
    1. LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
    2. regXboi, Wojciech. edwarnicke, and Mahesh to organize meeting to talk about AAA keystone federation
    3. edwarnicke, rovarga, and ttkacik1 to look into bootstrapping AAA
  3. LuisGomez
    1. LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
    2. LuisGomez to start a thread about how to unblock integration testing until patches are merged
  4. regXboi
    1. regXboi, Wojciech. edwarnicke, and Mahesh to organize meeting to talk about AAA keystone federation
  5. rovarga
    1. rovarga (and/or Thanh) to add an something to a backlog somewhere about measuring latency between merge and CSIT completely finishing
    2. edwarnicke, rovarga, and ttkacik1 to look into bootstrapping AAA
    3. rovarga to add the fact that BGP-PCEP currently won’t work with clustered data store to weather page
  6. zxiiro
    1. zxiiro to create revert patches for autorelease <relativePaths> and abandon existing patches. Will resolve <relativePaths> inside of autorelease scripts instead.


People present (lines said)

  1. tbachman (134)
  2. colindixon (30)
  3. odl_meetbot (17)
  4. dfarrell07 (12)
  5. phrobb1 (10)
  6. edwarnicke (7)
  7. ChrisPriceAB (6)
  8. LuisGomez (4)
  9. regXboi (4)
  10. tykeal (3)
  11. mohnish (3)
  12. Youcef (3)
  13. rovarga (2)
  14. jmedved (2)
  15. zxiiro (2)
  16. abhijitkumbhare (2)
  17. snoble (1)
  18. hideyuki (1)
  19. phrobb (0)


Generated by MeetBot 0.1.4.