#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:02 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:08)
    1. colindixon (colindixon, 17:00:16)
    2. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 17:00:46)
    3. Chris Price (too soon?) (ChrisPriceAB, 17:01:19)
    4. edwarnicke (edwarnicke, 17:02:04)
    5. dlenrow (dlenrow, 17:02:45)
    6. LuisGomez (LuisGomez, 17:02:49)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-09-17.00.html meeting minutes from last time (colindixon, 17:03:28)
    8. ACTION: dfarrell07 to draft a heuristic to determine if an issue for being a blocker to an SR (colindixon, 17:04:53)
    9. jmedved (jmedved, 17:05:59)
    10. ACTION: dfarrell07 to write up something about how to raise a bug as a (potential) blocker for lithium (colindixon, 17:06:18)
    11. mohnish (mohnish, 17:06:24)
    12. ACTION: regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround (colindixon, 17:07:16)
    13. LuisGomez suggests that if a project is blocking integration system tests from running, we should give them 24hrs to fix it before we kick them (easy to apply again once fixed) (dfarrell07, 17:08:39)

  2. Updates (dfarrell07, 17:11:07)
    1. Phil isn't here, so no event updates (dfarrell07, 17:11:16)
    2. http://www.opendaylight.org/news/events/ the events page (colindixon, 17:11:18)
    3. Youcef Laribi (Youcef, 17:11:18)

  3. Li and Stable Helium updates (dfarrell07, 17:11:43)
    1. gzhao says that all projects should have status reported, a number of projects haven't (dfarrell07, 17:12:17)
    2. two offset 1 and and two offset 2 projects have failed to provide M4 reports so far (colindixon, 17:12:20)
    3. gzhao reports on projects shifting between green<->yellow (dfarrell07, 17:13:06)
    4. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the status spreadsheet (colindixon, 17:13:14)
    5. See the status link above for details of those status changes (dfarrell07, 17:13:53)
    6. There are a number of projects that are in the process of withdrawing from the release, discussions ongoing (dfarrell07, 17:14:39)
    7. at this point in time the following projects seem like the may withdraw: SXP, plugin2oc, Maple, Discovery (colindixon, 17:15:39)
    8. Discovery has sent an email to ask to formally withdraw (dfarrell07, 17:15:49)
    9. https://lists.opendaylight.org/pipermail/release/2015-April/002030.html <-- persistence (gzhao, 17:15:54)
    10. https://lists.opendaylight.org/pipermail/tsc/2015-April/002925.html Discovery project request to withdraw from Li (dfarrell07, 17:16:30)
    11. phrobb is working with Maple to figure out what makes sense, they are likely to withdraw as they still don’t have resources because of IPR issues (even though they are now resolved) (colindixon, 17:16:46)
    12. phrobb is working with Maple to figure out what makes sense, they are likely to withdraw as they still don’t have resources because of IPR issues (even though they are now resolved) (colindixon, 17:16:55)
    13. As discussed past weeks, Plugin2OC is dropping from SR (dfarrell07, 17:18:00)

  4. Integration and Test updates (dfarrell07, 17:18:09)
    1. Super Committers are now able to merge patches for release, which is good (dfarrell07, 17:18:54)
    2. two things to improve our ability to do integration tests: (1) allow for faster (or automated) version bumping and (2) pull back time to be remove people from integration if they break things to 24 hours (colindixon, 17:19:16)
    3. 24hr limit on breaking Integration tests before kick mentioned by LuisGomez (dfarrell07, 17:19:17)
    4. No objections raised to LuisGomez kicking projects if they break Integration tests for >=24hrs (dfarrell07, 17:20:02)
    5. edwarnicke says he’s pretty sure he knows how to write the test to catch the last remaining loophole that allows projects to break the integration build (colindixon, 17:22:04)
    6. ping edwarnicke if you're willing to take that "last loophole" TODO above (dfarrell07, 17:22:47)
    7. ACTION: colindixon to send mail and/or maybe just push the last test that lets projects break integration (colindixon, 17:22:56)
    8. Integration team is working to get additional perf jobs in CI (dfarrell07, 17:23:35)

  5. Infrastructure (dfarrell07, 17:23:44)
    1. Our LF heros, tykeal and zxiiro, have been fighting a bunch of fires in infra during the past few days (dfarrell07, 17:24:46)
    2. tykeal gives overview of Jenkins problem, still working on it (dfarrell07, 17:25:35)
    3. we're still processing jobs way faster than in past releases, FYI (just not stable atm) (dfarrell07, 17:26:23)
    4. https://wiki.opendaylight.org/view/Weather#Jenkins_slave_instability (colindixon, 17:26:26)

  6. Committer Promotions (dfarrell07, 17:27:54)
    1. noone from GBP on call (dfarrell07, 17:28:05)
    2. no one from CAPWAP on call (dfarrell07, 17:28:18)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-April/002909.html proposal Luis Gomez on RelEng/Builder (colindixon, 17:28:26)
    4. Reviewing adding LuisGomez to as committer on RelEng (dfarrell07, 17:28:35)
    5. ACTION: colindixon to start e-mail voting threads on CAPWAP and GBP to the mailing list (colindixon, 17:29:38)
    6. VOTE: Voted on "Shall the TSC approve LuisGomez as a committer on RelEng/Builder?" Results are, +1: 8 (dfarrell07, 17:30:09)
    7. AGREED: LuisGomez is approved as a committer on RelEng/Builder (dfarrell07, 17:30:24)

  7. Beryllium Release Plannig (colindixon, 17:31:23)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-April/002931.html some sample dates for a Lithium-like Beryllium release (colindixon, 17:31:41)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-April/002931.html Sample dates for Be release planning (dfarrell07, 17:31:52)
    3. colindixon gives updates on status of Be release planning, see dates link above (dfarrell07, 17:33:06)
    4. No feedback from TSC to colindixon on Be planning, take it to the lists (dfarrell07, 17:33:55)
    5. colindixon points out that both M1 and M3 are so fuzzy as to be almost useless, dropping them may give us a faster release cadence with lower overhead (dfarrell07, 17:36:19)
    6. edwarnicke likes the "declare participating" part of M1, discussion about that being in M0 (dfarrell07, 17:36:50)
    7. https://lists.opendaylight.org/pipermail/tsc/2015-April/002923.html here is the more blunt e-mail saying maybe we should drop M1 and M3 (colindixon, 17:38:15)
    8. edwarnicke talks about importance of having a sufficient release to M0 gap (dfarrell07, 17:38:44)
    9. General positive feedback about shorter release cycles in general (dfarrell07, 17:39:37)
    10. colindixon points out that offset 0 projects likely don't need much time to figure out if they will take part in release, don't need much gap between release and M0 (dfarrell07, 17:40:59)
    11. so offset concept will build in enough time between release and M0, address edwarnicke's points (dfarrell07, 17:41:35)
    12. Discussion about various times between Ms, if they are enough for various activities for various offset projects (dfarrell07, 17:45:21)
    13. High order bits, per colindixon, are that we want to lower overhead of release. Might can do that by not causing people to plan for things that are far away, and maybe reducing the number of milestones. (dfarrell07, 17:54:14)
    14. People should look at the dates and talk about this on the lists (dfarrell07, 17:54:59)
    15. To be clear, you don't have to avoid working before you declare intent to participate in a release (dfarrell07, 17:58:10)
    16. colindixon and likely others would like to have Be release plan done in next few weeks, as offset 0 projects are getting fairly close to thinking about next release (dfarrell07, 17:59:33)
    17. No time for board request discussion this week (dfarrell07, 18:00:33)

  8. cookies (colindixon, 18:00:44)
  9. Cookies (dfarrell07, 18:00:45)


Meeting ended at 18:00:48 UTC (full logs).

Action items

  1. dfarrell07 to draft a heuristic to determine if an issue for being a blocker to an SR
  2. dfarrell07 to write up something about how to raise a bug as a (potential) blocker for lithium
  3. regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround
  4. colindixon to send mail and/or maybe just push the last test that lets projects break integration
  5. colindixon to start e-mail voting threads on CAPWAP and GBP to the mailing list


Action items, by person

  1. colindixon
    1. colindixon to send mail and/or maybe just push the last test that lets projects break integration
    2. colindixon to start e-mail voting threads on CAPWAP and GBP to the mailing list
  2. dfarrell07
    1. dfarrell07 to draft a heuristic to determine if an issue for being a blocker to an SR
    2. dfarrell07 to write up something about how to raise a bug as a (potential) blocker for lithium
  3. edwarnicke
    1. regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround


People present (lines said)

  1. dfarrell07 (62)
  2. colindixon (32)
  3. dneary (11)
  4. odl_meetbot (11)
  5. ChrisPriceAB (5)
  6. dlenrow (4)
  7. gzhao (3)
  8. jmedved (3)
  9. snoble (3)
  10. edwarnicke (3)
  11. tykeal (3)
  12. LuisGomez (2)
  13. Youcef (2)
  14. mohnish (2)
  15. dbainbri (1)
  16. phrobb (0)
  17. tbachman (0)


Generated by MeetBot 0.1.4.