17:00:29 <colindixon> #startmeeting tsc
17:00:29 <odl_meetbot> Meeting started Thu Apr 30 17:00:29 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:29 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:29 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:37 <colindixon> #topic roll call and agenda bashing
17:00:39 <colindixon> #info colindixon
17:00:51 <phrobb1> #info TSC members please #info in
17:00:54 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place
17:01:04 <phrobb1> colindixon:  please chair me
17:01:13 <colindixon> #chair phrobb1
17:01:13 <odl_meetbot> Current chairs: colindixon phrobb1
17:01:17 * dfarrell07 is here
17:01:18 <colindixon> #char tbachman dfarrell07
17:01:24 <colindixon> #chair tbachman dfarrell07
17:01:24 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb1 tbachman
17:01:44 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-23-17.00.html last week’s meeting minutes
17:02:05 <edwarnicke> #info edwarnicke
17:02:19 <colindixon> #info gzhao volunteered to work with mlemay and edwarnicke on the better single feature test
17:02:44 <colindixon> #info we had new committers promoted on both CAPWAP and GBP on the mailing list
17:02:50 <jmedved> #info jmedved
17:02:55 <dfarrell07> #link https://wiki.opendaylight.org/view/Weather#Blocking_Bugs_definition Working definition of blocking bugs, #action of dfarrell07 and LuisGomez
17:02:56 <dneary> Hi all
17:03:00 <dlenrow> #info dlenrow
17:03:11 <LuisGomez> #info LuisGomez
17:03:46 <mohnish> #info mohnish anumala
17:04:09 <colindixon> #action colindixon to add the moxy issue to the wiki page with the workaround listed as being ping Ryan and/or Ed
17:04:14 <dfarrell07> 6 TSC ppl so far
17:04:44 * dfarrell07 is pinging cdub to see if I can proxy for him
17:04:52 <colindixon> #info Uri is on the phone
17:05:14 <Youcef> #info Youcef Laribi
17:06:13 <colindixon> #topic events
17:06:22 <colindixon> #link http://www.opendaylight.org/news/events/ the main events page
17:06:32 <dfarrell07> #info NFV World Congress is next week in CA, dev track will happen
17:06:33 <colindixon> #info NFV world congress next week in Santa Clara
17:06:35 <colindixon> #undo
17:06:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c35bd0>
17:06:44 <colindixon> thanks dfarrell07
17:06:53 <dfarrell07> #info OpenStack summit will be soon, ODL will have a presence
17:07:09 <dfarrell07> #info ONS will have an ODL dev track, submit CFPs ASAP
17:07:28 <dfarrell07> #info ODL Summit CFP has been completed, dev track talks will start at a later date
17:07:33 <colindixon> #info [if you’re looking for more info, these are all linked in from the events page above
17:07:52 <dfarrell07> #link http://www.opendaylight.org/news/events ODL Events
17:08:21 <dfarrell07> #info phrobb1 and dneary are working together to make it easier for downstream ODL consumers to give us feedback (think OPNFV)
17:08:21 <dneary> phrobb: Joined the call just a bit late
17:08:34 <dneary> phrobb: Any input needed from me?
17:08:48 <dfarrell07> #topic lithium and stable/helium updates
17:08:50 <phrobb1> nope, I just touched on our latest task to give them a heads up
17:09:14 <colindixon> #link https://wiki.opendaylight.org/view/Weather the weather page to track any known isssues in Lithium
17:09:15 <dfarrell07> #info gzhao doesn't have much to report about Li/stable He updates
17:09:19 * ChrisPriceAB #info chris price, sneaking in late...
17:09:25 <phrobb1> dneary:  I told them that we'll come back for their review once we have a draft wiki page up
17:09:34 <dneary> sound.
17:09:49 * dneary sees ChrisPriceAB sneaking in
17:10:08 * ChrisPriceAB ducks for cover
17:10:20 <dfarrell07> #info Discussion about release cutting docs, that they could be better, colindixon asks for help from LF admins to make those docs better
17:10:32 <dfarrell07> #undo
17:10:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3e610>
17:10:52 <dfarrell07> #info Discussion about stable branch SR release cutting, that they could be better, colindixon asks for help from LF admins to make those docs better
17:11:24 <colindixon> #action zxiiro to write better description of how to cut your stable/lithium project, e-mail that out and help projects do that appropriately
17:12:17 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Blocking_Bugs_definition candidate definition of what would be release blocking bugs that LuisGomez and dfarrell07 worked on the last week
17:12:54 <colindixon> #info please edit the wiki or reach out to the communtiy (mailing list thread to be started) if you want to provide input
17:14:34 <dfarrell07> #info edwarnicke suggests that spreadsheet used by gzhao in the past to tracking blocking bugs was useful, discussion about using that vs wiki
17:16:09 <dfarrell07> #info There isn't currently an Li bug tracking spreadsheet
17:17:05 <dfarrell07> #info Using the to-be-created spreadsheet above seems to be (by consensus) the right/authoritative source for blocking bug info, link to it from wiki
17:17:10 <colindixon> #actoin gzhao to add a tab to the release tracking spreadsheet for tracking release blocking bugs
17:17:49 <colindixon> #action gzhao to provide a link from the weather page to the release blocking bugs tab
17:18:10 <colindixon> #action gzhao to add a tab to the release tracking spreadsheet for tracking release blocking bugs
17:19:01 <colindixon> #action gzhao to send mail to TSC and release noting that the spreadsheet will be the authoritative list of blocking bugs
17:19:36 <dfarrell07> #topic System Integration and Testing
17:19:56 <dfarrell07> #info LuisGomez has lots of cool perf stuff to report
17:20:38 <dfarrell07> #info Integration team has been doing a lot of work to add perf/scale tests to CI
17:20:43 <colindixon> #info during the hackfest and since then the integration team has been working to get scalability and performance tests into CI
17:21:34 <colindixon> #info so far, this has been focused on openflowplugin, but in the future the goal is to test more projects and have projects provide these tests not just integration
17:21:46 <dfarrell07> #info Integration is hoping in future releases, projects will be able to build on the examples we created during Li to build their own tests
17:21:56 <dfarrell07> ^^good to state diff ways, imho
17:22:08 <dfarrell07> #info LuisGomez shows OF PktIn test result graphs in CI
17:22:37 <colindixon> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/ the jobs can be see in the openflowplugin for now
17:23:33 <dfarrell07> #info NB REST API add/del tests also added to CI, LuisGomez shows plot
17:23:43 <colindixon> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-cds-cbench-performance-only-master/plot/ plots of cbench performance
17:25:06 <colindixon> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-cds-config-performance-only-master/plot/Config%20Performance/ plots of RESTCONF performance for add and delete
17:26:36 <colindixon> #info jmedved says that he needed 8 python clients to get the max RESTCONF performance and he was finding something like 2,000 RESTCONF ops/sec
17:27:12 <dfarrell07> #info The current NB REST tests in CI may be able blocked on threads dedicated to Python client, Integration will address that feedback and adjust test out-of-band
17:27:19 <dfarrell07> #undo
17:27:19 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x17aad90>
17:27:25 <dfarrell07> #info The current NB REST tests in CI may be blocked on threads dedicated to Python client, Integration will address that feedback and adjust test out-of-band
17:27:56 <colindixon> #info colindixon asks how we’re persisting this data, LuisGomez says not any differently right now
17:28:22 <colindixon> #action LuisGomez and tykeal to work out retaining the performance metrics for as long as we can
17:28:37 <dfarrell07> #info Data from plots isn't currently long-term persistent, there have been discussions about that via zxiiro and LuisGomez but there's still uncertainty about how to do so
17:30:03 <dfarrell07> #info LuisGomez demos long-term CBench (so OF PktIn) test, jamoluhrsen gives details, same test but 1 hour long daily
17:30:17 <colindixon> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-periodic-1node-cds-cbench-daily-only-master/plot/ this is the same cbench numbers but instead of running for 4 minutes, it runs for an hour once per day to get longer time
17:30:45 <colindixon> #info jamoluhrsen says that we can store the graphs forever (or a whole release) if we want
17:30:49 <dfarrell07> #info jamoluhrsen reports that there seems to be support for storing results long-term in the Jenkins Plot Plugin
17:31:03 <dfarrell07> #info LuisGomez shows max-number-of-switches scale test in CI
17:31:28 <dfarrell07> #info This test is really cool, basically ups number of switches until controller breaks and plots how high we get
17:32:15 <dfarrell07> Mininet
17:32:25 <colindixon> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-periodic-1node-cds-scalability-daily-only-master/plot/Inventory%20Scalability/ scalabilty testing the max number of switches in a linear topology: right now we hit an OOM at 400 mininet switches
17:33:20 <dfarrell07> #info Switch # scale test uses Mininet (someone asked)
17:33:33 <colindixon> #info mohnish asks about details around how this is done
17:34:33 <dfarrell07> #info Discussion about other types of scale (Integration is well aware that we want *all the scale tests*)
17:34:48 <colindixon> #info mohnish notes that we need to be careful about what we report in terms of # of switches, people might take that to mean that we can handle that number of physical switches, or the number of vswitches, or the number of hosts
17:35:15 <colindixon> #info LuisGomez says yes, we definitely want to test more kinds of scale and we would love help getting them up and going
17:35:47 <colindixon> #info LuisGomez also notes that right now the goal isn’t the numbers per say but to make sure we look for any regressions
17:36:02 <dfarrell07> #info Super important: we're not trying to report max numbers with these tests, we're looking for regressions. Don't quote these numbers as our max values!
17:36:21 <colindixon> dfarrell07: +10000
17:36:42 <ttkacik1> dfarrell07: +1
17:37:03 <hideyuki> dfarrell07: it makes sense.
17:37:46 <colindixon> #info along those lines, this is running things in a VM without super amounts of tuning, so these results are likely well below what actual max performance/scale numbers would be
17:38:04 <dfarrell07> s/super/any
17:38:15 <colindixon> dfarrell07: feel free to undo/redo
17:38:31 <dfarrell07> colindixon: it's good, I think we made it clear :)
17:39:05 <colindixon> #info edwarnicke notes that mininet tends to flap a lot (e.g., switches disconnecting and reconnecting) when get beyond about 100 switches depending on the environment, we should make sure we’re testing our controller not the test tools
17:40:24 <edwarnicke> #info colindixon has run out of adjectives to express his joy
17:40:47 <dfarrell07> ^^lol, nice one
17:40:54 <icbts> :)
17:41:02 <jamoluhrsen> I didn't know it was possible
17:41:05 <gzhao> How many very did Colin use?
17:41:08 <edwarnicke> edwarnicke: Questions whether we are really testing the scalability of colindixon's vocabulary for happiness, or the test tools we are applying to them
17:41:08 <phrobb1> #info colindixon notes that Uri is jumping with joy over the testing metrics shown by LuisGomez
17:41:20 <dfarrell07> edwarnicke: rofl
17:42:03 <dfarrell07> #info Future TODOs around putting all this in a central dashboard-like place, writing docs to describe all of these
17:42:28 <colindixon> #action LuisGomez (or somebody else) to send out an e-mail with links to the tests and a few sentence descriptions of what they are
17:42:54 <colindixon> #action snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium
17:45:02 <dfarrell07> #info Committer promotions on mailing list
17:45:12 <dfarrell07> #topic Beryllium Planning
17:45:40 <dfarrell07> #undo
17:45:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1c3d850>
17:45:43 <dfarrell07> #undo
17:45:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3db90>
17:45:45 <dfarrell07> lag...
17:45:52 <colindixon> dfarrell07: thanks!
17:46:05 <dfarrell07> #topic Committer promotions
17:46:08 <snoble> sorry was on my tablet so not on irc :)
17:46:19 <dfarrell07> #info No one here from OVSDB, mailing lists
17:46:29 <dfarrell07> #topic Beryllium Planning
17:46:42 <dfarrell07> #info Phill will send out info to lists, please review
17:46:49 <colindixon> #topic introductions
17:47:27 <evanz> he's on irc but just got net split ^_^
17:47:32 <dfarrell07> #info ODL TSC welcomes odlcasey
17:47:41 <dfarrell07> so much lag
17:47:53 <edwarnicke> odl-casey: or odlcasey ?
17:47:57 <colindixon> #info Casey Cain is new to the project with the LF folks and will be helping out with overall project management and community management, on IRC he’s odl-casey
17:48:56 * ChrisPriceAB I like odlcasey already!!!
17:49:09 * dfarrell07 is hitting *lots* of IRC lag
17:50:09 <colindixon> #topic cookies
17:50:12 <colindixon> #endmeeting