#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:31 UTC (full logs).

Meeting summary

  1. agenda bashing and roll call (colindixon, 17:00:38)
    1. colindixon (colindixon, 17:00:41)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=30397#Agenda the agenda (colindixon, 17:01:12)
    3. dlenrow (dlenrow, 17:01:16)
    4. edwarnicke has asked that we talk about IPv6 downstream patches, I’m putting it on the agenda under lithium (colindixon, 17:01:28)
    5. Chris Price (ChrisPriceAB, 17:01:39)
    6. edwarnicke (edwarnicke, 17:01:43)
    7. LuisGomez (LuisGomez, 17:01:43)
    8. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-05-07-17.01.html meeting minutes from last week for action items (colindixon, 17:03:36)
    9. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade (colindixon, 17:04:24)
    10. ACTION: LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can (colindixon, 17:05:26)
    11. jmedved (jmedved, 17:06:21)
    12. http://www.opendaylight.org/news/events/ the events in the usual place (colindixon, 17:07:47)
    13. mohnish anumala (mohnish, 17:09:44)
    14. VOTE: Voted on "could you attend a TSC meeting next week for ~30-45 minutes (-1 no, +1 yes)?" Results are (colindixon, 17:10:54)
    15. AGREED: the TSC will meet next week, but it may be abridged (colindixon, 17:11:35)
    16. ACTION: phrobb to find a room at openstack if possible (colindixon, 17:11:52)
    17. ONS notifications should be out by end of week (dfarrell07, 17:12:07)
    18. OpenStack Summit is next week, many ODL ppl attending (dfarrell07, 17:12:26)
    19. OpenStack next week, ONS mid june, our main summit at the end of July (colindixon, 17:12:31)
    20. OPNFV is having a meeting on Monday afternoon where it would be good for OpenDaylighter’s to be ther if possible (colindixon, 17:12:55)
    21. http://openstacksummitmay2015vancouver.sched.org/type/opnfv+day#.VVTXoluBBDY opnfv event at openstack (ChrisPriceAB, 17:13:19)

  2. lithium update (colindixon, 17:13:24)
    1. offset 2 M5 deadline is today (colindixon, 17:13:37)
    2. two offset 1 projects haven’t submitted M5, which is now 2 weeks late: SNBI and SNMP4SDN, nobody depends on them, so we can treat them as offset 2 and they’re not causing any pain (colindixon, 17:14:19)
    3. projects we’re looking to remove from Lithium because they haven’t responded (colindixon, 17:15:15)
    4. https://lists.opendaylight.org/pipermail/coretutorials-dev/2015-May/000021.html discussion around coretutorials in Lithium and whether to ship it (colindixon, 17:17:17)
    5. ACTION: colindixon to work with alagalah_, tom pantelis and LuisGomez around what do with coretutorials (colindixon, 17:18:23)
    6. Youcef Laribi (Youcef, 17:18:28)
    7. https://lists.opendaylight.org/pipermail/tsc/2015-May/003060.html the other projects are discovery, maple, and plugin2oc (colindixon, 17:19:05)
    8. ACTION: phrobb to contact those three projects to figure out if they will withdraw on their own (discovery, maple, and plugin2oc) (colindixon, 17:19:35)
    9. ACTION: colindixon to start a thread on what it means to ship something as part of a release (colindixon, 17:21:14)

  3. version bumping and IPv6 issues (colindixon, 17:22:01)
    1. yangtools fixed a bug on master, e.g., Beryllium, which now correctly enforces IPv6 prefix format, which breaks lots of downstream projects that were providing incorrect IPv6 prefixes (colindixon, 17:23:21)
    2. the result is that downstream projects need to fix these bugs *before* they can cut their stable/lithium branches (colindixon, 17:24:22)
    3. edwarnicke's details of version bumping issue demonstrate more general issue with how we do cut/merge, solution being discussed on lists (dfarrell07, 17:24:26)
    4. the result is that openflow plugin is currently blocked on this, so most (if not) all offset 2 and many offset 1 projects are also blocked (colindixon, 17:24:56)
    5. on the plus side, we’re fixing a lot of possible IPv6 bugs (colindixon, 17:25:11)
    6. https://lists.opendaylight.org/pipermail/tsc/2015-May/003063.html version bumping/branch cutting being discussed here (dfarrell07, 17:26:11)
    7. ACTION: gzhao to send out a mail to release saying that many projects will be unable to cut stable/lithium right now, and point to this e-mail chain about it here: https://lists.opendaylight.org/pipermail/release/2015-May/002315.html (colindixon, 17:26:41)
    8. https://lists.opendaylight.org/pipermail/coretutorials-dev/2015-May/000021.html < email thread for coretutorial discussion. (gzhao, 17:27:36)
    9. LuisGomez asks if projects should branch without bumping, colindixon says "no" and gives reasons too quickly to document (dfarrell07, 17:27:52)
    10. colindixon says to send M5 status anyway without the branch cut, report whether you are holding it or not based on that bug and then we’ll track branch cutting separately (colindixon, 17:29:12)

  4. helium to lithum migration (colindixon, 17:29:37)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-May/003014.html we could use help here if anyone wants to volunteer (colindixon, 17:29:53)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=3160 this is the bug gracking things (colindixon, 17:30:04)

  5. bugs it yangtools and controller (colindixon, 17:30:24)
    1. https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-05-12-16.07.html during the last bug scrub ttkacik said he would help mentor people on easy bugs in section 4 of those minutes (colindixon, 17:31:44)
    2. that’s a really good way to get involved (colindixon, 17:31:52)
    3. reach out to ttkacik or tonytkacik or his e-mail which you can find plastered over every mailing list everywhere (colindixon, 17:33:00)

  6. system integration and test (colindixon, 17:33:12)
    1. there was a weird problem with single feature test that lori found the workaround for, yay! (colindixon, 17:33:46)
    2. otherwise everything is the same as before (colindixon, 17:33:59)
    3. phrobb asks for information about spirent and performance testing (colindixon, 17:34:11)
    4. spirent activity has died down, but people are using the stuff when they don’t have the gear, also some interns are getting VMs through the spirent lab to do more testing (colindixon, 17:35:11)
    5. LuisGomez didn't explicitly mention this, but dfarrell07 wants to call out the success of Integration wrt spinning-up new people. We have more devs pushing more useful code in parallel than ever before. Huzzah! (dfarrell07, 17:35:13)
    6. snoble is waiting for IXIA to get back to me on the license, working with Spirent also, have some issues running their virtual system, will meet both at ONF appfest next week (colindixon, 17:36:00)
    7. Integration is still pushing to get perf tests in CI, especially to make the recent batch of additions more stable (dfarrell07, 17:37:02)
    8. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-cds-cbench-performance-only-master/plot/ the performance dropped recently, people are debugging it (colindixon, 17:37:49)
    9. LuisGomez says “my kingdom for a dashboard” (colindixon, 17:39:02)

  7. infrastructure (colindixon, 17:39:21)
    1. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-master/26/artifact/dependencies.log (zxiiro, 17:39:43)
    2. Thanh wrote a tool which scans pom files and lists what other projects it thinks you depend on (see above link for lastest results) (colindixon, 17:39:56)
    3. tykeal says some people may have seen a slight outage this morning to deal with the venom cdd and he apologizes for the outage and everything should be back up (colindixon, 17:40:56)

  8. committer promotion on packetcable (colindixon, 17:41:42)
    1. Thomas Kee would like to to move Steven Pisarski on packetcable (colindixon, 17:42:19)
    2. http://spectrometer.opendaylight.org/?user_id=spisarski&project_type=opendaylight&release=all&metric=loc&company= ~7000 lines of code (colindixon, 17:42:37)
    3. https://wiki.opendaylight.org/view/PacketCablePCMM:Main the only issue is that while Thomas Kee is demonstrobly the only committer, there are several others that we haven’t gotten to vote (colindixon, 17:45:20)
    4. Thomas Kee +1 (xsited, 17:45:40)
    5. VOTE: Voted on "Shall the TSC approve Steven Pisarski as a committer for the PacketCable project?" Results are, +1: 8 (phrobb1, 17:46:04)
    6. AGREED: The TSC approves Steven Pisarski as a committer for the PacketCable project (dfarrell07, 17:46:13)
    7. AGREED: Steven Pisarski is now a committer on the PacketCable project (phrobb1, 17:46:31)
    8. Thomas Kee as the only active committer I vote +1 for steven pisarski committer promotion (xsited, 17:47:55)

  9. new committer on integration (colindixon, 17:48:46)
    1. Vratko has been very active/useful on Integration code reviews, created new tests (dfarrell07, 17:49:17)
    2. https://lists.opendaylight.org/pipermail/integration-dev/2015-May/003211.html Thread with votes from current active Integration committers (dfarrell07, 17:49:22)
    3. https://lists.opendaylight.org/pipermail/tsc/2015-May/003078.html (LuisGomez, 17:49:22)
    4. https://git.opendaylight.org/gerrit/#/q/project:integration+owner:%22Vratko+Pol%25C3%25A1k+%253Cvrpolak%2540cisco.com%253E%22 his commits on integration (colindixon, 17:49:40)
    5. http://spectrometer.opendaylight.org/?metric=commits&user_id=vrpolak&module=integration looks like 11 commits and ~1389 lines of code (colindixon, 17:50:10)
    6. LuisGomez says he has also help to review a ton of patchs (dfarrell07 says that’s be huge) (colindixon, 17:50:31)
    7. VOTE: Voted on "Shall the TSC approve Vratko Polak as a committer for the Integration project?" Results are, +1: 9 (phrobb1, 17:51:09)


Meeting ended at 17:51:09 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade
  2. LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
  3. phrobb to find a room at openstack if possible
  4. colindixon to work with alagalah_, tom pantelis and LuisGomez around what do with coretutorials
  5. phrobb to contact those three projects to figure out if they will withdraw on their own (discovery, maple, and plugin2oc)
  6. colindixon to start a thread on what it means to ship something as part of a release
  7. gzhao to send out a mail to release saying that many projects will be unable to cut stable/lithium right now, and point to this e-mail chain about it here: https://lists.opendaylight.org/pipermail/release/2015-May/002315.html


Action items, by person

  1. alagalah_
    1. colindixon to work with alagalah_, tom pantelis and LuisGomez around what do with coretutorials
  2. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade
    2. colindixon to work with alagalah_, tom pantelis and LuisGomez around what do with coretutorials
    3. colindixon to start a thread on what it means to ship something as part of a release
  3. gzhao
    1. gzhao to send out a mail to release saying that many projects will be unable to cut stable/lithium right now, and point to this e-mail chain about it here: https://lists.opendaylight.org/pipermail/release/2015-May/002315.html
  4. LuisGomez
    1. LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
    2. colindixon to work with alagalah_, tom pantelis and LuisGomez around what do with coretutorials
  5. phrobb
    1. phrobb to find a room at openstack if possible
    2. phrobb to contact those three projects to figure out if they will withdraw on their own (discovery, maple, and plugin2oc)
  6. tykeal
    1. LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can


People present (lines said)

  1. colindixon (78)
  2. dfarrell07 (23)
  3. odl_meetbot (21)
  4. ChrisPriceAB (17)
  5. phrobb1 (8)
  6. edwarnicke (8)
  7. alagalah_ (8)
  8. dlenrow (7)
  9. mohnish (6)
  10. LuisGomez (5)
  11. tykeal (5)
  12. jmedved (4)
  13. xsited (3)
  14. Youcef (3)
  15. gzhao (2)
  16. snoble (1)
  17. odl-casey (1)
  18. cdub (1)
  19. zxiiro (1)
  20. ttkacik (1)
  21. phrobb (0)
  22. tbachman (0)


Generated by MeetBot 0.1.4.